Jump to content

30 posts in this topic

Recommended Posts

Copying this over from the other major forum as things seem pretty dead over there. Didn't see a dedicated "builds" forum here so hope this is the right spot. People on other social media recommended coming here. 

Alright, so the build has commenced, just waiting on the power supply (ended up not realizing that I bought the compatible power brick for the HDPlex 400w and then bought the PicoPsu 160, so that is going back and HDPlex is on its way) and monitor to get here.

Found a smoking deal on an Acer-K272HUL-Dbmidpx 27" IPS display through Newegg ($216 shipped to my door) that has gotten great reviews, be careful when looking for this as the EBmidpx (different model) looks the exact same but is a TN Panel and comes up in many of the searches.


Anyways, here is specs for final build...

- Mobo - ASRock Z370m-itx/ac [$120 amazon]

- RAM - Crucial Ballistix Sport LT 8gb [$49 amazon]

- WiFi/BT - Lenovo Broadcom BCM94352Z [$13 ebay]

- SSD - Samsung EVO860 1tb [$128 amazon]

- CPU - Intel Core i5 8400 [$185 newegg]

- Cooler - Noctua L9i [$40 amazon]

- Case - Wesena ITX4 v3 [$97 perfect home theater]

- PSU - HDPlex 400w [$95 hdplex]

- PSU Brick - Dell PA-9E 240w [$37 ebay]

- Monitor - Acer K272HUL 27" IPS [$216 newegg]

Total: $883 (shipping included in prices, most were free shipping)


This build will be mainly for your everyday computing needs, paying bills, watching YouTube videos and the occasional light photo editing session (have other expensive hobbies now so photography has fallen to the wayside). This is coming from a mid-2011 iMac 21.5" base model that is slowly dying (getting graphical artifacts on a constant basis now and the occasional sudden reboot). The iMac is no longer compatible with any new Mac OS upgrades (no Mojave) so I figured she had a good life over the last 8yrs and it was time to pick-up something new. Since I was fairly unimpressed with the specs for the money with regards to the new Mac Mini's I figured this would be a good chance for me to do a hackintosh.


Install will be a Vanilla High Sierra build, since that is the only version I have access to on my iMac. From my research I have downloaded the following kexts for install.

- Broadcom Fix (both the firmware repo and firmware patch)

- IntelMausiEthernet

- WhateverGreen

- Lilu

I am using the two following builds on the other forum as my baseline as they are very similar builds to mine.

Suneys Mini Cube from the other forum and the Tiny But Might build from the same forum. 


With that said, I plan to use Morgonaut's guide from YouTube to build the hackintosh up (hopefully next weekend). Once everything is running stable in High Sierra I will hopefully be able to update to Mojave without any major issues and then keep moving forward with life. So, am I forgetting anything?

Edited by mizznfizz
adding tags

Share this post

Link to post
Share on other sites

Please see my signature for rules. Posting links to that forum isn’t a good idea.


As for your build, looks good but you will also need FakeSMC.kext or VirtualSMC.kext. This is a must have kext.

What audio codec does it have?

Lilu + AppleALC for audio plus the appropriate layout.



Sent from my iPhone using Tapatalk

Share this post

Link to post
Share on other sites

Thanks @savageAUS I removed the links. It is ok to link to YouTube videos? I did see the reference you were talking about but understood it differently.

I will definitely download the FakeSMC as that is the one the referenced builds use.

As for the Audio codec, it uses the RealTEK ALC892. Which one would I need for that.. Here is link to spec sheet for the board

Share this post

Link to post
Share on other sites
6 hours ago, millusions said:

since you have an imac.

1.carbon copy the hard disk to USB drive

2. install clover to backup disk

3. install kexts, edit config.plist

4. applealc.kexts with lilu will do your sound

5. boot your hack on the PC

6. find tune kexts and config.plist/smbios


your hack is ready, with all your data and apps

Thanks for the info but I have no way to CC the drive as I don't have a connector or external enclosure that will allow that. Plus this thing has been upgraded so many times I would rather to a clean and fresh install. Can I get all the apps and whatnot, no settings, from doing a timemachine backup or will that be just as difficult?

Share this post

Link to post
Share on other sites
19 hours ago, millusions said:

organise a usb drive, you will save yourself a lot of time in the long run.

when you do a hack it helps a lot to have a carbon copy.

i cant comment on time machine, i've never used it

Yeah that is what I am trying to do and be a little proactive however I am not quite understanding where some of these files go. From the stuff that I have read most talk about putting .kext files in the "other" folder within clover. Then there are those that talk about manually putting the file in the L/E/ folder. For instance, RehabMans FakeSMC file does not have a .kext file that I can seem to find on his github repository. Pretty sure that I need to do a bit more reading on this to understand where to put these particular files. 

Looks like from the one of those other builds this should be all I need to get everything functioning....

RehabMan's FakeSMC kexts
IntelMausiEthernet for Ethernet
Lilu.kext + AppleALC + CodecCommander for sound
USBInjectAll + XHCI-200 series injector in /L/E to get USB to work on initial boot
Rehabman's FakePCIID + FakePCIID_Broadcom_Wifi kexts
RehabMan's Broadcom Kexts (BcrmFirmwareRepo, BcrmPatchRAM2)

Share this post

Link to post
Share on other sites

RehabMans github is the project page. You either need the butbucket link in the descriptions to download them or build them from master.
I prefer VirtualSMC.kext though.

Sent from my iPhone using Tapatalk

Share this post

Link to post
Share on other sites

Thanks for the help guys... @millusions Yeah have always loved Noctua stuff, and damn is that thing big. Could barely fit the ram stick in that slot as it's heatsink was rubbing against the heatsink. So threw it into the other slot and hoping that there will be no issues with that. If I ever decide to add another 8gb stick I may be screwed.


@savageaus any particular reason you like the virtualsmc.kext over the FakeSMC?

Share this post

Link to post
Share on other sites

@millusionsSo you are saying purchase one of those external adapters and go through the install process for that drive on my iMac as though I were replacing that drive. Then once done installing as a "true iMac" go through the process of using clover, installing kexts, etc? Basically, dual booting with the soon-to-be hackintosh drive as though it were an actual mac drive?!Remember I am currently running a mid-2011 iMac base model that is no longer able to upgrade/update to Mojave. This is my first foray into the world of hackintosh's so still a little new to stuff like this, though I have built plenty of windows machines in the past. 


And if I am reading what you are saying correctly, it basically bypasses the need for all the kexts and other changes to be able to do the initial install. Is that correct?

Edited by mizznfizz

Share this post

Link to post
Share on other sites
2 minutes ago, millusions said:



i find it a lot easier to do it like that.


the mojave thing could be a deal breaker, you decide :)

Meh... mojave ain't that big a deal for me. I could technically run down to the wife's salon and download the installer for Mojave from there. But was also going to see about using one of my time machine backups for the install (just do documents, etc., not settings from the backup) but I still need to do some research on that. 

Share this post

Link to post
Share on other sites

Discrete gfx card recommendation (AMD only please)


Other thing that I wanted to add was that I may end up adding a discrete graphics card down the road (really really liking what I am seeing from the previous of Pantheon: Rise of the Fallen). Since I am in a mini-itx case (wesena ITX4 v3) I can take a low profile graphics card but the thing is that it really needs to be fairly thin, can't be much bigger than the single-slot size. Originally I was looking at grabbing something like a Radeon Pro WX2100/3100 but was wondering if you guys had any other recommendations. If/When Pantheon comes out that would pretty much be the only game that would be played on the machine. 

Share this post

Link to post
Share on other sites
17 minutes ago, millusions said:

nah. forget time machine if it's documents/apps.


network them, copy over network.


as for discrete graphics. well, all i can say that i tried gaming on High Sierra, really would prefer to game on OSx, the windows interface is just so pathetic and annoying, but in the end gave up.

sure Diablo III runs very smooth, but that will run smooth on anything.  Basically my GTX 980Ti works like a 780 ti at best on Mac OSX in games, gaming graphics in windows are not just slightly better it's like night and day.



LOL... probably should have clarified at that point the system will then be given an m.2 SSD drive for a dedicated windows install that would be strictly used for gaming... no bootcamp garbage as I never had luck with that or VMfusion, etc.... More than likely when Pantheon comes out it will not be dual system compatible. 

Share this post

Link to post
Share on other sites
5 minutes ago, millusions said:

ah ok.

why Radeon Pro? it looks {censored}house

64 bit?





No mainly because of size concerns. I will take a pic tonight that will better explain. Can fit pretty much a full length card in the case but needs to be "low profile" and fairly narrow. Most everything I see on the Nvidia side of things ends up being considered "single-slot" only because it doesn't have an a fan intake/exhaust that takes up the second port. Would rather put something like and RX460/560 in there but most I can find are too wide (back of pcb to front of fan). 

Share this post

Link to post
Share on other sites

Here is what I am talking about with the GPU...

The 1cm (10mm) mark is about dead middle of the PCI-E slot.. So I have about 23mm from the middle of the PCI-E slot to end of case and really that is not accurate as the way the top attaches to the full case there is about a 10mm block that is on the inside. 



Then this came in the mail tonight..!




Share this post

Link to post
Share on other sites

Yup that build was actually the one that turned me on to the Wesena case. Found out that Wesena is the US name for Streacom cases. I may have to change out to a large room case down the road if I do decide to do some gaming just so that I can actually handle a semi decent card. Only other slim profile ones I have found were older Radeon series cards like the HD 7k or HD 8k. There are apparently some R7 hard that are like that but they become harder to find with the newer gen cards. 

Share this post

Link to post
Share on other sites

Unfortunately, yeah. Take a look above in the original photos and look at the last two. FEom what I have been seeing about Pantheon they are still at least a year out in development since they are still in pre-alpha. By then I will probably have the time/money to upgrade the case to allow for a full size card. 

Share this post

Link to post
Share on other sites
9 hours ago, millusions said:



should be able to find a cheap one nowdays


i have a 1070 in my Xbox Killa build, it's a beast (for now)

Yeah I have seen that card mentioned in other builds similar to mine but think that it may be too tall. This case really limits what it can accept with how wide and how tall the card is, length is just fine for standard card lengths, its just everything else about the card that is difficult apparently!! LOL

Thanks for all the help @millusions

Share this post

Link to post
Share on other sites

Alright well she is running.... somewhat. Still have a couple issues that I am trying to work through..

1. UHD 630 internal graphics is only recognizing 14mb for some reason in High Sierra 10.13.6. Monitor is not recognized either. 

2. Bluetooth is not being recognized at all even with the Broadcom kexts installed in the other folder..

Gonna pick this up tomorrow night but so far everything went pretty smoothly. I originally messed up my Clover Bootloader so I kept getting a hang. Resolved that by taking my USB install disk, ended up finding a NEWER boot loader (as of a few days ago) and installed that on the USB as well as saved the folder (which I hadn't in the first place apparently.... d'oh!) and then went through that portion of the process again. Now it boots just fine on its own, get a quick graphical glitch when I first log in but I have a feeling that is due to issue #1. 


Good thing is that all my USB ports as recognized, which I figured was going to be my first issue outside of the ethernet. Been fun so far. Now just got to get everything running properly. 

Share this post

Link to post
Share on other sites

Thanks @millusions haven't really tested to see if sleep works as I was putzing around on the machine last night when I was working on everything, so I never setup sleep or activated hot corners. However, this morning I did so Apple>Sleep and that seemed to work however my screen did not fully go to sleep (could still see mouse arrow too) so I would say it is partially working but have not fully tested. 




Have to say that once this thing gets to the Apple Logo boot screen, she screams to the password entry!



and here is my kexts/other folder as of this morning before I left for work.


Share this post

Link to post
Share on other sites

So have a little bit of success tonight with the hack.... Was able to finally get wifi recognized with items from Rehabman for the FakePCIID and Broadcom_fix packages. Still working on trying to get the bluetooth portion recognized though. Figured that it would have worked when the wifi was recognized but I must have missed a step. 


For the video I am getting the below kernel panic when booting. 


Think I remember reading about a framebuffer fix for intel graphic acceleration. Time for some more digging. And yes, I have increased the iGPU memory to at least 128mb in the bios.

Share this post

Link to post
Share on other sites

Ok thanks @millusions I appreciate all your help.


So for anyone else that may be watching this, here are my remaining issues..

1. No graphics acceleration on the Intel UHD630 integrated graphics

2. No bluetooth (wifi works though)

3. No sounds/audio (but think I may have that figured out)

4. ...


Share this post

Link to post
Share on other sites

Alright!!! So I can mark off #3 from the list... ended up going back through removing all my kext files from the Other folder as well as the ones that I had put in the /L/E folder and kinda started over from scratch.

Went through and did the sudo kextcache -i / command from the command line and cleared my cache. 


Confirmed after restart that NOTHING was working that previously had (e.g. wifi and ethernet).

Installed the IntelMausiEthernet.kext into the Other folder and reboots... ethernet now works

Then I started working on the sound following Morgonauts video and got it to work with the first number (1) in the Inject Audio after installing the AppleALC.kext in the kext/Other folder. So have one small success tonight so far. 

Share this post

Link to post
Share on other sites

Alright, after hours of messing with the video to try and get things to work properly giving me full gfx acceleration I had no luck. I have not gone through the Hackintool read yet but after trying multiple other methods, even attempting to spook the platform and device IDs in Clover I had not luck.  


Seems crazy to me that there are a couple other threads where people are able to get these items working right away with minimal issues and I am running into so many problems, kinda makes we want to wipe my drive and start over again. 


So Items that are still not working

- No gfx acceleration (Intel UHD 630 is recognized but only showing 14mb of memory)

- No bluetooth (wifi portion is working fine however bluetooth hardware is not recognized)


Solutions (proposed)

- For video, framebuffer patching needs to occur apparently. This is referenced by the message received during verbose boot process. Hackintool [created by @headkaze] recommended by @Allan as way to appropriately fix.

- For bluetooth, seems that there is an issue with USB configuration in ACPI from reading different forums/threads. This is remedied by correctly assigning USB ports through usage of USBInjectAll.kext


Seems like both of these items are fairly involved with the latter requiring the creation of a custom SSDT file and injection of USB items. 

Share this post

Link to post
Share on other sites

Holy #$%@!! Finally got bluetooth working after going through the USB cleanup thread by @headkazewhile utilizing the Hackintool!! 

One thing that I have realized is that when inputting items into your /L/E or /S/L/E folder you definitely need to be using a KEXT installer. Had just been dragging and dropping into the respective folder.


For me, the following worked.

- Going through the USB Cleanup thread steps and activated all the applicable ports

- Used Hackintool to create a USBPorts.kext file, once created you drop this into EFI>Kexts>Other as this is now your proper port mapping for your system. 

- Make sure that you have Rehabman's FakePCIID and Broadcom kexts in your EFI>Kexts>Other folder to supplement


After all of that, a few restarts and now my bluetooth is recognized!!!



So that now leaves me with fixing the damn graphics acceleration..... time to do some more researching!!

Edited by mizznfizz

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Arman Hossain
      I want install High Sierra  on my pc . my CPU is : AMD Ryzen 3 2200g and my MotherBoard is : ASUS EX A320m. and 8gb ram DDR4 ram . i dont have any external gripch card. i have seen some video on youtube how to install High Sierra but they use extranal gripch card to make it good  but i don't have any extranal gripch card . on my windows sysem the shared gpu is 2GB which is using my ram to crate the vega gripch  . i want know is it possible to install High Sierra on my pc with out any extarnal gripsh card  ?

    • By verdazil
      Notebook: Acer A315-53-34MP, High Sierra 10.13.6 && Mojave 10.14.6 installation
      CPU: Intel® Core™ i3-8130U, 3400 MHz
      Memory: Kingston, DDR4, 2x4Gb, 2400 MHz
      Video: Intel UHD620 (integrated)
      Display: CMN N156HGA-EAB [15.6" LCD] (embedded)
      External monitor: LG TV 42LF650V
      SSD: Leven JAJS300M240C, 240 Gb (replacement)
      Chipset: Intel Sunrise Point-LP
      Sound: Intel Kaby Lake HDMI + Realtek ALC255
      LAN: Realtek RTL8168/8111 PCI-E Gigabit Ethernet Adapter
      Wi-Fi + Bluetooth: Broadcom BCM94352Z (replacement)
      Touchpad: ELAN0504 
      Cardreader: Realtek PCIE RTS5289
      VGA WebCam
      Mac model: MacBookPro14,2
      MacOS versions tested: High Sierra 10.13.6 (17G8030) && Mojave 10.14.6 (18G95) && Catalina 10.15 (19A558d)
      Here is what I used to install and configure the system:
      - Video settings: https://www.insanelymac.com/forum/topic/334899-intel-framebuffer-patching-using-whatevergreen/
      - Wi-Fi settings: https://github.com/acidanthera/AirportBrcmFixup
      - Bluetooth settings: https://github.com/RehabMan/OS-X-BrcmPatchRAM/blob/master/README.md
      - Touchpad settings: https://voodooi2c.github.io
      - Cardreader settings: https://www.insanelymac.com/forum/topic/321080-sineteks-driver-for-realtek-rtsx-sdhc-card-readers/
      - Clover, version v2.5k r5033: https://github.com/Dids/clover-builder/releases/tag/v2.5k_r5033
      - The results of the work of many developers in this and other forums.
      What works?
      - Video: Full HD x 60Hz accelerated video on embedded and external (HDMI) monitors
      - Sound: embedded and external (audio jack + HDMI audio)
      - Microphone
      - Touchpad (gestures)
      - Cardreader
      - Wi-Fi
      - USB2 && USB3 ports
      - LAN
      - Bluetooth
      - VGA WebCam
      - Sleep mode
      - Display brightness and volume control using function keys
      - Battery Indication
      - Automatically dimming the screen when the laptop is running on battery power
      - Sound notification when external power is connected
      What does not work?
      How to use
      1. Update BIOS to version 2.02. Secure boot must be disabled, Touchpad settings - Advanced
      2. To make a bootable flash drive, you can use my EFI directory (link at the end of the message) Tested for High Sierra 10.13.6 (17G8030) && Mojave 10.14.6 (18G95) && Catalina 10.15 (19A558d) installation.
      Note: you must insert your own SeralNumber && MLB && ROM in the config.plist file.
      3. After installation, just copy EFI directory from flash drive to the system drive.
      4. Install kexts BrcmFirmwareRepo.kext && BrcmPatchRAM2.kext to the /Library/Extensions and update system caches.
      Link: https://drive.google.com/open?id=11vTmPKjQUSEs2ddUzgwXG9A59EcDMrCs
    • By ludufre
      Installing macOS Mojave 10.14.6 on Gigabyte Z370N WIFI + i7 8700K + UHD 630

      09/01/2019 15:57h GMT-0
      - Updated to 10.14.6.
      06/10/2019 00:44h GMT-0
      - Completely rewritten.
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
      10/07/2018 00:36h GMT-0
      - First version.
      What works and what does not
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not tested yet.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
      - Test DP.
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover Configurator
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches

      How create create the install flash drive
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes. / 8 minutes with USB 3.0

      Install bootloader

      Download the CloverEFI (used 5058, from Automated Clover Builds) and install with this options on "Install macOS Mojave":
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended drivers (check all)
      - UEFI Drivers - Human Interface Devices (check all)
      - UEFI Drivers - FileVault 2 UEFI Drivers (check all, If you are going to use FileVault)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (if you are going to use NVMe)

      Make things works
      We'll make a full working flash drive, so follow these instructions:
      Will be mounted the EFI partition of the flash drive.
      Open the the /Volumes/EFI/CLOVER/config.plist inside this new partition with Clover Configurator (used
      Important modifications
      ACPI Page
      - Check: SSDT - PluginType
      BOOT Page
      - Add: Arguments - darkwake=2
      - Check: Legacy - XMPDetection=Yes
      - Check: KernelPm
      - Change: CsrActiveConfig - 0x3E7
      SMBIOS Page
      - Change: Macmini8,1 - Mac mini (Late 2018) | Intel Core i7-8700B @ 3.20 GHz

      - Click: Generate New (few times in the two buttons)

      Need some Kexts in the folder /EFI/CLOVER/kexts/Other/
      - Download the HWSensors 3 from here. I used the FakeSMC.kext, ACPIMonitor.kext, ITEIT87x.kext and IntelCPUMonitor.kext inside of DMG version r240.
      - Download the Lilu.kext from here. I used the version 1.3.8.

      Intel UHD 630
      ACPI Page
      - Uncheck: Fixes - AddHDMI
      - Uncheck: Fixes - FixDisplay
      - Uncheck: Fixes - FixHDA
      GUI Page
      - Change: Screen Resolution - 3840x2160 (My monitor is 4K)

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
      - Download the WhateverGreen.kext from here. I used the version 1.3.1.

      Audio ALC 1220 and HDMI audio

      BOOT Page
      - Add: Arguments - alcid=11

      DEVICES Page
      - Change: Audio - Inject - 11
      - Uncheck: Audio - AFGLowPowerState
      - Uncheck: Audio - ResetHDA

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
      - Download the AppleALC.kext from here. I used the version 1.4.0.

      All USBs (2.0, 3.0, Type-C, internal)
      KERNEL AND KEXT PATCHES Page - KextsToPatch
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      - MatchOS: 10.14.x
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      - MatchOS: 10.14.x
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      - MatchOS: 10.14.x
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FF0F0F
      - Replace* [HEX]: 83FF3F0F
      - Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      - MatchOS: 10.14.x
      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      Need SSDT patch in the folder /EFI/CLOVER/ACPI/patched/
      - Download the SSDT-EC.aml, SSDT-UIAC.aml and SSDT-USBX attached bellow.
      Wifi and Bluetooth (BCM94360CS)
      Works out of box (plug 'n' play).
      LAN Cards
      Need a Kext for feach card in the folder /EFI/CLOVER/kexts/Other/
      - Download the IntelMausiEthrenet.kext from here. I used the version 2018-1031.
      - Download the SmallTreeIntel82576.kext attached bellow. I do not remember where I found it.

      Now you can start the instalation without problem (I guess).
      How install
      UEFI Setup Configuration and Installation

      UEFI configuration
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Save & Exit Setup
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
      The installer will start. 
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      The second part of the installation will begin. This will take 16 minutes.

      Post installation

      Install bootloader
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the EFI folder inside your destination disk EFI parittion, with EFI folder inside flash card EFI partition.

      If the flash drive EFI partition of your destination disk or flash drive is unmounted:
      Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 0 for destination disk and 1 for flash drive.
      Then, eject the flash drive.
      Last step
      Move all Kexts from EFI partition to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
      It's done!
      System update 10.14.6
      - Download and open latest CloverConfigurator
      - Open Mount EFI and click in Mount Partition in EFI Partitions list
      - Click in Open Partition that appears
      - Go to EFI -> CLOVER
      - Backup config.plist and ACPI folder to desktop
      - Go back and delete CLOVER folder
      (If you restart now you can't boot in macOS - DON'T RESTART)
      - Download latest Clover and install (link and config above)
      - Replace config.plist and ACPI folder from your desktop
      - Update Lilu.kext, AppleALC.kext, WhateverGreen.kext, HWSensors kexts (FakeSMC, ACPIMonitor, IntelCPUMonitor, ITEIT87x) in /Library/Extensions/
      - Run:
      sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i /  
      - Install macOS Update 10.14.6 and restart

      And last but not least
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
      Z370N-WIFI v2.zip
    • By fusion71au
      Clover r5051 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
      1. Download and unzip "EFI_Clover_r5051 for VMware.zip". Mount Clover-v2.5k-5051-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By MaLd0n
      ---Original Post---
      ---CLOVER FOLDER---
      GigaByte Z390 M Gaming

      Intel Core i9-9900K

      CoolerMaster MasterLiquid ML120R RGB

      Corsair Dominator Platinum 16GB (2 x 8GB)

      Sapphiretech Radeon RX 590 8 GB GDDR5

      Samsung 970 EVO NVMe M2 Flash Drive

      EVGA 750 N1, 750W

      TP-Link Archer T9E

      Orico BTA-403

      Thermaltake View 21 Tempered Glass Edition

      --DSDT Patches--

      --USB-C-- test with SanDisk Ultra USB-STICK 128gb

      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!