Jump to content

30 posts in this topic

Recommended Posts

So oddity I noticed last night... when the system is booting to the clover bootloader screen, I do not have bluetooth at that point, so i have to plug my keyboard in to ensure I have it boot from my macOS drive vs. something else (like the Vault or Preboot Bootloader). I need to go through and rearrange my boot items so that it always boots from last used (still running verbose mode so that adds to boot time). 

Share this post


Link to post
Share on other sites
Advertisement
On 1/19/2019 at 4:25 PM, mizznfizz said:

So oddity I noticed last night... when the system is booting to the clover bootloader screen, I do not have bluetooth at that point, so i have to plug my keyboard in to ensure I have it boot from my macOS drive vs. something else (like the Vault or Preboot Bootloader). I need to go through and rearrange my boot items so that it always boots from last used (still running verbose mode so that adds to boot time). 

So looks like this ends up being a continuity issue with Bluetooth. What I didn't realize from Rehabmans Broadcom thread is that while the Z2 wifi/bt chip is supported it is not NATIVELY supported, so looks like I will have some other work to go through and get BT continuity working properly. 

 

Ok ran into some other issues last night with an ACPI error that would not let me get into safe mode or anything. Not really sure what I did but I couldn't get macOS to load so I reformatted and started again. Getting everything else working first (USB ports, Ethernet, WiFi/BT) then I will worry about the iGPU. 

 

Here is the weirdest thing, there are two builds on another forum that use same board, same processor with slightly different other items and installing Mojave and/or High Sierra and both were able to get their setups working right away. Not sure where I am going wrong.

Mobo- ASRock Z370m-itx/ac with 3.10 BIOS (I believe, need to verify in BIOS tonight and looks like there is an updated bios with minor fixes)

CPU - Core i5 8400

Monitor is an Acer k272HUL IPS display connected via Display Port (has 2xHDMI ports available as well)

 

Oddity that I noticed last night and believe it is associated with the USB port fix that needs to be done, is that while the board has two gigabit lan ports, only one works for me. I had the second working at one point but not working OOB like I thought. Have installed IntelMausiEthernet.kext to resolve ethernet issue in the clover>kexts>other folder.

 

Really starting to wonder if there is something up with my board too. Get an oddity, will have to take a pic with my phone, when booting into the boot device selection screen where I get all kinds of graphical artifacts. I did end up winning an old bid I put in on a Dell OEM Radeon R7 350x low profile card that should fit my case and that will be here on Friday. But the bid in before I realized that there may be some compatibility issues with the card OOB (great another thing to mess with) but that will at least give me an idea of there is something else going on here. 

 

Share this post


Link to post
Share on other sites

Ok so finally got everything working again and started trying to get the framebuffer taken care of to get graphics acceleration. 

Attempted using a "general" framebuffer guide as the Framebuffer Patching via WEG guide just isn't making sense to me and I am not getting any framebuffer dumps when using the two boot arguments.

 

So here is where I am at. tried using a different guide that has been updated as of a few days ago from another site that had a similar board to mine. I am now stuck at a kernal hang. I get hung up on AppleACPICPU for multiple "Busy" signals then I will go into the Apple logo (quickly and very broken) and I get a black screen. Can't get past this even in safemode to get to my config.plist to swap it out for the previous settings. 

 

Any ideas how to get back to the system desktop to get this fixed?

Share this post


Link to post
Share on other sites

Finally was able to get past the ACPICPU error, realized that I had not changed my boot order so I was still attempting to use the UEFI partition for the drive to boot instead of the bootable usb thumbdrive. Got past that and was able to replace the EFI folder with my back-up that I created before I started messing with the integrated graphics. Now I can boot into the system with everything working except the integrated graphics which is fine for the moment as I will work through that.

 

Also got the R7 350x card only to find out that the system recognizes it as an r7 250 card but same as the integrated graphics I get no graphics acceleration. Spent 3hrs messing with different injections, framebuffer patches in clover, etc. to get no graphics accelerations. Biggest bummer is while this card is TINY (only 15.9mm wide from back of pcb to front of fan) it literally pushes up against the side mount of the wesena. I would have to gun into the wesena to remove the standoffs that hold the side mount piece to get it to have enough room (which would afford me about another 9mm) but with this card seeemingly not supported I am stuck.

 

So I am at a hard spot now.. Either I got to figure out what is needed to get the integrated graphics working properly or I need to return the card, sell the case and possibly the psu and replace those three with something similar but that is OOB supported. My less than $700 build is suddenly causing me issues.. BLEH!!


But serious thanks to @millusions @Allan for attempting to help me so much over other threads. 

Share this post


Link to post
Share on other sites

Well I am finally up and running completely and stably. I was still having trouble with getting full graphics acceleration when a user in another thread recommended using a clover folder from someone else's build that he was able to get functioning.

Well I gave it a shot and sure enough I have everything up and running perfectly now. I will probably take the next week to make little tweaks here and there to ensure everything is stable, then upgrade to Mojave. Once that is done and stable I can call this complete!

 

I still need to go through the other users Clover>Kexts>Other folder to see what was different and also their clover settings. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By 22eme_arkane
      Hi everyone !
       
       I build a new os on High Sierra and i have problem with my Skarkoon RAID 5 - 5 bay, is unmounting, work fine in windows but not in Mac Os.
      I use a card eSata in chipset Marvell 88SE9215, and i have the kext 3-party eSata  but nothings change.
      I try with the AppleAHCIPort.kext v328, nothings change.
       
      Any solution ?
       
      Thanks a lot !
       
      Config : GA-Z68X-UB3-B3 // BIOS UEFI, Version: U1f //
    • By bummercheese
      I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.
       
      Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

      Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.
       
      I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.
       
      I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.
       
      I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. 
    • By gannok
      Hello and thanks for taking the time to read this, I can't seem to get past this screen, I've tried booting in verbose and safe mode to help diagnose the issue, but it keeps looking like the system is rejecting my CPU? am I forgetting something to do in the bootloader menu of clover on the drive? Kernel extensions? or the plist files? I've tried a lot of things. help would be much appreciated.

      Don't have access to download the Mojave installer and try that, but I assume it would be similar to this.

      I have included my EFI boot loader, and the error in hopes that it may help

      System build here

      Z370 Aorus Ultra Gaming Wifi
      i3-8100
      32GB ballistix ddr4
      RX560 4GB

      EFI.zip
    • By laelsirus
      GA-B360M D3H with UHD630 iGPU AMD dGPU CLOVER
      Specifics
      CPU : Intel® Core™ i7-8700 Processor (12M Cache, up to 4.60 GHz) Mainboard : Gigabyte GA-B360M D3H Durable Edition Graphics : Intel® UHD Graphics 630, SAPPAIRE RX 570 4GB Sound : Realtek ALC892 Wireless : BCM943602CS Bios/Clover Bootloader/macOS Version
      Bios : F12 Clover Bootloader : v2.4k r4920 (or Higher) macOS : Above 10.14 Bios Setup
      Load Optimized Defaults [Internal Graphics] Enable Kexts
      AirportBrcmFixup.kext AppleALC.kext BrcmFirmwareRepo.kext BrcmPatchRAM2.kext EFICheckDisabler.kext FakeSMC_ACPISensors.kext FakeSMC_CPUSensors.kext FakeSMC_GPUSensors.kext FakeSMC_LPCSensors.kext FakeSMC_SMMSensors.kext FakeSMC.kext IntelMausiEthernet.kext Lilu.kext USBPorts.kext - Hackintool generated VoodooPS2Controller.kext Issues
      none
       
      Files and Details (Github)
      https://github.com/laelsirus/Dell-Latitude-5290-2-in-1-UHD620-iGPU-CLOVER
       



×