Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By pink101
      So, here's what i think clover do when it patch ati framebuffer, first it read a cached kext, then it search the original hex value of the connector, then it changed the value with the new one. Is it correct? now, here's what i find confusing... let's say that i want to patch AMD7000Controller.kext, in that kext, i want to patch "AJI" framebuffer with a new value, so clover try to find the hex value of "AJI" connector then replace it with the new one, simple right? but when i search the AMD7000Controller binary file for other framebuffer, some of them didn't exist in the binary, for example, i tried to patch "Ramen" framebuffer, from various source, it said that:
      Ramen (6) @ 0xeba70 LVDS, HDMI, DP, DP, DP, DP 020000000001000039050108000000002001050600000000 000800000402000000010200000000001000030500000000 000400000403000000010343000000001102010100000000 000400000001000000010431000000002103040300000000 000400000403000000010563000000001204020200000000 000400000001000000010651000000002205040300000000 So i open a hex editor and search for:
      020000000001000039050108000000002001050600000000000800000402000000010200000000001000030500000000000400000403000000010343000000001102010100000000000400000001000000010431000000002103040300000000000400000403000000010563000000001204020200000000000400000001000000010651000000002205040300000000 but, it turns out that hex editor couldnt find that hex value in AMD7000Controller,

       
      most of the framebuffer exist in the AMD7000Controller, but some doesnt, If this is the case, then, where does clover find the original framebuffer to be patched? am i missing something?
       
       
    • By ngochoaic3
      Hi everyone, 
      I hava a dell precision m4700 with option dgpu amd firepro m4000, The Intel HD4000 Graphic is disable, i can't enable it on to install Hackintosh
      I'd like to enable it on and ask you for setting custom connectors to get the internal display to work, and enable the iGPU in order to get things like AirPlay screen mirroring to work
      Could you help me?
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.6 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
       
      EliteDesk800 G4 Mini - Rev 1.0.zip
    • By ISmokeAir
      I am using opencore. I have an asrock z270 și killer and a core i7 7700k. I don't have a dgpu. I am using the integrated igpu(UHD 630). After booting up I get this kernel Panic.
       
    • By sapnupuas69
      hello everyone, so my Intel HD 530 is not getting recognised by macOS. In the about my mac section, it shows as 'Display 7mb'
      Im using HDMI connected to motherboard. I can only boot into os with 0x12345678 or 0x193b0005 as Fake Id and 0x19120000 as platform id with Mac17,1 as smbios. I do have the latest version of Lilu and WhateverGreen installed in boot loader and in L/E too. 
      I have looked through many forum posts, and have not found a solution yet. 
       

      edit: i forgot to change the smbios in the picture, I tried changing to 17,1 and restart, still no luck
      EFI.zip
×