Jump to content
Sign in to follow this  
Followers 0
vanadium

[Guide] Thinkpad T440p (Mojave 10.14.3)

10 posts in this topic

Recommended Posts

Posted (edited)

Lenovo Thinkpad T440p Hackintosh (Tested on High Sierra 10.13.6 and Mojave 10.14.3)

 

2019-01-23

MacOS Mojave 10.14.3 works fine! Upgraded from Mojave 10.14.2 without any issue. After update, I just had to rebuild kexts cache:

 

sudo kextcache -i /

 

Tutorial

 

The zip file contains everything you need to have a Thinkpad T440p Hackintosh work flawlessly:

- Brightness control (with keyboard shortcuts),

- HD4600 graphical acceleration (QE/CI),

- power management (sleep, CPU thermal control),

- secondary HDD in ultrabay, (requires AHCI kexts in `/Library/Extensions`)

- Audio (internal speakers ok, but 3.5mm jack not working)

- T450 Trackpad driver from T460 guide written by @tluck

- Intel Ethernet controller,

- USB ports custom mapping,

- Wifi using TP-Link wn725n USB Adapter (much cheaper than Broadcom mini-pci cards),

- and battery management.

 

I initially followed the guide provided on TonyMacX86, but it was sadly a bit out of date. So I worked a couple of days on it to use the latest kexts and config.plist settings available.

 

It runs very well on mine with the following configuration:

 

- Intel Core I7 4712MQ,

- Motherboard with HD4600 only (but the patched SSDT automatically disables the Nvidia GT730M if any found)

- 16GB RAM Samsung Sodimm DDR3L 1600Mhz,

- 2.5 inches Western Digital Blue 500GB SSD in primary SATA bay, (TRIM enabled forcefully using Terminal)

- 2.5 inches Western Digital Blue 1TB HDD in ultrabay (replaces the optical drive),

- Synaptics T450 Trackpad,

- FullHD (1920x1080) IPS Panel.

 

A french guide is available here: Thinkpad T440p Hackintosh

t440p-macos.jpg

Edited by vanadium

Share this post


Link to post
Share on other sites
Advertisement

Hello,

 

Noticed the Boot folder is not included in the zip only Clover. Could you please check and add.

 

 

Many thanks,

 Art

Screen Shot 2019-01-14 at 1.04.37 PM.png

Edited by gwn
Fix image

Share this post


Link to post
Share on other sites

I created a Mojave Install usb drive then mounted EFI partition and created EFI folder with your Clover folder. Next I copied Boot folder from my own EFI folder on a T430 with Mojave. When I booted the usb on T440p the boot menu appeared with Clover options but the actual Install Mojave was not visible. Would you mind checking this as well.

P1340197.JPG

Share this post


Link to post
Share on other sites

I may have narrowed the problem down to the files in Drivers64UEFI folder. Your files are

ApfsDriverLoader-64.efi
AppleImageLoader-64.efi
AppleUISupport-64.efi
AptioInputFix-64.efi
AptioMemoryFix-64.efi
DataHubDxe-64.efi
FSInject-64.efi
SMCHelper-64.efi

 

When I substituted my T430 files the USB volume finally appeared in the boot. They are

FSInject-64.efi
HFSPlus-64.efi
NTFS-64.efi
OsxAptioFix2Drv-64.efi
OsxFatBinaryDrv-64.efi
SMCHelper-64.efi
apfs.efi

 

Now booting the Mojave Install option it reaches the Mac OS Install menu and when I tried to install to the hard drive it progresses to two minutes left then screen blanks out and reboots back to the Clover menu. Note the hard drive was initialized with Mac OS Extended (Journaled) and GUID partition.

 

 

Share this post


Link to post
Share on other sites

Right, I have included the Apfs driver but not the HFS one (as most install on SSD which is going to be converted to APFS by MacOs Mojave anyway). I'm going to include the boot folder too, thanks!

Share this post


Link to post
Share on other sites

Cannot get Mini DP

Mini DP -> HDMI

Mini DP -> VGA

 

VGA -> VGA

 

none of these external monitors is working.

 

I have it working on Dell e7440 and is also using Haswell CPU, can you help us make that patch?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×