Jump to content
vladboing

Need help with Lenovo 330s-14IKB

11 posts in this topic

Recommended Posts

Hi everyone, recently got a Lenovo 330s-14IKB, it has 14' 1080p display, Core i5-8250u CPU, Intel UHD 620 GPU, and 8gb RAM. I see on our forum that it's posssible to make it run Mojave, but I have have no luck even getting to the installation of it, the laptop just restarts after ~2 minutes after starting booting from the USB drive.
Can you please help me with making this machine run Mojave or at least Sierra, Thanks everyone, you are the best!

Share this post


Link to post
Share on other sites
Advertisement
11 hours ago, Allan said:

Hi!

 

Follow this guide

 

Hi! Thank you for the link, but with this guide, trying to boot Mojave installer, I stuck at: End RandomSeed, here is the screenshot

IMG_20181226_082126.jpg

 

Trying to boot the Sierra installer ends with this:
 

IMG_20181226_084658.jpg

Edited by vladboing

Share this post


Link to post
Share on other sites
38 minutes ago, Allan said:

You have configured your BIOS correctly?

Do a quick research in the Forum or in Google, and you'll see the right settings.

Yes, the BIOS is configured, like it's recommended in guides:
PTT disabled,
Secure Boot disabled
Boot mode - UEFI
etc.

Share this post


Link to post
Share on other sites
13 minutes ago, Allan said:

Try inject this values to your video:

 

- GRAPHICS: Check InjectIntel
- GRAPHICS: “ig-platform-id” changed to 0x591b0000
- DEVICES: “Fake ID” for IntelGFX changed to 0x59168086

 

Source: https://olarila.com/forum/viewtopic.php?t=6257

Credits: @MaLd0n

Got a bit further, but got a KP, here is the screenshot of it
BTW, thank you so much, helping me!

IMG_20181226_150719.jpg

Share this post


Link to post
Share on other sites
5 hours ago, vladboing said:

But how I can run that patcher, if I can't even get to installer?

for install uncheck injectintel and use intelgfx 0x12345678

Share this post


Link to post
Share on other sites
On 12/27/2018 at 3:21 AM, MaLd0n said:

for install uncheck injectintel and use intelgfx 0x12345678

This worked like a charm, finally got to the installer, thank you so much!
I'll be back, if there will be any problems after install, thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×