Jump to content
oneghost

Gigabyte Z390 Aorus Master - request for help with DSDT

3 posts in this topic

Recommended Posts

DSDT_ORIGIN_GB_Z390_Aorus_Master.zip

Could someone help me with patching DSDT for this MOBO? I'm having problem with iGPU of i9-9900K, maybe this would help. It's detected as "Display 7MB" and no acceleration is working. I can make force it by using custom values in clover, but then I get no output from HDMI. 

Also please add any patches that you can think of that will help with this board.

Thank you.

Edited by oneghost

Share this post


Link to post
Share on other sites
Advertisement

I was able to get an ASRock Z390 working by spoofing ig-platform/device-id as 0x3E9B8086 or 0x3E928086. I think "AddIntelHDMI" is audio related but didn't hurt my machine to have it on. 

 

However, I think your issue could be due to the graphics config. It sounds like you are using only the iGPU -- you should also make sure you have the right SMBIOS (one without a dedicated card), or spoof your ig-platform-id as 3E9B0000 or 3E920000 -- if you don't override this, it will be taken from your SMBIOS, which might have a dedicated card / an ig-platform-id that is associated with a dedicated graphics card -- this could be causing your graphics to not work after boot as it's not targeting the right output.

Share this post


Link to post
Share on other sites

DSDT.aml.zip

 

use

 

GLAN to GIGE
474c 414e
4749 4745

GFX0 to IGPU
47465830 
49475055 

HDAS to HDEF
48444153 
48444546 

HECI to IMEI
48454349 
494d4549 

SAT0 to SATA
53415430 
53415441

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×