Jump to content
Razak

(processing) Surface pro 6 - High Sierra and Mojave

6 posts in this topic

Recommended Posts

Hello,

 

This post is reserved to step-by-step guide for installing High Sierra and/or Mojave on Surface Pro 6, released on 2018.

As I haven't succeeded to install High Sierra or Mojave, It will be partially written.

 

See posts in below to help each other for figuring out the installing process of High Sierra and/or Mojave on Surface Pro 6.

Edited by Razak

Share this post


Link to post
Share on other sites
Advertisement

I tried to install High Sierra and Mojave on Surface pro 6 (i5, 256 GO, 8go model). I tried each Clover published in this forums and many suggested on other websites.

I am blocking at end randomseed. The computer is totally stopping/stuck. I couldn't even write anything.

 

1335201826_HackintoshRAMNotDetected.thumb.jpg.1b508796ce2b8c0f8205ba1441eb1bad.jpg


root device uuid is ’xxxxxxxx—-'
End InitBootStruct
Start LoadRamDisk
End LoadRamDisk
Start FinalizeBootStruct
Start RandomSeed
End RandomSeed

+++++++++++++++++++

 

Did someone overcome this issue?

 

Share this post


Link to post
Share on other sites

Having the same issue. I'm beginning to fear it's an incompatibility rendered by the most recent firmware update, as everything I can possibly try is doing nothing to fix it. 

Other forums and threads past have talked about memory incompatibilities being the root of this error message, but none of the alternate drivers for Clover have worked, at least the ones I've tried.

Let me know if you figure anything out. 

Share this post


Link to post
Share on other sites
 

I tried to install High Sierra and Mojave on Surface pro 6 (i5, 256 GO, 8go model). I tried each Clover published in this forums and many suggested on other websites.

I am blocking at end randomseed. The computer is totally stopping/stuck. I couldn't even write anything.

 

1335201826_HackintoshRAMNotDetected.thumb.jpg.1b508796ce2b8c0f8205ba1441eb1bad.jpg


root device uuid is ’xxxxxxxx—-'
End InitBootStruct
Start LoadRamDisk
End LoadRamDisk
Start FinalizeBootStruct
Start RandomSeed
End RandomSeed

+++++++++++++++++++

 

Did someone overcome this issue?

 

I am having this same exact issue, did you ever get past it?

Share this post


Link to post
Share on other sites
On 11/29/2018 at 11:00 PM, Razak said:

I tried to install High Sierra and Mojave on Surface pro 6 (i5, 256 GO, 8go model). I tried each Clover published in this forums and many suggested on other websites.

I am blocking at end randomseed. The computer is totally stopping/stuck. I couldn't even write anything.

 

1335201826_HackintoshRAMNotDetected.thumb.jpg.1b508796ce2b8c0f8205ba1441eb1bad.jpg


root device uuid is ’xxxxxxxx—-'
End InitBootStruct
Start LoadRamDisk
End LoadRamDisk
Start FinalizeBootStruct
Start RandomSeed
End RandomSeed

+++++++++++++++++++

 

Did someone overcome this issue?

 

The USB port loses power at this point, i think it unmounts and you cant run the rest of Clover. Probably need to try other USB 3 kexts? I'm going to try boot from SD card or else boot from a partition in the SSD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×