Jump to content
XOBX

No picture on the built-in Monitor. Nvidia 650M

6 posts in this topic

Recommended Posts

Hello Everybody
Have Mojave successfully installed without any error. But I can only start Mojave with nv_disable = 1.
If I start without nv_disable the screen will remain black.
The same thing happens with all versions after Mavericks.
The PC has an HDMI In / Out connection.

995061965_HDMIIn-Out.jpg.a66c33627a144c315bc47e0164e32037.jpg


About the HDMI connection Works everything. The graphics card is recognized correctly. The graphics acceleration works wonderfully. But the built-in Minitor stays black.

I have a fully functioning Mavericks. I can not update it. When I update the same thing happens as above.

 

My PC is an AIO Lenovo B540P

Intel Core i5-3350P Ivy Bridge-DT
Board: LENOVO MAHOBAY
Chipset: Intel H77 (Panther Point Base)
NVIDIA GeForce GT 650M GK107M / N13P-GT (Kepler) Usually it does not need a driver. Is the same as Imac 13.1 only with 2GB of RAM

 

It is the only graphics card in the system.

 

 

That's on my TV via HDMI Out.

20181116_094514.thumb.jpg.59138978f8323a5deedcb59c6ed6c80e.jpg

20181116_094720.thumb.jpg.531c67c4da2450c77499ea4e3c1a6893.jpg

 

I can not get any further.
I think the problem is due to the HDMI Out.
I have to direct it to the internal connection but unfortunately I do not know how?

I do not have that much knowledge about OSX

 

 

With nv_disable I see picture but the resolutions are wrong and the graphics acceleration is not available.
Like here in the picture.

20181126_033352-1710x1090.thumb.jpg.617c47ad048d3dd5156cfa41185e1db0.jpg

 


The system loads the correct drivers, but somehow does not recognize the internal monitor connection.

I have to find out where in the OSX system this is. Or I have in the OSX system HDMI Out disable and redirect it.
This is not possible in the Config.plist

20181116_094446.jpg

Share this post


Link to post
Share on other sites
Advertisement

Hello.

ALC was not inside but the other 2 already. Even with the 3 and the boot parameters the screen stays black.

 

About HDMI Out comes picture. Can not adjust somewhere Monitor 1, 2. HDMI Out On / Off?

 

I have a fully functioning Mavericks. Where can I check what is different here than the Mojave. Which area of OSX is responsible for this?

Edited by XOBX

Share this post


Link to post
Share on other sites

Hi@ styrian

 

Yes. But I normally do not have to set anything. If I were to use the AIO with an external monitor, everything would be fine. I do not normally have to adjust anything in the Clover. I can start an original OSX system from my MacBook with Clover Bootstick. But full resolutions only via HDMI Out.

Share this post


Link to post
Share on other sites

I had this problem a long time ago, after mavericks 10.9.2 update NVDAResman.kext stops supporting LVDS.

 

I don't think any developers are able to fix this for many years now.

 

only thing I could do was plug the HDMI-out to the HDMI-In as a loop and then the screen works.

 

I tried again recently with Lilu + whatevergreen but this is still an issue.

 

also, currently AppleALC does not fully support GK107 audio it seems, no volume control is present.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×