Jump to content
Sign in to follow this  
Followers 0
emeee

How to configure HWP through clover

14 posts in this topic

Recommended Posts

My system: Majove 10.14.1, SMBIOS: macmini8,1, cpu:8700

I inject plugintype and select plugin type as 1 in Clover, by doing this HWP is enabled.
However, I get this:
IA32_HWP_REQUEST................(0x774) : 0x202E2E08

This configuration sets the performance level at 20 (first two bit), which prefers performance more.
I want to change 20 to 80 (i.e., 0x802E2E08) to reduce performance and save power.

How can I achieve this goal? Could anyone help me? Thank you.

Share this post


Link to post
Share on other sites
Advertisement
3 hours ago, Hervé said:

Have you tried this?

HWP_settings.jpg.b9430b74a872cfb7402b8bfd55d1f6d2.jpg

 

Thank you. I have tried this. It did not work.

I find that if I inject the plugintype, the HWP will be enabled, but the HWPValue will not work.

Do not know the reason.

948364099_ScreenShot2018-11-23at08_23_45.thumb.png.51164985e3ba5f12792ce38034a5f8c6.png

Edited by emeee

Share this post


Link to post
Share on other sites

The thing is why do you want to reduce performance and save power on a desktop computer? It's not as if you'd be interested in extending battery life...

Share this post


Link to post
Share on other sites
17 hours ago, Hervé said:

The thing is why do you want to reduce performance and save power on a desktop computer? It's not as if you'd be interested in extending battery life...

 

The reason is that my Alienware desktop do not allow to set fan speed in BIOS, and the default fan strategy is strange.

Though the CPU temp is only 35 c, the fan will increase the speed when the CPU frequency increases.

For example, when I open a website or an application, the transient CPU frequency increases to around 4.3 Ghz immediately, then the fan will suddenly run in a high speed with high loud.

 

Share this post


Link to post
Share on other sites
20 hours ago, styrian said:

Hello!

 

Please post your clover folder.

 

Have fun.

 

Is it related to clover settings? just want to know how to set HWP.

Share this post


Link to post
Share on other sites
10 hours ago, styrian said:

 

With newer version of Clover, it works in a different way, HWP can be enabled by simply injecting plugintype and select plugin type as 1.
However, by doing this you get:
IA32_HWP_REQUEST................(0x774) : 0x202E2E08

This configuration sets the performance level at 20 (first two bit), which prefers performance more.
My question is how to to change 20 to 80 (i.e., 0x802E2E08).

Share this post


Link to post
Share on other sites
On 11/25/2018 at 8:46 AM, emeee said:

 

With newer version of Clover, it works in a different way, HWP can be enabled by simply injecting plugintype and select plugin type as 1.
However, by doing this you get:
IA32_HWP_REQUEST................(0x774) : 0x202E2E08

This configuration sets the performance level at 20 (first two bit), which prefers performance more.
My question is how to to change 20 to 80 (i.e., 0x802E2E08).

 

Have you tried what Herve sent you and uncheck the Plugin and type?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×