Jump to content
Sign in to follow this  
Followers 0

General question mojave harware

5 posts in this topic

Recommended Posts



Im glad to be a part of this forum. Just signed up 20 mins ago.

I have an old macpro 2008 fully loaded using yosemite 10.10.5.


I would not like to touch that OSX version but been curious with mojave on hackintosh PC.


i also have a low/mid range gaming windows PC.


My specs for my W7/10 dual boot (same SSD) windows PS are as follows:

Motherboard: Asus P8B75-V

Intel i7 3770k

8GB DDR3 1600mhz RAM

Antec HCG 620W PSU

Asus GTX 560 DC

Corsair Force GT 120GB SSD


Built everything in mid 2012.


Will these hardware lets me install Mojave? If not, whats the max OSX i can install? 

Then worst case, will i be able to install atleast yosemite 10.10?

I dont mind if i get Nullcpupowermanagement and not be able to use my bios C1 packages and sleep or any intel speedstep as i dont use them anyways in my windows OS.

i just need it to work smoothly with MB audio built-in, wifi, ethernet, Usb port 2.0 and 3.0.

im not a gamer but likes to use Logic pro X.



was thinking of using the W10 partition for the hackintosh OSX but if possible, i could use a 64GB USB 3.0 thumbdrive.


Thanks in advance.











Share this post

Link to post
Share on other sites

Your system should be able to hackintosh. However, Metal does not support Fermi GPUs. It might be possible to make it run on Mojave, but due to the lack of Metal you'll experience some graphical issues.

High Sierra should run fine, or upgrade your GPU (e.g. Kepler)

Edited by ricoc90

Share this post

Link to post
Share on other sites

So my sytem is hackintoshible?

you have just made me very excited. 


is the Intel HD4000 built in the i7 3770k will do for mojave?


also one more thing. Is it possible to use a 64GB USB 3.0 thumb stick on PC and use that as my main boot drive instead of a 2,5  3,5 HDD?


ill make sure to run all usb sticks on USB 2.0 porta only for full compatiblity. 

Edited by Macpro3.1

Share this post

Link to post
Share on other sites

Intel HD4000 will do for Mojave indeed. 

It should be possible to run macOS off from a USB Stick, but I don't think it'll do any good to the overall performance of the OS.

Share this post

Link to post
Share on other sites



just want to update on this thread that the system is still going strong. Pretty stable with the rig im using. 


Id gladly help if anyone needs. 



Now instead making a new thread for a new build about id specific hardware would work for hackintoshing, i decided to wake this thread up. 



I recently got my hands on a windows PC running. 8.1 and id like to hack it to mojave using a different drive. 


Hardware is as follows:


MB: asus m5a97 r2.0

CPU: AMD FX 8320 

RAM: kingston hyper x fury ddr3 16GB

PS: xfx 850watts PRO

GPU: Sapphire HD 7970 dual X non OC edition. 


Will this do a clean install of mojave or is it better to run from yosemite10.10.5 and then update to mojave?





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By simras

      I am trying to make a new Hackintosh under 10.13 with this specs:
      i7 6800K,
      Asus X99-E
      Asus GTX 970

      But the problem is that I can't pass those errors :
      - couldn't allocate runtime area
      - end randomseed ++++++++++++++ _

      I have always passed this thing on all hackintoshs that I have done, but here, impossible.

      Tried those tests :
      - AptioMemoryFix alone,
      - AptioMemoryFix with EmuVariableUefi and RC Scripts,
      - OsxAptioFix2Drv-free2000 with EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFix2Drv, EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFix2Drv, OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFix2Drv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFix2Drv, OsxAptioFixDrv, EmuVariableUefi and RC Scripts.

      I have tried all this with npci=0x3000 that I have never used before instead of npci=0x2000

      I have done an Hackintosh on Asus X99 Deluxe II and it pass with AptioMemoryFix with EmuVariableUefi and RC Scripts....

      I have tried to reset NVRAM with F11.

      I have tried with 1 RAM stick that I have indicate in the SMBIOS :
      I have follow KGP guide for X99 :
      The BIOS settings are exactly the same.

      I link my CLOVER folder.

      Thank you.
    • By mpe
      After wakeup my system is slow, console input show some duplicate character when I type some commands. Intel Power Gadget is shows no more statistics.
      I am looking for solution several days, but I can't find.
      Maybe some one have the same system or tips for me?
      I have already attach the Runme.app zip
      Best regards,
      Send me mpe.zip
    • By AwlsomeAlex
      My Laptop:
      ASUS ZenBook UX330UAR
      8GB RAM / 256GB SSD
      Intel i5-8250U
      1920 x 1080 (UHD 620)

      After using this guide to setup my laptop as a Hackintosh (macOS 10.14.6), every once in a while it'll result in the screen flickering, and usually the intervals between the flickering get smaller and smaller to the point where sometimes the screen just panics. I tried injecting my EDID and setting my SMBIOS to iMac18,1 but none of those defeated the dreaded flickering. 

      Any assistance would be greatly appreciated!
      EDIT: I'd also note that this does not happen with Linux nor Windows so it is a macOS issue not a hardware issue. 
    • By Criis87
      Hello guys, how are you? I have been trying to make this work for the last 3 days but I really can't. I have a 2500K overclocked from 3.3ghz to 4.4ghz but my Hacki doesn't seem to care . I have used Piker Alpha script to make a new SSDT and move into EFI/Clover/ACPI/PATCHED but it seems its not being loaded in clover? I attached a print below. My mother is an Asus p8p67 deluxe.

      This is my AppleIntelinfo:

      CPU Ratio Info:


      CPU Low Frequency Mode.............: 1600 MHz

      CPU Maximum non-Turbo Frequency....: 3300 MHz

      CPU Maximum Turbo Frequency........: 5900 MHz

      CPU P-States [ (16) 32 33 ]

      CPU C3-Cores [ 1 2 ]

      CPU C6-Cores [ 1 2 ]

      CPU P-States [ (16) 26 32 33 ]

      CPU C3-Cores [ 1 2 3 ]

      CPU C6-Cores [ 1 2 3 ]

      CPU P-States [ (16) 26 30 32 33 ]

      CPU P-States [ 16 26 30 31


      Cpu goes from 1.6ghz to 3.3ghz max, in won't use overclock at all, it locked to 3.3ghz max. 
      These are my kexts in HD/Library/Extensions:

      In Windows 10 partition overclock is being shown by CPUZ, 4.4ghz as it is. If I am missing something can you please give me a hand? Thanks in advance!!