Jump to content
BrianWong11031

My hackintosh won't sleep!

20 posts in this topic

Recommended Posts

Hi, my hackintosh won't sleep!

It often sleeps for 3-5 seconds and auto wakes up.

sometimes it can't enter the sleep mode even you click the sleep button.

I have uploaded my DSDT file.

but I don't know how to patch DSDT.

If you know how to solve this issue, please help me!

 

Cheers,

Brian

DSDT.aml

Share this post


Link to post
Share on other sites
Advertisement
42 minutes ago, MaLd0n said:

CLOVER.zip

generate one ssdt for CPU PM

https://olarila.com/files/Utils/SSDT_Automator.zip

 

i think u need a correct config for IGPU, IGPU don't need appears in "Graphics and Monitors", there appears only a principal GPUMaLd0n 2018-11-14 às 10.12.16.pngMaLd0n 2018-11-14 às 10.11.47.pngMaLd0n 2018-11-14 às 10.11.40.png

check mine

 

So what I need to do is use your clover files to instead mine?

do I have another thing to do about CPU power management?

Thanks

Cheers,

Brian

Share this post


Link to post
Share on other sites

After you have a good hackintosh configs; Sometimes.. sleep-wake issue could because apps, or hidden background services that are running on your system as well. Identify the problem with Terminal:

pmset -g assertions

 

Edited by Badruzeus

Share this post


Link to post
Share on other sites
30 minutes ago, MaLd0n said:

idk to, never use it in ur GPU

 

CPU PM, for ur proc, the best is SSDT

Hi,

After I used the application which you sent to me to create a SSDT, but the issue still not solved.

the monitor shows "No signal" even I pressed the power button.

Thanks for helping me.

 

Cheers,

Brian

32 minutes ago, MaLd0n said:

idk to, never use it in ur GPU

 

CPU PM, for ur proc, the best is SSDT

By the way, there's one thing that I have not told you yet.

I have enabled the iGPU multi monitors option in BIOS because I want to use AirPlay.

and I have not do anything with my iGPU but I have inject 0x00030010 as ig-platform-id in Clover->Graphics.

 

Cheers,

Brian

Share this post


Link to post
Share on other sites

May I know how to enable iGPU with High Sierra?

Thanks.

Or Mojave is better.

Because I think iGPU is more compatible than NVIDIA graphics card.

I mean use ONLY IGPU.

I tried that but not successes last time.

there's 4 error messages I've got.

1. IOConsoleUser....(still waiting for help)

2.Sound Assertion in AppleHDADriver at....(still waiting for help)

3.Waiting for DMSOS.... (SOlVED - FAKE SMC VERSION ISSUE)

4......... reboot.(SOLVED - NEED TO CHECK A BOX IN CLOVER)

 

Thanks for helping guys!

 

Honestly, I don't know many things about Hackintosh.

SO, thanks for your patient!

 

Cheers,

Brian

Share this post


Link to post
Share on other sites
On 11/14/2018 at 8:13 PM, MaLd0n said:

CLOVER.zip

generate one ssdt for CPU PM

https://olarila.com/files/Utils/SSDT_Automator.zip

 

i think u need a correct config for IGPU, IGPU don't need appears in "Graphics and Monitors", there appears only a principal GPUMaLd0n 2018-11-14 às 10.12.16.pngMaLd0n 2018-11-14 às 10.11.47.pngMaLd0n 2018-11-14 às 10.11.40.png

check mine

 

HI,

my Hackintosh won't wake again...

Send me huanghaoyuans-iMac.zip

Share this post


Link to post
Share on other sites
some monitors 4k wake fail, check it

My monitor only supports 1080p


Sent from my iPhone using Tapatalk
some monitors 4k wake fail, check it

SO, what I need to do next?
I really need it. It almost makes me crazy!!!
It can t wake up while I am using it to do some projects.



Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
10 minutes ago, BrianWong11031 said:


My monitor only supports 1080p


Sent from my iPhone using Tapatalk
SO, what I need to do next?
I really need it. It almost makes me crazy!!!
It can t wake up while I am using it to do some projects.



Sent from my iPhone using Tapatalk

i think have a solution, some ppl have same problem, check in search forum

Share this post


Link to post
Share on other sites
i think have a solution, some ppl have same problem, check in search forum

I’ve done a lot of research on the internet, but I cant find a useful method to solve this issue...


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By soumaxetuirk
      If you have a working Brightness Slider and you might be using Brightness slider or manual hotkeys to control brightness then this guide may help you to use your Native hotkeys of laptop.
       
      (All the Credits goes to @RehabMan     For OS-X-ACPI-Debug Kext and DSDT Patches.)
       
       
      This step assumes that you are using RehabMan's VoodooPS2Controller
      Install the kext: https://github.com/RehabMan/OS-X-ACPI-Debug Open MaciASL and click on patch.(Add rehab man repo) Apply "Add DSDT Debug Methods" and "Instrument EC Queries" that are under Brightness Fix. Save the DSDT and restart Look in Syslog as you press the key corresponding to brightness to determine which _QXX methods handle the keys (UPDATE: From Sierra Apple changed logging process. So you won't find ACPIdebug result using syslog command. Instead use following command )
      log show --last 5 | grep ACPIDebug 6. Then patch DSDT:
      into method label _Q1D replace_content begin // Brightness Down\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0205)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0285)\n end; into method label _Q1C replace_content begin // Brightness Up\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0206)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0286)\n end; Change the variable _Q1D/_Q1C as per the log. 

      7. Try compiling and check if it generates errors
      8. If it does, then change the PS2M to PS2X according to the one found in your DSDT
      9. Save and place the compiled DSDT.
      10. Now you should see that you have your corresponding keys to change your brightness 
       
       
       FOR  more detail and Queries,Check Out original Post of @RehabMan Here;
      http://www.insanelym...18#entry1997112
      Get Latest Version of  OS-X-ACPI-Debug kext here:
      https://bitbucket.org/RehabMan/os-x-acpi-debug/downloads
    • By plasticduck35
      I have a hackintosh running 10.13.5 (High Serria) that works except it doesn't shutdown properly and it doesn't seem to be going to sleep. 
       
      Here are some diagnostics that I gathered 
       
      Davids-MacBook-Air-2:~ davidozersky$ sudo pmset -g Password: System-wide power settings: Currently in use: hibernatemode 0 womp 0 networkoversleep 0 sleep 5 (sleep prevented by diskmanagementd, UserEventAgent, mds, diskarbitrationd, coreaudiod, mds_stores, Disk Utility) Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage disksleep 10 displaysleep 5  
      And I've attached files from a RunMe utility app I've found online. 
       
       
      Any ideas? 
       
      Thank you, 
      David
      runmereport.ioreg
    • By Drovosek
      Hey.
      I have a Dell Vostro 3267 system unit. It has a Skylake processor Intel Core i5-6400 with integrated graphics Intel HD 530, 8 GB RAM, 256 GB SSD. The monitor is connected via HDMI.
      I faced a problem that if I enter Hackintosh in a sleep mode, and then I press something on the keyboard, the system unit wakes up (I hear as coolers begin to turn), but the monitor does not react in any way.
      I tried to disconnect and reconnect the HDMI cord, tried to inject EDID in config tried to change SMBIOS on MacMini8,1, but it did not change the situation.
      How to solve the problem?
       
      P.S.
      All in Mojave 10.14.6
      CLOVER.7z
×