Jump to content
Sign in to follow this  
Followers 0
hacc

El Capitan on Asrock ION 330

1 post in this topic

Recommended Posts

So for the past few days i've been tryinng to install El Capitan on this thing - An Atom 330 nettop with the ION chipset.

 

I used a usb installer i had created with macpwn some years ago. Pretty much all I had to do was to enable kernel patching in clover and the installer ran just fine, could format the HDD and install the system to it. But that's where my luck ended.

 

According to this thread about the Asus 1201n, which has the ION chipset and Atom 330 cpu, El Capitan should be possible, but I'm having a hard time with clover. There is a guide to get clover running on the machine, but the links are broken.

 

The macpwn usb with clover couldn't see my HDD, so i downloaded the latest clover and installed it onto the hdd from another machine, the thing always showed the grey efi screen with some boot options indicating it can't find the clover efi file (according to the clover wiki). I tried an older version of clover and also tried the biosblockio (supposedly should be working on all sata controllers supported by the bios) option, but with no luck.

 

I then tried to install clover on another flash drive, but choosing the regular sata option it wouldn't see my hdd and with the biosblockio option it didn't even load up (stuck with a text cursor on the top left corner of the monitor not doing anything).

 

I did some investigating about the "1201n support package" presented here and found this github repo containing most likely the source files for the compilation of a pkg or something. There I found "ION-64.efi" in the drivers64 folder, thinking it was the driver for the sata controller on the ion chipset.

 

I put the file on my el capitan installer usb with clover and that did produce some success. Clover could finally see my hdd and I tried booting from it. The boot process, however, failed on "Still waiting for root device" indicating that it still couldn't access the hdd.

 

So if anyone still has any knowledge about running clover on the ION (MCP79) chipset, please share it (I'm pretty sure I need to use biosblockio, but had no success in getting clover to work with it)

Thanks!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×