Jump to content
Graeme43

No picture HD4600

4 posts in this topic

Recommended Posts

Hey, 

 

I have a Gigabyte Z97M-D3H rev 1.0 with F8 bios, 4690K CPU and nv 980 running 10.13.6. Been trying to get the HD4600 to run for the past few months. Getting kextd stall or busy timeout for the iGPU and no ability to get to desktop. It will display verbose boot up to 4 iGPU time outs then stops at giolockstate3 but it never gets to the OS.  

 

I'm sure I got into the OS with it before on 10.12. The OS does come up on the 980 eventually while the HD4600 display stuck with the verbose boot ending until i shut down

 

I have tried multiple platform-ids (0x0A160000, 0x0A260000 ,0x0D220003 ,0x0A2E000A ,0x0A26000A ,0x0A2E000D) and other stuff like the whatevergreen frame buffer patch guide.  Don't seem to get far with that either lol

 

Maybe someone can spot an error in the config, clover or ioreg? Sorta looks like its working but theres no ports or something? I'm trying to use the HDMI one on it

 

Cheers

 

 

 

 

IOREG.zip CLOVER.zip origin.zip

Messages Image(2266498235).jpeg

Messages Image(4003926037).jpeg

Messages Image(4292889495).jpeg

 

Edited by Graeme43

Share this post


Link to post
Share on other sites
Advertisement

hi,

i've got HD4600 working easy, just inject Intel. they say you need 64mb of ram in Bios but it worked fine for me with auto or 512MB.

 

but getting it working with another graphics card is a different kettle of fish. it's patchy at best.

even when it works the 2nd screen is not usable, in my experience.

you probably better off hooking up the 2nd screen to the nvidia

Share this post


Link to post
Share on other sites

I want to sell my 980 as I need the money and I would love to be able to get the HD4600 to give me a picture. I had an HD2000(?) Pentium G3220 give me picture on the same motherboard in the past, although its unsupported and 1024x768, it was more than I can get with the HD4600 in 10.13

 

I had HD4600 working in 10.12 as I remember getting the azul patch to stop safari freezing when going to youtube. 


I have tried 10.14.0 also and it gives iGPU timeout

 

It works in Windows fine. I have a secondary machine with Z97N-WIFI board and same CPU, less ram and 1080Ti. Shown on the right side, booted from my backup - it seems to work better than my main machine :( I just use CCC to save my windows on it

 

Thanks

IMG_4679.jpg

Messages Image(2129349367).jpeg

Share this post


Link to post
Share on other sites

I don't know what im doing wrong but it works on the Z97N-Wifi, not the Z97M-D3H. Same cpu model. Just booting off a backup as I use this for non Mac stuff

IMG_4768.jpg

Edited by Graeme43

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Sectum Sempra
      Hi.
      I have a Lenovo Z510-b Laptop which I wanted to Hackintosh.this is my first one so I'm a newbie and don't kjow much.
      I did the process using an easy guide on Hackintosh zone which all I needed to do was to restore a pre maid installer on a usb disk and then boot ETC.
      After installation, I have faced several issues which I have managed to fix some of them gradually, but there are some I couldn't make it work:
      GRAPHICS:
      first of all lets talk about my main issue. The macOS only recognizes 4MB of my igpu and I can't make any difference. ( ill say what I have done for it so far)
      and for my Nvidia graphic I think it won't go so well ( after screwing my laptop up for 3 times) because I only have discrete or igpu option in my bios. ( discrete AFA I heard won't work)
      so im mainly hoping for my igpu.
      Things I have done for igpu:
      Have installed:
      FakePCIID_Intel_HD_Graphics.kext
      FakePCIID.kext
      intelGraphicsFixup.kext.kext using M u L Ti Be a St
      Have done clover settings:
      in devices tab,IntelGfx: 0x4128086
      in Graphics tab, ig-platform-id: 0x0a260006 ( inject EDID and inject Intel checked)
      have checked fix intelgfx in api tab under fixes section
      * I even set the VRAM box in graphics tab to like 64 or 256 to see if it changes anything although I don't really know what is that for lol*
      PS: my bios doesn't have any option to set Vram like some guides suggest.
       
      AUDIO:
      this should be a minor issue. I do have the audio working using "M u L Ti Be_a St "and re booting after installing "100/200/300 series Audio Support" under "Realtek ALCxxx" section under audio tab under drivers section. but when I restart again, it just goes off! 
      the installation suggests "Adds Rename HDAS to HDEF patch to /Volumes/EFI/EFI/CLOVER/config.plist." but I had( and still have) this patch in my acpi section! so I don't know what is the deal there; but I think its minor.
       
       
       
      Sorry for long text. I really hope you could help me out. I will now send you the information you need about my laptop specs and will attach my problem reporting files which I made using the script rehab man has suggested. NOTE : I get some warnings and errors during boot (verbous) although it boots perfectly, but I don't know if those are included in my problem reporting file or not, or whether it is important at all or not.but I haven't seen any errors there relating to graphics. ( I might be wrong tho).
       
       
      My laptop:
      Lenovo Z510 
      Inel Core i7 4702MQ
      Intel HD 4600
      Nvidia Geforce GT740M
      Realtek Audio ( I thing its 230)
      Realtek Ethernet
      Intel Wi-fi ( obviously couldn't make it work)
       
      Thanks in advance!
      debug_3979.zip
    • By dedede2137
      Hello
      I can't use HDMI, when I plug the cable (with laptop off or on), the screen becomes black. What can I do? I tried FakePCIID and AppleIntelHD (actually they are both in my kexts folder). Here's my config. If fixing HDMi is not possible can I make VGA working instead?
      Sorry for my english.
      <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>ACPI</key> <dict> <key>DSDT</key> <dict> <key>Debug</key> <false/> <key>DropOEM_DSM</key> <false/> <key>Fixes</key> <dict> <key>AddPNLF_1000000</key> <true/> <key>FixLAN_2000</key> <true/> <key>NewWay_80000000</key> <true/> </dict> <key>Patches</key> <array> <dict> <key>Comment</key> <string>change EHC1 to EH01</string> <key>Disabled</key> <false/> <key>Find</key> <data> RUhDMQ== </data> <key>Replace</key> <data> RUgwMQ== </data> </dict> <dict> <key>Comment</key> <string>change EHC2 to EH02</string> <key>Disabled</key> <false/> <key>Find</key> <data> RUhDMg== </data> <key>Replace</key> <data> RUgwMg== </data> </dict> <dict> <key>Comment</key> <string>change GFX0 to IGPU</string> <key>Disabled</key> <false/> <key>Find</key> <data> R0ZYMA== </data> <key>Replace</key> <data> SUdQVQ== </data> </dict> <dict> <key>Comment</key> <string>change B0D3 to HDAU</string> <key>Disabled</key> <false/> <key>Find</key> <data> QjBEMw== </data> <key>Replace</key> <data> SERBVQ== </data> </dict> </array> <key>ReuseFFFF</key> <false/> </dict> <key>DropTables</key> <array> <dict> <key>Signature</key> <string>#MCFG</string> </dict> <dict> <key>Signature</key> <string>DMAR</string> </dict> </array> <key>SSDT</key> <dict> <key>DropOem</key> <false/> <key>Generate</key> <false/> <key>PluginType</key> <integer>1</integer> </dict> </dict> <key>Boot</key> <dict> <key>Arguments</key> <string>nv_disable=1 kext-dev-mode=1</string> <key>Debug</key> <false/> <key>Legacy</key> <string>LegacyBiosDefault</string> <key>NeverHibernate</key> <true/> <key>Secure</key> <false/> <key>Timeout</key> <integer>5</integer> <key>XMPDetection</key> <string>Yes</string> </dict> <key>CPU</key> <dict> <key>UseARTFrequency</key> <false/> </dict> <key>Devices</key> <dict> <key>FakeID</key> <dict> <key>IntelGFX</key> <string>0x04128086</string> </dict> <key>USB</key> <dict> <key>AddClockID</key> <true/> <key>FixOwnership</key> <true/> <key>Inject</key> <true/> </dict> </dict> <key>DisableDrivers</key> <array> <string>VBoxHfs</string> </array> <key>GUI</key> <dict> <key>Custom</key> <dict> <key>Entries</key> <array> <dict> <key>Disabled</key> <false/> <key>FullTitle</key> <string>UEFI internal</string> <key>Hidden</key> <string>Always</string> <key>Ignore</key> <false/> <key>NoCaches</key> <false/> <key>Type</key> <string>Other</string> </dict> </array> </dict> <key>Mouse</key> <dict> <key>DoubleClick</key> <integer>500</integer> <key>Enabled</key> <false/> <key>Mirror</key> <false/> <key>Speed</key> <integer>8</integer> </dict> <key>Scan</key> <dict> <key>Entries</key> <true/> <key>Legacy</key> <true/> <key>Linux</key> <false/> <key>Tool</key> <true/> </dict> <key>Theme</key> <string>El Capitan</string> </dict> <key>Graphics</key> <dict> <key>Inject</key> <dict> <key>ATI</key> <false/> <key>Intel</key> <true/> <key>NVidia</key> <false/> </dict> <key>LoadVBios</key> <true/> <key>NvidiaSingle</key> <false/> <key>VideoPorts</key> <integer>3</integer> <key>ig-platform-id</key> <string>0x0a260006</string> </dict> <key>KernelAndKextPatches</key> <dict> <key>AppleRTC</key> <true/> <key>AsusAICPUPM</key> <false/> <key>Debug</key> <false/> <key>DellSMBIOSPatch</key> <false/> <key>ForceKextsToLoad</key> <array> <string>\System\Library\Extensions\IONetworkingFamily.kext</string> </array> <key>KernelCpu</key> <false/> <key>KernelHaswellE</key> <false/> <key>KernelLapic</key> <false/> <key>KernelPm</key> <true/> <key>KextsToPatch</key> <array> <dict> <key>Disabled</key> <false/> <key>Find</key> <data> AQAAdSU= </data> <key>Name</key> <string>IOGraphicsFamily</string> <key>Replace</key> <data> AQAA6yU= </data> </dict> </array> </dict> <key>RtVariables</key> <dict> <key>BooterConfig</key> <string>0x28</string> <key>CsrActiveConfig</key> <string>0x3</string> </dict> <key>SMBIOS</key> <dict> <key>BiosReleaseDate</key> <string>12/22/2016</string> <key>BiosVendor</key> <string>Apple Inc.</string> <key>BiosVersion</key> <string>MBP111.88Z.0138.B21.1612221936</string> <key>Board-ID</key> <string>Mac-189A3D4F975D5FFC</string> <key>BoardManufacturer</key> <string>Apple Inc.</string> <key>BoardType</key> <integer>10</integer> <key>ChassisAssetTag</key> <string>MacBook-Aluminum</string> <key>ChassisManufacturer</key> <string>Apple Inc.</string> <key>ChassisType</key> <string>0x08</string> <key>Family</key> <string>MacBook Pro</string> <key>LocationInChassis</key> <string>Part Component</string> <key>Manufacturer</key> <string>Apple Inc.</string> <key>Mobile</key> <true/> <key>ProductName</key> <string>MacBookPro11,1</string> <key>SerialNumber</key> <string>C02L3Y0FFGYY</string> <key>Trust</key> <false/> <key>Version</key> <string>1.0</string> </dict> <key>SystemParameters</key> <dict> <key>InjectKexts</key> <string>Yes</string> </dict> </dict> </plist>
    • By BiTRiP
      Since 10.9 I was always using integrated graphics (hd4600) of my 4770K.
      This was never a problem in 10.9, 10.10, 10.11 but now the HDMI is not working anymore.
       
      I have one display on DVI and a secondary on HDMI which now only gives distorted picture, mirrored from my main screen.
      The monitor is also not shown in Display prefs, neither in system info. Only the one on DVI.
       
      When I boot with HDMI only than it crashes middle in boot without KP.
       
      I'm using latest clover (v3763) with Intel injection enabled. No ig-platform-id was ever needed but now tried several without any luck.
      Also tried using AppleIntelHD5000Graphics.kext and AppleIntelFramebufferAzul.kext from 10.11 but no luck there either.
       
      Any ideas why this is suddenly broken?
       
      I attached some screenshot and my DSDT.
       

       

       
       
      DSDT.aml.zip
    • Guest jonatrapezita
      By Guest jonatrapezita
      Hola amigos, un gusto.
       
      He tenido esta duda-problema desde hace un rato atrás y quería consultarles a ustedes que saben mucho más que yo.
      El problema es el siguiente:
       

       
      Como ven, el video se ve sucio, como con interferencia.
      Pero esto no solo aparece en los videos de YouTube, sino en las miniaturas de los videos que tengo en la computadora:
       

       
      Ahora el misterio
       
      Este problema aparece exclusivamente cuando tengo esta configuración:
       
      System definition: iMac 14,2                               = Fail
      Bios: Intel Proccesor Graphics Enabled          
               Initial Display Output Pcie 1                
       
       
      PERO si cambio el System definition a MacPro 3.1, todo vuelve a la normalidad. Todo funciona perfecto con mi GTX 780, tanto en miniaturas de videos como en YouTube.
       
      System definition: MacPro 3,1                            = Ok
      Bios: Intel Proccesor Graphics Enabled
               Initial Display Output Pcie 1
       
       
      De igual manera, si deshabilito los Intel Graphics así tenga el System definition Imac 14,2, funciona todo correctamente. Así es como tengo actualmente mi hackintosh.
       
      System definition: iMac 14,2                              = Ok
      Bios: Intel Proccesor Graphics Disabled
               Initial Display Output Pcie 1
       
       
       
      Uso cable DisplayPort, aunque este problema se presenta tanto con HDMI como con DVI.
      No uso Nvidia Web Drivers, pero igual se presenta el problema si los uso.
       
      ¿Cuál creen que sea el inconveniente entre iMac 14,2 y los Intel Graphics habilitados? 
       
      Muchas gracias cualquier respuesta.
       
      Adjunto mi carpeta EFI para que le den un vistazo.
      https://www.dropbox.com/s/zqnlc2ghg0udhkr/EFI.zip?dl=0
    • By RBrNx277
      Hi there, this is my first desktop Hackintosh build with El Capitan 10.11.3 and everything is very nearly working. My only problem I have is that my Intel HD4600 is only being recognised as having 7mb of RAM. I have tried to install the AppleIntelFramebufferAzul.kext, along with the FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext but there is still only 7mb of VRAM recognised and there is huge screen tearing happening.

      I've spent the last two hours looking for a fix for this but most of the solutions are for laptops only. Is there any way to fix this?

      Thanks, RBrNx

       

      Specs:

      i5 4590 @ 3.3Ghz - Intel HD4600

      Gigabyte H97-D3H Motherboard

      Crucial Ballistix 8GB RAM

      Western Digital Green 1TB HDD

      Corsair CS450M Power Supply

       

      Here is my current config.plist: https://gist.github.com/anonymous/45936957495302b0e27e

×