Jump to content

No picture HD4600


4 posts in this topic

Recommended Posts

Hey, 

 

I have a Gigabyte Z97M-D3H rev 1.0 with F8 bios, 4690K CPU and nv 980 running 10.13.6. Been trying to get the HD4600 to run for the past few months. Getting kextd stall or busy timeout for the iGPU and no ability to get to desktop. It will display verbose boot up to 4 iGPU time outs then stops at giolockstate3 but it never gets to the OS.  

 

I'm sure I got into the OS with it before on 10.12. The OS does come up on the 980 eventually while the HD4600 display stuck with the verbose boot ending until i shut down

 

I have tried multiple platform-ids (0x0A160000, 0x0A260000 ,0x0D220003 ,0x0A2E000A ,0x0A26000A ,0x0A2E000D) and other stuff like the whatevergreen frame buffer patch guide.  Don't seem to get far with that either lol

 

Maybe someone can spot an error in the config, clover or ioreg? Sorta looks like its working but theres no ports or something? I'm trying to use the HDMI one on it

 

Cheers

 

 

 

 

IOREG.zip CLOVER.zip origin.zip

Messages Image(2266498235).jpeg

Messages Image(4003926037).jpeg

Messages Image(4292889495).jpeg

 

Edited by Graeme43

I want to sell my 980 as I need the money and I would love to be able to get the HD4600 to give me a picture. I had an HD2000(?) Pentium G3220 give me picture on the same motherboard in the past, although its unsupported and 1024x768, it was more than I can get with the HD4600 in 10.13

 

I had HD4600 working in 10.12 as I remember getting the azul patch to stop safari freezing when going to youtube. 


I have tried 10.14.0 also and it gives iGPU timeout

 

It works in Windows fine. I have a secondary machine with Z97N-WIFI board and same CPU, less ram and 1080Ti. Shown on the right side, booted from my backup - it seems to work better than my main machine :( I just use CCC to save my windows on it

 

Thanks

IMG_4679.jpg

Messages Image(2129349367).jpeg

I don't know what im doing wrong but it works on the Z97N-Wifi, not the Z97M-D3H. Same cpu model. Just booting off a backup as I use this for non Mac stuff

IMG_4768.jpg

Edited by Graeme43
  • 3 weeks later...

still cant get this to get to desktop with igpu and no dedicated  card

 

I have been trying all sorts and the IMEI  disappears from IOREG when I have HECI -> IMEI patch enabled

Edited by Graeme43
×
×
  • Create New...