Jump to content
ambose

High Sierra su Asus X554L - (F55LD-XX876H)

34 posts in this topic

Recommended Posts

56 minutes ago, ambose said:

Penso di essermi spiegato da solo in merito al DSDT.aml, una volta effettuata la patch e compilato lo si testa, se l'ultima patch è andata a buon fine per applicarne un altra mi è sufficiente decompilare nuovamente il DSDT.aml ed aggiungere le patch che voglio provare, altrimenti butto via il compilato e torno sul sorgente senza la patch non funzionante.

Chiariamo due cose. Per sorgente intendi il file decompilato o il binario estratto da Clover? Nel primo caso, quando salvi (prima di compilare), le modifiche vengono salvate. Nel secondo caso, basta che ti salvi un duplicato.

59 minutes ago, ambose said:

Per l'audio per il momento ho solo trovato le patch che iniettano il layout, penso servano per evitare di metterlo nel config.

Giusto

59 minutes ago, ambose said:

Rifacendo il DSDT ho patchato anche il rename che mi hai dato da inserire nel config, quindi non dovrei più aver bisogno di inserirlo.

Sicuro? Clover non applica patch solo al DSDT, e su Haswell è probabile che ci siano pochissimi riferimenti a B0D3 sul DSDT.

1 hour ago, ambose said:

Per l'ultimo problema che ha questo portatile (escludendo le anomalie sul touchpad che tratterò in un topic a parte) cioè l'audio pare che il problema sia la mancanza del CODEC come si può notare dallo screen in allegato.

 

Probabile che debba patchare anche per l'audio il DSDT ma al momento non saprei proprio da dove iniziare. 

Se manca il codec è grave...

DPCIManager non è una fonte affidabile per l'audio. Fai un codec dump e allegalo.

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, foskvs said:

Sicuro? Clover non applica patch solo al DSDT, e su Haswell è probabile che ci siano pochissimi riferimenti a B0D3 sul DSDT.

Le patch che ci sono su MaciASL (ti ho fatto lo screen).

 

1 hour ago, foskvs said:

Se manca il codec è grave...

DPCIManager non è una fonte affidabile per l'audio. Fai un codec dump e allegalo.

 

Ok ho fatto il codec dump tramite linux ed ho ottenuto che sono sul codec Realtek ALC3236, ti allego i dump.

o1.txt

oo.txt

Schermata 2018-10-11 alle 13.29.34.png

Share this post


Link to post
Share on other sites

il codec è ALC233...prova i relativi layout...

Che ci siano patch non vuol dire nulla.. sono quelle "già pronte" possono andare bene come anche no..

serve una conoscenza di acpi...ioreg etc etc

non è che prendi e le applichi tutte a priori

Share this post


Link to post
Share on other sites

Si la conoscenza sto cercando di farmela ma è particolarmente complicato.. Adesso mi sto leggendo:

https://www.insanelymac.com/forum/topic/211061-guida-modifica-del-dsdt-le-basi-e-le-fix-più-comuni/

e poi passerò a:

 

Ovviamente se avete suggerimenti più mirati son tutt'orecchi..

 

Quelle patch già pronte le ho provate ad applicare, se una volta funzionante il codec, mi funziona l'audio via HDMI vorrà dire che ha funzionato. Purtroppo sto cercando di capire queste cose da solo e magari faccio anche qualche pasticcio, ma cerco di lavorare sempre in backup e in modo ordinato in modo da non mescolare i tentativi. 

Comunque adesso ho visto che i layout possibili per ALC233 sono: 3,13,27,32,33 ora mi preparo i config.plist per ognuno di questi e riavvio sperando di sentire qualche rumore :rofl:

Come mai il ALC3236 = ALC233 ?

 

12 minutes ago, gengik84 said:

non è che prendi e le applichi tutte a priori

un minimo di criterio l'ho usato... :hyper:

Share this post


Link to post
Share on other sites

Nulla, ho provato con tutti i layout e per sicurezza togliendo anche il DSDT patchato da me. 

Stasera mi metto li tranquillo e faccio pulizia aggiorno tutti i kext per essere sicuro di essere all'ultima versione e rifaccio il DSDT mettendo solo la patch della batteria. 

Vi aggiorno, per adesso grazie.

Edited by ambose

Share this post


Link to post
Share on other sites

Ragazzi io ci rinuncio.

Ho provato tutti i layout per il codec ALC233 dopo aver ripulito il sistema ed avendo solo appleALC e lilu.kext all'ultima versione.

Probabilmente mi ci vuole una patch per poter procedere.

io vi allego la cartella Clover e IOreg, se avete voglia di buttarci un occhio, ma non ho nessuna fretta in quanto questa è una macchina muletto didattica.

Magari anche se ci credo poco riuscirò a farlo funzionare io! ma adesso devo ancora studiare :wallbash:

 

 

CLOVER.zip

MacBook Pro di Andrea.zip

Share this post


Link to post
Share on other sites

intanto che studi, prova i voodoo

togli AppleALC e metti in EFI VoodooHDA e AppleHDAdisabler, riavvii e vedi

Share this post


Link to post
Share on other sites

Reboot loop con voodoo

Inviato dal mio FIG-LX1 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×