Jump to content
Shaneee

AMD Mojave Kernel Development and Testing

252 posts in this topic

Recommended Posts

On 12/25/2018 at 6:26 AM, XLNC said:

https://www.dropbox.com/s/xdbimsaenc71h5j/XLNC_fx2.zip?dl=0
try this kernel guys !

- replace the kernel and system.kext in mojave macos and rebuild kextcache and reboot .

NOTE prelinkedkernel provided for those users who want to boot without rebuilding caches ! 

Thanks, but it still got the same KP as previous kernel.fx & prelinkedkernel.fx at 10.14.1 in FX-6300 hackintosh.

In Ryzen 1700X it can login desktop at 10.14.1/10.14.2/10.14.3.

Safari & App Store work now in addition to Firefox and Google Chrome, but cpu-x and EFI Mount V3 crashed.

It can play video smoothly in Safari.

But it took longer time to shutdown or reboot than prelinkedkernel.fx in which Safari & App Store crashed.

Edited by jsl2000

Share this post


Link to post
Share on other sites
Advertisement

Gave it another try. 

 

Used disk utility to restore basesystem.dmg to flash drive then copied packages folder and applediagnostics/basesystem to flash drive. Then copied foxlet’s B7 kernel to /S/L/Kernels and prelinkedkernel.bits to /S/L/Prelinkedkernel and the extensions to /S/L/E and kexts (nullcpu and fakesmc) to clover efi partition. Copied config.plist from my 10.13 install over to thumb drive. Put boot arg “kcsuffix=bits” in config plist. 

 

Boot args are npci=0x2000 kcsuffix=bits -v

 

After booting i now get stuck at “FakeSMCKeyStore: Started” line. 

 

Gonna give virtualSMC a go

 

virtualsmc also failed. Think it’s actually a kernel panic. 

Edited by pixelkid94

Share this post


Link to post
Share on other sites
10 hours ago, XLNC said:

https://www.dropbox.com/s/xdbimsaenc71h5j/XLNC_fx2.zip?dl=0
try this kernel guys !

- replace the kernel and system.kext in mojave macos and rebuild kextcache and reboot .

NOTE prelinkedkernel provided for those users who want to boot without rebuilding caches ! 

is it compatible for amd a10 5800k?

Share this post


Link to post
Share on other sites
9 hours ago, jsl2000 said:

Thanks, but it still got the same KP as previous kernel.fx & prelinkedkernel.fx at 10.14.1 in FX-6300 hackintosh.

In Ryzen 1700X it can login desktop faster and cleaner than previous version at 10.14.1/10.14.2/10.14.3.

Safari & App Store work now in addition to Firefox and Google Chrome, but cpu-x and EFI Mount V3 crashed.

Amazing fast shutdown & restart ----- the best kernel for Ryzen 1700X hackintosh !

Highly recommendable to everyone to try it by yourself !


can you boot with debug=0x100 boot flag on FX and send a pic of the kp ?
 

1 hour ago, Mc Jacej said:

is it compatible for amd a10 5800k?

yes !

Share this post


Link to post
Share on other sites
1 hour ago, XLNC said:


can you boot with debug=0x100 boot flag on FX and send a pic of the kp ?
 

yes !

XLNC & Shaneee:

Tested with your kernel or prelinkedkernel always got the same KP as the first one:

The actual one was attached too.

20181212_175555.thumb.jpg.a8b4e21df32d30cfafec86a9ce3f565f.jpg

IMG_0198.JPG

Edited by jsl2000

Share this post


Link to post
Share on other sites
2 minutes ago, jsl2000 said:

It is same as the first one:

The actual one was attached too.

20181212_175555.thumb.jpg.a8b4e21df32d30cfafec86a9ce3f565f.jpg

IMG_0198.JPG

what GPU are you using with FX system ?

Share this post


Link to post
Share on other sites
55 minutes ago, jsl2000 said:

XLNC & Shaneee:

Tested with your kernel or prelinkedkernel always got the same KP as the first one:

The actual one was attached too.

20181212_175555.thumb.jpg.a8b4e21df32d30cfafec86a9ce3f565f.jpg

IMG_0198.JPG

i get  this error in my fx8350  when i try to load  Kernel  of foxlet.

try to use The kernel and prelinked   of XLNC.

my System Goes  up but i have Problems with Smc

fakesmc= Enter in  Logo NVIDIA but don’t Start the graphic Mode 

Virtualsmc = Don’t enter in Logo  and Return  error on appleacpicpu

Share this post


Link to post
Share on other sites
20 minutes ago, fagneroliveira said:

i get  this error in my fx8350  when i try to load  Kernel  of foxlet.

try to use The kernel and prelinked   of XLNC.

my System Goes  up but i have Problems with Smc

fakesmc= Enter in  Logo NVIDIA but don’t Start the graphic Mode 

Virtualsmc = Don’t enter in Logo  and Return  error on appleacpicpu

Which version of XLNC's kernel & prelinkedkernel did you use ?

Share this post


Link to post
Share on other sites
3 minutes ago, jsl2000 said:

Which version of XLNC's kernel & prelinkedkernel did you use ?

The both

 

3 minutes ago, jsl2000 said:

Which version of XLNC's kernel & prelinkedkernel did you use ?

 The both work  but use The fx2 

Share this post


Link to post
Share on other sites
On December 25, 2018 at 9:47 PM, fagneroliveira said:

The both

 

 The both work  but use The fx2 

I have tried both versions in vain.

I'll re-test it again when I get AMD R9 380 or 7950 GPU soon later.

RX-560 is not fully compatible to this M5A MB.

Edited by jsl2000

Share this post


Link to post
Share on other sites

Currently can't get passed the installer (unsupported metal graphics), I assume because the Pascal drivers aren't out for Mojave? I have a GTX 1080, but I noticed someone was able to install successfully with their GTX 1050.

Share this post


Link to post
Share on other sites

How's it going, guys? :)  I'm on High Sierra 10.13.3 now. Can I take a part in tests and try to update from HS to Mojave?

Edited by edgar90

Share this post


Link to post
Share on other sites
6 hours ago, 0xAE9 said:

Currently can't get passed the installer (unsupported metal graphics), I assume because the Pascal drivers aren't out for Mojave? I have a GTX 1080, but I noticed someone was able to install successfully with their GTX 1050.

 

Hello,

I don't know what smbios you are using, but the installer just started with MacPro 6.1!

MacPro5.1 shouted at Metal support not supported by me!

 

I don't think the GTX 1080 has a webdriver

 

Sorry, bad English!

Edited by BCBoy1

Share this post


Link to post
Share on other sites
2 hours ago, BCBoy1 said:

 

Hello,

I don't know what smbios you are using, but the installer just started with MacPro 6.1!

MacPro5.1 shouted at Metal support not supported by me!

 

I don't think the GTX 1080 has a webdriver

 

Sorry, bad English!

Thank you so much! I must wait for the web drivers, but afterwards I should be able to install properly.

Share this post


Link to post
Share on other sites
20 hours ago, XLNC said:


can you boot with debug=0x100 boot flag on FX and send a pic of the kp ?
 

yes !

Can you share with us your sysctl -a in FX-8320 hackintosh at 10.14.1 ?

Edited by jsl2000

Share this post


Link to post
Share on other sites
On 12/26/2018 at 12:57 PM, jsl2000 said:

Can you share with us your sysctl -a in FX-8320 hackintosh at 10.14.1 ?


i cant login without an amd GPU ! 
so cant send it : (
curently my main developemnt machine is still high sierra 10.13.6

Share this post


Link to post
Share on other sites
2 hours ago, XLNC said:


i cant login without an amd GPU ! 
so cant send it : (
curently my main developemnt machine is still high sierra 10.13.6

Please try nv_disable=1 for your GTX-960 GPU.

If the kernel & prelinkedkernel are valid at least you can login desktop at 10.14.1

Edited by jsl2000

Share this post


Link to post
Share on other sites
On December 26, 2018 at 12:09 AM, 0xAE9 said:

Currently can't get passed the installer (unsupported metal graphics), I assume because the Pascal drivers aren't out for Mojave? I have a GTX 1080, but I noticed someone was able to install successfully with their GTX 1050.

You may try booted with nv_disable=1 if no nvidia web drive yet.

Share this post


Link to post
Share on other sites
1 minute ago, Shaneee said:

@jsl2000 Are those images booting the installer or HDD?

Booted by Cloned Intel partition (HDD)  in which replaced with AMD's kernel, prelinkedkernel, & related Kexts/FrameWorks.

It worked perfectly in Ryzen 1700X hackintosh, but always got KP in FX-6300 hackintosh.

Share this post


Link to post
Share on other sites

Would it be possible to build a kernel with OPEMU? I have a some 32 bit apps here and it would be nice to get them running on Mojave. 

Thank you in advance!

Share this post


Link to post
Share on other sites
13 hours ago, jsl2000 said:

Booted by Cloned Intel partition (HDD)  in which replaced with AMD's kernel, prelinkedkernel, & related Kexts/FrameWorks.

It worked perfectly in Ryzen 1700X hackintosh, but always got KP in FX-6300 hackintosh.

 

Please test on your FX with this.

 

 

prelinkedkernel.test.zip

Share this post


Link to post
Share on other sites
1 hour ago, Shaneee said:

 

Please test on your FX with this.

 

 

prelinkedkernel.test.zip

Shaneee: Thank you very much. You are my hero !

Great news: it worked perfectly in FX-6300 hackintosh at 10.14.1 & 10.14.3 beta.

Safari, App Store, cpu-x, & Hinet.Dr.Speed.OSX, etc. all worked.

The only issue is shutdown will restart instead of power off.

RX-560_OpenCL.gb4

RX-560_Metal.gb4

FX-6300.txt.zip

Edited by jsl2000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×