Jump to content
Shaneee

AMD Mojave Kernel Development and Testing

250 posts in this topic

Recommended Posts

@The AMD Guy

I see you use the Same AMD  like me but it isn´t workimg with Vega 11 Graphics´s?

 

If not i need to Upgrade to a AMD GPU. (And With that to the 5 2600x)

Share this post


Link to post
Share on other sites
Advertisement

Mojave 10.14.4 beta 3 working with Kernel and Appstore, Safari are working fine.   However, RX 480 showing as display 7mb.   Will test other GPUs.  

Update:   No luck with other GPUs, GT710, RX Vega 64, RX 460, R7 265.   

 

Screen Shot 2019-02-24 at 12.19.39 PM.png

Edited by Gigamaxx

Share this post


Link to post
Share on other sites
8 hours ago, drago oonej said:

i have ryzen 7 2700x ,msi b450 carbon , ASUS Rog Strix RTX 2060 

Can install Mojave ?

 

Not with a Nvidia card. 

Share this post


Link to post
Share on other sites

@Shaneee Are you able to run some kind of VM? (VmWare, Virtualbox, Parallels) - I can not run any of the available options.

Parallels freezes the OS when it tries to start Ubuntu. VMWare says it can not read "symbols" and other errors.

I made a post here => https://forum.amd-osx.com/viewtopic.php?f=55&t=6234

 

This can be Kernel related? I've csrutil disabled but all I've found to fix Virtualbox didn't worked. That's odd.

 

Cheers.

Share this post


Link to post
Share on other sites
Posted (edited)
14 minutes ago, Micheldiz said:

@Shaneee Are you able to run some kind of VM? (VmWare, Virtualbox, Parallels) - I can not run any of the available options.

Parallels freezes the OS when it tries to start Ubuntu. VMWare says it can not read "symbols" and other errors.

I made a post here => https://forum.amd-osx.com/viewtopic.php?f=55&t=6234

 

This can be Kernel related? I've csrutil disabled but all I've found to fix Virtualbox didn't worked. That's odd.

 

Cheers.


yea ! the latest versions of these apps are not working 
use vmware fusion 10.1.5
also you have to downgrade parallels too.
and i found that the latest version of virtual box is working.

Edited by XLNC

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, XLNC said:


yea ! the latest versions of these apps are not working 
use vmware fusion 10.1.5
also you have to downgrade parallels too.
and i found that the latest version of virtual box is working.

1422806625_CapturadeTela2019-03-01as22_08_27.png.9cff1ef050cadf935e76653f0cb618ae.png
 

Actually, I was using this version now. I've tested several versions. I have a .DMGs mountain here. I have tested almost all versions of VirtualBox 5 and 6 (including the latest and the dev versions - always using the VB uninstall tool). I just did not test Parallels that much. I test 14.1.2 (45479) and the oldest one I could download. Parallels just freeze and I have to force reboot.

I did not succeed in either cases.

I wanted to see if anyone has any VM running, to see if I'm an isolated case.

 

Cheers.

UPDATE: (1 hour later)
I ware able to install and run Parallels 13.1.0 (43108) BUT I wasn't able to use boot camp, nor Docker ISO (default iso or VMware's Photon version) worked.
It has "kernel panic" - it can open normaly, but as soon it try to install docker it panic.

 

at least I know I can run a VM...

UPDATE: (a day later)

I've successfully run Virtualbox. Do not ask me how, because I would also like to know... I did A LOT of things.

But I think it had to do with safe mode (-x), disable SIP, add Virtual Box in "Security and Privacy / Accessibility" and also "Full Access to Disk". I GUESS! that was it.

1416203719_CapturadeTela2019-03-02as12_36_14.png.e1ff6c035b0e09e9566c65a973564921.png

Edited by Micheldiz

Share this post


Link to post
Share on other sites
Posted (edited)

1459644265_ScreenShot2019-03-05at6_48_26AM.thumb.png.5db109c81b64696d0204a2bd8aee1d86.png 

works fine !
using vmware 10.1.5 and latest version of virtual box.

Edited by XLNC

Share this post


Link to post
Share on other sites

Hello Everyone! What is the latest Kernals I can use with AMD-FX8370 and RX 580 GPU? Also, do we have a green light to update to Mojave 14.4.4?

 

Thanks!

Share this post


Link to post
Share on other sites
6 hours ago, amplebasilisk said:

Hello Everyone! What is the latest Kernals I can use with AMD-FX8370 and RX 580 GPU? Also, do we have a green light to update to Mojave 14.4.4?

 

Thanks!

 

https://github.com/Shaneee92/Mojave_AMD_XNU/releases

 

Only 10.14.1 is recommended. Wait for kernel source updates to update the system, https://opensource.apple.com/

Share this post


Link to post
Share on other sites

Hi guys!

Just a question..

how can i Install Mojave on my ryzen 7 1700?

there are so many topics and i'm so confused.

Can someone help me writing a short howto?

thx

Share this post


Link to post
Share on other sites
Posted (edited)

Update on Mojave 14.4 beta 4

 

I got my graphics working but they are at 1/2 potential.   Luxmark is normal but Geekbench Compute and Uningine Valley are half scores.

tested Vega 64, RX 480, and Radeon VII.   I updated to latest beta and replaced the kernel and prekernel from Shanee repository.   Last time I was using XNLC packet.

I noticed that the Systemkext is not loading it says "not signed"?

Safari and App Store still working.

Vega 64 14.4 beta 4 Ryzen 5 2400g.png

Screen Shot 2019-03-09 at 10.53.52 AM.png

Screen Shot 2019-03-09 at 10.18.33 AM.png

Screen Shot 2019-03-09 at 10.47.45 AM.png

Screen Shot 2019-03-09 at 10.14.43 AM.png

Edited by Gigamaxx

Share this post


Link to post
Share on other sites
On 3/17/2019 at 8:20 AM, AlGrey said:

Zen deserves having Siri.

 

Stock 10.14.1 patched in binary for Zen. Beta version. 

 

Enjoy.

kernel.algrey.zip

 

 

EDIT :  iMessage, FaceTime, and Home are working too !

is it compatible for amd a10 5800k?

Share this post


Link to post
Share on other sites
On 1/5/2019 at 7:59 PM, Shaneee said:

 

What we've seen before is this image is the result of not modifying the install plist. Either run this in Terminal from the installer replacing VOLUME NAME with the disk Mojave is installed to,

 


sed -i '' 's/auth-//g' /Volumes/"VOLUME NAME"/macOS\ Install\ Data/Locked\ Files/Boot\ Files/com.apple.Boot.plist

 

Or modifying the plist file manually and just remove the auth- part your self.

I cant boot becouse issue ++++++++++++++++++++++

how i can changing the com.apple.Boot.plist file. I need made the permissions Read & Write for  that file.  com.apple.boot.plist

 

 

Share this post


Link to post
Share on other sites
On 3/20/2019 at 1:20 PM, Trainspoting said:

I cant boot becouse issue ++++++++++++++++++++++

how i can changing the com.apple.Boot.plist file. I need made the permissions Read & Write for  that file.  com.apple.boot.plist

 

 

 

Copy the file to the desktop, modify and replace. Although this isn't needed now if using vanilla kernel with Clover patches.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×