Jump to content
bilbo

[Guide 2018] Z820 - HIGH SIERRA, The great guide (Sucess)

208 posts in this topic

Recommended Posts

On 12/4/2018 at 7:39 AM, pingyes said:

Why don't we use AppleIntelE1000e.kext? AppleIntelE1000e.kext gives me two port drivers, while IntelMausiEthernet.kext can only drive 82579LM, 82574L is invalid.

Talking about dsdt patching, Maldon suggested me to use this kext. I decide to include it thinking is a newer project. I have my second ethernet disabled, but I thought that is because I don't have any ethernet connector plugged in this port. I didn't realize that is because a failed driver.

 

I'll check this. Thanks for the notice.

 

 

 

On 12/7/2018 at 1:41 PM, Cass67 said:

Anyone able to install the recent 002 or 003 security updates ? I get I restart to install bar, 30 secs later device just reboots and nothing installs..

 

What partition are you choosing after boot? 

Share this post


Link to post
Share on other sites
Advertisement
15 minutes ago, Cass67 said:

我有一个z620,睡眠不起作用......不要以为它会...

My z820 2650v2 k6000, can sleep in 10.13.6, but can not wake up, in 10.14.2 seems to only s1 sleep, simply turn off the display, there is no way to solve.

Share this post


Link to post
Share on other sites
My z820 2650v2 k6000, can sleep in 10.13.6, but can not wake up, in 10.14.2 seems to only s1 sleep, simply turn off the display, there is no way to solve.
What did you do to make sleep work on 10.13.6 ? Not sure I see any other reports of this working.

Sent from my ONEPLUS A6003 using Tapatalk

Share this post


Link to post
Share on other sites
7 hours ago, Cass67 said:

你做了什么让睡眠工作在10.13.6?我不确定是否有任何其他有关此工作的报告。

使用Tapatalk从我的ONEPLUS A6003发送
 

1.png.50a16cea50309a80441391f0be1bff67.png1.png.50a16cea50309a80441391f0be1bff67.png

 

The default configuration of clover can play a sleep role in 10.13.6 and 10.14.2, but it can't wake up. I don't know what it is.

2.png

Share this post


Link to post
Share on other sites
On 12/5/2018 at 4:11 AM, jplele said:

Hi bilbo,

I finished PM setup following your guide strickly,no ERROR and KP.  but something wrong  seems. can you give some advised?  thanks. 
PS:  I patched my z420 DSDT with your patches, everything is perfect on mojave 14.1 except the PM currently. thank you!

Z420/v3.94/ E5-2670 v2/32G/RX580-4G

 

I dont´t know.... Post you script to generate the ssdt witk Pikescript , and the output message.

Share this post


Link to post
Share on other sites

important

 

Well, I did a test with ethernet. Indeed, with IntelMausiEthernet.kext, the second port doesn't work. It is shown as unplugged , but plugging the connector, it stills as disconnected. With AppleIntelE1000e.kext , everything works fine. I have just updated the guide. Thanks to pingyes for the report.

 

Edited by bilbo

Share this post


Link to post
Share on other sites

@Pingyes, my first attemp with your settings to test SLEEP, gave me a KP.  The patches  "rename _DSM... " and "rename HECI...." don't make sense for me. The patches ticked in clover, either. Some of them are obsolete, or unnecessary after clean the dsdt, ... honestly I don't understand anything. Anyway, as I said, I get a KP.

 

 Could you elaborate a bit the reason of those patches? Are essential all of them?

 

 

Edited by bilbo

Share this post


Link to post
Share on other sites
6 hours ago, bilbo said:

@Pingyes,我第一次尝试测试SLEEP的设置,给了我一个KP。修补程序“重命名_DSM ......”和“重命名HECI ....”对我来说没有意义。补丁也在三叶草中打勾。其中一些已经过时,或者在清理dsdt后不必要,...说实话,我什么都不懂。无论如何,正如我所说,我获得了KP。

 

 你能详细说明这些补丁的原因吗?他们都是必不可少的吗?

 

 

I don't understand what they mean. These are just the default configuration of the clover. I have given up on sleep. I think your configuration is the most reasonable.

Share this post


Link to post
Share on other sites

still working on sleep...

 

I tested the patches of pingyes screens. The "fixUSB" patch is the reason of KP. Testing with the rest of options, no way.

 

BUT, I've discovered something (I suspected of this time ago). The reason for no sleep in my case, is my raid card, exactly, the driver SASMegaRAID (developed in this forum bay dukzcry)

 

For those are testing, try to put in sleep mode, and then write this in terminal:

 

pmset -g log | grep sleep | tail -n 1

 

in my case, the output is:

 

System sleep preventers: SASMegaRAID

 

and then , you'll see if you have an specific hardware which is preventing the sleep.

 

 

Share this post


Link to post
Share on other sites

Another important topic is bios settings:

 

These are my bios settings:

 

IMG-2266a.jpg

IMG-2267b.jpg

 

Not sure 100% . With these settings, I have sleep in windows. Any comment is welcome.

 

So, to test it, at least, set first this in Bios.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, bilbo said:

still working on sleep...

 

I tested the patches of pingyes screens. The "fixUSB" patch is the reason of KP. Testing with the rest of options, no way.

 

BUT, I've discovered something (I suspected of this time ago). The reason for no sleep in my case, is my raid card, exactly, the driver SASMegaRAID (developed in this forum bay dukzcry)

 

For those are testing, try to put in sleep mode, and then write this in terminal:

 


pmset -g log | grep sleep | tail -n 1

 

in my case, the output is:

 

System sleep preventers: SASMegaRAID

 

and then , you'll see if you have an specific hardware which is preventing the sleep.

 

 

Interestingly enough until 10.13.6 i never was able to get sleep to work.. 

 

Z620:~ cass$ pmset -g log | grep sleep | tail -n 1

Idle sleep preventers: IODisplayWrangler

 

Always had that one put down to my Nvidia GPU keeping things awake in Sierra..  I swapped out GTX970 to a RX580 from AMD and got same results .. so was not that :)

 

Now under HS i can get sleep to work, its waking up thats the problem.. System powers down ok and mouse / kb lights go out but when hitting kb to wake it, system powers on, fans spin up and then nothing, blank screen and no kb/mouse lights..  Guess i never bothered trying this under HS. 

 

Using FixWAK and FixShutdown in config.plist shuts system down ok then automatically wakes it up with the same results, a bit worse than needing a key press.. Not sure if playing with the darkwake settings will make a difference.  Guess thats something else to play with when i can be bothered rebooting upto 11 times to see :)

Share this post


Link to post
Share on other sites
On 2018/12/19 at AM2点11分, bilbo said:

另一个重要的主题是bios设置:

 

这些是我的BIOS设置:

 

IMG-2266a.jpg

IMG-2267b.jpg

 

不确定100%。通过这些设置,我在Windows中睡觉。欢迎任何评论。

 

因此,至少要测试它,首先在Bios中设置它。

 

 

Win10 link to sata (suc) port will not sleep, link to sata (ahci) sleep normal, this is also a strange phenomenon.

Share this post


Link to post
Share on other sites

Hello to everybody!

Just a quick update to inform you that I successfully updated my Z620 from High Sierra to Mojave 10.14.3!

Need to get rid of my 1050 Ti and temporary put a GT 710 in order to have a decent display.

My RX 560 is on the way, tomorrow I should be able to test it.

The GT 710 doesn't have a DP port so I had to force the HDMI 1.4 to 2560x1440@50Hz by using this patch:

https://github.com/Floris497/mac-pixel-clock-patch-V2

 

PM works the usual way (patched AICPM and custom SSDT), didn't figure out how to use CPUFriend...

 

Best regards.

AC

Share this post


Link to post
Share on other sites

That's good news !

 

On my end, I've replaced my Graphics card (an Nvidia Gtx 740) with an RX580 which worked out of the box without any hassle.

Can't praise that card enough now that the mining-craze came to a halt.

 

But with that being said the cover inside the z280 doesn't fit anymore.

 

Does anyone of you guys know a hack to put it back in? (with the GPU still installed of course)

Share this post


Link to post
Share on other sites
5 hours ago, amadeusex said:

That's good news !

 

On my end, I've replaced my Graphics card (an Nvidia Gtx 740) with an RX580 which worked out of the box without any hassle.

Can't praise that card enough now that the mining-craze came to a halt.

 

But with that being said the cover inside the z280 doesn't fit anymore.

 

Does anyone of you guys know a hack to put it back in? (with the GPU still installed of course)

Could you please post a couple of pictures?

 

Unfortunately, the cheap RX 560 card (Asrock with 2 GB RAM) doesn't work at all in my system: I'll stick with the glorious GT 710 1 GB RAM at 2560x1440@50Hz via HDMI.

Share this post


Link to post
Share on other sites
On 1/27/2019 at 8:10 PM, antonio.clb said:

Hello to everybody!

Just a quick update to inform you that I successfully updated my Z620 from High Sierra to Mojave 10.14.3!

Need to get rid of my 1050 Ti and temporary put a GT 710 in order to have a decent display.

 

Great news. Nvidia's driver issue is a shame for apple. I wish they change of policies about that. I don't think change my 1080ti by any ati card.  If apple doesn't support nvida cards, it will mean the end of hackintosh for me. I'll survive with windows and/or linux.

 

 

15 hours ago, amadeusex said:

But with that being said the cover inside the z280 doesn't fit anymore.

 

With the 1080 ti, I had to leave out the bottom cover also. The card has enough room to fit, but the power connectors placed at the long side (not at back /short side) prevent close it wit the bottom cover. I don´t care that. With the main side cover is enough. Maybe the air flow is not so perfect, now, but I don´t notice wrong with temps or fans. Works 100%.

Edited by bilbo

Share this post


Link to post
Share on other sites

Thanks for the suggestions guys.

 

Only a dremel would do the trick but it's not worth the hassle and I don't really care lol.

z820.jpg

Share this post


Link to post
Share on other sites

Great guide thanx! 

I have a issue. I followed the guide as it should ( I believe) but I can't see my HFS+ disks. Why is that? I do have HFSplus.efi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        --Install Follow my tutorial and use my Clover folder http://www.insanelymac.com/forum/topic/323052-guide-sierra-high-sierra-on-intel-5-6-7-8-and-9-chipset-series-nehalem-sandybridge-ivybridge-haswell-broadwell/ CLOVER Install.zip   --Post Install --Install Clover bootloader and replace with my folder CLOVER Post Install.zip   Bingo!   Now you need a fine tune! DSDT time!   If you need edited DSDT... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app     -DSDT bios F23 My DSDT  DSDT.MaLd0n GA X99-UD3P.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -IMEI -SHUTDOWN -LAN -SPSR -EC -PNLF -HDMI


      e.g

       
      -Clover https://sourceforge.net/projects/cloverefiboot/files/Installer/ -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, nmano and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      -Install, check here 
      http://www.insanelymac.com/forum/topic/323052-guide-sierra-high-sierra-on-intel-5-6-7-8-and-9-chipset-series-nehalem-sandybridge-ivybridge-haswell-broadwell/
       
      -Clover Folder 
      CLOVER.zip
       
      -DSDT 
      DSDT.MaLd0n Supermicro X10DAI.zip
       
      -DSDT Patches 
      -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN #1 -LAN #2 -SPSR -WIFI -EC -PNLF -HDMI -NVME -Geekbench 

       
      -SS 


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders! Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, MMido and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   Installation   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER Post Install.zip   --Reboot   DSDT DSDT.MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC ----- -Disable GPU new patch and PNLF SSDT - Credits RehabMan


       
      SSDT    Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip  
      -Audio
      https://github.com/vit9696/AppleALC
       
      -FakeSMC
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/   -Atheros Ethernet https://github.com/Mieze/AtherosE2200Ethernet   -IntelGraphicsFixup https://sourceforge.net/projects/intelgraphicsfixup/   -IntelGraphicsDVMTFixup https://github.com/BarbaraPalvin/IntelGraphicsDVMTFixup   -USBInjectAll https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   Special Thanks to Pablo Galán   We're all here to have fun and learn from each other!   ENJOY!
    • By Ciumann
      Salve ragazzi!
      Dopo molti tentativi sono riuscito a fare hackintosh con High Sierra. Ogni sistema operativo ha il suo Hard Disk.
       
      Scheda madre: AsRock B85M (UEFI)
      Processore: Intel i5 4460
      Scheda Video: Palit GTX 960 4 GB
      Ram: 2 schede HyperX Fury 4 GB ognuna.

      Ora ho un po' di cose da risolvere.

      Innanzitutto vorrei scegliere all'avvio del PC quale dei sistemi operativi far partire. Ho fatto la procedura con "moltebestie" (in ogni tipo di opzione nel quick start) ma all'avvio devo sempre inserire la pennetta per poter scegliere Sierra.
       
      Secondo problema è che mi mancano i vari driver, scheda video... E, cosa strana, ho notato che nelle informazioni di sistema mi da che ho 4 GB di Ram invece che 8.


      Ringrazio in anticipo!

    • By autantpourmoi
      Hello , I just put a new M2 samsung ssd disk in my hack and a And rx 580 sapphire 8go and installed High Sierra 10.13.6 , everything seems ok except the sleeping mode
      When I go to sleeping mode , the 2 monitors will turn to sleeping mode and after 3 to 5 sec the computer too , but the computer restart in a kind os stand by mode while the monitors still black 
      Is it a normal behaviour which I'm doubting about it , is there any way to keep the computer in sleep and reactivate it by keys?
      any help will be appreciated
       
×