Jump to content
bilbo

[Guide 2018] Z820 - HIGH SIERRA, The great guide (Sucess)

418 posts in this topic

Recommended Posts

My Z820 E5-2670 v1 was running Sierra for the long while. I had to replace a hard drive, so I decided to upgrade it High Sierra. I tried multiple times to get the installer USB too boot, did't have any luck. I just went ahead and give Mojave a try and not waste more time on High Sierra... Woah! it's pretty easy to get going with it Mojave.  I still need to work on power management, but so far it's pretty snappy out of the box.

Mojave 10.14.6, Clover_v2.5k_r5103

Edited by Dr Droid

Share this post


Link to post
Share on other sites
Advertisement

I decided for the time being, upgrade from Sierra to High Sierra is the better route for my situation. I gave up on Mojave for now. I was wasting too much time messing around with Mojave, to get PM working. I will try again when I have more free time, as I need this system to do work. High Sierra was a non issue. 

Share this post


Link to post
Share on other sites

Bilbo -

 

Would you consider making a Mojave installation thread for the x20 series that is as awesome as this one is for High Sierra? I am running it on my 620 and I love how in-depth and how much attention to detail is in the instructions. People don't realize that writing a great instruction manual is super hard work and requires quite a bit of attention to detail and hand holding. That is what separates this guide form others. So many people glaze over steps or omit things...but not you. Also if Catalina is capable maybe down the road. I know that HS works as well on the x20 as Sierra does on the first gen Z series.

Share this post


Link to post
Share on other sites
On 1/25/2020 at 1:40 AM, Dr Droid said:

I decided for the time being, upgrade from Sierra to High Sierra is the better route for my situation. I gave up on Mojave for now. I was wasting too much time messing around with Mojave, to get PM working. I will try again when I have more free time, as I need this system to do work. High Sierra was a non issue. 

 

Sorry about that. Ragimund was able to get pm working on Mojave. Didn't those post (previous page) useful for you?

Share this post


Link to post
Share on other sites
14 hours ago, arkieboy72472 said:

Bilbo -

 

Would you consider making a Mojave installation thread for the x20 series that is as awesome as this one is for High Sierra? I am running it on my 620 and I love how in-depth and how much attention to detail is in the instructions. People don't realize that writing a great instruction manual is super hard work and requires quite a bit of attention to detail and hand holding. That is what separates this guide form others. So many people glaze over steps or omit things...but not you. Also if Catalina is capable maybe down the road. I know that HS works as well on the x20 as Sierra does on the first gen Z series.

 

Thanks for your words. I really appreciate it. Yes, it's really really hard and it takes eons, specially considering that English is not my native language and I'd say it's not my main skill. :whistle:

 

About mojave's guide, I mentioned time ago. Since the lack of nvidia support (damn Apple) , simply , I can't install Mojave. (I have a 1080ti). Sadly, my road in Hackintosh is simply closed. I would like it , sure. In fact, I'm still on Sierra (because a compatibility issue of the soft I use), and I installed High Sierra only for test and the guide. But now... simply, it's impossible. Now I'm spending all time with my machine under windows and centos.

 

But , anyway, I think that just updating main kexts , all guide should apply to Mojave. Several users has reported the success. Basically, except some finding,  that what's I did from Sierra to HighSierra

Share this post


Link to post
Share on other sites

I hear you. I am extremely impressed with Centos 8. It is a few minor tweaks away from being a top tier desktop OS. If I give you a spare graphics card, would you consider a guide? I have a k4000 quadro I am not using :-)

Share this post


Link to post
Share on other sites

Hello to everybody!

I'm writing just to inform you that yesterday I did a flawless update from 10.15.2 to 10.15.3 without any problem.

PM is still working, see my AppleIntelInfo.kext output after a Cinebench 20 run:

Every 1,0s: sudo cat /tmp/AppleIntelInfo.dat                                                                  Mac-Pro-di-Antonio.local: Fri Jan 31 10:21:52 2020

AppleIntelInfo.kext v2.9 Copyright    2012-2017 Pike R. Alpha. All rights reserved.
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 28 (2800 MHz)
Maximum Turbo Ratio/Frequency............: 36 (3600 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ 29 (31) ]
CPU C3-Cores [ 2 3 6 7 ]
CPU C6-Cores [ 0 2 5 11 ]
CPU P-States [ 29 31 (33) ]
CPU C3-Cores [ 0 1 2 3 4 6 7 8 9 ]
CPU C6-Cores [ 0 2 5 6 9 11 15 17 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 9 11 15 17 ]
CPU C3-Cores [ 0 1 2 3 4 6 7 8 9 12 13 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 9 11 15 17 ]
CPU P-States [ 29 31 33 (35) ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 11 15 17 ]
CPU P-States [ 29 30 31 33 (35) ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 15 17 ]
CPU P-States [ (12) 29 30 31 33 35 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 12 13 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 15 17 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 14 15 16 17 ]
CPU P-States [ 12 29 30 31 32 (33) 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 12 14 15 16 17 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 12 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 29 30 31 32 33 (34) 35 ]
CPU P-States [ 12 (24) 29 30 31 32 33 34 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 24 (28) 29 30 31 32 33 34 35 ]
CPU P-States [ 12 (20) 24 28 29 30 31 32 33 34 35 ]
CPU P-States [ 12 20 24 28 29 30 31 32 33 34 35 (36) ]
CPU P-States [ 12 20 24 27 28 29 30 31 32 33 34 (35) 36 ]
CPU P-States [ (12) 18 20 24 27 28 29 30 31 32 33 34 35 36 ]
CPU P-States [ 12 18 20 24 26 27 28 29 30 (31) 32 33 34 35 36 ]

Have fun!

AC

Share this post


Link to post
Share on other sites

Hi All,

 

Original High Sierra guide for HP Zxxx works Ok 1:1 to Mojave also, no need for new HP Zxxx Mojave guide. Even I, as a beginner (Newbie) in Hackintosh world, managed to install Mojave to my Z820.

 

And IF you have any model of NVidia graphics card, sorry, High Sierra is the highest for you. Apple dropped NVidia support totally in Mojave & Catalina due NVidias own "bad co-operation & problems". You have to buy AMD graphics card! I have RX580 and it has Native support.

 

Mainly my problems were issued to "I didn't read guide carefully from word to word before doing something" - jumping too fast to things without knowing what I was doing got me troubles (as I was from Windows world, but also knowing Linux helped me).

 

Big Thanks to Bilbo, Antonio, others as they helped me to understand things and kindly corrected me where I had done my errors - learned quite much on the way...

 

Getting PM working was actually easy, just stick with the guide. My problem was related to wrong SW version of that ssdtPRGEN - correct version was the "beta" version (latest). I downloaded the older as I thought that it was more "stable".

 

Haven't try the Catalina yet, I will stick with Mojave as it's more Mature.

 

 

To Antonio: I did bought the 1TB NVMe SSD. As almost every place is selling this Samsung 970 EVO Plus version (over 220 euros, previous 970 EVO versions not available) and you mentioned that Plus version has some problems with Apple NVMe driver I took the risk and bought something else.

 

After reading many tests and reviews I bought A-data XPG SX8200 Pro with 149 euros. +22 euros for PCIe NVMe adapter with heatsink.  It's specs are pretty good and is a good competitor for Samsung with 5 years warrant.

 

I have almost the same speed results as you with your Samsung.

Reading gives 2800 and writing 2500. It's Ok for me, at least it beats the SATA SSD with 550/520.

 

Interesting was that I tried it first with windows 10. There it gave almost the maximums related the A-data specs. 3500/3000. So it's not the HP Zxx hardware problem, it related to Apple's own driver.

 

BR

 

-Ragimund

Share this post


Link to post
Share on other sites
On 2/19/2020 at 6:06 AM, Ragimund (HP Z820) said:

Hi All,

 

Original High Sierra guide for HP Zxxx works Ok 1:1 to Mojave also, no need for new HP Zxxx Mojave guide. Even I, as a beginner (Newbie) in Hackintosh world, managed to install Mojave to my Z820.

 

And IF you have any model of NVidia graphics card, sorry, High Sierra is the highest for you. Apple dropped NVidia support totally in Mojave & Catalina due NVidias own "bad co-operation & problems". You have to buy AMD graphics card! I have RX580 and it has Native support.

 

Mainly my problems were issued to "I didn't read guide carefully from word to word before doing something" - jumping too fast to things without knowing what I was doing got me troubles (as I was from Windows world, but also knowing Linux helped me).

 

Big Thanks to Bilbo, Antonio, others as they helped me to understand things and kindly corrected me where I had done my errors - learned quite much on the way...

 

Getting PM working was actually easy, just stick with the guide. My problem was related to wrong SW version of that ssdtPRGEN - correct version was the "beta" version (latest). I downloaded the older as I thought that it was more "stable".

 

Haven't try the Catalina yet, I will stick with Mojave as it's more Mature.

 

 

To Antonio: I did bought the 1TB NVMe SSD. As almost every place is selling this Samsung 970 EVO Plus version (over 220 euros, previous 970 EVO versions not available) and you mentioned that Plus version has some problems with Apple NVMe driver I took the risk and bought something else.

 

After reading many tests and reviews I bought A-data XPG SX8200 Pro with 149 euros. +22 euros for PCIe NVMe adapter with heatsink.  It's specs are pretty good and is a good competitor for Samsung with 5 years warrant.

 

I have almost the same speed results as you with your Samsung.

Reading gives 2800 and writing 2500. It's Ok for me, at least it beats the SATA SSD with 550/520.

 

Interesting was that I tried it first with windows 10. There it gave almost the maximums related the A-data specs. 3500/3000. So it's not the HP Zxx hardware problem, it related to Apple's own driver.

 

BR

 

-Ragimund

 

One correction:

 

https://www.reddit.com/r/hackintosh/comments/b91vf5/mojave_gpu_buyers_guide/

 

Native nVidia GPUs

Kepler GPUs (GTX 6xx, 7xx) Highest Supported OS: Current/Mojave 10.14.6

Currently the only 100% native Nvidia architecture that works with Mojave. Users have reported issues with the GTX 650ti, 660, 660ti but this is caused by a driver issue on Apple’s end by not supporting the GK106 core(or quite poorly as the issue seems to be memory leakage which also affects real Macs). Another issue with this generation is lower end products marketed as first generation Kepler are actually using a Fermi core but have identical counterparts running Kepler cores as well(GF 116 vs GK 107 found in the GT 640). AND PLEASE NOTICE THAT GTX 745, 750 and ti VARIANTS ARE NOT INCLUDED, THEY'RE NOT KEPLER

 

Supported cards:

Kepler Gen 2:

GTX Titan (GK 110 Maxwell core)

GTX Titan Black(GK 110 Maxwell core)

GTX Titan Z (One of the few dual GPU cards supported in MacOs)

GTX 780/ti

GTX 770

GTX 760/ti

GT 740

GT 730

GT 720

GT 710

Kepler Gen 1:

GTX Titan (GK 110 Maxwell core)

GTX Titan Black(GK 110 Maxwell core)

GTX Titan Z (One of the few dual GPU cards supported in MacOs, unfortunately was never truly utilized)

GTX 690(Another dual GPU card compatible with MacOS)

GTX 680

GTX 670

GTX 660/TI(MUST BE RUNNING A GK 104 core, NOT GK 106)

GTX 650(MUST BE RUNNING A GK 107 core, NOT GK 106)

GTX 645(GT 645 is Fermi)

GT 640(Kepler edition, GK 107/208 core)

GT 630(Kepler edition, GK 208 core)

Quadro:

Quadro 410

Quadro K420

Quadro K600

Quadro K2000/D

Quadro K4000/D

Quadro K4200

Quadro K5000

Quadro K5200

Quadro K6000

Share this post


Link to post
Share on other sites
On 2/19/2020 at 12:06 PM, Ragimund (HP Z820) said:

Hi All,

 

Original High Sierra guide for HP Zxxx works Ok 1:1 to Mojave also, no need for new HP Zxxx Mojave guide. Even I, as a beginner (Newbie) in Hackintosh world, managed to install Mojave to my Z820.

 

And IF you have any model of NVidia graphics card, sorry, High Sierra is the highest for you. Apple dropped NVidia support totally in Mojave & Catalina due NVidias own "bad co-operation & problems". You have to buy AMD graphics card! I have RX580 and it has Native support.

 

Mainly my problems were issued to "I didn't read guide carefully from word to word before doing something" - jumping too fast to things without knowing what I was doing got me troubles (as I was from Windows world, but also knowing Linux helped me).

 

Big Thanks to Bilbo, Antonio, others as they helped me to understand things and kindly corrected me where I had done my errors - learned quite much on the way...

 

Getting PM working was actually easy, just stick with the guide. My problem was related to wrong SW version of that ssdtPRGEN - correct version was the "beta" version (latest). I downloaded the older as I thought that it was more "stable".

 

Haven't try the Catalina yet, I will stick with Mojave as it's more Mature.

 

 

To Antonio: I did bought the 1TB NVMe SSD. As almost every place is selling this Samsung 970 EVO Plus version (over 220 euros, previous 970 EVO versions not available) and you mentioned that Plus version has some problems with Apple NVMe driver I took the risk and bought something else.

 

After reading many tests and reviews I bought A-data XPG SX8200 Pro with 149 euros. +22 euros for PCIe NVMe adapter with heatsink.  It's specs are pretty good and is a good competitor for Samsung with 5 years warrant.

 

I have almost the same speed results as you with your Samsung.

Reading gives 2800 and writing 2500. It's Ok for me, at least it beats the SATA SSD with 550/520.

 

Interesting was that I tried it first with windows 10. There it gave almost the maximums related the A-data specs. 3500/3000. So it's not the HP Zxx hardware problem, it related to Apple's own driver.

 

BR

 

-Ragimund

Hi Ragimund,

 

Thanks for all of this. I followed your progress as I have a Z820 2xE5-2670 v2 Bios 3.91 - Bilbo's guide is great and easy to follow as were your messages.  Mojave is working well with power management and GB3 scores are impressive.

The only problem I have is not being able to shutdown. My Z820 restarts when shutdown from Mojave and Windows 10. Will live with that as the usual solutions don't seem to work.

EDIT: I also have an NVME drive which I select after booting clover from a Sata SSD (which I use as backup for Mojave).  I bought the 970 PLUS and check that the firmware was the latest version which Samsung created to fix the Mac OS problem.

So I boot from SATA SSD with NvmExpressDxe-64.efi in Drivers64 so that Clover recognise the 970, select MacOS Samsung 970. Use CCC to clone any changes to the SATA SSD.

Stefan

Screenshot 2020-02-26 at 12.35.48.png

Edited by stefanza
Comment on NVME

Share this post


Link to post
Share on other sites

I followed the guide exactly and finally got Mojave to work. Catalina, not so much. There are some parts of the guide I have a few nit picks with but all in all it is great and worked for me.

 

If anyone reads this and wants to try it, here are some issues I noticed:

 

1) in the part about maciACL it says use 6.1 but the version he quotes uses version 6.2a. Just use that.

 

2) about ssdpregen, the folder it downloads to by default is a hidden folder. You will have to make hidden folders viewable to find it.

 

3) the appleintelCPU kext he refers to has a slightly different name than what is used.

 

4) to use mojave you will need a newer version of clover which will have a completely different layout so just be careful (and this guide is not for mojave so this kinda doesn't apply).

 

5) the guide doesn't get specific into how to make iMessage work and doesn't get into the specifics of certain parts of the config.plist, but it at least goes over the important parts

 

6) while this guide 99% works for Mojave like it does high sierra, make sure and get the newest kexts unless he says otherwise.

 

7) not everything is needed in the folder he provides but it has more than enough for most people.

 

8) When you first do f4 for dsdt etc, also save apic.aml as you will need it in the end.

 

All in all the guide is on the money and if you read the threads and the guide and pay close attention you can run Mojave or High Sierra on your second get Z series. Oh, and make sure your BIOS time and date is set right. 

 

Also if you are trying Catalina you may need other kexts not located in this guide and not linked to by this thread. It may or may not work. When people post results, they often leave out many details. People tend to skim over things they know that you do not.

Edited by arkieboy72472

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, Hackintosh noob here trying to get Catalina working. Following the guide and Antonio's new PM approach in Catalina, I was able to get PM working a couple days ago. But today I check HWMonitor and AppleIntelinfo.kext, my CPUs are back to stock speeds. I am not sure what could have caused the problem.

 

Output of AppleIntelinfo.kext:

sudo cat /tmp/AppleIntelInfo.dat                 
AppleIntelInfo.kext v2.9 Copyright © 2012-2017 Pike R. Alpha. All rights reserved.
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 28 (2800 MHz)
Maximum Ratio/Frequency..................: 28 (2800 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ (28) ]
CPU C3-Cores [ 0 1 3 8 15 16 17 ]
CPU C6-Cores [ 4 5 7 8 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 15 16 17 19 ]
CPU C6-Cores [ 0 1 4 5 6 7 8 9 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 10 12 13 15 16 17 19 ]
CPU C6-Cores [ 0 1 4 5 6 7 8 9 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 10 11 12 13 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 19 ]
CPU C3-Cores [ 0 1 2 3 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
 3 4 5 6 7 8 9 10 11 12 13 14 15 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]

 

Here's the outputs when I run the 4 commands:

kextstat|grep -y appleintelcpu               
   40    0 0xffffff7f83209000 0x2a000    0x2a000    com.apple.driver.AppleIntelCPUPowerManagement (222.0.0) F76E3420-6A3B-3C54-AECF-3CE52F3F1EEC <8 7 6 5 3 1>
   55    0 0xffffff7f83298000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (222.0.0) 95FDE1E5-9403-31D1-B8DE-E337BC88BC55 <8 7 6 5 3 1>
kextstat|grep -y x86plat
  115    1 0xffffff7f826d6000 0x19000    0x19000    com.apple.driver.X86PlatformPlugin (999.9.9) 337EC7D0-E726-38CA-9C14-3C4B7C4C7B52 <114 66 27 15 12 8 7 6 5 3 1>
  162    1 0xffffff7f826ef000 0x7000     0x7000     com.apple.driver.X86PlatformShim (1.0.0) E0AA6793-A683-35E1-821D-6680D7B1B6B4 <115 114 15 8 5 3>
sysctl -n machdep.xcpm.vectors_loaded_count
0
sysctl -n machdep.xcpm.mode
0

 

Edited by kyroschow

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, kyroschow said:

Hi, Hackintosh noob here trying to get Catalina working. Following the guide and Antonio's new PM approach in Catalina, I was able to get PM working a couple days ago. But today I check HWMonitor and AppleIntelinfo.kext, my CPUs are back to stock speeds. I am not sure what could have caused the problem.

 

Output of AppleIntelinfo.kext:


sudo cat /tmp/AppleIntelInfo.dat                 
AppleIntelInfo.kext v2.9 Copyright © 2012-2017 Pike R. Alpha. All rights reserved.
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 28 (2800 MHz)
Maximum Ratio/Frequency..................: 28 (2800 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ (28) ]
CPU C3-Cores [ 0 1 3 8 15 16 17 ]
CPU C6-Cores [ 4 5 7 8 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 15 16 17 19 ]
CPU C6-Cores [ 0 1 4 5 6 7 8 9 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 10 12 13 15 16 17 19 ]
CPU C6-Cores [ 0 1 4 5 6 7 8 9 11 19 ]
CPU C3-Cores [ 0 1 2 3 6 7 8 10 11 12 13 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 19 ]
CPU C3-Cores [ 0 1 2 3 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 14 15 16 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
 3 4 5 6 7 8 9 10 11 12 13 14 15 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]

 

Here's the outputs when I run the 4 commands:


kextstat|grep -y appleintelcpu               
   40    0 0xffffff7f83209000 0x2a000    0x2a000    com.apple.driver.AppleIntelCPUPowerManagement (222.0.0) F76E3420-6A3B-3C54-AECF-3CE52F3F1EEC <8 7 6 5 3 1>
   55    0 0xffffff7f83298000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (222.0.0) 95FDE1E5-9403-31D1-B8DE-E337BC88BC55 <8 7 6 5 3 1>

kextstat|grep -y x86plat
  115    1 0xffffff7f826d6000 0x19000    0x19000    com.apple.driver.X86PlatformPlugin (999.9.9) 337EC7D0-E726-38CA-9C14-3C4B7C4C7B52 <114 66 27 15 12 8 7 6 5 3 1>
  162    1 0xffffff7f826ef000 0x7000     0x7000     com.apple.driver.X86PlatformShim (1.0.0) E0AA6793-A683-35E1-821D-6680D7B1B6B4 <115 114 15 8 5 3>

sysctl -n machdep.xcpm.vectors_loaded_count
0

sysctl -n machdep.xcpm.mode
0

 

Hello!

My AppleIntelInfo.dat on Catalina 10.15.3 is still correct:

AppleIntelInfo.kext v2.9 Copyright © 2012-2017 Pike R. Alpha. All rights reserved.
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 28 (2800 MHz)
Maximum Turbo Ratio/Frequency............: 36 (3600 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ (12) 23 31 ]
CPU C3-Cores [ 0 2 ]
CPU C6-Cores [ 2 3 4 12 ]
CPU P-States [ 12 23 26 31 (32) ]
CPU C3-Cores [ 0 1 2 18 ]
CPU C6-Cores [ 1 2 3 4 5 12 ]
CPU P-States [ 12 23 26 29 (31) 32 ]
CPU C3-Cores [ 0 1 2 4 5 8 12 13 17 18 ]
CPU C6-Cores [ 1 2 3 4 5 7 12 ]
CPU P-States [ 12 23 26 28 29 (31) 32 ]
CPU C3-Cores [ 0 1 2 4 5 8 9 12 13 17 18 ]
CPU C6-Cores [ 1 2 3 4 5 7 8 10 12 ]
CPU P-States [ 12 23 25 26 (28) 29 31 32 ]
CPU C3-Cores [ 0 1 2 4 5 8 9 12 13 17 18 ]
CPU C6-Cores [ 1 2 3 4 5 7 8 9 10 12 13 ]
CPU P-States [ 12 23 25 26 27 28 29 31 32 (33) ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 12 13 17 18 ]
CPU C6-Cores [ 1 2 3 4 5 6 7 8 9 10 12 13 14 15 ]
CPU P-States [ 12 (20) 23 25 26 27 28 29 31 32 33 ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 12 13 14 17 18 19 ]
CPU C6-Cores [ 1 2 3 4 5 6 7 8 9 10 12 13 14 15 18 19 ]
CPU C6-Cores [ 1 2 3 4 5 6 7 8 9 10 12 13 14 15 17 18 19 ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 11 12 13 14 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 12 13 14 15 17 18 19 ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 10 11 12 13 14 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 17 18 19 ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 10 11 12 13 14 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ (12) 20 23 24 25 26 27 28 29 31 32 33 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 20 23 24 25 26 27 28 29 30 (31) 32 33 ]
CPU P-States [ 12 20 23 24 25 26 27 28 29 30 31 32 33 (34) ]
CPU P-States [ 12 20 23 24 25 26 27 28 29 30 31 32 33 34 (35) ]
CPU P-States [ 12 20 22 23 24 25 26 27 28 29 30 31 32 33 (34) 35 ]
CPU P-States [ (12) 19 20 22 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ (12) 17 19 20 22 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ 12 17 19 20 22 23 24 25 26 27 28 29 30 31 32 33 34 35 (36) ]
CPU P-States [ 12 17 19 (20) 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 ]
CPU P-States [ 12 16 17 19 20 21 22 23 (24) 25 26 27 28 29 30 31 32 33 34 35 36 ]
CPU P-States [ 12 16 17 18 19 (20) 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 ]
CPU P-States [ 12 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 (32) 33 34 35 36 ]

Double check your ACPI/patched folder under EFI/CLOVER, it should contain at least 3 files (mine has 4 because of the NVMe external pactch):

image.thumb.png.cddff19a18ba1d28a79ab2337487ba29.png

Edited by antonio.clb

Share this post


Link to post
Share on other sites
On 12/11/2019 at 12:01 PM, antonio.clb said:

Thanks for the tip bilbo! I've enabled it:

image.thumb.png.8d40fd80b800d6344a2fcbdfbca55081.png

I confirm that security update from Mojave 10.14.6 (18G1012) to 10.14.6 (18G2022) has worked flawlessly (3 reboots needed).

No need to repatch AICPM after update. My CPUs multiplier factors oscillates between x12 and x35 according to HWMonitor. All 40 CPUs are showed on activity monitor (Window -> CPU Usage).

I can confirm Mojave works perfectly on my Z620 by following my AICPM patching routine described early and, of course, based on your great work!

 

Update

Here's my AppleIntelInfo.dat after a GeekBench 5 (712 sc - 10852 mc) run (36x!!!):


AppleIntelInfo.kext v2.9 Copyright © 2012-2017 Pike R. Alpha. All rights reserved.
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 28 (2800 MHz)
Maximum Turbo Ratio/Frequency............: 36 (3600 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ 27 32 (35) ]
CPU C3-Cores [ 0 1 13 14 ]
CPU C6-Cores [ 0 5 9 ]
CPU P-States [ (12) 23 27 32 35 ]
CPU C3-Cores [ 0 1 3 6 9 12 13 14 ]
CPU C6-Cores [ 0 2 5 7 9 12 ]
CPU P-States [ 12 23 27 28 32 (33) 35 ]
CPU C3-Cores [ 0 1 3 6 7 9 12 13 14 ]
CPU C6-Cores [ 0 2 3 5 6 7 9 12 ]
CPU P-States [ 12 23 26 27 28 32 33 (35) ]
CPU C3-Cores [ 0 1 3 4 5 6 7 8 9 12 13 14 ]
CPU C6-Cores [ 0 2 3 5 6 7 9 12 13 ]
CPU C3-Cores [ 0 1 3 4 5 6 7 8 9 10 11 12 13 14 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 8 9 12 13 ]
CPU C3-Cores [ 0 1 3 4 5 6 7 8 9 10 11 12 13 14 15 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 8 9 12 13 18 19 ]
CPU P-States [ 12 23 26 27 28 32 33 (34) 35 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 12 13 15 16 18 19 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 17 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 12 13 15 16 17 18 19 ]
CPU P-States [ 12 23 26 27 (28) 29 32 33 34 35 ]
CPU C3-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 23 (24) 26 27 28 29 32 33 34 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 (20) 23 24 26 27 28 29 32 33 34 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 20 23 (24) 25 26 27 28 29 32 33 34 35 ]
CPU P-States [ 12 20 23 24 25 26 27 28 29 (31) 32 33 34 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 ]
CPU P-States [ 12 20 23 24 25 26 27 28 29 30 31 32 33 34 (35) ]
CPU P-States [ 12 (20) 21 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ (12) 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ (12) 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ 12 18 19 (20) 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 ]
CPU P-States [ 12 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 (36) ]
CPU P-States [ 12 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 (34) 35 36 ]
CPU P-States [ 12 13 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 (33) 34 35 36 ]

 

Thanks a lot for all your efforts and contribution to the community!

 

Best regards.

AC

Hi Everyone,

 

Great job done in this forum/topic.

 

I am experiencing problems with my Z620 v1 on Catalina 10.15.3

 

I can't patch AICPM Kext, it states Read Only File ( I do this under sudo )

x86Platform file can't be loaded, either it is kext injected at S/L and S/L/E

 

Is there any way someone could share his CLOVER folder, please?  Config.plist will be awesome in order to double check if I have wrong parameters.

 

Thanks in advance.

 

Alex.

Share this post


Link to post
Share on other sites

Sorry, 

 

I finally found what has happening.  -xcpm flag needed to be enabled at Clover Boot in order to let x86platformplugin.kext to be loaded.

 

I was finally able to patch AICPM vía Clover and now I have PM working perfectly. Also a previous bug I had that created random reboots when plugin and unplugging USB´s 2.0 and 3.0 is gone.

 

Cheers!!

 

Alex.

Share this post


Link to post
Share on other sites
7 hours ago, Alex Andreu said:

Sorry, 

 

I finally found what has happening.  -xcpm flag needed to be enabled at Clover Boot in order to let x86platformplugin.kext to be loaded.

 

I was finally able to patch AICPM vía Clover and now I have PM working perfectly. Also a previous bug I had that created random reboots when plugin and unplugging USB´s 2.0 and 3.0 is gone.

 

Cheers!!

 

Alex.

Great news @Alex Andreu!

Notice that, according to @bilbo's guide, you should enable the xcpm_ipi flag if you have two physical CPUs:

Quote

31-Enable on clover “-xcpm” flag, or “-xcpm_ipi” custom flag, if you have a dual cpu, as the script recommends.

 

Best regards.

AC

Share this post


Link to post
Share on other sites

Thanks for getting back to me. I will try -xcpm_ipi instead to see if it makes any difference.

 

What I can assure is, when I created for Mojave SSDT.aml, If I used the flags for SandyBridge cpu´s ( I have dual E5-2690 v1 ), geekbench and cinebench performance was very poor.

 

If SSDT was created by "fooling" flags and telling to apply IvyBridge patches for a E5-2690 v2 with its proper max turbo speed, Cinebench score was fantastic ( around 4800 points ).

 

How can this be possible? Did anyone experience this kind of situation in the past?

 

I think I have both SSDT´s if anyone with Dual 2690´s wanna try.

 

Once again, thanks in advance for your support.

 

Regards,

 

Alex.

Share this post


Link to post
Share on other sites
Posted (edited)
On 11/30/2018 at 5:47 PM, pingyes said:

HighSierra, Mojave almost the same process, I work under cent os7.4, everything is normal, including Thunderbolt is still working out of the box

 

Hi I can get both mojave and High sierra installed on my z820 but the PCI Thunderbolt has no driver on either ?

 

Can you tell me how yours is working please and any advice i can to enable mine please ??

 

my pcie thunderbolt card shows as :

pci1a00,2     Other multimedia       No                 Firewire

 

Need thunderbolt for my audio interfeace any help is really appreciated  

Edited by Taccess
additional info

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By _ivan_palmisano_
      Ho provato tutti i modi ma sono arrivato alla conclusione che ha bisogno di una patch DSDT.
      Ciao, ho recentemente un hackintosh nel mio laptop e devo risolvere l'attacco video HDMI che non ha eseguito quando collego il mio laptop alla TV.
      le foto con queste informazioni sono state fatte con un programma quando che avrei vinto 10 nell'altra foto l'informazione di hackintosh.
      Acer Aspire 5741g Modello High Sierra System!
      Caratteristiche:
      CPU: Intel Core I3 350M 2.27Ghz Arrandale 32nm Tecnologia
      Ram: 6: 00GB
      Grafica: Monitor Pnp generico (1366x768 Ghz) 1024mb Nvidia GeForce GT 320M (Acer Incorporated)
      Archiviazione: 465 GB Sata
      Driver Optiocal: Optiarc DVD RW- AS-7585H
      Audio: dispositivo audio ad alta degradazione
      Qualcuno può aiutarmi!?! E 'la terza volta che faccio questo post in questo gruppo visto che sono nuovo nel mondo hackintosh preferisco se qualcuno è capace a risolvere il mio problema che lo faccia in remoto così non faccio sbagli.
    • By Prt91
      Ciao ragazzi, sono incappato in un problema che di sicuro sono io stupido.
      Premetto che: Chiavetta 32giga, formattata Journaled e GUID, Clover installato.
      In primis la cartella che crea Clover dei Driver non si chiama drivers64EFI e ne crea una drivers e basta, de facto non legge i driver e di conseguenza la chiavetta per fare l'installazione.
      Pazienza, ho scaricato i driver altrove e li ho buttati in una cartella drivers64EFI, ergo chiavetta rilevata dentro clover.
      Arrivo all'utility disco, inizializzo l'SSD(samsung 860pro) in APFS e facendo partire l'installer non mi fa cliccare l'SSD APPENA formattato dicendomi che sto provando ad installare un MacOS più VECCHIO di quello attualmente installato o.0????????
      Ok, CMD Q e torno all'utility, formatto in Journaled ma nulla di fatto, mi ridice la stessa frase. Faccio hackintosh da snow leopard ma una roba del genere mai vista.
      La chiavetta l'ho creata col classico create installer media da una virtual machine con Mojave. E il driver APFS l'ho cercato apposta per 10.13 e i driver scaricati li ho trovati sul web per una MOBO identica alla mia ma Mojave (Aorus Ultra Z390).
      Non ne vengo a capo. Devo forse formattare la chiavetta in MBR?
      GRAZIE A TUTTI e soz per la nabbaggine
    • By Ragimund (HP Z820)
      Hi All,
      Noob here asking Help or Hints,
      trying to build my first Hackintosh from HP Z820. Almost done...
       
      Read Z820 Sierra & High Sierra Z820 installation guides in this forum - following them I managed to create a Booting Mojave install USB and successful
      installation of Mojave 10.14.6 in to SSD. Via Clover Boot view I can choose Mojave SSD and it boots Ok, logging in Ok.
       
      Everything "looks" to work Ok.
      -CPU recognised Ok.
      -SSD & HDU Ok.
      -GPU Radeon RX580, 2 x DP in use.
      -Dual displays Ok (Full HD, no internal speakers)
      -Wired LAN working (2 Wired LAN RJ-45 connectors, using the one without text label "AMT" (?))
      -No Wifi (no dongle)
      -Audio working: line out & headphones, airplay (ALC262, injected 28) Ok.
      -Bluetooth dongle (Ebay) in USB2.0 port Ok (paired BT Speaker, Keyboard and Mouse).
      -Front: 1 x USB2.0, 2 x USB3.0 (all as USB2.0 mode, I think).
      -Back: 4 x USB2.0, 2 x USB3.0 (all as USB2.0 mode, I think).
      -Back: Firewire OK/NOK ? Don't own any fw device at the moment, how to test, not important now.
       
      Not yet signed to any Apple service, iCloud, etc. Not yet installed any other software except Clover 5098 and Hackintools 2.8.6
       
      MY PROBLEM:
      System Preferences is showing Update, Mojave 2019-001 (1.55GB). Safari was updated Ok with another smaller update.
      I try to install the Mojave Update. It downloads it Ok, warns about needed Restart and after accept it starts to install it.
      Apple logo visible, progress bar visible, text "Installing Software Update" visible. Progress bar shows a minor progress - stays almost in the beginning...
      and Wham! - Rebooting
       
      Logging in Ok, System Update window pops open and offers the same update again...
       
      Have read plenty of articles from different Forums (sorry, I'm desperate, Noob) and I have a feeling that it relates to my Z820 USB's (maybe??).
      HP Z820 uses "Texas Instruments USB3.0 xHCI Host Controller" - NOT Intel like Apple. That's why All my USB are in "usb2.0 mode" (??).
       
      I installed the system with SSD/HDU cables in factory settings (in SAS/SATA connectors. AstekFusion2Adapter & AstekFusion2Family kexts), worked fine.
      I changed the SSD/HDU cables to different connectors (ACHI 0 / 1) like in Z820 High Sierra guide later and Booted Ok. Tried Update, FAIL.
       
      Have no idea what's wrong or what's causing this - like I said, I'm a Noob and trying to build my first Hackintosh...
       
      Can anyone Help Noob ?
       
       
       
    • By Ciumann
      Ho notato nei giorni scorsi che mi sparivano alcune icone dal dock ma adesso non si accende proprio più. Mi esce la schermata che vi posto in allegato.
      Al pc stacco la corrente quando non ci sono in casa per evitare temporali improvvisi (quindi capitano anche giorni senza corrente).
      L'hackintosh aveva un problema di spegnimento: non si spegneva ma arrivava alla schermata finale e quando usciva CPU halted lo spegnevo manualmente.
      Ho due hard disk uno con Windows 10 e l'altro con high sierra.
      Si può ripristinare? Ho dei progetti di lavoro sopra 
×