Jump to content
Sign in to follow this  
Followers 0
Jerry_MK2

dell m6700 usb 3.0 intel viste come 2.0

8 posts in this topic

Recommended Posts

Ciao a tutti, ho un problema con le porte usb 3.0 intel del mio Dell Mobile Workstation M6700:

cpu i7-3940xm extreme
qm77 chipset
24gb ram ddr3 1600mhz
nvidia quadro k3000m 2gb gdrr5 (uso questa come scheda video, optimus disabilitato nel bios)
17,3" fullhd 1920x1080
ssd1 samsung 850 250gb (windows 10)
ssd2 crucial mx300 525gb (downloads)
ssd3 crucial mx300 750gb (caddy) (data and virtual machines)
ssd4 lite-on msata 256gb (sierra mac os)

5 porte usb in totale:
2 porte usb 2.0 (funzionano perfettamente)
1 porta usb/eSata combo (funziona perfettamente)
2 porte usb 3.0 intel (viste come 2.0 e lente come tali)

Ho provato usbinjectall.kext con la patch port limit per sierra in clover (rinominato ehci1 a eh01.....), nulla.

Ho applicato la patch (al dsdt.amd) 7-series/8-series usb di rehabman, nulla. (questo metodo ha funzionato su un altro dell e su un toshiba)

Ho provato fakepciid.kext + fakepciid_xhcimux.kext, nulla.

Il sistema le legge sempre come 2.0. Nel profiler si vedono 2 controllers usb 2.0 ehci e nessun controller xhci.

 

Spero possiate aiutarmi perchè ci sto impazzendo davvero :cry::cry:

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, iCanaro said:

visto che non hai hardware recente e usi sierra, forse il genericUSB ottiene risultati migliori... almeno da me è così

Io avevo letto che genericusb era funzionante fino a Yosemite. L'hanno aggiornato/riscritto? Funziona anche su Sierra?

Share this post


Link to post
Share on other sites

l'ultima release risale al 2015, ma come ho detto, nei miei hack con hardware non recente mi funziona sia su high sierra che mojave.

Lo metti in EFI lo provi e vedi se ti funziona, altrimenti lo cestini

Share this post


Link to post
Share on other sites

potrebbe darsi che hai un id del chip particolare e non ne voglia sapere di andare, ma sono tutte ipotesi, prova a riparare i permessi

 

sudo chown -R root:wheel /S*/L*/E* && sudo chmod -R 755 /S*/L*/E* && sudo kextcache -Boot -i /

 

anche se non dovrebbe servire, lascia operativa la patch port limit per il macOS in uso e metti USBinjectall.

Se ancora non ci siamo prova una ad una le varie versione meno recenti dell'USBinjectall. Se ancora non va, prima della canna del gas, metti genericUSB + USBinjectall contemporaneamente

Share this post


Link to post
Share on other sites

Jerry mk2 . Hi. 

I have the same m6700 only with k5000. I have usb3 working with USB inject all and I think the kext regarding usb3 is fackpciid_xhcimux kext ( I think u need fackpciid kext as well) they are in my clover folder. I think this is the cure for usb3 . 

I want to ask you : do you have option for Optimus in your bios ? I don't . And my internal screen is dead - external works fine. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×