Jump to content
Donk

macOS Unlocker V3.0 for VMware ESXi

70 posts in this topic

Recommended Posts

Advertisement
Just now, Naki said:

Yes, this is only for VMware Workstation, maybe Fusion, but not ESXi.

ok thanks, so for me the last version is 3.0.0?

i don't know where is my problem...

 

somebody have mojave on esxi 6.7 U3 works ?

 

 

Share this post


Link to post
Share on other sites

I was able to install macOS Catalina on ESXi 6.7 by following the instructions on this site https://www.jomebrew.com/2019/10/macos-catalina-beta-on-vmwwre-esxi-67-u2.html and installing esxi-unlocker30. However, I am unable to install VMware tools as it gives this error: "The VMware Tools upgrade operation was canceled. Vix error code = 21004". Does anyone know how to solve?

Share this post


Link to post
Share on other sites
On 11/1/2019 at 12:58 PM, edem2302 said:

ok thanks, so for me the last version is 3.0.0?

i don't know where is my problem...

 

somebody have mojave on esxi 6.7 U3 works ?

 

I was able to start up and run my Mojave VM under ESXi 6.7 U3 - no issues. I did need to reinstall the Unlocker 3.0 after the ESXi upgrade (from 6.7 U2). Unlocker 3.0 seemed to work fine before for me so I stayed with 3.0...never used 3.01 or 3.02. When installing macOS, make sure you erase the hard drive partition (using Apple's Disk Utility) and set the new partition to be of type APFS. I believe, I used to be able to use HFS+ in High Sierra, but for Mojave it is absolutely necessary to use APFS as the file system.

 

1.jpg

2.JPG

Edited by Cybernut

Share this post


Link to post
Share on other sites
On 11/15/2019 at 9:07 AM, Cybernut said:

 

I was able to start up and run my Mojave VM under ESXi 6.7 U3 - no issues. I did need to reinstall the Unlocker 3.0 after the ESXi upgrade (from 6.7 U2). Unlocker 3.0 seemed to work fine before for me so I stayed with 3.0...never used 3.01 or 3.02. When installing macOS, make sure you erase the hard drive partition (using Apple's Disk Utility) and set the new partition to be of type APFS. I believe, I used to be able to use HFS+ in High Sierra, but for Mojave it is absolutely necessary to use APFS as the file system.

 

1.jpg

2.JPG

Ok thanks for the reply !

 

i can't use apple disk utility because i can't go after the apple logo...

 

i have try different iso (make with my macbook) the iso seems good but can't boot...

 

i have a boot loop.

Share this post


Link to post
Share on other sites
7 hours ago, edem2302 said:

Ok thanks for the reply !

 

i can't use apple disk utility because i can't go after the apple logo...

 

i have try different iso (make with my macbook) the iso seems good but can't boot...

 

i have a boot loop.

I recommend uninstalling and re-installing Unlocker 3.0 for ESXi. If you still get boot loop after that, then that means the problem is with your Mojave iso.

Share this post


Link to post
Share on other sites

Hello!

 

I have successfully installed Mojave using unlocker. (ESXi6.7U3)

However, even if Tools are installed, all sounds become noise.

 

Is there a solution for this problem?

 

Thanks.

Share this post


Link to post
Share on other sites
On 11/20/2019 at 6:27 AM, Cybernut said:

I recommend uninstalling and re-installing Unlocker 3.0 for ESXi. If you still get boot loop after that, then that means the problem is with your Mojave iso.

yes, i have try uninstall and re-installing 4 or 5 times, same result.

 

maybe it's my mojave you're right...

 

i'll try...but i don't see where i made a mistake...

 

thanks for your help

Share this post


Link to post
Share on other sites

I have run into a problem using Unlocker and Catalina (10.15.1 19B88). I have tried this from a generated iso, using various tools in the macAdmin community (namely vfuse, AutoDMG, and installinstallmacos.py). 

 

I am using an Intel Nuc (NUC Kit NUC6i7KYK) with the following details below:

image.thumb.png.ddacd337a93a30563e871f64ba071572.png

 

As my main goal here is to test our DEP & MDM workflows on a non apple based esxi machine, I need to use a keyboard input. However, this appears to generate a problem. When setting the device to Apple macOS 10.14 as the VMs guest, the machine boots successfully, but keyboard input does not work correctly.

 

For instance, here:

image.png.3d2369d15fffdee988c2053978243541.png

 

I am presented with an authentication window, but, every key I press automatically initiates the cancel button, in the example above, I am hitting command which somehow sets "cancel". 

 

The only thing I can think of here is unlocker and changes in 10.15.. As the behavior doesn't happen with Mojave and below, and didn't happen with Catalina betas either. 

 

Alternatively, is anyone else having isues with running Catalina 10.15 (non-beta software) on ESXi 6.7u3 with Unlocker and having issues with keyboard inputs?

Share this post


Link to post
Share on other sites

Dear Donk,

 

Thank you so much for the Unlocker releases. They're always of major help. The issue I see right now is the following:

 

All recent unlockers modified to work with VMware Workstation 15.5.x:

https://github.com/DrDonk/unlocker

https://github.com/paolo-projects/unlocker

https://github.com/BDisp/unlocker

 

have the following issue:

 

You cannot install any macOS in new machines. 

 

The Installation ISO works fine in VMware Workstation 15.10, but it doesn't work in VMWare Workstation 15.5.x

 

Upon installation of macOS 10.11x, 10.12.x, 10.13.x, 10.14.x the error displayed at the state of starting the installation upon formatting the hardddrive with DiskUtilities is: "CORRUPTED INSTALLATION DISK"

 

macOS Catalina 10.15.x ISOs will install only by turning board-id.reflectHost = "TRUE". If board-id.reflectHost = "FALSE" then the installation will not proceed. it will be just stuck at continue with no error message.

 

As I mentioned the installation media I used works fine in 15.10 and preinstalled machines with whichever version of macOS will run just fine, however it is impossible to install new ones.

 

I believe Unlocked is missing something. Can you please check this out?

 

Thank you so much!

 

 

 

Share this post


Link to post
Share on other sites
On 12/1/2019 at 2:46 AM, BWEL said:

Dear Donk,

 

Thank you so much for the Unlocker releases. They're always of major help. The issue I see right now is the following:

 

All recent unlockers modified to work with VMware Workstation 15.5.x:

https://github.com/DrDonk/unlocker

https://github.com/paolo-projects/unlocker

https://github.com/BDisp/unlocker

 

have the following issue:

 

You cannot install any macOS in new machines. 

 

The Installation ISO works fine in VMware Workstation 15.10, but it doesn't work in VMWare Workstation 15.5.x

 

Upon installation of macOS 10.11x, 10.12.x, 10.13.x, 10.14.x the error displayed at the state of starting the installation upon formatting the hardddrive with DiskUtilities is: "CORRUPTED INSTALLATION DISK"

 

macOS Catalina 10.15.x ISOs will install only by turning board-id.reflectHost = "TRUE". If board-id.reflectHost = "FALSE" then the installation will not proceed. it will be just stuck at continue with no error message.

 

As I mentioned the installation media I used works fine in 15.10 and preinstalled machines with whichever version of macOS will run just fine, however it is impossible to install new ones.

 

I believe Unlocked is missing something. Can you please check this out?

 

Thank you so much!

 

 

 

 

Can you please post off-topic items in other threads (or create new threads if needed)? This thread is for Unlocker for ESXi, not Workstation. I do not care about issues with Workstation. And looks like you did post in other relevant threads (https://www.insanelymac.com/forum/topic/340416-unlocker-vmware-workstation-155/?do=findComment&comment=2699256) so please don't spam.

 

Edited by Cybernut

Share this post


Link to post
Share on other sites
1 hour ago, Cristina89 said:

on startup

 

Error.png.b8e2515eb4a5ca3e19185a471c385c6f.png

I could be wrong but looks like your unlocker was not installed properly.

Did you follow the instruction to verify that the install of unlocker was successful?

If not, uninstall and reinstall unlocker and then verify it was successful.

Edited by Cybernut

Share this post


Link to post
Share on other sites
11 hours ago, Cristina89 said:

no error

 

ESXI.thumb.JPG.d281d456bdb718475f578f3d0fb1e066.JPG

 

Yes, no error - but to be sure there is a test (to check if install was successful).

Look in the readme.txt file - in section 4, on how to run the test.

If your test results match with readme's results, then I am sorry, I don't know what the problem is - but the error looks more unlocker-related than macOS-related.

Share this post


Link to post
Share on other sites
23 hours ago, Cristina89 said:

Test OK

 

Tets.JPG.fd61b2f60a03214fb19189baa9bc84a8.JPG

Then I suspect something is wrong with your macOS installer.

I hope you build your installer iso. I never download installer iso from Internet - always a good chance of malware, etc. hidden.

I had no problems installing High Sierra (10.13.6), Mojave (1014.6) and the latest Catalina (10.15.2) using Unlocker 3.0

Share this post


Link to post
Share on other sites

Just an fyi. It is possible to install and run the latest Catalina (10.15.2) released on December 10, 2019, on ESXi 7.6 U3 using Unlocker 3.0.

I had some trouble installing the previous version of Catalina (10.15.1) and had given up.

But with the new Catalina I tried again and though I got the same error again (basically I was stopped during the installer loading - it never finishes loading), I tried one more time, but during VM configuration this time instead of changing my CDROM device to an IDE, I left it as a SATA device and installer loaded without problems. I proceeded with the rest of the installation, and everything worked as expected. I have not had the chance to experiment with that setting using the previous Catalina (10.15.1) once more...hopefully that will work with 10.15.1 too.

 

When creating the VM, I chose VM type of ESXi 7.6 U2 (since U3 type is not available). And chose macOS 10.14 (since 10.15 is not available).

 

Anyway, here's the screenshots:

ESXi1.thumb.png.019cf11c684a59abda51b511daeadc35.png

Catalina.thumb.png.26318d10d26f3e4907c77ae11f3bc06e.png

 

 

Edited by Cybernut

Share this post


Link to post
Share on other sites

We're a small org. We were on 6.0 and I used Unlocker 2.x to install Mojave. It was successful.

A colleague of mine upgraded to 6.5.

Now Mojave guest throws an error saying the host is not suitable or compatible when I try to power it on.

 

I ended up here and I wanted to try Unlocker 3.0.

I know the instructions say that I need to uninstall any existing scripts but in the process of upgrade we lost the version of script and we downloaded before. So I used 2.08, ran uninstall rebooted.

 

Then I downloaded 3.0 and installed it.

Script executes just fine and says it's successful prompting me to reboot.

However when I try the script to check it returns with smcpresent = false.

 

We thought we had secure boot enabled but when we ran the python script from VMware, it says that Secure boot is not enabled on the host.

I'm not sure what's causing this issue while it's working for many people.

 

Any insights greatly appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MSoK
      This is the current version of VMware Tools for OS X / macOS from the VMware CDS repository for Fusion 11.5.0
       
      VMware are no longer including the ISO images as separate "packages" in the CDS respository as of Fusion 11.5.0, instead the ISO images are included as part of the "core" download which is 522 MB.
      It is not possible to download the com.vmware.fusion.zip.tar due to upload limits.
       
      However, I have extracted the darwin.iso and darwinPre15.iso from the "core" and uploaded to this thread.
       
      If you prefer to download the "core" tar file and extract the ISO's they are located in the following directory in the tar file:
       
      com.vmware.fusion.zip.tar\com.vmware.fusion.zip\payload\VMware Fusion.app\Contents\Library\isoimages\
       
      Please note: In the latest VMwareGfx.kext from Fusion 8.5.5 onwards VMware have discontinued the 2D-Acceleration code, and graphics performance is better now, thanks to Zenith432 for the update.
       
      To check for the latest version visit http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/.
       
      The various VMware Tools downloads are located under the packages folder for each version upto and including 11.1.0.
       
      Instructions for extracting darwin.iso and darwinPre15.iso
      - Download the files above
      - Extract com.vmware.fusion.tools.darwin.zip.tar
      - darwin.iso is located in the "payload" folder
      - Extract com.vmware.fusion.tools.darwinPre15.zip.tar
      - darwinPre15.iso is located in the "payload" folder
    • By patpro
      Hello,
      I'm running a multi-head workstation built on top of ESXi 5.5 (can't upgrade for various reasons) with Unlocker 2.0.8. In particular: I'm running a Windows 10 pro VM and an OSX 10.11 (El capitan) VM. Those two VM uses PCI passthrough, so that each one has a dedicated PCI GPU and a dedicated USB PCI bus (close-to-native graphics performance, native USB devices, etc.).
      I've checked everything in my setup and I can't make nested virtualization work, but it worked previously on ESXi 5.0 with Unlocker 1.3.1.
       
      Is there any one here who succeeded with nested virtualization on top of ESXi 5.5 with PCI passthrough?
       
      Any help appreciated…
    • By Donk
      Here is a new utility to patch the EFI firmware in VMware Workstation and Fusion to allow the non-server versions of Mac OS X 10.5 (Leopard) and 10.6 (Snow Leopard) to run. Yoiu will need macOS unlocker 3 if you are using Workstation on non-Apple hardware. I still have to find a way to do this on ESXi as the UEFIPatch utility will not run in the ESXi console.
      This currently supports:
       
      Workstation 11/12/14/15 on Windows and Linux Workstation Player 7/12/14/15 on Windows and Linux Fusion 10/11 on macOS  
      https://github.com/DrDonk/efi-unlocker/releases/download/1.0.0/efi-unlocker100.zip
      https://github.com/DrDonk/efi-unlocker
       
      Please read the readme.txt file for details.
      readme.txt
×