Jump to content
Sign in to follow this  
Followers 0
Mayday Alaska

ASRock H170 Fatal1ty Performance BIOS help.

1 post in this topic

Recommended Posts

Hi everybody.

I'm trying to run MacOS High Sierra on tis configuration:

 

i5-6600

ASRock h170 Fatal1ty Performance

RX 480 8gb

 

The problem is that I'm not familiar with ASRock motherboards and their BIOS. Can anyone help me setting it up?

 

Thanks to everyone who will help.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Hugo_bee
      Here I am back again, with a little work for a noob colleague with a mission
       
      Asrock H270M is an ITX mobo (we really appreciate them) that is coming to become an IMAC.
      To let this, we have to do the basic Mojave USB setup installation (create install dir procedure) by erasing a normal 16gb USB3 pen
       
      After that, apply a Clover UEFI+ESP setup with latest Clover
       
      Mount EFI folder of the USB Mojave install disk
       
      Replace ENTIRELY the content of EFI partition with the one here.
       
      For the BIOS configuration I've applied this one:
       
      Advanced \ CPU Configuration → Intel Virtualization Technology : Enabled
      Advanced \ Chipset Configuration → Primary Graphics Adapter : PCI Express
      Advanced \ Chipset Configuration → Vt-d : Disabled
      Advanced \ Chipset Configuration → IGPU Multi-Monitor : Disabled
      Advanced \ USB Configuration → Legacy USB Support : Enabled
      Advanced \ USB Configuration → PS/2 Simulator : Disabled
      Advanced \ USB Configuration → XHCI Hand-off : Enabled
      Security  → Secure Boot: Disabled
      Boot  → Fast Boot: Disabled
      Boot  → Boot From Onboard LAN: Disabled
       
      Then: SETUP Mojave
      Reboot, mount EFI of DESTINATION DISK and REPLACE its EFI content as done before.
       
      you will have:
      1 lan 1gigabit (the 1st one to the left, by standing in front of ports)
      2 HDMI audio and video with QE/CI
      3 all the 15+ USB and XHCI ports enabled
      4 SATA and M2 up & running
      5 NO WIFI but you can replace with a broadcome native one easily.
      6 NO sleep wake
       
       
      H270M-Asrock.zip
    • By Majed DH
      Hi everyone. 
      I have HP 15-da0xxx series laptop. i got macos mojave installed on it. but I was trying to get my intel graphics working but i couldn't change dmvt preallocation. 
      So I updated the bios (unfortunately). And since then i could not boot any version of clover. 
      I tried two versions that were working and even an installer that worked before is not working:
       
      I searched alot about the error and found nothing relared to macos or hackintosh..  would it be solved by patching the dsdt? 

      Any suggestions people ? 
    • By evilshot
      Добрый день! Работает все, кроме встроенного WiFi/Bluetooth( нет модуля, не могу проверить). Сижу пока на USB Wi-Fi TL-WN722N, в дальнейшем собираюсь покупать модуль от MacBook.
      Железо:
      Процессор i5-9600k Материнская плата ASRock z390 Phantome Gaming 6 Встроенное видео: Intel HD Graphics 630 - ok, аппаратное ускорение работает Дискретное видео: Планируется покупка Встроенная сеть: Intel I219V - ok Встроенная сеть: Dragon RTL8125AG - нет драйвера Встроенный WiFi: - Bстроенный Bluetooth 5.0: - Встроенный звук: Realtek ALC1220 - ok SSD: M2 WD green 128gb Память: 24 Gb DDR4-3000 Full-HD монитор - HDMI - подключен к встроенной видеокарте - ок USB 3.0, 3.1, 3. 1gen2-ok Аппаратный NVRAM - не работает, решается тем, что кловер необходимо ставить с EmuVariableUefi - ок. Много усилий и времени заняла настройка биоса в мат плате. Это того стоило. Конечно же не обошлось без добрых людей, которые помогали в ходе установки, настройки загрузчика и системы. Mojave стоит в качестве основной системы, Windows на виртуалке. Прикрепляю загрузчик, Legacy USB, Backup биоса, версии 4,10.
      Вам остается только, вписать модель iMAC( какая вам больше подойдет, у меня сейчас iMac 19.1) и завести iСервисы (FaceTime,imasseges,и т.д.)
      Желаю удачной установки системы
      Фото настроек биоса 
      https://cloud.mail.ru/public/3xd9/2Xtpm64zq
      OSX.BIN.zip
      EFI.zip
      FixUSBPort_AsRockZ390_PG6.zip
      Mojave10,14,6.BIN.zip
    • By kromakey
      Hello ,
       
      Just changed my CPU to a E5450 to be able to Run Mojave , but now I can not run not even EL Capitan    (it was working well with CORE2DUO)
       
      I already flashed a modified bios to be able to recognise the CPU.
       
      here some print screens from Verbose :
       
      https://photos.app.goo.gl/kqWauSu5GZ9Kogxh7
       
      https://photos.app.goo.gl/F6kL5YbiFBqLcGyz6
       
       
      AZUS P5K PRO  - CPU E5450 - NVIDIA 9600GT - 5G RAM 
       
       
      ANY HELP is APPRECIATED
       
      Thanks/Obrigado
       
      Kromakey 
       
       
       
       
    • By ciriousjoker
      TLDR:
      I'm trying to boot MacOS on a Chromebook without UEFI. I'm stuck at getting the bootloader (Chameleon/Clover) to work.  
      My setup / context:
      I have an Acer Chromebook Spin 13.
      Available ports:
      2 x USB-C 1 x USB-A 3.0 MicroSD Slot No USB A 2.0 (I've read that Clover has problems with USB 3.0) Firmware:
      There's no UEFI firmware available and by default, it doesn't even allow booting anything other than ChromeOS. Thanks to MrChromebox (big shoutouts!), I flashed a custom legacy bios that allows me to boot anything linux related. This bios is flashed into the RW_LEGACY section of the existing bootloader (coreboot afaik) and doesn't have any configuration options. If I have to change a setting, I could try compiling his bios payload myself with the specific setting enabled.  
      What I've tried so far:
      Chameleon attempts:
      Only selected setting was "Install chameleon on the chosen path", rest was unselected.
       
      1 - Install chameleon first without restoring the basesystem:
      Output:
      > boot0: GPT
      > boot0: done
      (hangs; pressing power button once shuts down
      Chameleon installation log is attached as "Chameleon_Installer_Log_BEFORE".
       
      2 - Install Chameleon after restoring the base system:
      Output:
      > boot0: GPT
      > boot0: GPT
      > boot0: doneboot1: /boot       <- Exactly like that, no line break in between
      (hangs; pressing power button once shuts down)
       
      I haven't been able to reproduce #2 after wiping the drive and doing the same thing again. Subsequent attempts have resulted in either #1 of either Chameleon or Clover.
      Chameleon installation log is attached as "Chameleon_Installer_Log_AFTER".
       
      Clover attempts:
      I tried multiple settings and configurations, but all of them boiled down to either one of these.
       
      1 - Doesn't do anything, just hangs at "Booting from usb..."
      2 - Boots into the blue/grey mode as shown in the attached images.
      According to MrChromebox, this could be an old Tianocore DUET It doesn't detect anything (cpu frequency, ram, partitions or disks)  
      I've read pretty much every article, github readme and other types of documentation for coreboot, tianocore, clover, chameleon and MrChromebox' rw_legacy payloads and right now, I'm totally clueless as to what to try next...
       
      A few questions that came up:
      Why does chameleon hang? What is it looking for, /boot was clearly written to the disk by the Chameleon installer? What exactly is the blue/grey image? According to MrChromebox, it could be Tianocore DUET Where does it come from? Clover? The mainboard itself? Why does the blue/grey thing not detect my processor frequency or any partitions/drives? Can I use some sort of DUET bootloader to chainload Clover?  
      If you guys could answer any of them or if you have any other guesses or information as to what's happening, I'd be really happy!
      Chameleon_Installer_Log_BEFORE.txt
      Chameleon_Installer_Log_AFTER.txt





×