Jump to content
Mork vom Ork

[pre-release] macOS Mojave 10.14.1

151 posts in this topic

Recommended Posts

I made a SSDT for my usb, 10 usb2 10 usb3, no port limit patch so only get 10/5 ports.

Some observations:

the ssdt has a port-count which I set to 20.

                Buffer (0x04)
                     0x20, 0x00, 0x00, 0x00                         

If I set the port-count to 0x14(20) I only get 10/4 WTF

If I set to 0x0f I only get 10/0 WTF

Not behaving as expected, appears hex number is taken as decimal.

Behaves same in HS

I plug usb2 into port3/4 works.

I plug usb3 into port13/14 works.

usb2 and usb3 are 10 ports apart.



Edited by STLVNUB

Share this post

Link to post
Share on other sites

here is xcpm patch for 10.14.1 beta1

B9A00100 000F32

B9A00100 0031C0

cpuid_set_info_rdmsr (c) vit9696


B9E20000 000F30

B9E20000 009090

xcpm_idle_wrmsr (c) Pike R. Alpha


B9980100 000F32

B9980100 0031C0

xcpm_assert_rdmsr (c) Sherlocks


BE0B0000 005DE908 000000

BE0B0000 005DC390 909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha




cpuid_set_info  (c) Pike R. Alpha


89D804C4 3C22

89D804XX 3C22 XX <- YOUR CPU

xcpm_bootstrap (c) Pike R. Alpha


B9990100 000F30

B9990100 009090

xcpm_assert_wrmsr (c) Sherlocks


BE030000 0031D2E8 91FCFFFF

BE030000 0031D290 90909090

xcpm_core_scope_msrs (c) Pike R. Alpha


554889E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D9C57
C39089E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D9C57
xcpm_program_msrs (c) Pike R. Alpha



BE070000 0031D2E8 AEFCFFFF

BE070000 0031D290 90909090

xcpm_pkg_scope_msrs (c) Pike R. Alpha


BE0B0000 0031D2E8 7EFCFFFF

BE0B0000 0031D290 90909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha


C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05739C 76004883 C4085B5D C30F1F40 00
B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 739C7600 4883C408 5B5DC390 90

xcpm_assert_perf_max (c) PMheart



8A0284C0 7442

8A0284C0 EB42

Disable panic kext logging on 10.14 Release kernel (c) vit9696



Edited by Sherlocks

Share this post

Link to post
Share on other sites

Just updated to macOS Mojave 10.14.1 Beta 2 (18B50c) w/o issue on my Asus A43SJ laptop.



Cuda 8.x is still running fine, now waiting for Nvidia WebDriver before Oct 13-17 bcoz Adobe CC 2019 releases are expected to be announced at Adobe Max, Los Angeles on those date. B)


Thanks to @gengik84 for new MacOS_Updater script.



Share this post

Link to post
Share on other sites
On 10/1/2018 at 4:06 PM, onemanOSX said:

But what does these do?


Thank you.

I support. A small read me file would be very helpful

Share this post

Link to post
Share on other sites

I have installed Mojave 10.14 on a Dell Vostro 460 (XPS 8300 equivalent) with a supported metal graphics card.  When I update to 10.14.1 my installation stalls at " ...USBHostResources@: AppleUSBHostResources: :allocateDownstreamBusCurrentGated: assuming successful wakeUnits 30 sleepUnits 0".  I tried using the USBInjectAll.kext and patching com.apple.driver.usb.AppleUSBXHCI using Hex patch from by PMHeart; this did not work.  Any ideas ?

Share this post

Link to post
Share on other sites

I'm about to rally me and feel like breaking this laptop! On the X-99 desktop all versions of macOS (all) always worked and made updates without any problem! But in the backward mental Lenovo laptop that worked perfect until 13.6, no version of Mojave i can install... always KP from here! :wallbash::wallbash::wallbash:


Share this post

Link to post
Share on other sites

updated to beta 2 and then login for first time successfully.


2nd power on my PC, it is stuck at IOConsoleUsers: gIOScreenLockState 3


anyone know how to fix. I'm using hd630 with whatevergreen kext (latest version) and ran well with beta 1.


Thank you.

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.