Jump to content
Allan

macOS Mojave - It's out!

192 posts in this topic

Recommended Posts

Hi @Hervé
How you doing?

What is your setup for 10.14 on snb?

I m using the mac tool to create the bootable installer for unsupported macs but i ll probably make a vanilla one, it should boot without hwa so that i can replace gfx kexts manually (i think)

Are you replacing any other kext?
AppleALC has merged the now missing layout ids so vanilla audio kexts?

I ve just tried a quick clean install with that tool and the post install patcher (default options), there are few minor issues with both light and dark theme (unless the colors are a bit strange on macs too).
A kernel or cpu panic is a must on every first boot xD, it boots fine then.

Any advice?

Thanks

Share this post


Link to post
Share on other sites
Advertisement
23 hours ago, Hervé said:

It's just a classic QuickTime screen recording. Had to split into 2 x vids due to 10MB attachment limitation.

There's a new feature for that on Mojave, if you press Command+Shift+5 you can make screenshots and recordings for full screen or parts of it (you'll choose). Check it out if you didn't yet ;)

Edited by Swear

Share this post


Link to post
Share on other sites
23 hours ago, bocajoe said:

 

OK thanks! What program did you use to record your screen video? 

 

I installed Mojave on a 2nd computer and Preview acts REALLY strange when I try to crop part of an image from Screenshots from my desktop. I wanted to just grab a portion of the screen. Similar as the 1st computer I posted about. I'll post a video if I can find out what program to do a screen video capture.

As I said above, try out the new mojave feature.
Anyway now I'm on the regualr mojave and guess what? I'm having the same issue with jpeg...

Share this post


Link to post
Share on other sites

Hi @Cyberdevs,

Thanks for your answer but no I'm still using intelfixgraphics, and do you think that if I switch this problem with safari is fixed?

My error code is the following S7363-1260-FFFFD089, and Netflix plays in firefox without problems...

and now I remember that I tried to enable silverlight and it isn't possible because the option isn't in security safari....

Edited by MorenoAv

Share this post


Link to post
Share on other sites
5 minutes ago, MorenoAv said:

Hi @Cyberdevs,

Thanks for your answer but no I'm still using intelfixgraphics, and do you think that if I switch this problem with safari is fixed?

My error code is the following S7363-1260-FFFFD089, and Netflix plays in firefox without problems...

Same problem. And I'm using Whatevergreen.

S7363-1260-FFFFD1C1

Edited by Swear

Share this post


Link to post
Share on other sites
5 hours ago, MorenoAv said:

hi guys,

If this post is out of place feel free to move it, but anyone knows why Netflix don't work in safari? or how to reset the pram...?

Thanks 

 

Check shikioff on Clover boot, and restart...but the performance of GPU maybe down...try use Safari... to see works but im use Netflix only on my Smart TV :P

 

 

428028314_CapturadeTela2018-09-26s22_09_41.thumb.png.a27e1dca3d70b07c92632b3ae57a53aa.png

 

Edited by max.1974

Share this post


Link to post
Share on other sites
1 hour ago, max.1974 said:

 

Check shikioff on Clover boot, and restart...but the performance of GPU maybe down...try use Safari... to see works but im use Netflix only on my Smart TV :P

 

 

428028314_CapturadeTela2018-09-26s22_09_41.thumb.png.a27e1dca3d70b07c92632b3ae57a53aa.png

 

 

I will try this tomorrow.

 

This problem is not just for Hackintosh real macs also getting this error. I found this but I didn't try it; Some people on the comments saying apple support confirm this solution and give it to the people. Can we use this solution in our hacks is it safe?

 

Fix (workaround):

*Boot into Recovery Mode on your Mac (command+R)

*Open terminal and type in the command EXACTLY as written:

 

nvram 8be4df61-93ca-11d2-aa0d-00e098032b8c:epid_provisioned=%01%00%00%00

(The above command should occur on the same line)

 

and then press RETURN

 

It will go back to the prompt. Type reboot and RETURN.

 

https://www.reddit.com/r/macbook/comments/8r4g94/netflix_error_s73631260ffffd089_on_safari_mbp_2017/

 

Edited by telepati

Share this post


Link to post
Share on other sites
2 hours ago, telepati said:

 

I will try this tomorrow.

 

This problem is not just for Hackintosh real macs also getting this error. I found this but I didn't try it; Some people on the comments saying apple support confirm this solution and give it to the people. Can we use this solution in our hacks is it safe?

 

Fix (workaround):

*Boot into Recovery Mode on your Mac (command+R)

*Open terminal and type in the command EXACTLY as written:

 

nvram 8be4df61-93ca-11d2-aa0d-00e098032b8c:epid_provisioned=%01%00%00%00

(The above command should occur on the same line)

 

and then press RETURN

 

It will go back to the prompt. Type reboot and RETURN.

 

https://www.reddit.com/r/macbook/comments/8r4g94/netflix_error_s73631260ffffd089_on_safari_mbp_2017/

 

 

I dont know telepati, but we take a shot....by the way we love this game...if you use your Hack for work or save your files, im not recomended... im use for both, but my files was always safe in another HD...:)

Share this post


Link to post
Share on other sites

Hi @max.1974

Thanks for the tip and that did the trick, my safari is all happy playing Netflix, yupiii... :thumbsup_anim:

PS: Now for the second round my safari refuses to work again with Netflix, it only worked 2 seconds, when I ticked the shikioff ... 

Edited by MorenoAv

Share this post


Link to post
Share on other sites

InsanelyMac login does not hold the account information on Mojave? I logged in with my account info choosing remember me then quit Safari, I opened again and there is no any account info. I logged in some other sites there is no problem on them, just InsanelyMac doing this. Why this happening?

Share this post


Link to post
Share on other sites

Just like on my "High" Sierra))

InsanelyMac login does not hold the account information on Mojave? I logged in with my account info choosing remember me then quit Safari, I opened again and there is no any account info. I logged in some other sites there is no problem on them, just InsanelyMac doing this. Why this happening?

Share this post


Link to post
Share on other sites
7 hours ago, MorenoAv said:

Hi @max.1974

Thanks for the tip and that did the trick, my safari is all happy playing Netflix, yupiii... :thumbsup_anim:

PS: Now for the second round my safari refuses to work again with Netflix, it only worked 2 seconds, when I ticked the shikioff ... 

 

Maybe you need try run this command after check box shikioff and restart...

Olarila.command.zip you was repair permission on Kexts and reset your Nvram... im so sorry Man, like im said to you, works for me, but im not use because the Bench Scores goes so down...that im give up... use Windows to watch Netflix, because you get 4k resolution. In MacOS we not gave this...

 

Share this post


Link to post
Share on other sites

Hi again @max.1974,

don't be sorry, sometimes the things that work for us don't work for others, but that is the beauty of hackintoshing, I'm going to try with olarila script...

And I can watch Netflix... in firefox, but not in 1080 p...

Cheers

 

PS: Run the script and didn't work...

Edited by MorenoAv

Share this post


Link to post
Share on other sites
1 hour ago, MorenoAv said:

Hi again @max.1974,

don't be sorry, sometimes the things that work for us don't work for others, but that is the beauty of hackintoshing, I'm going to try with olarila script...

And I can watch Netflix... in firefox, but not in 1080 p...

Cheers

 

PS: Run the script and didn't work...

 

Obrigado amigo!!! Tens toda razão!!! Cheers !!! 

Share this post


Link to post
Share on other sites
21 hours ago, max.1974 said:

 

I dont know telepati, but we take a shot....by the way we love this game...if you use your Hack for work or save your files, im not recomended... im use for both, but my files was always safe in another HD...:)

 

I tried Shiki and my suggestion, both didn't work for me :no:

Share this post


Link to post
Share on other sites

This is bad.. I've downloaded Mojave Final from Apple server twice and got it damaged LoL;

I think need to use more stable internet connection or a new HDD.. hah haa..

 

[failed]
Finder DMG mounting
pkgutil --expand InstallESDDmg.pkg InstallESD
7zip v9.20 extract
TransMac DMG mounting

 

Screenshot 39.png

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

This is bad.. I've downloaded Mojave Final from Apple server twice and got it damaged LoL;

I think need to use more stable internet connection or a new HDD.. hah haa..

 


[failed]
Finder DMG mounting
pkgutil --expand InstallESDDmg.pkg InstallESD
7zip v9.20 extract
TransMac DMG mounting

 

Screenshot 39.png

 

I've downloaded twice with this tool without any problem. If you use the same tool probably there is a problem on apple server;

 

https://www.insanelymac.com/forum/files/file/944-mojave-mbr-hfs-firmware-check-patch/

 

Share this post


Link to post
Share on other sites
12 hours ago, Badruzeus said:

This is bad.. I've downloaded Mojave Final from Apple server twice and got it damaged LoL;

I think need to use more stable internet connection or a new HDD.. hah haa..

 


[failed]
Finder DMG mounting
pkgutil --expand InstallESDDmg.pkg InstallESD
7zip v9.20 extract
TransMac DMG mounting

 

Screenshot 39.png


I had to download it three times with "Q6-DownloadFullApp" method before I could get the full App (internet problems or slow servers, I really don't know...), but when it did download, it was good and worked at first attempt!
If you haven't yet, give it a try. The link to the download is on "telepati" post, above mine.

Edited by Swear

Share this post


Link to post
Share on other sites

here is xcpm patch for 10.14

B9A00100 000F32

B9A00100 0031C0

cpuid_set_info_rdmsr (c) vit9696

 

B9E20000 000F30

B9E20000 009090

xcpm_idle_wrmsr (c) Pike R. Alpha

 

B9980100 000F32

B9980100 0031C0

xcpm_assert_rdmsr (c) Sherlocks

 

BE0B0000 005DE908 000000

BE0B0000 005DC390 909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

04723CD0

04XX3CD0  XX <- YOUR CPU

cpuid_set_info  (c) Pike R. Alpha

 

89D804C4 3C22

89D804XX 3C22 XX <- YOUR CPU

xcpm_bootstrap (c) Pike R. Alpha

 

B9990100 000F30

B9990100 009090

xcpm_assert_wrmsr (c) Sherlocks

 

BE030000 0031D2E8 91FCFFFF

BE030000 0031D290 90909090

xcpm_core_scope_msrs (c) Pike R. Alpha

 

554889E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

C39089E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

xcpm_program_msrs (c) Pike R. Alpha

 

BE070000 0031D2E8 AEFCFFFF

BE070000 0031D290 90909090

xcpm_pkg_scope_msrs (c) Pike R. Alpha

 

BE0B0000 0031D2E8 7EFCFFFF

BE0B0000 0031D290 90909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05938D 76004883 C4085B5D C30F1F40 00

B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 938D7600 4883C408 5B5DC390 90

xcpm_assert_perf_max (c) PMheart

 

8A0284C0 7442

8A0284C0 EB42

Disable panic kext logging on 10.14 Release kernel (c) vit9696

 

enjoy:)

 

Edited by Sherlocks

Share this post


Link to post
Share on other sites
12 minutes ago, Sherlocks said:

here is xcpm patch for 10.14

B9A00100 000F32

B9A00100 0031C0

cpuid_set_info_rdmsr (c) vit9696

 

B9E20000 000F30

B9E20000 009090

xcpm_idle_wrmsr (c) Pike R. Alpha

 

B9980100 000F32

B9980100 0031C0

xcpm_assert_rdmsr (c) Sherlocks

 

BE0B0000 005DE908 000000

BE0B0000 005DC390 909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

04723CD0

04XX3CD0  XX <- YOUR CPU

cpuid_set_info  (c) Pike R. Alpha

 

89D804C4 3C22

89D804XX 3C22 XX <- YOUR CPU

xcpm_bootstrap (c) Pike R. Alpha

 

B9990100 000F30

B9990100 009090

xcpm_assert_wrmsr (c) Sherlocks

 

BE030000 0031D2E8 91FCFFFF

BE030000 0031D290 90909090

xcpm_core_scope_msrs (c) Pike R. Alpha

 

554889E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

C39089E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

xcpm_program_msrs (c) Pike R. Alpha

 

BE070000 0031D2E8 AEFCFFFF

BE070000 0031D290 90909090

xcpm_pkg_scope_msrs (c) Pike R. Alpha

 

BE0B0000 0031D2E8 7EFCFFFF

BE0B0000 0031D290 90909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05938D 76004883 C4085B5D C30F1F40 00

B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 938D7600 4883C408 5B5DC390 90

xcpm_assert_perf_max (c) PMheart

 

8A0284C0 7442

8A0284C0 EB42

Disable panic kext logging on 10.14 Release kernel (c) vit9696

 

enjoy:)

 

What is this for? ^^

Share this post


Link to post
Share on other sites
10 hours ago, Sherlocks said:

here is xcpm patch for 10.14

B9A00100 000F32

B9A00100 0031C0

cpuid_set_info_rdmsr (c) vit9696

 

B9E20000 000F30

B9E20000 009090

xcpm_idle_wrmsr (c) Pike R. Alpha

 

B9980100 000F32

B9980100 0031C0

xcpm_assert_rdmsr (c) Sherlocks

 

BE0B0000 005DE908 000000

BE0B0000 005DC390 909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

04723CD0

04XX3CD0  XX <- YOUR CPU

cpuid_set_info  (c) Pike R. Alpha

 

89D804C4 3C22

89D804XX 3C22 XX <- YOUR CPU

xcpm_bootstrap (c) Pike R. Alpha

 

B9990100 000F30

B9990100 009090

xcpm_assert_wrmsr (c) Sherlocks

 

BE030000 0031D2E8 91FCFFFF

BE030000 0031D290 90909090

xcpm_core_scope_msrs (c) Pike R. Alpha

 

554889E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

C39089E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6257

xcpm_program_msrs (c) Pike R. Alpha

 

BE070000 0031D2E8 AEFCFFFF

BE070000 0031D290 90909090

xcpm_pkg_scope_msrs (c) Pike R. Alpha

 

BE0B0000 0031D2E8 7EFCFFFF

BE0B0000 0031D290 90909090

xcpm_SMT_scope_msrs (c) Pike R. Alpha

 

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05938D 76004883 C4085B5D C30F1F40 00

B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 938D7600 4883C408 5B5DC390 90

xcpm_assert_perf_max (c) PMheart

 

8A0284C0 7442

8A0284C0 EB42

Disable panic kext logging on 10.14 Release kernel (c) vit9696

 

enjoy:)

 

 

 

Your CPU as in # of CPUs? total?

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
       


      E6410-Mojave-6v3.zip
    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By headkaze
      English: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md
      Russian: https://www.applelife.ru/threads/intel-hd-graphics-3000-4000-4400-4600-5000-5500-5600-520-530-630.1289648/
      Chinese: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.cn.md
    • By fantomas
      macOS Catalina 10.15.4 beta (19E224g)
×