Jump to content
Allan

macOS Mojave - It's out!

189 posts in this topic

Recommended Posts

Advertisement

The blurry font-rendering sub-pixel antialiasing in the final version of Mojave is still present? I saw that the font rendering from beta 1 to GM is blurry and bold on non-retina displays.

Thanks in advance.

Share this post


Link to post
Share on other sites
3 hours ago, ameris cyning said:

Nice. Cant wait to see Apple releasing the kernel sources so we can get this going on our AMD machines.

 

Yup wonder how long it'll take them. Still waiting on 10.13.4, 10.13.5 and 10.13.6 lol Once they've updated though I'll work on it :thumbsup_anim:

Share this post


Link to post
Share on other sites
6 hours ago, Allan said:

USB Installation using 'createinstallmedia' way:


sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Mojave.app --nointeraction

 

 

View full article

 

 

9 minutes ago, WinstonAce said:

applicationpath in createinstallmedia is deprecated.

Sent from my SM-G960F using Tapatalk
 

 

Yeah it seems to be. From Apple website,

 

sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume

 

Share this post


Link to post
Share on other sites

Update done, Apple store, all went as it should, and I still have sound (since the help of @arsradu), without updating any kext...

Captura de ecrã 2018-09-24, às 22.45.33.png

Share this post


Link to post
Share on other sites
1 hour ago, asdesoso said:

The blurry font-rendering sub-pixel antialiasing in the final version of Mojave is still present? I saw that the font rendering from beta 1 to GM is blurry and bold on non-retina displays.

Thanks in advance.

 

Font smoothing was tweaked between beta 1 and GM and it is not as bad as it was originally. Also, the font smoothing option in System Preferences - General can now be used to make it less bold.

Share this post


Link to post
Share on other sites

my tinu app just supports mojave out of the box for usb installers, for those wh doesn't know it's basically an user inteface for the "createinstallmedia" method with automated usb driver format and error cheching

Schermata 2018-09-25 alle 00.16.31.png

and also it seems like that mojave has a better software rendring when you don't have graphics acceleration, good for usesers with problems getting graphics to work or for vm users

Edited by ITzTravelInTime

Share this post


Link to post
Share on other sites
14 minutes ago, scj312 said:

 

Font smoothing was tweaked between beta 1 and GM and it is not as bad as it was originally. Also, the font smoothing option in System Preferences - General can now be used to make it less bold.

But in the 18A391 build it is still present as beta 1 or GM for example?

Thanks in advance.

Share this post


Link to post
Share on other sites
7 minutes ago, SavageAUS said:

How do we download the full installer from Mojave?


Sent from my iPhone using Tapatalk

That's funny! I would love to get to know the opposite: How to update instead of getting the full installer?

To get my full installer I went into System Preferences > Updates and removed myself from the Developer Seed Programme. If I didn't do that, it'd load the beta installer still.

Then I went into App Store and searched "mojave" and clicked Download. System Preferences then opens up and downloads the full installer.

That is with HFS+J GUID method made possible by crazybirdys script.

 

Now, when I search for updates, either with crazybirdys script or System Preferences Update pane, I see no updates. Did you guys get offered an (combo) update to 18A391?

On 18A389 right now.

 

Edit1: Or max.1974s method, he beat me!

Edited by illdev

Share this post


Link to post
Share on other sites
3 minutes ago, Allan said:

With this tool appointed above, it's possible to install Mojave using HFS+ in a GPT scheme partition?

 

Yes, no problem to install Mojave using HFS+ in a GPT scheme partition, but can't update from App Store for new version, need script (inside the dmg) to update it.

Share this post


Link to post
Share on other sites

I'd love to try Mojave. Would there be any downide since I'm using a 6670? :)

 

alright I'll stay on 10.13... :|

 

Quote

Known issues:

- Graphics anomalies: Currently, pre-metal video cards used in Mojave will produce a weird darkish grey Menu Bar and Finder sidebar when using the light theme. In the dark theme, however, these anomalies are not present.

- AMD Radeon HD 5xxx/6xxx series GPU acceleration: Currently, it is not possible to get full graphics acceleration when running Mojave on a system with a Radeon HD 5xxx or 6xxx series GPU. This includes the 15" and 17" MacBook Pro systems (MacBookPro8,2 and 8,3). If you want to enable GPU acceleration on these machines, you'll need to disable the AMD GPU. Weird colors will also be produced when running Mojave with one of these video cards installed/enabled.

 

Edited by Henry2010

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ryguy77
      Hello InsanelyMac Community!

      I have recently attempted to do a fresh vanilla build for Mojave to replace a mostly successful Sierra build I've been using for a couple of years.
       
      Specs:
      MB: GA-Z170MX Gaming 5 - F22f bios
      Intel 530 internal gfx (removed nvidia card)
       
      It mostly works except, sleep shuts it down/crashes it and needs to be powered on 2x to restart.  USB ports are also hit and miss as to whether they work and/or whether they work for USB 3 or only USB 2.

      Been pulling my hair out trying various "fixes" and have tried creating a custom SSDT etc for USB but, not overly successfully I don't think.  Was hoping to get through this build and move onto my older Yosemite machine but, close to giving up on it!
       
      Hoping someone here can give me a hand.
       
      Thanks!
      Send me Ryans-iMac.zip
    • By tokia
      Hello,
       
      My desktop Hackintosh is running macOS Mojave 10.14.2 with two dedicated GPUs installed: NVIDIA GTX 1080 Ti, AMD Radeon HD 7970.
       
      The AMD GPU is used primarily under macOS and the NVIDIA one under Windows.
       
      macOS boots without issues as long as there are no displays connected to the NVIDIA GPU. If a display is connected then the display connected to the AMD GPU will become blank. The system can be accessed using Screen Sharing/VNC.
       
      There are no problems if I swap PCI-e slots for the GPUs so that the AMD GPU is in the first slot (primary GPU), but I prefer not to do this.
       
      I have tried to remove the whole PCI (bridge) device in the DSDT file and all the lines that refer to it. The PCI entries in ioreg and System Information are gone but System Information still shows an NVIDIA GPU under Graphics/Display.
       
      Many of the suggestions I have found in guides and forum posts do not seem to apply here. My problem with some of the guides and answers is that they give the solution without explaining how anything works, or they tell you what to do without explaining the reasons behind it.
       
      What else can I do? Thank you for any assistance you can provide!
       
      I have attached some files that may help you help me.
       
      DSDT_BIOS_3101.zip contains the original ACPI (*.aml) files without any patches.
      Send me Steffens-iMac.zip is a file produced by RunMe.app, and do contain simple patches to rename some devices.
      DSDT.dsl.patch is a diff of the original DSDT.dsl file and the one with the PCI devices removed (commented out).
       
      Motherboard: ASUS Rampage V Extreme (X99), BIOS version 3101 (macOS does not boot with anything newer).
      Clover version: 4644 (macOS does not boot with the latest one, 4798).
       
      DSDT.dsl.patch:
      --- /Users/sl/Desktop/DSDT_BIOS_3101/DSDT.dsl 2018-12-17 05:24:30.000000000 +0100 +++ /Volumes/EFI/EFI/CLOVER/ACPI/patched/DSDT.dsl 2018-12-17 16:52:08.000000000 +0100 @@ -5,7 +5,7 @@ * * Disassembling to symbolic ASL+ operators * - * Disassembly of DSDT.aml, Mon Dec 17 05:24:30 2018 + * Disassembly of DSDT.aml, Mon Dec 17 04:01:52 2018 * * Original Table Header: * Signature "DSDT" @@ -2128,7 +2128,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2274,7 +2274,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2420,7 +2420,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2570,7 +2570,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2803,12 +2803,14 @@ If ((CSTA (Arg0, Arg1) == 0x00)) { FLAG = 0x00 - PRID (APID = 0xFF) = 0xFF + APID = 0xFF + PRID = 0xFF } Else { Local0 = APID - PRID (FLAG = 0x01) = Local0 + FLAG = 0x01 + PRID = Local0 } Return (APIC) @@ -15259,7 +15261,7 @@ ^BR2B.OSHP () ^BR2C.OSHP () ^BR2D.OSHP () - ^BR3A.OSHP () + //^BR3A.OSHP () ^BR3B.OSHP () ^BR3C.OSHP () ^BR3D.OSHP () @@ -26861,7 +26863,7 @@ } } - Device (BR3A) + /*Device (BR3A) { Name (_ADR, 0x00030000) // _ADR: Address OperationRegion (MCTL, SystemMemory, 0xE0013188, 0x04) @@ -27496,7 +27498,7 @@ { Name (_ADR, 0xFFFF) // _ADR: Address } - } + }*/ Device (BR3B) { @@ -30267,7 +30269,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -30567,21 +30569,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4158, // Range Minimum - 0x0000, // Range Maximum + 0x4158, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x5758, // Range Minimum - 0x0000, // Range Maximum + 0x5758, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x5858, // Range Minimum - 0x0000, // Range Maximum + 0x5858, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -37604,7 +37606,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -37904,21 +37906,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4558, // Range Minimum - 0x0000, // Range Maximum + 0x4558, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4259, // Range Minimum - 0x0000, // Range Maximum + 0x4259, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4359, // Range Minimum - 0x0000, // Range Maximum + 0x4359, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -44941,7 +44943,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -45241,21 +45243,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4958, // Range Minimum - 0x0000, // Range Maximum + 0x4958, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4559, // Range Minimum - 0x0000, // Range Maximum + 0x4559, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4659, // Range Minimum - 0x0000, // Range Maximum + 0x4659, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -53823,7 +53825,7 @@ Notify (\_SB.PCI0.BR2D.H007, Local0) } - If ((\_SB.PCI0.BR3A.PMEP == 0x01)) + /*If ((\_SB.PCI0.BR3A.PMEP == 0x01)) { Local0 = \_SB.PCI0.BR3A.PMEH (0x05) } @@ -53848,7 +53850,7 @@ Notify (\_SB.PCI0.BR3A.H005, Local0) Notify (\_SB.PCI0.BR3A.H006, Local0) Notify (\_SB.PCI0.BR3A.H007, Local0) - } + }*/ If ((\_SB.PCI0.BR3B.PMEP == 0x01)) { @@ -54608,11 +54610,11 @@ \_SB.PCI0.BR2D.PMEP = 0x01 } - If ((Local1 == 0x07)) + /*If ((Local1 == 0x07)) { \_SB.PCI0.BR3A.PMES = 0x01 \_SB.PCI0.BR3A.PMEP = 0x01 - } + }*/ If ((Local1 == 0x08)) { @@ -54879,10 +54881,10 @@ Notify (\_SB.PCI0.BR2D, 0x02) } - If ((\_SB.PCI0.BR3A.DEVS () != 0x00)) + /*If ((\_SB.PCI0.BR3A.DEVS () != 0x00)) { Notify (\_SB.PCI0.BR3A, 0x02) - } + }*/ If ((\_SB.PCI0.BR3B.DEVS () != 0x00)) { @@ -55927,10 +55929,10 @@ { Notify (\_SB.PCI0.BR2D, 0x00) } - Case (0x28) + /*Case (0x28) { Notify (\_SB.PCI0.BR3A, 0x00) - } + }*/ Case (0x29) { Notify (\_SB.PCI0.BR3B, 0x00) @@ -56736,11 +56738,11 @@ } } - Scope (_SB.PCI0.BR3A) + /*Scope (_SB.PCI0.BR3A) { Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { - If ((Arg0 == ToUUID ("e5c937d0-3553-4d7a-9117-ea4d19c3434d") /* Device Labeling Interface */)) + If ((Arg0 == ToUUID ("e5c937d0-3553-4d7a-9117-ea4d19c3434d") / * Device Labeling Interface * /)) { If (((Arg1 == 0x02) && (Arg2 == 0x00))) { @@ -56765,7 +56767,7 @@ 0x00 }) } - } + }*/ Scope (_SB.PCI1.QR1A) {  
      DSDT_BIOS_3101.zip
      Send me Steffens-iMac.zip
      DSDT.dsl.patch
    • By forum
      Hi guys,
      after using yosemite for a long time with a complete working system, i decided to jump into a fresh install on my old system.
      Most things work flawless, except USB3 and sleep which is the more important thing.
      Every time i set it to sleep, it shuts down for a moment and then the system starts again with black screen and low power consumption +- 100w (normal idle is around 120-140).
      I can only hard reset the system to get it working again.
      I used the DSDT Patch from my old system, but i think it may have some errors.
      I hape you do have an Idea what to do.
       
      Here are my specs:
       
      Gigabyte X79-up4
      i7-3930k
      32gb Ram
      NVIDIA GeForce GTX 660 Ti 3071 MB
      512 Samsung SSD
      Mojave 14.2
      newest bios
       
      I attached the RunMe files.
       
      Best
      forum
      Send me mojaves-iMac.fritz.box 2.zip
    • By markilark
      So I have an HP Envy Notebook (15t-q400) which features two Band & Olufsen speakers (tweeters) and one subwoofer - the audio codec used is the ALC290 (aka the ALC 3241). I'm running on Mojave. So far I've tried AppleALC with Lilu and have no luck - the audio plays through the headphones - although very poorly - but not the external speakers at all, and I've tried everything short of writing my own XML file for it. So I've decided to go for using the VoodooHDA kext.  
       
      While VoodooHDA sees my devices immediately, they are strangely configured, and I cannot use the subwoofer or even see it listed as a device. This is my main problem.
       
      As I'm aware the proper configuration of the laptop is: 
      Three speakers - one left, one right, and one subwoofer module One 3.5mm headphone jack An internal microphone for the webcam (this is one I'm not sure about, I don't know if it is two separate microphones or one as there are two holes in the display chasis)   
       
      In my devices while using the default VoodooHDA kext, I have 
                Output:
      Speaker (Analogue) - Type= Apple speaker port <--- only tweeters work  Headphones (Back Right) - Type= Headphone Port <--- this seems to work well           Input:
      Microphone (Black Right) - Type: Microphone Port <---- this works a little, sounds like it's muffled, not from the webcam Microphone (ATAPI) - Type: Microphone Port  <--- this works well, is definitely the webcam microphone  
       

      Here is my Pin Config (with disabled devices not ignored as I think the subwoofer is one of those devices):

      Here is my Pin Config for the photo above (disabled devices NOT ignored, fix not applied).
      01371c00 01371d00 01371e00 01371f40 01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01d71c2d 01d71d81 01d71e75 01d71f40 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04 01471cf0 01471d11 01471e11 01471f41 01671cf0 01671d11 01671e11 01671f41 01771cf0 01771d11 01771e11 01771f41 01971cf0 01971d11 01971e11 01971f41 01b71cf0 01b71d11 01b71e11 01b71f41 01e71cf0 01e71d11 01e71e11 01e71f41  
       
       
       

      Here is my Pin Config for the photo above (disabled devices ignored, fix not applied):
      01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04  
      I have been attempting to add the subwoofer as a node in the Info.plist of VoodooHDA but can't seem to get it to work (and frankly I'm not sure which device it is!) . I've tried adding both NID 19 and 20 into my Info.plist file for VoodooHDA but neither have done any good. Am I supposed to add the NID and PinDefault to the Info.plist AFTER Pin Configurator's fix? I was under the impression this only helped with a patched AppleHDA which VoodooHDA overwrites. 

      Thanks for all the help, I hope I conveyed this clearly! 
       
      I've attached my codec dump as well. 
      dumpcodec.rtf
    • By pgsubuntu2
      Buenas a todos, Queria saber si a alguien le pasa algo similar a mi con la nueva version de Mojave o en general con otras versiones.
       
      Recientemente pude instalar Mojave 10.14.2 previa preparacion con (esa app q todos sabemos pero q no me deja escribir aca). El sistema funciona bien luego de instalar los kext de audio y red desde (esa app que todos sabemos pero que no me deja escribir aca)
       
      A medida que iba usando y testeando Mojave me di cuenta de esta falla y sucede solo cuando abro alguna pagina con Safari o tambien ahora descubro que sucede cuando abro Appstore y mientras hago alguna busqueda o simplemente hago scroll con el mouse se bloquea completamente el hack sin poder hacer absolutamente nada ni matar ninguna app. Ahi solo toca reiniciar.
       
      Un ejemplo se da cuando abro esta misma pagina y aparece ese video en la esquina inferior derecha. Logre "solucionarlo" instalando Adblock pero en otras paginas vuelve a suceder ese cuelgue.
       
      Mi pc:
       
      Mother: GA-H81M-H
      Procesador: Core i5 4460  - Video: Intel HD 4600
      Kingston 8gb ram 1333
      clover version 4769.
       
      Aclaro que esto sucede en una instalacion limpia sin ningun plugin instalado de nada. 
       
       
      Bueno cualquier otra info necesaria estoy a su disposicion, gracias.
       
       
       
       
×