Jump to content
MikixIT

Problemi DUALBOOT Con Clover

43 posts in this topic

Recommended Posts

Ciao ragazzi! Grazie a questo forum con gente fantastica, sono riuscito a installare OS X e in seguito Win 10 su Clover SULLO STESSO HARD DISK

Ho un problema, di solito utilizzo Kali Linux, la famosa versione di linux in usb in live

Ora avrei la necessita di dedicargli 15gb di partizione del mio Hard Disk PER INSTALLARLA, e l'ho fatto effettivamente creando una partizione VUOTA tramite utility disco di Sierra.

Il problema sorge quando io vado a riavviare il pc e quindi ritrovandomi nella schermata di clover, e vedo sempre il solito OSX e il recovery Osx e al posto di Windows 10, mi trovo la partizione di 15gb che avevo creato per windows(con l'icona di windows)

Siccome ho paura di perdere i dati importanti che avevo su windows, non ho continuato installando Kali, ma mi sono fermato e ho eliminato la partizione sempre da utility di Sierra e come per magia, riavvio e Win10 è di nuovo lì dove dovrebbe stare

Appena creo la partizione vuota, clover me la sostituisce

Che devo fare raga?

Io voglio OSX,Win10 (Che già ho) e Kali(Solo 15gb) sullo stesso hard disk

Senza perdere dati di Win o Mac

Gengik ho visto in precedenti discussioni tue, di andare in GUI da clover config . e togliere Windows da quelli nascosti e l'ho fatto, ma il risultato non cambia.

Grazie per la lettura :)

Share this post


Link to post
Share on other sites
Advertisement

Che versione di clover hai

Che versione e quale driver .efi usi

Il config è impostato per rilevare nuove entries

 

Se la nuova partizione la metti prima di quella windows, andando a cambiare l'ordine il boot manager di windows non la farà avviare a meno di non ricreare il file di boot nuovamente con la nuova disposizione

 

Se invece la nuova partizione viene creata dopo windows non vi dovrebbero essere problemi particolari

Share this post


Link to post
Share on other sites
6 hours ago, iCanaro said:

Che versione di clover hai

Che versione e quale driver .efi usi

Il config è impostato per rilevare nuove entries

 

Se la nuova partizione la metti prima di quella windows, andando a cambiare l'ordine il boot manager di windows non la farà avviare a meno di non ricreare il file di boot nuovamente con la nuova disposizione

 

Se invece la nuova partizione viene creata dopo windows non vi dovrebbero essere problemi particolari

Queste informazioni ti saranno utili per capire di più

Io ho il bios legacy

 

Ti allego la mia EFI:http://www.mediafire.com/file/0fz38j0lomxtnid/EFI.zip

 

Dove c'è scritto "Boot Windows from Legacy HD4" Quando creo la nuova partizione viene sostituita con la partizione vuota da 15Gb e scrive infatti "Boot Windows from Legacy HD5" e quindi viene sostituito windows, io voglio tenere entrambi in modo da avere Win, OSX e Linux da 15gb come ti dicevo nel post

 

IMG_3701.thumb.jpeg.8036eb7edc26a115e9318d0830a25c75.jpeg

IMG_3698.jpeg

IMG_3700.jpeg

Share this post


Link to post
Share on other sites

https://sourceforge.net/projects/cloverefiboot/ aggiorna clover , puoi postare Ioreg ed Hack Info?????
X quello vedo NON usi DSDT e quindi mancano di sicuro alcune Fix , vedo hai NullCPU in kext , NON avrai mai un buon PM , puoi elencare le caratteristiche HW di questo PC???
Questa configurazione oltre i problemi hai mi sembra ARRANGIATA è di sicuro migliorabile ..... Parere MIO

 

Se vuoi provare da USB con Clover metti le configurazioni dell'HDD e togli NullCPU poi sovrascrivi il mi configplist , se avvia gestisce Clover il PM della CPU

 

Ho corretto un errore in Gui\ Hide Volume Legacy HD4 si può eliminare prova se è cambiata la Gui di clover

config.plist.zip

Edited by Baio77

Share this post


Link to post
Share on other sites
21 minutes ago, Baio77 said:

https://sourceforge.net/projects/cloverefiboot/ aggiorna clover , puoi postare Ioreg ed Hack Info?????
X quello vedo NON usi DSDT e quindi mancano di sicuro alcune Fix , vedo hai NullCPU in kext , NON avrai mai un buon PM , puoi elencare le caratteristiche HW di questo PC???
Questa configurazione oltre i problemi hai mi sembra ARRANGIATA è di sicuro migliorabile ..... Parere MIO

Ciao, mi spieghi cosa intenti per PM?

Comunque ho avuto un pò di problemi per installazione, è stato un parto

Ho ancora delle problematiche da allora, in cui ho aperto altre discussioni su questo forum ma nessun è riuscito ad aiutarmi

L' HW è scritto sotto il mio profilo comunque 

 

Per esempio questo: Ma non importa, forse non esiste una soluzione a quello, mi sono abituato ormai, l'importante è farmi installare questo benedetto Kali e farlo apparire nel bootloader senza togliere windows

 

Edited by MikixIT

Share this post


Link to post
Share on other sites

Mhhh forse x il fatto dell'SMBios devi scendere a compromessi PM\Grafica..........
Non saprei dirti in firma trovi come dare info Utili posta tutto ciò puoi al fine di dare info importanti , di sicuro possiamo solo apportare migliorie , Lan e Audio non vedo Kext , info please

Questo dovrebbe essere SMBios x la CPU tua CREDO , ma NON x la VGA sempre CREDO https://everymac.com/systems/apple/imac/specs/imac-core-i7-2.8-27-inch-aluminum-late-2009-specs.html

Edited by Baio77

Share this post


Link to post
Share on other sites
1 minute ago, Baio77 said:

Mhhh forse x il fatto dell'SMBios devi scendere a compromessi PM\Grafica..........
Non saprei dirti in firma trovi come dare info Utili posta tutto ciò puoi al fine di dare info importanti , di sicuro possiamo solo apportare migliorie , Lan e Audio non vedo Kext , info please

Audio mi esce dall'HDMI che utilizzo, il cavo lan ho installato i Realtek e va bene

La grafica "va bene", gioco alcuni giochi tranquillamente anche se a dirti la verità con qualche glitch grafico che su win non ho

Uso i Nvidia Web Driver

Share this post


Link to post
Share on other sites

Vedo da configplist x NvidiaWEB , aspetto dati allegati x il PM prova il mio configplist , credo la spunta su KP NON serva ma x adesso cambia solo connfigplist se va facciamo altre modifiche togli NullCPU ovviamente

Edited by Baio77

Share this post


Link to post
Share on other sites
Just now, Baio77 said:

Vedo da configplist x NvidiaWEB , aspetto dati allegati x il PM prova il mio configplist , credo la spunta su KP NON serva ma x adesso cambia solo connfigplist se va facciamo altre modifiche

Scusami, non ho capito cosa dovrei fare?

Apro il mio config della mia EFI e tolgo quale spunta?

Share this post


Link to post
Share on other sites

No adesso devi solo assicurarti di avviare da USB x fare prove .....
Poi in questa USB con clover metti la clover del tuo HD sovrascivendola , e dopo sovrascrivi il configplist ti ho passato al tuo e x ultimo prima di avviare cancelli NullCPU 

GUIDA PM dell MITICO Netgear 

 

Edited by Baio77

Share this post


Link to post
Share on other sites

Scusami se ti sto facendo perdere tempo e perdona la mia ignoranza,

Devo prendere la Pendrive dove ho l'installer di OSX?

O devo fare cosa?

 

EDIT: Ho capito, lo sto facendo

Ho capito male io

Edited by MikixIT

Share this post


Link to post
Share on other sites
2 minutes ago, Baio77 said:

ascolta , hai una USB con clover con cui fare il Boot ed arrivare al Desktop?????Va bene quella con cui hai installato nel caso
 

Si infatti sto utilizzando quella e sto togliendo NullCPU da i kext, e ora provo a riavviare dalla usb giusto?

Share this post


Link to post
Share on other sites
Just now, Baio77 said:

Scusa se mi ripeto , se togli NULLCPU devi sovrascrivere il mio configplist altrimenti NON avvierà MAI

Scusami se sono ritardato.. ma dovè il tuo config.plist? così lo sostituisco con il mio

Share this post


Link to post
Share on other sites

Il Pc si avvia, riesco ad avviare OSX ma dopo 10 sec lagga da morire e ci sono tanti glitch grafici che portano il pc a spegnersi da solo

4 minutes ago, Baio77 said:

Nel caso NON avvia , sovrascrivi questi File Configplist tolta spunta da KP e Kext messe in Other e aggiornate ...........

Archivio.zip

Provo

Share this post


Link to post
Share on other sites

Puoi postare Ioreg avviando dagli ultimi file postati??

 Dovresti provare a inserire la spunta su Grafica Nvidia , vedere se migliora , già che avvia è buono

RIPETO mi serve il report zippato di Hack Info , ho bisogno di vedere se Kext a spasso x OS possono dare fastidio , creando problemi di ogni tipo 

Nel caso spunta qui in configplist , cosi eliminiamo il problema grafico e proviamo a vedere di sistemare la CPU 

Schermata 2018-09-23 alle 17.35.19.png

Edited by Baio77

Share this post


Link to post
Share on other sites
14 minutes ago, Baio77 said:

Nel caso NON avvia , sovrascrivi questi File Configplist tolta spunta da KP e Kext messe in Other e aggiornate ...........

Archivio.zip

Allora avvio il pc, si avvia accedo a OSX metto la pass e lagga tutto, provo ad aprire safari e appare system uptime in seconds con schermata nera

e si spegne il pc

 

 

Share this post


Link to post
Share on other sites

Mhhhhh credo che cosi proprio NON vada , credo CPU , aggiorna Clover della USB con quello ti ho linkato nei post precedenti e prova a vedere se migliora , altra cosa sarebbe quella di cambiare SMBios con Macbookpro 6,2 o iMac11,1 che sarebbe il più consono

Edited by Baio77

Share this post


Link to post
Share on other sites
12 minutes ago, Baio77 said:

Puoi postare Ioreg avviando dagli ultimi file postati??

 Dovresti provare a inserire la spunta su Grafica Nvidia , vedere se migliora , già che avvia è buono

RIPETO mi serve il report zippato di Hack Info , ho bisogno di vedere se Kext a spasso x OS possono dare fastidio , creando problemi di ogni tipo 

Nel caso spunta qui in configplist , cosi eliminiamo il problema grafico e proviamo a vedere di sistemare la CPU 

Schermata 2018-09-23 alle 17.35.19.png

HackInfo_Report.zip  Ora provo a spuntare e riavvio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Run Vanilla OS X El Capitan, Sierra, High Sierra or Mojave in VMware Workstation on a Windows Host
       
      I wanted to make a simple guide on how to create a vanilla OS X El Capitan virtual machine running on a Windows host.  The virtual machine should be useful for testing El Capitan and also for creating installers for use on a real machine/hackintosh.
       
      There are many guides and videos on the net about running OS X on Windows machines using pre-made VMWare disk images but you can never guarantee what else is in there….
       
      I’ve gathered info for this guide from various threads in the Multibooting and Virtualisation section of this forum eg
       
      Workstation 11/12, Player 7/12, Fusion 7/8 and ESXi 6 Mac OS X Unlocker 2 by @Donk How to Install OS X 10.x from Snow Leopard to El Capitan in VMware Workstation 10/12, Player 6/8 or ESXi 5/6 by @MSOK HOW TO: Create a bootable El Capitan ISO for VMware Credit and thanks to @Donk, @Albert Nietsnie and @MSOK for all their hard work in creating and testing the VMware Unlocker program.
       
      Requirements
      Intel PC with four or more CPU cores running Windows 7 X64 or later OS (2 or more cores needed for OS X) 4GB or more RAM (2GB or more will be needed for OS X) Hard Disk with at least 40GB free for Virtual Machine VMware Workstation 12 or later VMware Unlocker 2.0.7 or later Install OS X El Capitan app and Mac or Hack to prepare installation iso <-- Now, no longer necessary to have previous access to a Mac or Hack by building the Installer.app from scratch - see post#41 16GB or larger exFAT formatted USB stick to transfer El Capitan iso from Mac/Hack to Host PC Prepare Installation ISO on your Mac or Hack
      1.  On your Mac or Hack, download "Install OS X El Capitan.app" from the App Store into your Applications folder.
      2.  Unmount any attached install image/InstallESD.dmg (if currently mounted) by rebooting the system or running the hdiutil unmount command in terminal eg
       
      3.  Download and unzip the CECI.tool (attached to this post) into your ~/Downloads folder. The commands in this executable script are shown below for informational purposes….
       
       
       
      4.  Open OS X terminal, then run the following commands to execute the script:
      cd downloads chmod +x CECI.tool ./CECI.tool 5.  At the end of the process, you will have an El Capitan iso on your desktop - copy this onto an exFAT formatted USB for use on the PC Host later.
       
      Updates:
      @shela has created an ISO generating script compatible with OS X 10.6-10.12: create_osx_iso post #362.
      See post#30 for macOS_iso_cim.tool script to create ISO for macOS 10.13+ using Apple's createinstallmedia utility.
       
      Install and Patch VMware Workstation 12 on your PC
      1.  Download and install VMWare Workstation Player 12 or later
      2.  Download and extract Unlocker 2.0.7 or later to your USB stick…
      3.  Run the win-install.cmd as administrator by right clicking the file in Windows explorer or run it from an Administrative Command Prompt.
       



       
      Create an El Capitan Virtual Machine
      1.  Double click on the VMware Workstation 12 Player icon on your desktop and click “Create a New Virtual Machine”.  Choose “I will install the operating system later” at the How will you install screen….
       

      2.  Select Apple Mac OS X as the Guest operating system and OS X 10.11 as the version.  By default, an OS X 10.11 folder will be created in your Documents\Virtual Machines folder.
       


      3.  Under Specify Disk Capacity, you can leave the default 40GB or set a larger value.  I personally store the virtual disk as a single file.  Click Finish and you will see OS X 10.11 on the Main Screen of Workstation 12.
       


      4.  Next, we need to edit the virtual machine settings to map the virtual SATA CD/DVD drive to the El Capitan installation iso we created earlier.
       


       
      5.  To prevent the virtual machine from crashing in Windows, the virtualHW.version set in the vmx configuration file needs to be changed from 12 to 10 (alternatively, the line smc.version = "0" can be added to the file).  The OS X 10.11.vmx file can be edited with the WordPad program (navigate to the OS X 10.11 virtual machine folder with Windows Explorer and right click on the file to open in WordPad).
       


       
      6.  For HW10, set USB compatibility to USB 2.0, otherwise your mouse and keyboard might not work in the virtual machine.
       

      7.  Finally click “Play virtual machine”
       

      Installation of El Capitan
      Installation should be relatively straight forward, just following the prompts of the OS X installer:
      1.  Select language, agree to legal terms
       

      2.  Use Disk Utility from the Utilities Menu to erase and format the virtual hard drive as a single partition GUID Mac OS X Extended.  I’ve named the drive Macintosh HD but you can enter whatever you like eg El_Capitan.
       



      3.  Quit DU and choose Macintosh HD to install El Capitan on.
       

      4.  After 20-30 min (depending on how fast your system is), the installation will complete and the VM will automatically reboot…
       

      5.  At the welcome screen, choose your country and keyboard layout.  You can skip transfer information, location services and logging in with your Apple ID if you wish…
       


      6.  Create a User Account and select your Time Zone.  You can skip sending diagnostics and usage data to Apple….
       


      7.  Finally, you will arrive at the El Capitan Desktop.  You should eject the Installation iso now by right clicking and selecting “Eject OS X Base System”.  This will allow you to install VMware Tools….
       



      8.  After rebooting, the VM can now be resized or run at full screen resolution.  Audio and network/internet should also work OOB.
       

       
      SMBIOS Customization and iMessage Vars
      To make the Virtual Machine more "Mac like", you can edit the vmx file to add unique identifiers from a real Mac's SMBIOS -
      eg for an iMac 11,3 SMBIOS, you can enter the following lines....
      smbios.reflectHost = "FALSE" board-id.reflectHost = "FALSE" board-id = "Mac-F2238BAE" hw.model.reflectHost = "FALSE" hw.model = "iMac11,3" serialNumber.reflectHost = "FALSE" serialNumber = "W80#######6" Refer How to spoof real Mac in VMware - Multi-booting and Virtualisation.
       
      The critical variables for iMessage/Facetime activation are MLB & ROM.  By default, VMware "reflects" the host's MLB and ROM since it assumes you are running the OSX guest on a real Mac host - see post#42 by @Donk.
       
      If the host is a Windows PC, the following lines need to be added to the vmx file (requires virtualHW.version 12 and smc.version = "0")....
      efi.nvram.var.ROM.reflectHost = "FALSE" efi.nvram.var.MLB.reflectHost = "FALSE" system-id.enable = "TRUE" and the MLB, ROM and optionally system-id entered manually eg
      efi.nvram.var.MLB = "W80######BA1A" (MLB can be 13 or 17 characters long, alphanumeric string) efi.nvram.var.ROM = "<=>?@A" (ROM is entered here as a 6 character ASCII string) uuid.bios = "## ## ## ## ## ## ## ##-## ## ## ## ## ## ## ##" <---Optional (if you want to inject a given system-id hexadecimal value) Note the output for ROM from imessage_debug is a 12 character hexadecimal that needs to be entered here as a 6 character ASCII string eg using an Hex to ASCII converter we find that "3c3d3e3f4041" hex is equivalent to   "<=>?@A".
       
      Vanilla Mavericks and Yosemite
      The same VM settings for El Capitan will also boot and run vanilla installations of OS X Mavericks and Yosemite .  Attached to this post are installer scripts to create bootable Mavericks (CMI.tool) and Yosemite (CYI.tool) ISOs for VirtualBox and VMware.
       
      With the respective OS X installer apps in the Applications folder, download and run the installer tools using terminal ie
       
      To create a Mavericks ISO on your desktop
      cd downloads chmod +x CMI.tool ./CMI.tool To create a Yosemite ISO on your desktop
      cd downloads chmod +x CYI.tool ./CYI.tool Here is a screenshot of the VM running Mavericks 10.9.5...
       

       
      Enjoy
       
      Update for macOS 10.12 Sierra
      The above settings still work for macOS Sierra after upgrading to VMware Workstation 12.5 and unlocker 2.0.8 - see post #13.
       
      Update for macOS 10.13 High Sierra and 10.14 Mojave
      See post#30 for macOS_iso_cim.tool script to create ISO for macOS using Apple's createinstallmedia utility.
      Post#41 describes how to build "Install macOS ******.app" on the fly from installer files downloaded beforehand in /SharedSupport folder.
       
      Update for macOS 10.15beta Catalina
      See post Update for macOS Catalina 10.15beta
       
      CECI.zip
      CYI.tool.zip
      CMI.tool.zip
    • By EvandroAluck
      eu tô muito perdido, sempre que eu tento instalar um driver do [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], ou até atualizar o sistema pela apple ele não incia mais. eu já instalei o sistema e reiniciei sem fazer alterações e funcionou perfeito ...

    • By ThatsMatt
      Salve, sono nuovo nel forum e mi serviva una mano nell'installazione dell' ultima versione di MacOs sul mio notebook HP Pavilion 15-ak112nl.
      Specifiche Tecniche: 
      CPU: Intel Core i7-6700HQ (2.60 / 3.50 GHz, 4 core, 6 MB CACHE L3). 
      Scheda Grafica: Intel HD Graphics 530 + NVIDIA GeForce GTX 950M 4 GB DDR3.
      Hard Disk: 1 TB SATA 5400 rpm.
      Ram: 8 GB DDR3L-1600.
      Audio: altoparlanti stereo Bang & Olufsen PLAY. 
      Rete: LAN 10/100, WLAN 802.11b/g/n, bluetooth 4.0 (Miracast).
      Grazie in Anticipo a chi mi risponderà
    • By t0mmenhansen
      I havent used my hackintosh in a while. I wanted to boot to my mac drive. This error comes up when i try to boot. Ive tryed using explorer++ and update the lilu kext and whatevergreen kext, no luck yet. Any ideas?
       
      9700k
      16GB corsair
      1080 nvidia card
      z370-f mobo
      mac drive is an SSD from kingston
      Display port outpoot
       
    • By chrisrlink
      hi so I recently upgrade to an Nvidia GT 730 (did an upgrade without needing a new PSU) the graphics card is detected by Mojave but no sound via the hdmi port I read Nvidia is forbidden to make web drivers past High Sierra (must be approved by apple) so how will I go about enabling sound through my HDMI (any additional info/files I'll be happy to supply)
×