Jump to content
doixanh

[GUIDE] Dell Inspiron 15R SE 7520 with macOS Mojave

15 posts in this topic

Recommended Posts

This follows my previous guide for macOS Sierra.

 

0. What works and does not

Works

- CPU power management

- QE/CI on Integrated Intel HD 4000

- Keyboard/Trackpad

- HDMI and LVDS output

- Audio: Headphone, speaker, HDMI (?).

- Ethernet

- Camera

- Battery info

- Bluetooth

- USB

 

Does NOT work

- Internal Wifi. Workaround: USB wifi or replace your internal wifi with a supported mPCI-e card.

- Sleep: does not work with an USB wifi. Workaround: Replace your internal wifi with a supported card.

- VGA out. Workaround: Use an « active » HDMI to VGA adapter. I use this way to connecting my laptop to projectors.

- Discrete AMD GPU

- Card reader. Workaround: Use an external USB card reader.

 

 

1. Specs

My Dell Inspiron 15R SE still has the following specs (I haven't upgraded it since Yosemite) :

- Intel Core i7 3632QM with Intel HD Graphic 4000

- 8GB + 4GB RAM (12GB total)

- 128GB Samsung EVO SSD + 1TB HDD

- AMD Radeon 7730M, won't be used by any Hackintosh build

- Full HD 15.4" screen

 

2. Requirements

- A Dell 7520, of course :D

- An USB Stick, minimum 16GB. Any 16GB should work.

- A pair of USB Mouse / Keyboard during the installation and fixes (you can use your built in keyboard and touchpad later)

- An existing Hackintosh (or a real Mac, if you have any ;) )

- Downloaded «Install macOS Mojave Beta» from App Store.

- A GPT-partitioned hard drive

- A 20GB (minimum) partition as the target.

- Dosdude1's macOS Mojave Patcher

 

3. Create USB Install. For full guide please see here

- Boot your existing Hackintosh or real Mac.

- First you need to be sure that you have downloaded the app «Install macOS Mojave» from App Store

- Use Disk Utilities to partition your USB stick with 1 partition in GPT mode, and choose «OS X Extended (Journaled)» as partition type. Note: don't use any space in label of your disk.

- Run Dosdude1's macOS Mojave Patcher, select the installer app, select usb disk as target.

- Be patient. It's quite slow.

- Download and install Clover Bootloader v4658 to the usb disk, note to install using EFI boot only

- Copy attached config.plist to /Volumes/ESP/EFI/CLOVER/

- Copy attached kexts to /Volumes/ESP/EFI/CLOVER/Other/

- Download NullCPUPowerManagement.kext and put it in /Volumes/ESP/EFI/CLOVER/Other/

- Reboot after finishing creating your USB for installation.

 

4. Install

- During boot, press F12 to have boot list. Choose your USB to start. Set ig-platform-id to 0x01660004 to boot the installation.

- It should boot directly to the installation UI

- Select Utilities and Disk Utility.

- Format your target partition as OS X Extended (Journaled). APFS can be used but it's your own risks :)

- Exit Disk utility.

- Begin the install procedure - it should be there already. Choose your newly formatted partition. Follow the instruction. Wait for a while (in my case I waited around 10 minutes).

- It will restart your computer as soon as it finishes the file copy.

- You still need to boot from USB. Hit F12 during boot to show boot list. Choose your USB to start. Set ig-platform-id to 0x01660004, select your installed partition and press Enter.

- You will be able to see user creation. Follow the instructions on screen. When you get to your desktop, rebuild kernel cache:

sudo touch /System/Library/Extensions
sudo kextcache -u /

- Reboot, you should be able to use both LVDS and HDMI outputs (with default ig-platform-id 01660003, already patched using this guide) with proper kext and config.plist attached.

 

 

Welcome to macOS Mojave!

100241270_ScreenshotatSep1714-59-05.thumb.png.47b13a0af2020acb05ccafee9fca6826.png

 

5. Device fixes

Most of the fixes are included in the attached kext zip.

5.1. CPU Power Management

Works fine with macOS Mojave (official version) as long as you use ssdtPRGen.sh as instructed here. Don't forget to delete NullCPUPowerManagement.kext afterward.

5.2. Wifi

The integrated wifi doesn't work. At all. I used an external wifi dongle TP Link WN725N (v2) for Internet access. After that I replaced the internal wifi with a Atheros AR5B29 and it works natively :)

If you use this AR5B29, copy the attached AirPortAtheros40.kext into /System/Library/Extensions

config.plist.zip

kexts.zip

AirPortAtheros40.kext.zip

Edited by doixanh

Share this post


Link to post
Share on other sites
Advertisement

Ace but what do you need Dosdude1's patcher for? It's not clear.

 

Also, you mentioned AR5B29. Are you sure you didn't make a typo somewhere? I don't know all cards but it sure ain't one I've heard of before and I cannot find any reference to that model on the Net... What's the patch applied to AirPortAtheros40.kext because the Info.plist looks unchanged; is it a binary one?

 

NB: section #3 "Create USB install" could do with a refresh because it still links to an old Sierra distro guide based on Enoch... -_-

Edited by Hervé

Share this post


Link to post
Share on other sites

Without the dosdude1's patch the installation went corrupted and I don't know why. I tried using the createinstallmedia command yet still went wrong.

 

The AR5B29 is essentially an Atheros 9285 (link to buy on ebay). I got the name on Windows Device Manager :D There is no patch applied for the kext, but it is removed on Mojave, so I got that one from High Sierra to make the AR5B29 work again on Mojave.

 

I'll update the #3 once I have some free time.

 

Thanks for your comments :)

Share this post


Link to post
Share on other sites

Ok, I found that, if I apply Dosdude1's patcher to my Mojave PB1 installation package, the USB installer is unbootable and loops indefintely with SIGKILL/SIGDEV errors, no matter what. I did notice an error at the end of the patcher's execution related to some incorrect DP1-related path when trying to copy OSXInstall.mkpg package or something like that. On the other hand, no such issue with the createinstallmedia method but then I cannot use it on officially unsupported platforms... I guess it'll all be sorted once Dosdude1 updates his patcher for the GA release that comes out on Monday.

 

Regarding your Atheros card, it is an AR9285-based AR5B95 (168c,2b); there is no such thing as an AR5B29... AR5B95 works OOB with a little DSDT patch to declare compatibility with a natively supported model based on Atheros chips such as AR9380 (168c,30) or AR9280 (168c,2a) as detailed here:

https://osxlatitude.com/forums/topic/2120-inventory-of-supported-and-unsupported-wireless-cards/

 

If you patch your DSDT, you'll never have to patch the Atheros40 kext again.

Edited by Hervé

Share this post


Link to post
Share on other sites

It's a natively supported card on pre-Mojave, no patch is required. I had no problem at all using it on Yosemite - High Sierra. 

 

However it's a problem of Mojave to drop support for it. The kext was intendedly removed from Mojave.

 

Share this post


Link to post
Share on other sites

Its not working for me due to my graphices not working can you guide please :( 

When enter to boot apple logo disappeared with blank screen

 

Edited by Purushothama

Share this post


Link to post
Share on other sites
On 9/17/2018 at 1:19 AM, doixanh said:

- You will be able to see user creation. Follow the instructions on screen. When you get to your desktop, rebuild kernel cache:

How are you? I would like to thank you for the tutorial. Could you help me with a problem? After booting with the pendrive created by the clover of its indication and its list (info.plist) the system does not go to the second part, which would give me access to the desktop. It simply resets. Using the patch macOS Mojave Patcher, the system goes to the second part, however using the configuration of a Macbook Pro 8.2. In short, the way you are in the tutorial you have done I can not make the system work. Below is the information in txt about the error. 

george error.rtf

Share this post


Link to post
Share on other sites

In case you have problems with reboots, try to update your BIOS to latest version. It should fix quite a bit of bugs.

 

Share this post


Link to post
Share on other sites

Hi! How are you?
The bios in my notebook has already been upgraded to A14. Can I send you the EFI folder and some images of the error? Remembering that the error happens when I choose the HD to boot. The system still goes into safe mode, showing the 1536mb of video memory. However, I think karnel Panic is related to something related to the deactivation of the AMD radeon 7730 GPU.

EFI.zip

Share this post


Link to post
Share on other sites
Posted (edited)

10.14.4 requires Clover 4910 to boot. Everything is still fine to me.

Screenshot at Apr 02 08-59-41.png

Edited by doixanh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      I was inspired by @duduclx post for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5.  Everything works perfectly except for sleep.  I'm starting this thread hoping to help others install Mojave on their E6410s and to diagnose and resolve the sleep issue.  This thread is not currently intended to be an installation guide and is better suited to the intermediate/advanced hackintosher.  Eventually, it may evolve into a guide.
       
      I started with this thread (Many thanks, @duduclx !!!) and ended up with the system captured in the attached files.  The keys were to change the LPCB._DSM.Name to "3b09" and remove all CLOVER configs not necessary for Mojave, plus some other items mentioned below.
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.5 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 5, not the original version) Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) MacOS: Mojave 10.14.5 CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads  No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)   
      What is NOT working:
      Sleep (display goes blank, but power light stays on.  System cannot wake and must be forced off with power button) Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings.  The slider appears in Display settings (because of the backlight DSDT injection in AGP.VID._DSM), but the slider doesn't work (yet).  Haven't spent time to figure this out, but would love help.
        What is NOT tested:
      SD Card Slot Smartcard Reader eSata (I have this disabled in my BIOS) Display Port Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS) Camera (I have this disabled in my BIOS)  
      What IS working:
      Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: @PlutoDelic) for working external VGA display. Headphone jack  
      Known issues and their solutions
      AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  This has been completed and tested, but does not fix the sleep behavior.  This fix is not reflected in the attached files. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European.  The updated VoodooPS2Controller.kext is not reflected in the attached files.  
      Brief Installation Guide (for the experienced Hackintosher):
      Follow duduclx's guide for BIOS config Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original) Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  


      CLOVER.zip
    • By fusion71au
      Patch Catalina or Mojave macOS Installer App for Unsupported Machines
       
      Often for economic reasons, Apple prevents the Installer.app for its latest macOS from installing on older machines perfectly capable of running it eg macOS 10.14 Mojave on Unsupported Macs Thread.
       

       
      In Mojave 10.14, @ASentientBot posted a method to patch the distribution file in OSInstall.mpkg to enable the Mojave installer to install on unsupported machines (with or without graphics card metal support). 
       
      In Catalina 10.15beta, the above method no longer works since Apple is checking OSInstall.mpkg for its file signature and the mandatory requirement in Catalina to install to 2 separate apfs volumes necessitates using the original Catalina macOS Base System Installer.  Fortunately, it is still possible to substitute High Sierra’s Apple Signed OSInstall.mpkg inside the Catalina or Mojave InstallESD.dmg by making it R/W.
       
      The procedure below will allow Macs or Hacks able to install High Sierra to also install Catalina or Mojave (eg SMBIOS MacPro5,1, iMac11,3, MacBook Pro7,1 which have been unsupported in macOS 10.14.x and 10.15beta) -credit to @ASentientBot's post.
       
      Prerequisites
      1. Mac or Hack capable of and running High Sierra 10.13.x
      2. An original, untouched copy of OSInstall.mpkg from High Serra InstallESD.dmg - attached OSInstall_10.13.6.mpkg.zip save to your ~/Downloads folder
      3. macOS Installer App eg for Catalina beta or Mojave downloaded to /Applications
      4. Add NVRAM boot arg (or Clover config.plist boot arg on a hack) -no_compat_check to enable system to boot to final completed Mojave or Catalina install.
       
      Procedure
      1. Open Terminal and type the following
       
      open /Applications/Install*/Contents/SharedSupport/InstallESD.dmg (assuming the Catalina or Mojave Installer App is in /Applications)  
      2. Open Disk Utility, click File|New Image|Image from ‘InstallESD”
      3. Save as read/write image, no encryption in /Applications
      4. Unmount InstallESD in DU by clicking the "eject" icon next to it
       
       
      5. Open the R/W InstallSD.dmg in /Applications and replace Catalina’s/Mojave's OSInstall.mpkg with High Sierra’s version by typing in terminal
       
      open /Applications/InstallESD.dmg cp ~/Downloads/OSInstall_10.13.6.mpkg /Volumes/InstallESD/Packages/OSInstall.mpkg  
      6. Unmount InstallESD in DU by clicking the "eject" icon next to it
      7. Replace original Catalina/Mojave InstallESD.dmg with our patched one, making a backup of the original.  In terminal, type
       
      sudo mv /Applications/Install*/Contents/SharedSupport/InstallESD.dmg /Applications/InstallESD_orig.dmg sudo mv /Applications/InstallESD.dmg /Applications/Install*/Contents/SharedSupport/  
      8.  Test the newly patched installer!…

    • By Coddyx
      Hi,
       
      I followed the AMD OSX Vanilla Guide and managed to successfully build my first hackingtosh.
      Everything works great EXCEPT for my MSI - Radeon RX 580 8 GB GAMING X.
      I ran some benchmarks (and tried World of Warcraft) and I am getting ~50% of the performance I am usually getting in Windows 10.
      Unigine Heaven reports ~950 vs 1750 in Windows and World of Warcraft runs @ 30 fps lowest settings vs 60 fps ultra settings in Windows.
       
      Here are the kexts I am using:
      AppleALC Lilu NullCPUPowerManagement RealtekRTL811 VirtualSMC WhateverGreen  
      I should mention that this is an AMD hackingtosh running on Ryzen 5 1600 3.2 GHz 6-Core Processor.
       
      I read and I completely understand that I should not expect 100% performance. But I believe a 50% drop is out of the ordinary.
       
      If anyone has ideas on what I could try to up the performance it would be greatly appreciated.
       
      Thank you!
       
       
    • By fusion71au
      Clover r4961 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4961 for VMware.zip". Mount Clover-v2.4k-4961-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×