Jump to content
SoxasoraIT

Surface Pro 2017 - macOS Mojave 10.14.4 Hackintosh - Success!

46 posts in this topic

Recommended Posts

Advertisement
On 12/9/2018 at 7:29 PM, cunc.cameron said:

Currently trying this guide on my Surface but I can't seem to get past this error - hangs after End RandomSeed once I've selected to boot the macOS installer. I've reinstalled clover, reformatted the USB, tried adding more drivers, no luck. Any ideas? Also tried using the clover version from when this guide was created and still, nothing. Can't be the USB, as I've successfully installed Mojave onto my desktop with this same one. I'm lost. 

 

IMG_6743.thumb.jpeg.3a273f8e59e4c2cd158204961f47748a.jpeg

remove osxaptio from driversuefi

 

Share this post


Link to post
Share on other sites
On 1/26/2019 at 5:20 PM, xuzhimin said:

Thanks to the help of the author of voodooi 2c, I modified voodooi 2c. Now you can use the touch pad. Please install it to L/E or S/L/E

voodooi2c.zip

are multi touch gestures working? if so, how smooth is it?

Share this post


Link to post
Share on other sites
On 3/3/2019 at 7:52 PM, Naborisk said:

are multi touch gestures working? if so, how smooth is it?

yes,all work

Share this post


Link to post
Share on other sites
On 1/26/2019 at 10:20 AM, xuzhimin said:

Thanks to the help of the author of voodooi 2c, I modified voodooi 2c. Now you can use the touch pad. Please install it to L/E or S/L/E

voodooi2c.zip

Can u plz make it work for surface book 2 that will be so coool thx 

Share this post


Link to post
Share on other sites
On 3/17/2019 at 4:58 AM, mrblackm123 said:

Can u plz make it work for surface book 2 that will be so coool thx 

Voodooi2c source code has added keyboard processing code, you can compile it yourself

Share this post


Link to post
Share on other sites
On 3/16/2019 at 2:04 PM, xuzhimin said:

yes,all work

I finally got the trackpad working, but the trackpad settings cannot be configured from system preferences.

Can you configure trackpad settings? (e.g. enable tap to click, 3 finger drag, etc.)

Share this post


Link to post
Share on other sites
On 3/30/2019 at 10:01 PM, Naborisk said:

I finally got the trackpad working, but the trackpad settings cannot be configured from system preferences.

Can you configure trackpad settings? (e.g. enable tap to click, 3 finger drag, etc.)

yes,I can

Share this post


Link to post
Share on other sites
On 4/5/2019 at 3:40 PM, xuzhimin said:

yes,I can

 

So, how do you enable trackpad settings in System Preferences? I mean, i have Voodoo I2C installed and the DSDT patch too, what did you do?

Share this post


Link to post
Share on other sites

Updated CLOVER EFI folder available for macOS 10.14.4+
Changelog:

- CLOVER bootloader updated to latest version because 10.14.4 breaks kext injection.
- Kexts updated for 10.14.4
- DSDT patch of VoodooI2C applied but still not working (Trackpad gestures)

Known Issues:

- VoodooHDA may cause somewhat of kernel panic, rare and only during boot. Booting macOS blocking VoodooHDA injection via CLOVER and then rebooting without blocking will fix the kernel panic. Odd, right?
 

Share this post


Link to post
Share on other sites

You need to install the modified version of voodooi2c that I provided, put it into S/L/E or L/E, fix the permissions and rebuild the cache, and then restart. After rebooting, you need to make sure that voodooi2c is loaded. In another forum, many people have succeeded.  With an address on it

Share this post


Link to post
Share on other sites
On 4/28/2019 at 2:25 PM, SoxasoraIT said:

 

So, how do you enable trackpad settings in System Preferences? I mean, i have Voodoo I2C installed and the DSDT patch too, what did you do?

https://github.com/alexandred/VoodooI2CHID/pull/3

I am based on this source code modified voodooi2chid, confirmed that this can be used on surface pro5, surface pro 5 recently updated uefi firmware 234.2344.769, you update this configuration file can not enter the system, will be stuck in +++, After experimenting, on 10.14.4, in some special cases, third-party kext may not be able to load, some may, maybe you can't use keyboard gestures, I am also looking for reasons

 

https://www.tonymacx86.com/threads/surface-pro-2017-install-mojave.273868/

This is the configuration file that the new uefi firmware can start, but there are some problems, such as the need to remove osxaptio* and must be added to emu*. Some people will not be able to modify the system permissions after using it, and cannot load third-party kext, such as voodooi2c, it must be installed in S/L/E or L/E

Share this post


Link to post
Share on other sites

i have xit randomseed error after i removed osxaptio from driversuefi as advised above im getting kernel panic. Any ideas?

Share this post


Link to post
Share on other sites

Hi All 

 

i have a surface pro 4 intel i5 6300u has the intel hd520 chip i am trying to get this to work with mojave  i have got it to boot into mojave by clover but cannot  get the graphics to work correctly 

 

When i boot they are sooooooo small lol 

 

does anyone have a working EFI Folder ?

 

Thank you All 

 

Mike 

Share this post


Link to post
Share on other sites

I was managed to install the Mojave but I can't access it with the file provided :(

I'm using I7 8G btw

Share this post


Link to post
Share on other sites
Posted (edited)

Thumbs up! Installation done... but my resolution is not that good. Acceleration is working but I do not have a valid resolution. About my Mac shows an Internal Retina display running 1368 not 2736 Maybe I am wrong but what about your resolution. Under system settings - Graphics: 
 

Intel HD 620 1536 MB

BUS: Build-In

Metal: supported

Display: 2736 x 1824

UI Looks like: 1368 x 912 @60 Hz - seems to be wired, or?

Connection Type: Display Port

 

 

 

Thanks for a quick replay. Cheers, P

Edited by iPfeils

Share this post


Link to post
Share on other sites

bonjour , voila quand j'installe la mise a jour Catalina finale au démarrage de Clover efi impossible de boot sur Catalina car le logo pour lancer Catalina n'apparait plus seul le recovery existe :s je suis sur Clover efi 5070

Share this post


Link to post
Share on other sites

@SoxasoraIT @xuzhimin

 

dose your latest efi having working HiDPI?? or is it still glitchy when using HiDPI?

 

im using hackermans efi from github but getting glitches when using HiDPI

 

thanks 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×