Jump to content
LAbyOne

Lilu Suite builder

91 posts in this topic

Recommended Posts

Posted (edited)
2 hours ago, LAbyOne said:

that just mean you had no previous version on your disk into /local directpry

so once launched the application it should be installed ( or application exit )

 

about the empty folders i think You run some older version by mistake

otherwise its impossible to get such result....  check again and trash older version before...

 

 

 

Yes, the first time I am using these apps. For both apps when I start to it I am getting this, And I click to Geeez button and it starts to install after the finish it starts to create and says successfully created but when I look the folder always empty;

 

2121124787_ScreenShot2019-04-05at00_12_18.png.7f1ce9bd05d79b6a5ba3c08b6bc06d7b.png

 

After finished I am getting this;

 

894070784_ScreenShot2019-04-05at00_41_56.png.3a299a0529a721a8fa1829f806376adc.png

 

I click to got it button. Then go to the folder on the desktop; And both Debug and the Release folders are empty.

 

Could you please inform me what am I doing wrong?

 

Edit: I find the problem. The app doesn't install these tools when I install them as a manually  starts working now.

 

mtoc

mtoc.NEW

nasm

ndisasm

 

Edited by telepati

Share this post


Link to post
Share on other sites
Advertisement

@telepati

 

what really is strange at first look is the time it took to buiild

counting even the missing tools it should be done in around 3 min max.

 

then my only guess would go for xcode (and tools) 

on all my machines i still use 10.1, but even if you upgraded to 12, it should still works or someone else would also already reported if upgrading Xcode caused some issues.

 

back to the buildtime could also be some download were corrupted or incomplete causing the fail on building

such a long time is totally incredible...  my guess is all the issue comes from there,

 

as expected timings you should have 2 to 3 min for Vsmc and 3 to 4 mins for LiluSuite

maybe some connection troubles ? is your connection stable today?

 

Share this post


Link to post
Share on other sites
2 hours ago, LAbyOne said:

@telepati

 

what really is strange at first look is the time it took to buiild

counting even the missing tools it should be done in around 3 min max.

 

then my only guess would go for xcode (and tools) 

on all my machines i still use 10.1, but even if you upgraded to 12, it should still works or someone else would also already reported if upgrading Xcode caused some issues.

 

back to the buildtime could also be some download were corrupted or incomplete causing the fail on building

such a long time is totally incredible...  my guess is all the issue comes from there,

 

as expected timings you should have 2 to 3 min for Vsmc and 3 to 4 mins for LiluSuite

maybe some connection troubles ? is your connection stable today?

 

 

Boot time shows wrong. It took approximately 5 to 9 minutes. I am creating in an old real iMac which is using Core2Duo chipset but Mojave installed. Xcode version is 10.2 (10E125).

 

Anyway, everything works now. Thank you for the apps.

Share this post


Link to post
Share on other sites
Posted (edited)

@LAbyOne

No need to using Old source now, you can build by only the main source 

 

Edited by chris1111

Share this post


Link to post
Share on other sites
Posted (edited)

@chris1111

Thanks, in fact that's exactly what i have done, as stated into my post, I indeed reverted to Acidanthera source again... for Vsmc.... all other plugins are from their devs respectively sources

 

 

10 hours ago, telepati said:

 

Boot time shows wrong. It took approximately 5 to 9 minutes. I am creating in an old real iMac which is using Core2Duo chipset but Mojave installed. Xcode version is 10.2 (10E125).

 

Anyway, everything works now. Thank you for the apps.

yep sorry I forgot a ' 0 ' in 10.2 :)

I'm glad everithing is working now.

Edited by LAbyOne

Share this post


Link to post
Share on other sites
On 4/4/2019 at 11:13 PM, telepati said:

Edit: I find the problem. The app doesn't install these tools when I install them as a manually  starts working now.

 

mtoc

mtoc.NEW

nasm

ndisasm

 

 

Don't know what to say... as per my experience in never failed to install the missing ones, most likely you unintentionally skipped it without noticing, as I retested both apps on my 3 machines and it always installed when missing...

 

Btw next upcoming release will also install the Xcode tool directly when missing so there should be no more issues concerning the compilation..

 

(sometimes also happens to read about people complaining about some installation not working, just to discover later they had not even the basic tools installed on their machines)

 

This hopefully will solve the issue for newcomers.

Share this post


Link to post
Share on other sites

Done!

UPDATED

Lilu Suite Builder version 1.1.4 and VirtualSMC Builder to version 1.0.6

Added automatic detection and installation of Xcode Tools (previously only detected the installation and invited you to install using terminal command)

Share this post


Link to post
Share on other sites
1 hour ago, LAbyOne said:

 

Don't know what to say... as per my experience in never failed to install the missing ones, most likely you unintentionally skipped it without noticing, as I retested both apps on my 3 machines and it always installed when missing...

 

Btw next upcoming release will also install the Xcode tool directly when missing so there should be no more issues concerning the compilation..

 

(sometimes also happens to read about people complaining about some installation not working, just to discover later they had not even the basic tools installed on their machines)

 

This hopefully will solve the issue for newcomers.

 

I tested the new version. Remove my tools from /usr/bin and start Lilu Suite Builder v1.1.4. This time everything works without any problem. The builder installs all tools and creates kexts without any problem. Good Job. Thank you @LAbyOne

Share this post


Link to post
Share on other sites

NEW UPDATE

Lilu Suite Builder version 1.1.5 and VirtualSMC Builder to version 1.0.7

*modied to the compilation, to reflect actual changes made into Acidenthera VSMC build

 

Due to those actual changes I would recommend you to update.

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATED again

now

Lilu Suite Builder version 1.1.6 and VirtualSMC Builder to version 1.0.8

Added :

New iconset, and since the new simplified build of Vsmc, I finally modified the interface building sequence, monitoring the execution buid, you will now be visually informed about the kext being built

(nothing you can't live without :P )

Edited by LAbyOne
my english suck

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry Guys.

but it turn out my latest Suite 1.1.6 had little typo which prevented a plugin to make a valid Release build

 

* added ulterior checks to the Needed tools,

1032624146_ScreenShot.png.c9cfd1a005c4696972ddfa8512e77ef1.png

and modified the compilation,

Rewritten the code in order to make a Cleaner and faster build

Added automatic detection and installation of Xcode Application, Xcode Tools, Nasm + Disasm, Mtoc + Mtoc.NEW

So Now if Xcode is missing the build will be terminated

Lilu Suite Builder is version 1.1.7 and VirtualSMC Builder is version 1.0.9

 

Edited by LAbyOne

Share this post


Link to post
Share on other sites

 

Lilu Suite Builder version 1.1.8 and VirtualSMC Builder to version 1.1.0

UPDATED

* added ulterior checks to the Needed tools,

   and modified the compilation, to produce all build logs for each kext

and... added a new Icon as well, i like this one better....

 

Added Build Logs to the compilation

Now the application generate the log for each build process

you will find all of them into Logs folder inside package folder of both Debug and Release version

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATED, now its

Lilu Suite Builder version 1.1.9 and VirtualSMC Builder to version 1.1.1

only a little adjustment to the XCode installation

770185566_Screenshot2019-04-17at10_34_09.png.c107442cdc2f513c86c310236936961a.png

 

*** Updated Xcode Application detection, now when missing, by clicking on "Open AppStore" button, you will be

be directly redirected to the XCode download section on the AppStore.

 

Edited by LAbyOne

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATED, now its

Lilu Suite Builder version 1.2.0 and VirtualSMC Builder to version 1.1.2

only a few little adjustments to the Gui for XCode installation detection

1964374302_Screenshot2019-04-20at16_32_35.png.7c9d367bfb76d588734450914ec61cae.png

 

* users who are not willing to install Xcode can NOW abort the process

 

 

Edited by LAbyOne

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATED, now 

 

Lilu Suite Builder version 1.2.1, and 

VirtualSMC Builder version 1.1.3

* New plugin added to collection, it's AsusSMC ( a VirtualSMC plugin provides native macOS support for ALS, keyboard backlight and Fn keys on Asus laptops)

 

all infos can be found here and more here

Edited by LAbyOne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×