Jump to content
BibouI

Battery 0% On high sierra 10.3.2 HP Probook 650 G1

62 posts in this topic

Recommended Posts

Hello guys i have fresh clean 10.3.2 on my laptop i patched my brightness and my graphic card and i already have / patched/ dsdt.aml 
but when i tried to patch it for my laptop always shows me my battery is 0% 
I have tried to patch it with rehab patches but nothing works please help
and i'm offering a donation for any one he could help me 
and thank you

Share this post


Link to post
Share on other sites
Advertisement
35 minutes ago, Allan said:

You can use VirtualSMC with the SMCBatteryManager plugin.

Run this app, and upload the file result here.
RunMe

Thanks for your reply i could'nt find the relase version how i can install it in my system ?

Share this post


Link to post
Share on other sites

You need remove the FakeSMC, SMCHelper-64.efi, ACPIBatteryManager.kext.

 

Install VirtualSMC.kext and VirtualSmc.efi driver

Try boot with your USB stick

Share this post


Link to post
Share on other sites
12 hours ago, Allan said:

You need remove the FakeSMC, SMCHelper-64.efi, ACPIBatteryManager.kext.

 

Install VirtualSMC.kext and VirtualSmc.efi driver

Try boot with your USB stick

 

I did all the above 

and my system gives me Printif dose work ??

and when i boot with USB stick and i removed VirtualSmc.efi from driver64

system works again even tho I removed every SMC 

and ACPIBatteryManager 

and fake smc and fakesmc_gpu etc..

Share this post


Link to post
Share on other sites
14 hours ago, Allan said:

You need remove the FakeSMC, SMCHelper-64.efi, ACPIBatteryManager.kext.

 

Install VirtualSMC.kext and VirtualSmc.efi driver

Try boot with your USB stick

 

 

29150220-C30A-4755-B2FF-D2C9CDB9D8BF.jpeg

798EDC45-857F-4736-9293-3A0C6508D246.jpeg

Edited by BibouI

Share this post


Link to post
Share on other sites
Just now, Allan said:

Post your hardware specs.


My device is: HP Probook 650 G1
Graphic card is: 4600 Intel
I5-4200M CPU@2.50Ghz

can't we just patch the dsdt to make my battery works ??
do u have any idea about it please

Share this post


Link to post
Share on other sites
1 minute ago, BibouI said:

can't we just patch the dsdt to make my battery works ??

Yes, we can do that. But I'll need the untouched DSDT.

Share this post


Link to post
Share on other sites
Just now, Allan said:

Yes, we can do that. But I'll need the untouched DSDT.

Yes i have it 
I will attach it right now

Share this post


Link to post
Share on other sites
25 minutes ago, Allan said:

Test: DSDT.aml.zip

I tested system works fine but still 0% always i have tried to unplug and plug again the AC and my battery but still showing the icon of the battery 0% even tho before it wasn't showing ''signification usage'' in the battery icon

Edited by BibouI

Share this post


Link to post
Share on other sites
20 minutes ago, Allan said:

Try this: EFI.zip

SYSTem wont boot and gives me error

SMCvirtuale not found

key is missing and after that i got this one

 

0D7AE250-7254-4A6E-81E0-FEAB71F0ABE9.jpeg

B25FA0BB-64A1-4A8E-9FEE-5DE459DF9CCC.jpeg

Share this post


Link to post
Share on other sites
6 minutes ago, Allan said:

Hmmm <_<

Go back to the other (older) EFI folder.

I already did

system working but when i add the new smc my system break and wont work that’s why the only solution is dsdt but I don’t know why i dosnt work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×