Jump to content
Donw35

HP 840 G3 EliteBook ** WiFI and Bluetooth resolved** Big Sur / Catalina

113 posts in this topic

Recommended Posts

09222020 - Big Sur Beta 8 update, no issues.

09192020 - Big Sur Beta 7 update, no issues.

09042020 - Big Sur Beta 6 update, no issues.

 

I have moved on with this and do not use my HP G2 for Hackintosh, its mainly used for Kali Linux for Packet analysis these days, with that said I am using the HP 840 G3 for Hackintosh. I transitioned to OpenCore and Big Sur for this laptop but feel free to continue to ask questions. 

 

My G3 has the BCM84360CS2 mod, I got the module from eBay for $10 and the adapter for $10 off amazon.

 

Big Sur Beta 5 is working using the below EFI folder. OpenCore 6.1.0 and latest kexts

 

Method: USB Big Sur installation

  • Create an Big Sur Beta5 or Catalina USB installer (google is your friend here, plenty of tutorials there)
  • Mount the EFI partition of your USB installer using Clover Configurator
  • Copy the EFI file attached here.
  • Boot your laptop using F9 and choose the USB installer and follow the prompts

 

 

Spoiler

464583856_ScreenShot2020-08-22at9_03_25AM.thumb.png.d97630c6ded3254674812fd0e03dfebd.png

IMG_0823.thumb.jpeg.7da62e5ad95165f069c7ca99011f8da5.jpeg

IMG_0824.thumb.jpg.ad6cca2763d1fb663f58953d8297e93d.jpg

 

Catalina and old method in the Spoiler

 

Spoiler

Catalina update 10.15.5 without issues, make sure you update your kexts before hand and clover 5118

Catalina update 10.15.4 without issues, make sure you update your kexts before hand and clover 5107

Catalina update 10.15.3 without issues, make sure you update your kexts before hand.

Catalina update 10.15.2 without issues, make sure you update your kexts before hand.

Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.

HP 840 G2/G3, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 

Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.

 

My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist

 

Not working

SD Card reader

Finger Print device

 

Working

Video - screen looks better in OS X then it does in Windows 10

Display port

VGA port

WiFi and BlueTooth working OOO using the below hack

Battery status with Rehabman's DSDT patch

Brightness controls

Sounds - using VoodooHDA

* Microphone - cannot turn it off or mute

Keyboard backlight - controlled though BIOS anyways

touchpad - using VoodooPS2Controller

USB3 - this laptop has two on board only and I haven't test them using the docking station

USB3.1 C

Ethernet - using IntelMausiEthernet

Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.

Web Cam, works but I covered it up.

 

Credits go to Jake Lo for creating this EFI file. I did make some changes to his, this one is Open Core 6.1.0 and latest Lilu.kext and WhatEverGreen.kext

HP_840_G3_BSB5.zip

Edited by Donw35
updated

Share this post


Link to post
Share on other sites
Advertisement

I resolved the WiFi and Bluetooth issues by using a supported module

 

NOTE I have found that the NCM94322 doesn't work well in Catalina, it does kind of work but other problems like iMessage and FaceTime are problematic. I recommend using the BCM94360, its supported and all works. 

 

BCM943224PCIEBT2 Card To NGFF(M.2) Key A/E Adapter from Amazon for $14

MacBook Air 13 A1369 11 A1370 WiFi Bluetooth Air Port Card from eBay $10

 

 I had to do some cutting on the A/E adapter but was able to get it to fit, its a lot taller but the case closes without problems. I rather like this hack as the WiFi and Bluetooth are needed services and OS support will increase over all performance and confidence. 

 

IMG_0001.jpg

Edited by Donw35

Share this post


Link to post
Share on other sites

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Share this post


Link to post
Share on other sites

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

 

HP G2 800.zip

Edited by Donw35

Share this post


Link to post
Share on other sites

Donw35, thanks for your post.

 

I am interested in trying this on my G3, and my plan was to follow this guide:

https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.261719/

 

But as i understand correctly, I can just install it without doing all the tweaks and stuff, but just copy and paste your clover folder (because it contains the config and .kext's)?

Quote

 

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

 

Do you mean the clover folder with the EFI folder?

 

Share this post


Link to post
Share on other sites

Yes, install Mojave on a hard disk from a real Mac, then install clover, then use my EFI folders. done.

 

Note, without the proper wifi card you will not have have Wifi or bluetooth, Intel doesn't work

Share this post


Link to post
Share on other sites
On 9/28/2018 at 9:36 PM, Donw35 said:

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

HP_840_G3_Clover.zip

Donw35 this your DRIVER UEFI , they are too many, you put them ALL ...

the renames see in the pictures are correct for your HW

The kext are to be updated

Test this Clover and Post ioreg with these settings if it starts

 

Schermata 2018-11-11 alle 08.28.56.png

Schermata 2018-11-11 alle 08.32.51.png

Schermata 2018-11-11 alle 08.36.42.png

Clover.zip

Share this post


Link to post
Share on other sites

Correct, that is an old EFI folder, I am going to remove it and add the latest one when I get home. sorry for the confusion.

 

EDIT- I added the new clover folder

 

 

 

Edited by Donw35

Share this post


Link to post
Share on other sites
On 9/26/2018 at 2:32 AM, Donw35 said:

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Hey! Great build, but i have some remaining questions:

 

Where'd you find a working VGA driver? Can you give me  a link or the name of it?

 

What if i don't own a real mac, how can i upgrade then? I don't wanna lose my current files of my High Sierra build. (If there's no other choice than doing a clean install of  Mojave and backing up important stuff on another drive or so, that's ok.

 

Because i can't upgrade directly somehow.

Share this post


Link to post
Share on other sites

The video drivers are supported by OS X already nothing to do unless your system has desecrate graphics chip.

 

I haven't done a upgrade or an USB install but its well documented

Share this post


Link to post
Share on other sites

Hello @Donw35,

 

I am a complete noob and maybe I'm missing something, so I hope that you will have 5 minutes to spare to help me ^_^

 

I used the hackintosher.com EFI folder that i put on the EFI partition of my USB installer. I then replaced the content of the CLOVER folder with your files. However, when I try to boot from my USB drive, I am greeted with a black screen.

 

Do you have any idea?

 

Thanks in advance for your great help!

Share this post


Link to post
Share on other sites

Ok, I'm dumb as a rock. I simply proceeded with a vanilla install and then used your EFI files directly on the laptop's drive.

 

So here is my little contribution:

  • DisplayPort image works (tested with a HDMI <> DP cable)
  • No sound output (except via the 3,5mm jack), even after installing VoodooHDA
  • Battery percentage works
  • Both USB 3,1 ports work (tested with a keyboard and a mouse, as well as with a USB hub)

 

I wonder what keeps the sound from working.

 

Anyway: thank you so, so much for the files! You saved me 3-4 more hours days of searching.

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for this topic.

I have a similar laptop (820 g3) and i am attempting to install osx el capitan.

I believe your work would be of great help if i can get a functional clover for Sierra.

Would it be possible for you to re-upload you clover files please?

 

Thanks

 

Edited by Pikiman

Share this post


Link to post
Share on other sites
El 26/8/2018 a la 1:40, Donw35 dijo:

BCM943224PCIEBT2 Tarjeta a NGFF (M.2) Adaptador A / E de Amazon por $ 14

MacBook Air 13 A1369 11 A1370 WiFi Tarjeta de puerto Bluetooth Air de eBay $ 10

 

Hola ¿Tienes un enlace a este producto? gracias

Hello do you have a link to this products? thanx and sorry my english

Edited by linuxmac

Share this post


Link to post
Share on other sites

Hi everyone... will get a Samsung 970 EVO and split/ dual boot Mojave and W10.

 

BIG Question - since my 840 G3 is the touchscreen, any way of getting the touch to work in MacOS? :))

Share this post


Link to post
Share on other sites

I have a Elitebook 840 G2 with touch screen, works out of the box. the OS isn't well suited for touch but it does work. Keep in mind that the M.2 in your Laptop is an SSD not an NVME, make sure the Samsung 970 EVO is going to work, I don't think it will.

Share this post


Link to post
Share on other sites

first of All, thanks for sharing your own experience and Clover with us here ... it made it much easier to install, since i'm not a fan of DSDT patching stuff ! 

Nonetheless I have some issues would be glad if someone can help me with: 

1- I can't upgrade Clover every-time i do that the Laptop fails to boot ,it shows Apple Logo only and shut down no idea what the problem , so I keep on the latest version shared here 4920 . 

2- the Sound output doesn't change automatically when 3.5 mm plugged in , with googling I understood this has to do with AppleALC patching i'm not sure .

3- the laptop doesn't always sleep with closing Lid or it sleeps and wakes up immediately , I wonder if USB wifi is the reason ?

I did order BCM94360CS2 card and its adapter maybe this issue would be solved after replacement.

Away from that I guess the device is doing great on Mojave ! i'm glad that I could use it for everyday stuff and my studying 

anyone has faced those troubles or has suggestions - solutions ? would be thankful ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.7 WhateverGreen.kext 1.4.2 AppleALC.kext 1.5.2 IntelMausi.kext 1.0.3 (acidanthera version, not IntelMausiEthernet) NVMeFix.kext 1.0.3 EFIChecikDisabler.kext 0.5  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 1.2.zip
    • By mridhulofficial
      Hi team,
      Please advice me for the issue. Already gone through other posts.
      My spec Ryzen 9 3900x and Gigabyte B550 Aorus Pro AC motherboard.
      I installed Cataliana on my system .. everything looking perfect exept ethernet. Installed LucyRTL8125Ethernet.kext and ethernet is showing on network window but no internet connection. Adjusted hardware settings in network as Manually/100baseTX/full-duplex, flow-control but issue not fixed.
      Please help me.
       
      Thanks is advance.
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
×