Jump to content
About Just Joined group Read more... ×
Donw35

HP 840 G3 EliteBook ** WiFI and Bluetooth resolved** Big Sur / Catalina

116 posts in this topic

Recommended Posts

8 hours ago, cuti_it said:

 

I have HP 840 G2 too. But my trackpad can't work ? How fix, thank !

I don't know if my answer is relevant, but maybe it works for you on G2 , I had the same issue with G3 after I updated my PS2VOODOO kext to the latest version ..

maybe u need to update or downgrade Kext and it could work 

Share this post


Link to post
Share on other sites
Advertisement

Yes, I have experience the same issue, I will do some testing, it worked before

Share this post


Link to post
Share on other sites
On 3/12/2020 at 4:24 PM, Donw35 said:

Yes, I have experience the same issue, I will do some testing, it worked before

are you talking about my issue with Catalina or the other reply about trackpad ?

Share this post


Link to post
Share on other sites
On 8/22/2018 at 7:54 AM, Donw35 said:

Catalina update 10.15.4 without issues, make sure you update your kexts before hand and clover 5107

Catalina update 10.15.3 without issues, make sure you update your kexts before hand.

Catalina update 10.15.2 without issues, make sure you update your kexts before hand.

Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.

HP 840 G2/G3, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 

Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.

 

My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist

 

Not working

SD Card reader

Finger Print device

 

Working

Video - screen looks better in OS X then it does in Windows 10

Display port

VGA port

WiFi and BlueTooth working OOO using the below hack

Battery status with Rehabman's DSDT patch

Brightness controls

Sounds - using VoodooHDA

* Microphone - cannot turn it off or mute

Keyboard backlight - controlled though BIOS anyways

touchpad - using VoodooPS2Controller

USB3 - this laptop has two on board only and I haven't test them using the docking station

USB3.1 C

Ethernet - using IntelMausiEthernet

Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.

Web Cam, works but I covered it up.

 

 

IMG_2447.JPG

 

SSDT-ECUSBX.aml

CLOVER.zip

CLOVER_HP_840_G3_02032020.zip

 

Thank you very very much for your clover, I have a problem, dont understand.

 

Power on and initiate Catalina to your clover, error.

 

Graphic problem? My laptop is HP 840 G3 same.

 

Help please... Great great work :)

 

Thank you very very much!!!!

 

 

IMG_20200416_200703.jpg

Share this post


Link to post
Share on other sites

Try this clover EFI folder, I made some improvements and updates, still based on CLOVER version 5107. I don't update CLOVER unless is addresses issues.

 

 

EFI_5107_04162020.zip

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Donw35 said:

Try this clover EFI folder, I made some improvements and updates, still based on CLOVER version 5107. I don't update CLOVER unless is addresses issues. 

 

 

EFI_5107_04162020.zip

 

I am going to check it right now, thank you very much for your great work, I have been able to verify besides that error, is that my partition with High Sierra and EFI of Windows 10, has disappeared also in clover, it only shows cataline partition, preboot and recovery, how strange, it had never happened to me.

Thank you very much!

 

EDIT:

 

Now I can really get into the system and with absolutely everything working! Thank you very much.


Now the only thing missing, is that all the partitions can be seen again, High Sierra and EFI (Windows 10) so that everything is perfect :)

Edited by LuisImpreza

Share this post


Link to post
Share on other sites

Hi guys!. I have the EliteBook 820 G2 (the one with i5-5300u and hd550, 1366x768 + webcam screen variant) and it's all working good so far. The main problem it's the suspension, it doesn't want work. Anyone that has it working? I tried to put "darkwake=no" in boot arguments and adjust settings in power management but nothing changed...

Share this post


Link to post
Share on other sites

Thanks Donw35

 

I'm still learning OC 0.5.7 to first boot and install on this Laptop HP EliteBook 840G2 (i5, 5500) 

With your help, I now successfully can see the applefs partition from the USB key. The hint is to set UEFI/UnblockFsConnect to yes !!! (that's for HP laptop !). I spend more than 1 month for this parameter !

 

Now I encounter another issue.

135:825 01:053 Prelinked status - Success
136:018 00:193 AAPL: [EB|`LD:LKFS] } Ok(0)
137:057 01:038 AAPL: [EB|`LD:LKC] } Ok(0)
137:236 00:179 AAPL: [EB|#FWFM] 0xFF9FFF3F
137:497 00:261 AAPL: [EB|#FWFT] 0xFD8FF53E
137:674 00:176 AAPL: [EB|#CSR:OUT] 0x00000067
137:856 00:181 AAPL: [EB|`BST:FBS] {
138:034 00:178 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
138:211 00:176 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
138:353 00:141 OCSMC: SmcReadValue Key 4D535463 Size 1
138:494 00:141 OCSMC: SmcReadValue Key 4D534163 Size 2
138:671 00:177 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB 71B4903C-14EC-42C4-BDC6-CE1449930E49
139:711 01:039 AAPL: [EB|#LOG:DT] 2020-04-20T01:43:23
139:887 00:176 AAPL: [EB|#LOG:EXITBS:START] 2020-04-20T01:43:24

 

and the laptop reboot.

Here is my config.plist: https://opencore.slowgeek.com/?file=broadwelle057Gh7JAg&rs=broadwelle057

 

Share this post


Link to post
Share on other sites

I have had zero luck getting OC to work on my laptop, I think its the BIOS, Clover works fine. stops at the same place as yours, something to do with the drivers.

Share this post


Link to post
Share on other sites

So today, I backup my "not working OC" project, and unzip your EFI_5107_04162020.zip

on my HP EliteBook 840G2 (i5-5300U CPU @ 2.30GHz, Intel HD Graphics 5500 (rev 09)

 

1. unzip your Clover5107 on my USB

2. modify Serial, Board Serial, SmUUID, UUID

3. try to boot, the system restart after screen 2

4. copy my DSDT.AML (extracted previously by liveLinuxUSB)

 

I attach the pic1 and pic2

 

What is the next step ?

- is my applefs not installed correctly ? I use gibMacOS-master

- my bios has a prob ? I put the latest version on (HP Notebook System BIOS, 01.30 Rev.A    15.1 MB    Nov 8, 2019)

- i misconfigured my BIOS (I followed all the indication), or may be I should copy all the option down.

- what is 71B4903C-14EC-42C4-BDC6-CE1449930E49 ? 

 

The last line in my error is in Clover5107 as well as in OC0.5.7 (71B4903C-14EC-42C4-BDC6-CE1449930E49)

Thanks for pointing me out. Linux Ubuntu 20.04 is runing perfectly well on this PC.

 

Thanks in advance,

Pic1.jpg

Pic2.jpg

Share this post


Link to post
Share on other sites

Make sure you hit F11 at the clover boot loader to clear NVRAM, always need to do that when moving between OC and CLOVER

Share this post


Link to post
Share on other sites

I was wondering if anyone has the LTE Modem in HP 840 G3 and managed to let it work on Mac 

Mac sees the modem as HP lt4120 Snapdragon X5 LTE, t I couldn't manage to connect with it.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi:

 

New in this forum. First of all, thanks to all contributors, is a great job.

 

I have a 840 G2, ATI graphics. I disabled the ATI on BIOS. I've done the wireless and bluetooth hack showed on the frst post and I have my wifi and bluetooth perfectly working, after replace my CLOVER EFI with the clover attached at the first post. Everything that can work is working correctly, but:

 

My WiFi - Bluetooth button is always orange, And I don't know why. Anyone can give me an idea to check what is wrong in my configuration?

 

Hibernation doesn't work very well. Sometimes works but after the first Hibernation cycle, the second fails, but no kernel panic at the moment.

 

Working on battery with Youtube videos running, I can work for 3 hours. Can I expect a much loger battery time?

 

Again, thanks a lot.

Edited by JFNAV1
Add ATI info

Share this post


Link to post
Share on other sites
On 4/27/2020 at 6:00 AM, JFNAV1 said:

Hi @JFNAV1

I have the same hardware HP Elitebook840G2.

I am really unable to boot opencore or Clover.

Desperately need your help.

the system keep rebooting, without getting into installation.

 

 

Share this post


Link to post
Share on other sites

Hi all,

I have a HP 840 G3 i7, it was working fine with your EFI & Catalina 10.15.1.

I did a fresh install with Catalina 10.15.4, something goes wrong with the BIOS setting. Now I am unable to boot from SSD. I tried with 10.15.1 with several EFI with no luck. :-( 
Installation works fine, I am able to boot from USB and select SSD, but I couldn't get BIOS detects SSD as a Boot drive.

As a test I installed Win10, it worked fine. Also have replace SSD.

 

Do you have any guideline or advice about how to configure BIOS? (I used  versions N75 1.20 & N75 1.45)

Thank you.

 

Share this post


Link to post
Share on other sites
On 5/2/2020 at 4:23 AM, LucAndersen said:

 

 

Hi:

 

I don´t know if you have installed Catalina succesfully and your problem is at the first boot or if your problem is that you have not a success installing. Anyway, I send you my CLOVER EFI folder, may be the config.plist can help you. I had a problem on first install due to the ATI Graphics. Try to disable the Dual graphics on BIOS. The laptop will be use only the Intel Graphics.

EFI .zip

On 5/2/2020 at 4:23 AM, LucAndersen said:

 

 

Hi:

 

I don´t know if you have installed Catalina succesfully and your problem is at the first boot or if your problem is that you have not a success installing. Anyway, I send you my CLOVER EFI folder, may be the config.plist can help you. I had a problem on first install due to the ATI Graphics. Try to disable the Dual graphics on BIOS. The laptop will be use only the Intel Graphics.

Share this post


Link to post
Share on other sites
On 5/3/2020 at 3:07 PM, PeterBoy71 said:

Hi all,

I have a HP 840 G3 i7, it was working fine with your EFI & Catalina 10.15.1.

I did a fresh install with Catalina 10.15.4, something goes wrong with the BIOS setting. Now I am unable to boot from SSD. I tried with 10.15.1 with several EFI with no luck. :-( 
Installation works fine, I am able to boot from USB and select SSD, but I couldn't get BIOS detects SSD as a Boot drive.

As a test I installed Win10, it worked fine. Also have replace SSD.

 

Do you have any guideline or advice about how to configure BIOS? (I used  versions N75 1.20 & N75 1.45)

Thank you.

 

 

this is a known issue with 10.15.4, there is a thread about it and some things you can try...

 

https://www.insanelymac.com/forum/topic/343112-release-macos-10154-is-out/

Share this post


Link to post
Share on other sites

Hi, can any one help me get the display port working? I have full graphics acceleration but unable to get display port working. 

My laptop specs are;

 

HP Elitebook 840 G3 i7 2.6GHz and intel HD 520 graphics.

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/21/2018 at 10:54 PM, Donw35 said:

 

i have hp elitebook 840 g2. and itis stuck on installation. any one can upload EFI for catalina?

Edited by nipun3898

Share this post


Link to post
Share on other sites
On 3/12/2020 at 4:08 PM, Isaac24 said:

I don't know if my answer is relevant, but maybe it works for you on G2 , I had the same issue with G3 after I updated my PS2VOODOO kext to the latest version ..

maybe u need to update or downgrade Kext and it could work 

 

same here , 1.9.2 is working fine

newer version does not work properly.

 

is there a chance to get sleep working with a 1600x900 display ( 840G2 )

EFI_840g2.zip

Share this post


Link to post
Share on other sites
On 5/24/2020 at 8:31 PM, lanpilot said:

 

same here , 1.9.2 is working fine

newer version does not work properly.

 

is there a chance to get sleep working with a 1600x900 display ( 840G2 )

EFI_840g2.zip

On my 840g2, I have change the video memory size to 64 in the bios and now sleep works well.

Share this post


Link to post
Share on other sites

Hello . i have a 840 g3, calatina last version and a problem....button of touchpad not work and two finger scroll too.. anyone can help me ?  thanks

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the USBPorts.kext in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.8 WhateverGreen.kext 1.4.3 AppleALC.kext 1.5.3 IntelMausi.kext 1.0.4 (acidanthera version) NVMeFix.kext 1.0.4 EFIChecikDisabler.kext 0.5  
      Credits To be provided
       
      ScreenShots
       
       
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk 800 G4 Mini - Rev 1.3.zip
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11L, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT (connected to the monitor via the DisplayPort)
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO Plus 1TB NVMe SSD macOS Catalina 
      • Samsung 970 EVO 1TB NVMe SSD Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11L or Higher to use any of these EFI's, The DSDT is not designed for any other Bios revision
      Z390AORUSMASTER.F11l.zip  - Aorus Z390 Master Bios Firmware F11L 
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 05/10/2020
       
       
      Clover EFI Update v5120 - 04/08/2020 - Use with Bios revision F11L or Higher Only or Replace with the older F11c/F10 DSDT if you don't want to update the bios
       
      EFI Clover VEGA Navi 030820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT SMBios 19,1 EFI
      EFI Clover Polaris NVIDIA 030820.zip - RX500 Polaris Series (RX590, 580, 570 etc) SMBios 19,1 EFI
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
       
      OpenCore EFI Update v0.6.2 - 05/10/2020 (Big Sur Ready)
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 062 Z390 Master 19,1 051020.zip - OpenCore v0.6.2, SMBios iMac19,1
      OpenCore 062 Z390 Master 1,1 051020.zip - OpenCore v0.6.2, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0 so please use the new Config.plist instead.
       
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11L Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      CFG Unlock (MSR) F11L BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU

       
      Test EFI
      OpenCore 0.6.3 with onboard Bluetooth and WIFI Enabled and Working 21/10/2020.
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Z390AORUSMASTER.F11l.zip - Aorus Z390 Master Bios Firmware F11L 
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11L)
       
      • Enter BIOS -> Press Delete -> Enter Setup
      • Save & Exit -> Load Optimized Defaults
      • Boot -> CFG Lock -> Disabled
      • Boot -> Windows 8/10 Features -> Win 8/10 WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> Super IO Configuration -> Serial Port -> Disabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
       
       
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.7
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 05/10/2020
       
       
      Clover EFI Update - 04/08/2020 - Use with Bios revision F12K (F12J Pro Wifi) Only or Replace with the older F11 DSDT if you don't want to update the bios
       
      Clover Z390 Pro Navi Vega EFI 040820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 040820.zip - RX500 Polaris Series (RX590, 580, 570 etc) DSDT EFI
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      OpenCore EFI Update - 05/10/2020 (Big Sur Ready)
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
       
      OpenCore 062 Z390 Pro 19,1 051020.zip  - OpenCore v0.6.2, SMBios iMac19,1
      OpenCore 062 Z390 Pro 1,1 051020.zip - OpenCore v0.6.2, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0. Use the new Config.plist instead.
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      For OpenCore Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12K (F12J Pro Wifi) to use my current Clover EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO/Pro Wifi BIOS Firmwares
       
      mb_bios_z390-aorus-pro_f12k.zip - Aorus Z390 Pro Bios Firmware F112K
      mb_bios_z390-aorus-pro-wifi_f12j.zip - Aorus Z390 Pro Wifi Bios Firmware F112J
       
       
      CFG Unlock (MSR) F12K (F12J Pro WIFI) BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's FOR CLOVER ONLY (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
       
      BIOS SETTINGS (Bios Revision F12k & F12j Pro Wifi)
       
      • Enter BIOS -> Press Delete -> Enter Setup
      • Save & Exit -> Load Optimized Defaults
      • Boot -> CFG Lock -> Disabled
      • Boot -> Windows 8/10 Features -> Win 8/10 WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled (Z390 Pro Wifi Only)
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       

       

       

×