Jump to content
Donw35

HP 840 G2 G3 EliteBook ** WiFI and Bluetooth resolved** (Catalina working)

73 posts in this topic

Recommended Posts

Catalina update 10.15.4 without issues, make sure you update your kexts before hand and clover 5107

Catalina update 10.15.3 without issues, make sure you update your kexts before hand.

Catalina update 10.15.2 without issues, make sure you update your kexts before hand.

Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.

HP 840 G2/G3, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 

Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.

 

My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist

 

Not working

SD Card reader

Finger Print device

 

Working

Video - screen looks better in OS X then it does in Windows 10

Display port

VGA port

WiFi and BlueTooth working OOO using the below hack

Battery status with Rehabman's DSDT patch

Brightness controls

Sounds - using VoodooHDA

* Microphone - cannot turn it off or mute

Keyboard backlight - controlled though BIOS anyways

touchpad - using VoodooPS2Controller

USB3 - this laptop has two on board only and I haven't test them using the docking station

USB3.1 C

Ethernet - using IntelMausiEthernet

Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.

Web Cam, works but I covered it up.

 

 

IMG_2447.JPG

 

SSDT-ECUSBX.aml

CLOVER.zip

CLOVER_HP_840_G3_02032020.zip

Edited by Donw35
updated

Share this post


Link to post
Share on other sites
Advertisement

I resolved the WiFi and Bluetooth issues by using a supported module

 

NOTE I have found that the NCM94322 doesn't work well in Catalina, it does kind of work but other problems like iMessage and FaceTime are problematic. I recommend using the BCM94360, its supported and all works. 

 

BCM943224PCIEBT2 Card To NGFF(M.2) Key A/E Adapter from Amazon for $14

MacBook Air 13 A1369 11 A1370 WiFi Bluetooth Air Port Card from eBay $10

 

 I had to do some cutting on the A/E adapter but was able to get it to fit, its a lot taller but the case closes without problems. I rather like this hack as the WiFi and Bluetooth are needed services and OS support will increase over all performance and confidence. 

 

IMG_0001.jpg

Edited by Donw35

Share this post


Link to post
Share on other sites

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Share this post


Link to post
Share on other sites

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

 

HP G2 800.zip

Edited by Donw35

Share this post


Link to post
Share on other sites

Donw35, thanks for your post.

 

I am interested in trying this on my G3, and my plan was to follow this guide:

https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.261719/

 

But as i understand correctly, I can just install it without doing all the tweaks and stuff, but just copy and paste your clover folder (because it contains the config and .kext's)?

Quote

 

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

 

Do you mean the clover folder with the EFI folder?

 

Share this post


Link to post
Share on other sites

Yes, install Mojave on a hard disk from a real Mac, then install clover, then use my EFI folders. done.

 

Note, without the proper wifi card you will not have have Wifi or bluetooth, Intel doesn't work

Share this post


Link to post
Share on other sites
On 9/28/2018 at 9:36 PM, Donw35 said:

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

HP_840_G3_Clover.zip

Donw35 this your DRIVER UEFI , they are too many, you put them ALL ...

the renames see in the pictures are correct for your HW

The kext are to be updated

Test this Clover and Post ioreg with these settings if it starts

 

Schermata 2018-11-11 alle 08.28.56.png

Schermata 2018-11-11 alle 08.32.51.png

Schermata 2018-11-11 alle 08.36.42.png

Clover.zip

Share this post


Link to post
Share on other sites

Correct, that is an old EFI folder, I am going to remove it and add the latest one when I get home. sorry for the confusion.

 

EDIT- I added the new clover folder

 

 

 

Edited by Donw35

Share this post


Link to post
Share on other sites
On 9/26/2018 at 2:32 AM, Donw35 said:

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Hey! Great build, but i have some remaining questions:

 

Where'd you find a working VGA driver? Can you give me  a link or the name of it?

 

What if i don't own a real mac, how can i upgrade then? I don't wanna lose my current files of my High Sierra build. (If there's no other choice than doing a clean install of  Mojave and backing up important stuff on another drive or so, that's ok.

 

Because i can't upgrade directly somehow.

Share this post


Link to post
Share on other sites

The video drivers are supported by OS X already nothing to do unless your system has desecrate graphics chip.

 

I haven't done a upgrade or an USB install but its well documented

Share this post


Link to post
Share on other sites

Hello @Donw35,

 

I am a complete noob and maybe I'm missing something, so I hope that you will have 5 minutes to spare to help me ^_^

 

I used the hackintosher.com EFI folder that i put on the EFI partition of my USB installer. I then replaced the content of the CLOVER folder with your files. However, when I try to boot from my USB drive, I am greeted with a black screen.

 

Do you have any idea?

 

Thanks in advance for your great help!

Share this post


Link to post
Share on other sites

Ok, I'm dumb as a rock. I simply proceeded with a vanilla install and then used your EFI files directly on the laptop's drive.

 

So here is my little contribution:

  • DisplayPort image works (tested with a HDMI <> DP cable)
  • No sound output (except via the 3,5mm jack), even after installing VoodooHDA
  • Battery percentage works
  • Both USB 3,1 ports work (tested with a keyboard and a mouse, as well as with a USB hub)

 

I wonder what keeps the sound from working.

 

Anyway: thank you so, so much for the files! You saved me 3-4 more hours days of searching.

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for this topic.

I have a similar laptop (820 g3) and i am attempting to install osx el capitan.

I believe your work would be of great help if i can get a functional clover for Sierra.

Would it be possible for you to re-upload you clover files please?

 

Thanks

 

Edited by Pikiman

Share this post


Link to post
Share on other sites
El 26/8/2018 a la 1:40, Donw35 dijo:

BCM943224PCIEBT2 Tarjeta a NGFF (M.2) Adaptador A / E de Amazon por $ 14

MacBook Air 13 A1369 11 A1370 WiFi Tarjeta de puerto Bluetooth Air de eBay $ 10

 

Hola ¿Tienes un enlace a este producto? gracias

Hello do you have a link to this products? thanx and sorry my english

Edited by linuxmac

Share this post


Link to post
Share on other sites

Hi everyone... will get a Samsung 970 EVO and split/ dual boot Mojave and W10.

 

BIG Question - since my 840 G3 is the touchscreen, any way of getting the touch to work in MacOS? :))

Share this post


Link to post
Share on other sites

I have a Elitebook 840 G2 with touch screen, works out of the box. the OS isn't well suited for touch but it does work. Keep in mind that the M.2 in your Laptop is an SSD not an NVME, make sure the Samsung 970 EVO is going to work, I don't think it will.

Share this post


Link to post
Share on other sites

first of All, thanks for sharing your own experience and Clover with us here ... it made it much easier to install, since i'm not a fan of DSDT patching stuff ! 

Nonetheless I have some issues would be glad if someone can help me with: 

1- I can't upgrade Clover every-time i do that the Laptop fails to boot ,it shows Apple Logo only and shut down no idea what the problem , so I keep on the latest version shared here 4920 . 

2- the Sound output doesn't change automatically when 3.5 mm plugged in , with googling I understood this has to do with AppleALC patching i'm not sure .

3- the laptop doesn't always sleep with closing Lid or it sleeps and wakes up immediately , I wonder if USB wifi is the reason ?

I did order BCM94360CS2 card and its adapter maybe this issue would be solved after replacement.

Away from that I guess the device is doing great on Mojave ! i'm glad that I could use it for everyday stuff and my studying 

anyone has faced those troubles or has suggestions - solutions ? would be thankful ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks (Laptop: Thinkpad T61 / Nvidia NVS 140m, Laptop: Dell Latitude E6410 / Nvidia G3100m, Desktop: Gigabyte G31 / GeForce 9600, Desktop: Biostar TH55HD / Sapphire Pulse RX580) are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (Watching this - not sure it's a problem) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (No solution yet - work-around is to use Firefox) Safari has problems loading insanelymac web pages after sleep / wake.  Work-around: use Firefox or reboot.  I have seen reports in forums where Safari issues are experienced after sleep / wake on a real Mac.  Not sure if the problems are related.  I suspect that it might be related to streaming video on InsanelyMac pages (since I haven't observed the issue on "static" pages).
      Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable  (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A  
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausiEthernet 2.5.0  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.5.zip

    • By josebv98
      So, ive trying to install various versions of macOSs to an old hp laptop.
      Specs: intel i7 3610qm, 8gb ram, nvidia 650m, intel HD4000
      model: hp dv6
       
      3 ago i did managed to install Niresh yosemite, even bought the right wifi adapter so i could use it on campus, but even then, i had to set cpus=1
       
      Now, ive tried several guides, tried internet vanilla install guide (which ive done successfully in 2 devices), opencore guide, opencore laptop guide
       
      Im currently having some financial problems, so i want sell my macbook to pay student loans, i really want to daily drive this laptop in mac os, but i cant get to boot the installer.
       
      Anyone here have a similiar laptop? so i could borrow the efi folder, just to get it to install, then ill change stuff
       
    • By e285ne
      Hello,
       
      could you help me with Intel UHD 620 HDMI port?
       
      HP ProBook G6 440
      Intel Core i5-8265u
      Catalina 10.15.4

      I've installed Catalina 10.15.4
      But I can't get HDMI working
      When I connect HDMI cable I got freezes and errors as in file freezes.png (attached)

      [IGFB][INFO ] Setting DP power failed (0xe00002bc), ignoring empty dongle handling (likely HDMI/TMDS case)

      I also looked into IOregistryExplorer and see that the connect type is 00400000 there for FB@1
      I tried to patch it via setup.plist but it seems that there is no change in IOregistryExplorer.
      Though the Hackintool sees the change (image attached)
      e285ne.zip
    • By Fantome1S
      Finaly Success to boot on Sierra 10.12.6 (16G29) with Touchscreen working theres still things to fix but everything is almost working. During the Corvid StayAtHome Period I was able and have time to make this laptop boot on MacOS after a lot of attemps before going back to job. It was the hardest laptop hackintosh install attemp i've done so far and Sierra OS is the only that works. I tried El Capitan and Mojave and its never boot so I not even tested Catalina. I searched on the web and theres no install guide for this specific laptop or no Success install post on this laptop its look like a not very well supported laptop by hackintosh. Maybe some of you can help me correct the things that still not work. Audio work but with voodo (low sound and low quality) I want to make it work with AppleALC to get better quality sound. Thanks in advance
       
      Things that work:
       
      -Touchscreen
      -Trackpad (not the gesture for now) - Backlight Keyboard
      -EthernetPort and Wireless (with a wifi dongle. I will change to a broadcom wifi mini-pci chip)
      -Brightness Controls with FN key
      -Sleep (half working) _ usb ports not work after wake from sleep.
       
      Things that not work or need to be fixed:
       
      -Weird double long booting screen-first loading bar on the right. after real loading bar is visible ?
      -Audio (Voodoo) work but with low volume sound- still not success to make work AppleALC.kext method
      -SENSORS -CPU-HDD Temperatures, BATTERY LEVEL, ETC…
      -USB ports not works after wake from sleep
      -Trackpad Gestures
       
      Hardware:
       
      CPU: Intel Core i7-3687U, 2100 MHz
      GPU: Intel HD Graphics 4000
      RAM: 12 GB (4GB soldered + 8 GB Samsung DDR3 1600)
      Motherboard/Laptop model: Intel Panther Point QM77, Intel Ivy Bridge - (HP Revolve 810 G1)
      Audio Codec: IDT 92HD91BXX @ Intel Panther Point PCH - High Definition Audio Controller
      Ethernet Card: Intel(R) 82579LM Gigabit Network Connection
      Wifi/BT Card: Intel(R) Centrino(R) Advanced-N 6235
      HP hs2350 HSPA+ MobileBroadband Network Adapter
    • By End3rPower50
      Hi, i want install MacOS catalina in my laptop.
      i created a USB bootable with Catalina and Clover but it crashed at startup.
      Thanks in advance. 
       
      P.S I upload my EFI’s folder and crash screenshot
       
      Sorry for my bad english.
       
      This is my laptop: 
      CPU: intel i7 6500U 
      Graphics: Intel HD Graphics 520
      Ethernet: Realtek FE Family 
      Wireless: Dell 1820A (BCM94350ZAE)
      USB 3.0
       

      EFI.zip
×