Jump to content
cmyk

Devices on USB 3.1 Gen2/C ejected on wakeup

4 posts in this topic

Recommended Posts

Hi All,

 

my Hackintosh is working well.

I have just one minor glitch, I would like to fix:

 

Devices connected to the USB 3.1 Gen2 and USB C Port on the back plate of the ASUS Prime Z370-A are improperly ejected on wake from sleep.

I get the notification: "Disk Not Ejected Properly".

 

On all other USB 3.0 Gen 1 and USB 2.0 port this does not happen.

I attached my config.plist.

 

Any ideas?

 

Cheers

cmyk

 

config.plist

Edited by cmyk

Share this post


Link to post
Share on other sites
Advertisement

It'll be related to ports being powered off during sleep so the OS believes they've been like pulled out without being properly ejected via the expected menu option.

Eject.png.6073da359b0eaabc207405f3a1238eea.png

 

See if you have an option in BIOS to retain power during sleep (like USB power share or other). Then connected devices won't be "ejected".

Edited by Hervé

Share this post


Link to post
Share on other sites

Thanks @Hervé. I figured that much. Curiously, it's only on the 3.1 Gen2 USB hubs. I only found something in the AMP Configuration of the Bios (v1002). But ErP is disabled.

 

Share this post


Link to post
Share on other sites

There is a BIOS entry for 3.1 Gen2: Asmedia USB 3.1 and it's on.

There's no other place to set anything regarding Power on USB ports.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×