Jump to content
FeelingX

Slow performance after wake from sleep

11 posts in this topic

Recommended Posts

Hello,
This is my 2nd hackintosh and I think everything works but sleep/wake function.

Everytime I try to put my hack to sleep, it instantly wakes and everything starts to lag real bad. Intel Power Gadget shows “NaN” results from sensors after sleep.

Mobo: ASROCK H110M-HG4
CPU: i5-7400
GPU: Gigabyte GT 640


BIOS:

  • XHCI hand-off: enabled
  • Suspend to RAM: auto          Deactivating Suspend to RAM makes the sleep/wake function into a false state of sleep (screen off but FANs running and LED on)
  • ACPI HPET Table: enabled


USB peripherals:

  • Logitech Headset H390 (compatible)
  • Logitech Keyboard K230 (compatible)
  • Razer Deathadder 2013 (the villain who is causing instant wake?)

 

2018-08-02 15:08:09.615736-0300  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GIGE XDCI


Some details from my config.plist:

  • Boot args: darkwake=8
  • XMPDetection=Yes / PluginType=Yes
  • USB: Inject / Add ClockID / FixOwnership
  • Audio: Inject 3
  • Inject Intel (ig-platform-id: 0x59120003)
  • USB 10.13.6 patch by PMHeart
  • SMBIOS: iMac18,2


Kexts:

  • FakeSMC + sensors
  • WhateverGreen
  • Lilu
  • AppleALC
  • RealtekRTL8111
  • USBInjectAll


I’m using the USB SSDT from this post https://www.insanelymac.com/forum/topic/328831-success-asrock-h110m-gm2-with-macos-high-sierra/ and it seems to work fine (both MOBOs have the same USB map).

I appreciate any help.

 

nan.png

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, Allan said:

Disable the Hibernation file: 

 

And FYI, the ASRock mobos have a much issues with sleep/wake.

Hey Allan, thanks for giving me a bit of your time.
I did run your script to disable hibernatemode, autopoweroff and standby. However, the problem persists.

Unfortunately, I didn't think about hackintosh when I built this PC one month ago. I really want to try more before I give up, 'cause a new MOBO vai doer no bolso. :lol::cry:

Share this post


Link to post
Share on other sites
11 minutes ago, FeelingX said:

Unfortunately, I didn't think about hackintosh when I built this PC one month ago.

Sorry buddy. But yeah, I had feel the same when I saw some friends with this mobo and they discovered in the hardest way about this...

 

13 minutes ago, FeelingX said:

I really want to try more before I give up, 'cause a new MOBO vai doer no bolso.

Sure! ;)

And another note: USB dongles may can be cause of the sleep/wake issues. 

Share this post


Link to post
Share on other sites
18 minutes ago, Allan said:

Sorry buddy. But yeah, I had feel the same when I saw some friends with this mobo and they discovered in the hardest way about this...

 

Sure! ;)

And another note: USB dongles may can be cause of the sleep/wake issues. 

So, I just discovered that Logitech Keyboard's dongle was the one causing instant wake. :unsure:
And lag after wake persists... :cry:

Share this post


Link to post
Share on other sites

Check your BIOS settings; disable any "Wake on USB/USB wake" option if available.

 

Post a zipped copy of your Clover folder (without Themes subfolder).

Edited by Hervé

Share this post


Link to post
Share on other sites
2 hours ago, Hervé said:

Check your BIOS settings; disable any "Wake on USB/USB wake" option if available.

 

Post a zipped copy of your Clover folder (without Themes subfolder).

G'mornin Hervé,
I've already disabled all "Wake" BIOS options.

Here we go:

CLOVER.zip

Share this post


Link to post
Share on other sites
1 hour ago, Allan said:

Try it: CLOVER.zip

G'nite, Allan
Just replaced my CLOVER folder with yours and the issue is still here. :unsure:

Share this post


Link to post
Share on other sites

Put to sleep, wait 5min, and return to the Desktop.

 

Run this command at the Terminal:

log show --style syslog | fgrep "Wake reason"

 

Share this post


Link to post
Share on other sites
15 hours ago, Allan said:

Put to sleep, wait 5min, and return to the Desktop.

 

Run this command at the Terminal:


log show --style syslog | fgrep "Wake reason"

 

G'morning, Allan. I didn't had time to venture into my hack yesterday, so I couldn't answer you on the same day.
This is the wake reason after 5 mins:

2018-08-04 11:31:33.067843-0300  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GIGE XDCI

It doesn't wake instantly anymore after I pulled out keyboard's dongle - I'll learn to _PRW patch so I won't have to remove the USB every time I wake from sleep. Lag after wake still persists badly.

I'm starting to think myself this might be related to native power management not working 100% for me. Gonna try different SMBIOS + ssdtPRgen and see how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×