Jump to content
headkaze

Hackintool v2.8.6

735 posts in this topic

Recommended Posts

Advertisement

The "installed" window is not picking up your update to the BrcmFirmwareStore kexts.

Hackintool.thumb.png.620145b576b8aa55c176d436a13c0dee.png

Share this post


Link to post
Share on other sites
1 hour ago, mnfesq said:

The "installed" window is not picking up your update to the BrcmFirmwareStore kexts.

I haven't changed the url to my fork yet as I wasn't sure if the Catalina changes would be necessary when it comes out of beta. So let's wait for the full release first. I may also move it to the acidanthera Github account by then.

Share this post


Link to post
Share on other sites

Thanks @headkaze  We appreciate your hard work.

2032156598_ScreenShot2019-09-06at8_43_24AM.thumb.png.f3b6fdde6daab36b39639ef73b161f11.png2032156598_ScreenShot2019-09-06at8_43_24AM.thumb.png.f3b6fdde6daab36b39639ef73b161f11.png

 

How to fix blue line(Driver Installed-No)?

 

Share this post


Link to post
Share on other sites
1 hour ago, nmano said:

How to fix blue line(Driver Installed-No)?

From my understanding it's normal for there to be PCI devices without drivers installed on a Hackintosh. Can anyone confirm this?

Edited by headkaze

Share this post


Link to post
Share on other sites
2 hours ago, nmano said:

Thanks @headkaze  We appreciate your hard work.

2032156598_ScreenShot2019-09-06at8_43_24AM.thumb.png.f3b6fdde6daab36b39639ef73b161f11.png2032156598_ScreenShot2019-09-06at8_43_24AM.thumb.png.f3b6fdde6daab36b39639ef73b161f11.png

 

How to fix blue line(Driver Installed-No)?

 

 

Blue Lines seems not native or incompatible with macOS. Just my opinion.

 

Do you have this issue in February:

 

 

Share this post


Link to post
Share on other sites

Good evening @headkaze many thanks for the 2.8.0 release!

I'd like to update you on a couple of points, a major and a few minor (text fixes).

 

1. Please update the list of kexts with the new Intel Mausi kext for LAN by acidanthera:

https://github.com/acidanthera/IntelMausi

Already at v1.0.2 I am using it on my two Intel NUCs and they seem to perform very well.

 

2. In the list of "Model" data in INFO tab, please do expand the English for these (if you agree):

 

"2nd Disp Support" to "2nd Display Support"

"2nd Max Res" to "2nd Max. Resolution"

"Avg Weight" to "Average Weight"

"Int HD Interface" to "Internal HDD Interface" or "Int. HDD Interface"

"Introduction Date" to "Date Introduced"

"Url" to "URL"

 

3. In the PCI tab, when updating PCI IDs, is there a need for the "Cancel" button in the confirmation dialog that pops up?

 

4. In the POWER tab, would it be interesting to have a round-arrow-icon to be able to refresh the status? For example, I changed my hibernatemode to 0 in Terminal, and could not "refresh" it in Hackintool.

 

Thanks for listening!

Share this post


Link to post
Share on other sites

Hi @headkaze and everyone here, there's something that may have changed and that I missed.

Your Hackintool reports latest Clover as being 5071, most likely using https://sourceforge.net/projects/cloverefiboot/files/Installer/

I've been using Sourceforge's URLs all this time too.

 

However, the Clover_v2.5k_r5071.zip package there only extracts a text file saying:

Quote

 

Is this the end of Sourceforge, does anyone know?

Is the CloverHackyColor version/repo now the only official place to look?


Thanks again for your feedback and if this is a change, perhaps consider updating Hackintool, when you can.
Cheers

Share this post


Link to post
Share on other sites
20 minutes ago, MacKonsti said:

Hi @headkaze and everyone here, there's something that may have changed and that I missed.

Your Hackintool reports latest Clover as being 5071, most likely using https://sourceforge.net/projects/cloverefiboot/files/Installer/

I've been using Sourceforge's URLs all this time too.

 

However, the Clover_v2.5k_r5071.zip package there only extracts a text file saying:

 

Is this the end of Sourceforge, does anyone know?

Is the CloverHackyColor version/repo now the only official place to look?


Thanks again for your feedback and if this is a change, perhaps consider updating Hackintool, when you can.
Cheers

 

Right. CloverHackyColor version/repo is now the only official place

Share this post


Link to post
Share on other sites

could you confirm that hackintool is doing this ?

 

 

prelinkedkernel into prelinkedkernelbackup
immutablekernel
 into immutablekernelbackup
PlatformSupport.plist
 into PlatformSupportbackup

 

 

thanks a lot

Share this post


Link to post
Share on other sites
2 hours ago, maclinuxG4 said:

could you confirm that hackintool is doing this ?

 

prelinkedkernel into prelinkedkernelbackup
immutablekernel
 into immutablekernelbackup
PlatformSupport.plist
 into PlatformSupportbackup

 

thanks a lot

Sorry, no idea what you're talking about.

2 hours ago, Shaneee said:

Not really a bug I suppose but because I built OC from source (0.5.2) it's showing an older version as an update.

Okay I admit I was being lazy and doing a simple string compare for the version! Please check out Hackintool v2.8.3!

1 hour ago, SavageAUS said:

Is the AzulPatcher broken?

When you generate the patch you still have to export it to your config.plist. Did you try that?

Edited by headkaze

Share this post


Link to post
Share on other sites

what's new in Version 2.8.3 ? 

 

Missing your release notes ;) @headkaze

Edited by DSM2

Share this post


Link to post
Share on other sites

Hi @headkaze,

 

At first thanks for your nice tools. I have a feature suggestion.

Could you please add a CPU tab where CPUFriend related SSDT or CPUFriendDataProvider.kext can be generated.

Alternatively who doesn't prefer CPUFriend can generate x86platformplugininject.kext with piker's freqVectorEdit.sh for cpu power management.

I think this would help so much people with power management issue.

 

Regards,

Junaed

Share this post


Link to post
Share on other sites

A few findings on v2.8.3:

No Graphic Devices listed for RX 5700 card (1002:731f);

Original Apple BRCM wireless/BT card (05ac:8294) doesn't report FW Loaded;

No Displays listed for those connected to a RX 5700 card (DP and/or HDMI);

 

Possibly unrelated to the tool:

Two unknown PCI devices off RX 5700 card (super small screen capture down the bottom);

 

Wish list from the tool:

Allow column resizing of the IOReg Name column on PCI Devices tab;

Screen Shot 2019-10-29 at 6.28.00 PM.png

Screen Shot 2019-10-29 at 6.28.41 PM.png

 

Screen Shot 2019-10-29 at 6.30.43 PM.png

Edited by Alex HQuest

Share this post


Link to post
Share on other sites
17 hours ago, Alex HQuest said:

A few findings on v2.8.3:

No Graphic Devices listed for RX 5700 card (1002:731f);

Original Apple BRCM wireless/BT card (05ac:8294) doesn't report FW Loaded;

No Displays listed for those connected to a RX 5700 card (DP and/or HDMI);

 

Possibly unrelated to the tool:

Two unknown PCI devices off RX 5700 card (super small screen capture down the bottom);

 

Wish list from the tool:

Allow column resizing of the IOReg Name column on PCI Devices tab;

Can you please run "ioreg -l >~/ioreg.txt" and attach the file here. Once I figure out what the entry for your video card is it should also fix the displays not being listed.

 

An unknown ("???") PCI device is quite normal. It just means the pci.ids database does not list the device (you can submit to them).

 

You can already resize the PCI Devices columns.

 

I have fixed the "FW Loaded" issue.

 

Thanks for your feedback.

Share this post


Link to post
Share on other sites

ioreg output compressed and attached. Thanks for the hint on submitting it to the pci.ids database - forgot that it existed...

 

About the resizing, it "can" be resized, but still not enough to display the entire line - it seems limited to a certain size and it crops the initial portion of the field if they are longer than the max allotted. And I take the FW loaded will be part of your next version, which is not out yet ;)

ioreg.txt.gz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×