Jump to content
headkaze

Hackintool v2.8.6

735 posts in this topic

Recommended Posts

2 hours ago, jamesxxx1997 said:

 

I'm pretty sorry to bother you , @headkaze , for I found out a weird thing when using hackintool to generate SSDT-UIAC & SSDT-USBX.

When I does the exact same patch with Rehabman's SSDT.UIAC and Hackintool's SSDT.UIAC  , the rehabs' result is this ; while the hackintools' result is this.  This is my ioreg dump and EFI , hoping you can take a look when you have time , thanks!

The only difference I can see is that "XHC" is defined as "8086_9dxx".

 

I've attached one with "XHC" changed to "8086_9d2f". Can you see if it works the same way as Rehabman's?

SSDT-UIAC_hackintool_test.aml

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
53 minutes ago, jamesxxx1997 said:

Not correct... The SS01&SS02 should show usb3

But that's how you have SS01/SS02 set in your aml file. You need to set the ports to the correct one's in Hackintool and then export.


                    "SS01", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x0A, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x11, 0x00, 0x00, 0x00                           // ....
                        }
                    }, 

                    "SS02", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x0A, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x12, 0x00, 0x00, 0x00                           // ....
                        }
                    }, 

See how the "UsbConnector" value is 0x0A? That means when you exported the SSDT-UIAC.aml file from Hackintool the ports were set to "TypeC". You need to set them to "USB3" then export and they will be set to 0x03.

 

You can download MaciASL to open the SSDT-UIAC.aml file and check the values. For reference they are the following:

USB2 = 0x00
USB3 = 0x03
TypeC+Sw = 0x09
TypeC = 0x0A
Internal = 0xFF

Once you have your ports configured and you've rebooted, you can run Hackintool and then click the "Clear" button then "Refresh" button for it to load your current ports for checking (as it states in the instructions)

Edited by headkaze

Share this post


Link to post
Share on other sites
Posted (edited)

Hackintool v2.7.0 Release
- Launch process output fix (big thanks to @jaymonkey for the help testing this)
- Prepends "Intel" for IGPU name for Intel Power Gadget (thanks again to @jaymonkey for discovering this)
- System Info now includes all graphics cards

- iMessage Keys are now clearly labeled
- Added new OpenCore logo
- Updated pci.ids / AppleALC audio data

Edited by headkaze

Share this post


Link to post
Share on other sites

Hi, I realised I set one of my ports wrong, HS01 is meant to be listed as USB 2 but in Hackintool it's showing as USB 3. I'm using USBPorts kext method. Can I change the code in the kext to set the correct port type? 

 

I just don't know which part to change and what to change it to, please help! From the post above I've seen 'USB2 = 0x00' but don't get how to make that change in below example text:

 

                <dict>
                    <key>HS01</key>
                    <dict>
                        <key>UsbConnector</key>
                        <integer>3</integer>
                        <key>port</key>
                        <data>
                        AQAAAA==
                        </data>
                    </dict>

 

 

Share this post


Link to post
Share on other sites
26 minutes ago, NGF86 said:

Can I change the code in the kext to set the correct port type?

You should be able to make the change in Hackintool and export again.

Share this post


Link to post
Share on other sites
2 hours ago, headkaze said:

You should be able to make the change in Hackintool and export again.

 

Great thanks, hoping it would be that simple. 

Share this post


Link to post
Share on other sites

I think I found a bug in version 2.70.  In "Installed Kexts" the Hand-off/Continuity kext is misspelled.  It reads "BT4LEContiunityFixup.kext" but it should be "BT4LEContinuityFixup.kext".  The "n" should come before the "u".

Share this post


Link to post
Share on other sites
I think I found a bug in version 2.70.  In "Installed Kexts" the Hand-off/Continuity kext is misspelled.  It reads "BT4LEContiunityFixup.kext" but it should be "BT4LEContinuityFixup.kext".  The "n" should come before the "u".
The project itself is misspelled

Share this post


Link to post
Share on other sites
35 minutes ago, headkaze said:
1 hour ago, mnfesq said:
I think I found a bug in version 2.70.  In "Installed Kexts" the Hand-off/Continuity kext is misspelled.  It reads "BT4LEContiunityFixup.kext" but it should be "BT4LEContinuityFixup.kext".  The "n" should come before the "u".

The project itself is misspelled

 

They fixed it in version 1.1.3.

 

https://github.com/acidanthera/BT4LEContinuityFixup/releases

Share this post


Link to post
Share on other sites
In this new version, I can't see the info about my Hack in some tabs.

Can you run Hackintool from Terminal and post any exceptions on startup. It's almost certainly going to be the cause.

Share this post


Link to post
Share on other sites
24 minutes ago, headkaze said:


Can you run Hackintool from Terminal and post any exceptions on startup. It's almost certainly going to be the cause.

Even using open -a Hackintool command, didn't work

Share this post


Link to post
Share on other sites
23 minutes ago, Allan said:

Even using open -a Hackintool command, didn't work

Can you run Hackintool from Terminal (run Hackintool.app/ Contents/MacOS/Hackintool) and post the output here.

Share this post


Link to post
Share on other sites
55 minutes ago, headkaze said:

Can you run Hackintool from Terminal (run Hackintool.app/ Contents/MacOS/Hackintool) and post the output here.

That's right?

 

2019-07-29 13:33:31.219 Hackintool[529:5304] Initializing Bundle Data
2019-07-29 13:33:31.281 Hackintool[529:5304] Initializing PCI
2019-07-29 13:33:31.490 Hackintool[529:5304] Initializing Displays
2019-07-29 13:33:31.496 Hackintool[529:5304] Initializing General
2019-07-29 13:33:31.498 Hackintool[529:5304] macOS Version: Version 10.14.6 (Build 18G84)
2019-07-29 13:33:31.498 Hackintool[529:5304] Model Identifier: MacBookPro9,2
2019-07-29 13:33:31.499 Hackintool[529:5304] IntelGen: Ivy Bridge
2019-07-29 13:33:31.499 Hackintool[529:5304] PlatformID: 0x01660003
2019-07-29 13:33:31.500 Hackintool[529:5304] IGPU: Intel HD Graphics 4000 (0x01668086)
2019-07-29 13:33:31.605 Hackintool[529:5304] Initializing Settings
2019-07-29 13:33:31.612 Hackintool[529:5304] Initializing Menus
2019-07-29 13:33:31.612 Hackintool[529:5304] Initializing Bootloader
2019-07-29 13:33:32.085 Hackintool[529:5304] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x24acc16570cbb081
2019-07-29 13:33:32.086 Hackintool[529:5304] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x24acc16570cbb081

 

Share this post


Link to post
Share on other sites

 

 

 

That's right?

Yes, thanks. It's the "-[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance" part that tells me what I need to know.

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/30/2019 at 12:39 AM, headkaze said:

Can you run Hackintool from Terminal (run Hackintool.app/ Contents/MacOS/Hackintool) and post the output here.

I'm having the same problem (specifically Info-Misc, Installed, Audio, USB, Disks, and Logs) so I'm attaching the output below. Thanks

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool ; exit;
2019-08-03 14:25:37.010 Hackintool[1420:1552326] Initializing Bundle Data
2019-08-03 14:25:37.048 Hackintool[1420:1552326] Initializing PCI
2019-08-03 14:25:37.199 Hackintool[1420:1552326] Initializing Displays
2019-08-03 14:25:37.203 Hackintool[1420:1552326] Initializing General
2019-08-03 14:25:37.204 Hackintool[1420:1552326] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-03 14:25:37.204 Hackintool[1420:1552326] Model Identifier: MacBookPro11,1
2019-08-03 14:25:37.204 Hackintool[1420:1552326] IntelGen: Kaby Lake
2019-08-03 14:25:37.204 Hackintool[1420:1552326] PlatformID: 0x59160000
2019-08-03 14:25:37.206 Hackintool[1420:1552326] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-03 14:25:37.306 Hackintool[1420:1552326] Initializing Settings
2019-08-03 14:25:37.311 Hackintool[1420:1552326] Initializing Menus
2019-08-03 14:25:37.311 Hackintool[1420:1552326] Initializing Bootloader
2019-08-03 14:25:38.164 Hackintool[1420:1552326] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x8e7a7c698a25dad3
2019-08-03 14:25:38.164 Hackintool[1420:1552326] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x8e7a7c698a25dad3

BTW, will you be updating the patches concerning EC according to this: https://applelife.ru/threads/nastrojka-usb-v-10-11-10-15.627190/page-213#post-807985?

Edited by displhehynehym

Share this post


Link to post
Share on other sites
3 hours ago, headkaze said:

Hackintool v2.7.1 Released

- Bug fixes

- Updated pci.ids / AppleALC audio data

 

@Allan / @displhehynehym can you please verify this release fixes the "unrecognized selector" exception.

Unfortunately...no I can't test.

 

My Notebook died (7yrs old), now I only have my cellphone :wallbash::(

Share this post


Link to post
Share on other sites
14 hours ago, headkaze said:

Hackintool v2.7.1 Released

- Bug fixes

- Updated pci.ids / AppleALC audio data

 

@Allan / @displhehynehym can you please verify this release fixes the "unrecognized selector" exception.

 

I still have "unrecognized sectors". :(

MacBook-Pro:downloads jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-04 15:40:00.515 Hackintool[672:51903] Initializing Bundle Data
2019-08-04 15:40:00.553 Hackintool[672:51903] Initializing PCI
2019-08-04 15:40:00.702 Hackintool[672:51903] Initializing Displays
2019-08-04 15:40:00.706 Hackintool[672:51903] Initializing General
2019-08-04 15:40:00.706 Hackintool[672:51903] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-04 15:40:00.706 Hackintool[672:51903] Model Identifier: MacBookPro11,1
2019-08-04 15:40:00.706 Hackintool[672:51903] IntelGen: Kaby Lake
2019-08-04 15:40:00.706 Hackintool[672:51903] PlatformID: 0x59160000
2019-08-04 15:40:00.707 Hackintool[672:51903] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-04 15:40:00.765 Hackintool[672:51903] Initializing Settings
2019-08-04 15:40:00.769 Hackintool[672:51903] Initializing Menus
2019-08-04 15:40:00.770 Hackintool[672:51903] Initializing Bootloader
2019-08-04 15:40:01.147 Hackintool[672:51903] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x9829c40ae088293b
2019-08-04 15:40:01.147 Hackintool[672:51903] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x9829c40ae088293b

 

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, displhehynehym said:

I still have "unrecognized sectors". :(

Can you post the log output for the one attached.

 

Edited by headkaze

Share this post


Link to post
Share on other sites
8 hours ago, headkaze said:

Can you post the log output for the one attached.

Hackintool.zip

Here's the output. Still...

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-05 10:06:20.786 Hackintool[645:36320] Initializing Bundle Data
2019-08-05 10:06:20.828 Hackintool[645:36320] Initializing PCI
2019-08-05 10:06:20.987 Hackintool[645:36320] Initializing Displays
2019-08-05 10:06:20.993 Hackintool[645:36320] Initializing General
2019-08-05 10:06:20.994 Hackintool[645:36320] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-05 10:06:20.994 Hackintool[645:36320] Model Identifier: MacBookPro11,1
2019-08-05 10:06:20.994 Hackintool[645:36320] IntelGen: Kaby Lake
2019-08-05 10:06:20.994 Hackintool[645:36320] PlatformID: 0x59160000
2019-08-05 10:06:20.995 Hackintool[645:36320] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-05 10:06:21.064 Hackintool[645:36320] Initializing Settings
2019-08-05 10:06:21.068 Hackintool[645:36320] Initializing Menus
2019-08-05 10:06:21.068 Hackintool[645:36320] Initializing Bootloader
2019-08-05 10:06:21.068 Hackintool[645:36320] Test1
2019-08-05 10:06:21.068 Hackintool[645:36320] Test2
2019-08-05 10:06:21.069 Hackintool[645:36320] Test3
2019-08-05 10:06:21.470 Hackintool[645:36320] Test4
2019-08-05 10:06:21.470 Hackintool[645:36320] Test5
2019-08-05 10:06:21.470 Hackintool[645:36320] Test6
2019-08-05 10:06:21.470 Hackintool[645:36320] Test7
2019-08-05 10:06:21.470 Hackintool[645:36320] Test8
2019-08-05 10:06:21.471 Hackintool[645:36320] Test9
2019-08-05 10:06:21.483 Hackintool[645:36320] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x576b75126de0e7d5
2019-08-05 10:06:21.483 Hackintool[645:36320] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x576b75126de0e7d5

 

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, headkaze said:

Please try the one attached.

Hackintool.zip

Working! :) Thank you! :thumbsup_anim:

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-05 17:31:25.437 Hackintool[1537:719813] Initializing Bundle Data
2019-08-05 17:31:25.475 Hackintool[1537:719813] Initializing PCI
2019-08-05 17:31:25.628 Hackintool[1537:719813] Initializing Displays
2019-08-05 17:31:25.633 Hackintool[1537:719813] Initializing General
2019-08-05 17:31:25.633 Hackintool[1537:719813] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-05 17:31:25.633 Hackintool[1537:719813] Model Identifier: MacBookPro11,1
2019-08-05 17:31:25.634 Hackintool[1537:719813] IntelGen: Kaby Lake
2019-08-05 17:31:25.634 Hackintool[1537:719813] PlatformID: 0x59160000
2019-08-05 17:31:25.635 Hackintool[1537:719813] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-05 17:31:25.738 Hackintool[1537:719813] Initializing Settings
2019-08-05 17:31:25.742 Hackintool[1537:719813] Initializing Menus
2019-08-05 17:31:25.742 Hackintool[1537:719813] Initializing Bootloader
2019-08-05 17:31:26.625 Hackintool[1537:719813] Initializing USB
2019-08-05 17:31:26.630 Hackintool[1537:719813] Found USB Controller: XHC Sunrise Point-LP USB 3.0 xHCI Controller (100-series) Controller (0x9D2F8086)
2019-08-05 17:31:26.630 Hackintool[1537:719813] Initializing Disks
2019-08-05 17:31:26.633 Hackintool[1537:719813] Initializing Info
2019-08-05 17:31:26.638 Hackintool[1537:719813] Initializing Installed
2019-08-05 17:31:26.639 Hackintool[1537:719813] Initializing System Configs
2019-08-05 17:31:26.642 Hackintool[1537:719813] Initialization Done

I don't know if you still need my output... so here it is anyway XD

Edited by displhehynehym

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×