Jump to content
headkaze

Hackintool v2.7.6

703 posts in this topic

Recommended Posts

Posted (edited)
On 7/30/2019 at 12:39 AM, headkaze said:

Can you run Hackintool from Terminal (run Hackintool.app/ Contents/MacOS/Hackintool) and post the output here.

I'm having the same problem (specifically Info-Misc, Installed, Audio, USB, Disks, and Logs) so I'm attaching the output below. Thanks

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool ; exit;
2019-08-03 14:25:37.010 Hackintool[1420:1552326] Initializing Bundle Data
2019-08-03 14:25:37.048 Hackintool[1420:1552326] Initializing PCI
2019-08-03 14:25:37.199 Hackintool[1420:1552326] Initializing Displays
2019-08-03 14:25:37.203 Hackintool[1420:1552326] Initializing General
2019-08-03 14:25:37.204 Hackintool[1420:1552326] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-03 14:25:37.204 Hackintool[1420:1552326] Model Identifier: MacBookPro11,1
2019-08-03 14:25:37.204 Hackintool[1420:1552326] IntelGen: Kaby Lake
2019-08-03 14:25:37.204 Hackintool[1420:1552326] PlatformID: 0x59160000
2019-08-03 14:25:37.206 Hackintool[1420:1552326] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-03 14:25:37.306 Hackintool[1420:1552326] Initializing Settings
2019-08-03 14:25:37.311 Hackintool[1420:1552326] Initializing Menus
2019-08-03 14:25:37.311 Hackintool[1420:1552326] Initializing Bootloader
2019-08-03 14:25:38.164 Hackintool[1420:1552326] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x8e7a7c698a25dad3
2019-08-03 14:25:38.164 Hackintool[1420:1552326] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x8e7a7c698a25dad3

BTW, will you be updating the patches concerning EC according to this: https://applelife.ru/threads/nastrojka-usb-v-10-11-10-15.627190/page-213#post-807985?

Edited by displhehynehym

Share this post


Link to post
Share on other sites
Advertisement
3 hours ago, headkaze said:

Hackintool v2.7.1 Released

- Bug fixes

- Updated pci.ids / AppleALC audio data

 

@Allan / @displhehynehym can you please verify this release fixes the "unrecognized selector" exception.

Unfortunately...no I can't test.

 

My Notebook died (7yrs old), now I only have my cellphone :wallbash::(

Share this post


Link to post
Share on other sites
14 hours ago, headkaze said:

Hackintool v2.7.1 Released

- Bug fixes

- Updated pci.ids / AppleALC audio data

 

@Allan / @displhehynehym can you please verify this release fixes the "unrecognized selector" exception.

 

I still have "unrecognized sectors". :(

MacBook-Pro:downloads jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-04 15:40:00.515 Hackintool[672:51903] Initializing Bundle Data
2019-08-04 15:40:00.553 Hackintool[672:51903] Initializing PCI
2019-08-04 15:40:00.702 Hackintool[672:51903] Initializing Displays
2019-08-04 15:40:00.706 Hackintool[672:51903] Initializing General
2019-08-04 15:40:00.706 Hackintool[672:51903] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-04 15:40:00.706 Hackintool[672:51903] Model Identifier: MacBookPro11,1
2019-08-04 15:40:00.706 Hackintool[672:51903] IntelGen: Kaby Lake
2019-08-04 15:40:00.706 Hackintool[672:51903] PlatformID: 0x59160000
2019-08-04 15:40:00.707 Hackintool[672:51903] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-04 15:40:00.765 Hackintool[672:51903] Initializing Settings
2019-08-04 15:40:00.769 Hackintool[672:51903] Initializing Menus
2019-08-04 15:40:00.770 Hackintool[672:51903] Initializing Bootloader
2019-08-04 15:40:01.147 Hackintool[672:51903] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x9829c40ae088293b
2019-08-04 15:40:01.147 Hackintool[672:51903] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x9829c40ae088293b

 

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, displhehynehym said:

I still have "unrecognized sectors". :(

Can you post the log output for the one attached.

 

Edited by headkaze

Share this post


Link to post
Share on other sites
8 hours ago, headkaze said:

Can you post the log output for the one attached.

Hackintool.zip

Here's the output. Still...

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-05 10:06:20.786 Hackintool[645:36320] Initializing Bundle Data
2019-08-05 10:06:20.828 Hackintool[645:36320] Initializing PCI
2019-08-05 10:06:20.987 Hackintool[645:36320] Initializing Displays
2019-08-05 10:06:20.993 Hackintool[645:36320] Initializing General
2019-08-05 10:06:20.994 Hackintool[645:36320] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-05 10:06:20.994 Hackintool[645:36320] Model Identifier: MacBookPro11,1
2019-08-05 10:06:20.994 Hackintool[645:36320] IntelGen: Kaby Lake
2019-08-05 10:06:20.994 Hackintool[645:36320] PlatformID: 0x59160000
2019-08-05 10:06:20.995 Hackintool[645:36320] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-05 10:06:21.064 Hackintool[645:36320] Initializing Settings
2019-08-05 10:06:21.068 Hackintool[645:36320] Initializing Menus
2019-08-05 10:06:21.068 Hackintool[645:36320] Initializing Bootloader
2019-08-05 10:06:21.068 Hackintool[645:36320] Test1
2019-08-05 10:06:21.068 Hackintool[645:36320] Test2
2019-08-05 10:06:21.069 Hackintool[645:36320] Test3
2019-08-05 10:06:21.470 Hackintool[645:36320] Test4
2019-08-05 10:06:21.470 Hackintool[645:36320] Test5
2019-08-05 10:06:21.470 Hackintool[645:36320] Test6
2019-08-05 10:06:21.470 Hackintool[645:36320] Test7
2019-08-05 10:06:21.470 Hackintool[645:36320] Test8
2019-08-05 10:06:21.471 Hackintool[645:36320] Test9
2019-08-05 10:06:21.483 Hackintool[645:36320] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x576b75126de0e7d5
2019-08-05 10:06:21.483 Hackintool[645:36320] -[NSTaggedPointerString unsignedIntValue]: unrecognized selector sent to instance 0x576b75126de0e7d5

 

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, headkaze said:

Please try the one attached.

Hackintool.zip

Working! :) Thank you! :thumbsup_anim:

MacBook-Pro:~ jinmo$ /Users/jinmo/Downloads/Hackintool.app/Contents/MacOS/Hackintool 
2019-08-05 17:31:25.437 Hackintool[1537:719813] Initializing Bundle Data
2019-08-05 17:31:25.475 Hackintool[1537:719813] Initializing PCI
2019-08-05 17:31:25.628 Hackintool[1537:719813] Initializing Displays
2019-08-05 17:31:25.633 Hackintool[1537:719813] Initializing General
2019-08-05 17:31:25.633 Hackintool[1537:719813] macOS Version: Version 10.14.6 (Build 18G84)
2019-08-05 17:31:25.633 Hackintool[1537:719813] Model Identifier: MacBookPro11,1
2019-08-05 17:31:25.634 Hackintool[1537:719813] IntelGen: Kaby Lake
2019-08-05 17:31:25.634 Hackintool[1537:719813] PlatformID: 0x59160000
2019-08-05 17:31:25.635 Hackintool[1537:719813] IGPU: Intel UHD Graphics 620 (0x59168086)
2019-08-05 17:31:25.738 Hackintool[1537:719813] Initializing Settings
2019-08-05 17:31:25.742 Hackintool[1537:719813] Initializing Menus
2019-08-05 17:31:25.742 Hackintool[1537:719813] Initializing Bootloader
2019-08-05 17:31:26.625 Hackintool[1537:719813] Initializing USB
2019-08-05 17:31:26.630 Hackintool[1537:719813] Found USB Controller: XHC Sunrise Point-LP USB 3.0 xHCI Controller (100-series) Controller (0x9D2F8086)
2019-08-05 17:31:26.630 Hackintool[1537:719813] Initializing Disks
2019-08-05 17:31:26.633 Hackintool[1537:719813] Initializing Info
2019-08-05 17:31:26.638 Hackintool[1537:719813] Initializing Installed
2019-08-05 17:31:26.639 Hackintool[1537:719813] Initializing System Configs
2019-08-05 17:31:26.642 Hackintool[1537:719813] Initialization Done

I don't know if you still need my output... so here it is anyway XD

Edited by displhehynehym

Share this post


Link to post
Share on other sites

Can I suggest that for the installed kexts window, you switch from RehabMan's VoodooPS2Controller kext to Acidanthera's version.  He seems to have taken the kext forward from where RehabMan left off.  The most current version is 2.02.  Here's the link:

 

https://github.com/acidanthera/VoodooPS2

 

Thanks.  I use your app all the time now and really appreciate its many functions.

Share this post


Link to post
Share on other sites

Was using 2.7.1 with Clover, been moving to OC, worked in 0.3, worked in 0.4 but something changed and now I get this.

 

2019-08-11 09:47:08.389 Hackintool[506:8717] Initializing Bundle Data

2019-08-11 09:47:08.449 Hackintool[506:8717] Initializing PCI

2019-08-11 09:47:08.660 Hackintool[506:8717] Initializing Displays

2019-08-11 09:47:08.667 Hackintool[506:8717] Initializing General

2019-08-11 09:47:08.668 Hackintool[506:8717] macOS Version: Version 10.14.5 (Build 18F132)

2019-08-11 09:47:08.668 Hackintool[506:8717] Model Identifier: MacBookAir7,2

2019-08-11 09:47:08.669 Hackintool[506:8717] IntelGen: Broadwell

2019-08-11 09:47:08.669 Hackintool[506:8717] PlatformID: 0x16260006

2019-08-11 09:47:08.669 Hackintool[506:8717] *** +[NSString stringWithUTF8String:]: NULL cString

 

None of the tabs populate data except Display, PCI and NVRAM if I refresh. It does work if I boot with Clover on the same install though.

Share this post


Link to post
Share on other sites

Hackintool v2.7.2 Released
- Added EDID injection to IGPU
- Added DPCD Max Link Rate patching
- Added tooltips for Advanced / LSPCON patch options
- Updated pci.ids / AppleALC audio data

 

23 hours ago, REKTIMU2 said:

2019-08-11 09:47:08.669 Hackintool[506:8717] *** +[NSString stringWithUTF8String:]: NULL cString

Can you confirm this is fixed in v2.7.2?

Share this post


Link to post
Share on other sites
42 minutes ago, headkaze said:

Hackintool v2.7.4 Released
- Added EveryMac.com Serial Check

 

Great as usual :) Where I can find it

Share this post


Link to post
Share on other sites

I also have VoodoPS2Controller

   51    2 0xffffff7f8325e000 0xb000     0xb000     org.voodoo.driver.PS2Controller (6.0.1) A74FDC09-77D8-336F-9EBB-990E9AE4A53C <11 7 5 4 3 1>

But the tool doesn't see it.

Share this post


Link to post
Share on other sites
6 hours ago, Slice said:

My ioreg if you want

I search IORegistry for devices matching IOHDACodecDevice. Why doesn't AZAL have this entry? Also why don't you rename AZAL to HDEF? Are you using AppleALC?

IOHDACodecDevice.png

Edited by headkaze

Share this post


Link to post
Share on other sites
5 hours ago, Slice said:

I also have VoodoPS2Controller


   51    2 0xffffff7f8325e000 0xb000     0xb000     org.voodoo.driver.PS2Controller (6.0.1) A74FDC09-77D8-336F-9EBB-990E9AE4A53C <11 7 5 4 3 1>

But the tool doesn't see it.

It looks like it's due to project name being different to the bundle id (VoodooPS2Controller != PS2Controller). I'll fix this in the next release.

Share this post


Link to post
Share on other sites
21 hours ago, headkaze said:

I search IORegistry for devices matching IOHDACodecDevice. Why doesn't AZAL have this entry? Also why don't you rename AZAL to HDEF? Are you using AppleALC?

IOHDACodecDevice.png

I am using VoodooHDA. I have to not rename AZAL to HDEF to be sure AppleHDA is not loaded.

Share this post


Link to post
Share on other sites

Looks like

VoodooHDADevice corresponds to AppleHDAController

and

VoodooHDAEngine corresponds to IOHDACodecDevice

   | |   | | +-o VoodooHDAEngine  <class VoodooHDAEngine, id 0x10000027d, registered, matched, active, busy 0 (27 ms), retain 16>
    | |   | | | | {
    | |   | | | |   "IOAudioEngineNumActiveUserClients" = 0
    | |   | | | |   "IOAudioEngineInputSampleOffset" = 64
    | |   | | | |   "IOGeneralInterest" = "IOCommand is not serializable"
    | |   | | | |   "IOAudioEngineDescription" = "Headphones (Black Left)"
    | |   | | | |   "IOAudioEngineInputSampleLatency" = 32
    | |   | | | |   "IOAudioEngineState" = 0
    | |   | | | |   "IOAudioEngineOutputChannelLayout" = (1,2)
    | |   | | | |   "IOAudioEngineNumSampleFramesPerBuffer" = 32768
    | |   | | | |   "IOAudioEngineGlobalUniqueID" = "VoodooHDAEngine:pci8086,1e20:0"
    | |   | | | |   "IOAudioEngineClockDomain" = 68138088
    | |   | | | |   "IOAudioSampleRate" = {"IOAudioSampleRateWholeNumber"=44100,"IOAudioSampleRateFraction"=0}
    | |   | | | |   "IOAudioEngineFlavor" = 1
    | |   | | | |   "IOAudioEngineSampleOffset" = 64
    | |   | | | |   "IOAudioEngineOutputSampleLatency" = 32
    | |   | | | |   "IOAudioEngineClockIsStable" = Yes
    | |   | | | | }
    | |   | | | | 
    | |   | | | +-o IOAudioStream  <class IOAudioStream, id 0x10000027e, registered, matched, active, busy 0 (0 ms), retain 7>
    | |   | | | |   {
   

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×