Jump to content
Cyberdevs

How to fix Unknown CPU Error in About This Mac

2 posts in this topic

Recommended Posts

If you get the Unknown CPU in About This Mac you can use the following settings according to your processor.

Use IORegistry Explorer or IOJones to check the current "cpu-type" value for your processors. You can find the value by clicking the CPU0@0 like shown in the picture below:

1007990348_ScreenShot2018-08-02at11_16_30PM.png.5c204f15f679d777cca4eda514c97798.png

 

I have an Intel Core i7 6700K so the value is 0507.

 

For Core i3 Series you can set the CPU type to:

0x0309 = Core i3

1004

For Core i5 series you can set the CPU type to:

0x0407

0x0601 or 0x0605 (to be more accurate) = Intel Core i5

1005

For Core i7 Series you can set the CPU type to:

0x0701 or 0x0705 (to be more accurate) = Intel Core i7

You can also try 0x0507 if the values above didn't work.

1006

For Xeon Series you can set the CPU type to:

0x0505 Dual-Core Intel Xeon

0x0510 Quad-Core Intel Xeon

0x05A5 Quad-Core Intel Xeon

Edited by Cyberdevs

Share this post


Link to post
Share on other sites
Advertisement

8-Core Intel Xeon E5

Intel 5960X

0x0a01

Screen Shot 2018-07-27 at 4.00.49 PM.png

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By thomaspetersen
      Hi All
       
      I'm trying to start a Hackintosh High Sierra 10.13.5 installation:
      - MSI B350 PC Mate
      - Ryzen 5 - 2600
      - Radeon Pro 580 GPU
      - 4 x 8GB DDR4
      (Have a working clover bootloader for HS 10.13.3 - but for some reason, I can't use that setup with the 10.13.5) 
       
      Have tried different bootloader setup, with different outcomes...
      ATM. I get this error/hang - "Unknown CPU: family = 0x17, model = 0x8, Stepping = 0x2"
      Have search google, and can see that the threads ppl. are getting this, is when they look at "About this mac", I haven't yet installed the OSX.
       
      So can someone help...

      I'm running the newest Kexts: AppleALC, FakeSMC, Lilu, RealtekRTL8111, USBInjectAll and WhateverGreen.
      In Bootloader setup, i'm running: -v, -s, -f, -no_compat_check, busratio=34, PCIRootUID=1, npci=0x2000, dart=0 and nv_disable=1
      In SMBIOS i'm using the iMac18,2 and in RT i'm using BooterConfig: 0x28 and CsrActiveConfig: 0x67
      In installed drivers i'm using: AptioMemoryFix, EmuVariableUefi-64, OsxAptioFixDrv-64 (Have tried Fix2 as well)
       
      But i'm, keep getting the Unknown CPU hang/error, can someone help...
      Or do someone have a setup with the same CPU and GPU, that can show me his/her setup for Bootloader/Kexts...
    • By armourer2
      Hi,
       
      I have copied my virtual machine (OS X Maverick 10.9) to new Dell laptop with i7-5600u CPU and received endless boot logo.
      I have added "sudo nvram boot-args="-v"" on the old machine and now I am stuck with number of errors and don't know how to continie.
       
      Please take a look on attached screenshot ...
      I am using VMWare 10.0.3.

    • By vladmark
      Hi guys, I need help to change About This Mac ram memory size and possible processor type, I'm using chameleon enoch 2773.
       
      About this mac shows:
       
      Processor: 2.5 GHz Quad-Core Intel Xeon - to be Intel Core2 Quad Q9300
      Memory: 8.38 GB 1066 MHz DDR2 SDRAM - to be 8GB
       
      Thanks
    • By Teresa77
      Hi, I would like to ask for little help. In "about this Mac" my processor is not correctly recognized and is showing as an Intel Core i7 instead of Xeon E3... My build is using latest Clover, everything is working, sleep etc. Smbios I used iMac14,2 because it is the closest Haswell model to mine.
      Can anyone please help me to correct this issue? Thanks a lot.

    • By mine2hit
      Hello Guys..! With our Forums Help, I could install Yosemite and Enjoying Hackintosh..!
       
      In my About This Mac > Serial No showing Unavailable. But in my Clover config i have entered Serial No..
       
      Please help me resolve. Note I'm trying to resolve my iMessage activation. many forum suggest to get serial no showing correctly.
       
      many Thanks in advance
      ABT.tiff
×