Jump to content
fantomas1

[pre-release] macOS Mojave

2,463 posts in this topic

Recommended Posts

1 hour ago, ellaosx said:

Any fix for

 


sudo nvram -c
nvram: Error clearing firmware variables: (iokit/common) not permitted

 

 

40 minutes ago, arsradu said:

Mmm no...and it seems to be something specific to Mojave, for as far as I could see.

 

But, have you tried pressing F11 in Clover GUI?

 

30 minutes ago, Moviemakergr said:

Give a try if u want.

 

nvram -c clears my nvram. its just the error though

Share this post


Link to post
Share on other sites
Advertisement
10 hours ago, ellaosx said:

 

 

nvram -c clears my nvram. its just the error though

 

Ah, ok. Then the short answer is: no. The long answer is: you could call Apple and tell them about it. :)) I'm pretty sure it also occurs on a real Mac.

 

EDIT:

@ellaosx seems that I was wrong. The error above does NOT occur on my MBP. But, for as far as I could see, it seems to be related to SIP. Still not sure how to fix it.

Edited by arsradu

Share this post


Link to post
Share on other sites
On 7/25/2018 at 3:46 PM, ellaosx said:

Any fix for

 


sudo nvram -c
nvram: Error clearing firmware variables: (iokit/common) not permitted

 

Disable SIP from Clover. That is the NVRAM protection

Share this post


Link to post
Share on other sites
On 7/25/2018 at 12:14 PM, ellaosx said:

 

 

nvram -c clears my nvram. its just the error though

 

Hi

I've same issue with csractiveconfig=0X3E7 in config.plist: Error clearing firmware variables: (iokit/common) not permitted. However SIP is desactivated.

 

So, I reboot into recovery partition. In terminal: nvram -xp (display all variables). Type nvram -c without issues. Re-type nvram -xp no more data... Reboot/ All work fine.

 

You can also use latest app created by cyberdevs @Moviemakergr tell you in a previous post

Edited by Matgen84

Share this post


Link to post
Share on other sites
1 hour ago, ellaosx said:

cyberdev's nvram app has also the same command which is nvram -c

 

 

 

Yes of course. That's what @Moviemakergr and I tell you in previous posts. Look at this link:

 

NVRAM and Kext Cache Cleanup and Rebuilding PrelinkedKernel Tool 1.0.4

Share this post


Link to post
Share on other sites

Hi all,

 

I'm having some GFX glitches on Mojave... it all seems to work fine, even with games... (QE/CI is enabled) however the glitches are very noticeable with google maps on safari...very noticeable when zooming in and out ...I remember I had this issue with High Sierra at the time and I think some Lilu plug-ins fixed it (InterlGFXfixup or 4600Azulpatcher) however it's not working on Mojave...this is a has well laptop with intelhd4600 gfx card... I'm running the latest clover with the latest Lilu and now the whatevergreen kext instead of IntelGFXFixup...

 

Thanks for any help!

 

D.

Share this post


Link to post
Share on other sites
On 7/9/2018 at 1:45 AM, crazybirdy said:

 

 

 

Test is done.

Works fine here with Core2 Duo E7400 CPU with only SSE4.1, without SSE4.2.:thumbsup_anim::thumbsup_anim:

Replace only one file from 10.13.5.


/System/Library/UserEventPlugins/com.apple.telemetry.plugin

[edit]

here for you, if anyone need it.

telemetry-plugin-10135.zip

 

E7400.thumb.gif.e3845c20e1ed9fde3637b7ee5bbfbbbb.gif

 

Holy cow!!This is really awesome!!

Share this post


Link to post
Share on other sites

Update made, all is well... without update of kexts and more important I have sound...

Captura de ecrã 2018-07-30, às 20.36.27.png

Share this post


Link to post
Share on other sites

Bug in the latest update Audio Midi clicking on the icon Audio Midi opens and then closes so no access to that feature

can anyone else confirm?1417623003_Screenshot2018-07-31at00_09_29.png.9b50e42fb78611ff3953ad7ff0521f60.png

Edited by osxone

Share this post


Link to post
Share on other sites

Update fine on HFS+J  :lol: with macOS Mojave HD From my macOS HighSierra

2023169654_ScreenShot2018-07-30at7_43_50PM.png.5d0a065c425e4be408332b8c819f75ad.png

No issue with Audio Midi setup

 

EDIT*** Yes is quit after couples minutes of use

1187419280_ScreenShot2018-07-30at7_51_38PM.png.fda1b3703b0ab049574beea143c1c112.png

also the Audio record screen is fix with ☛☛ Capture.app

Edited by chris1111

Share this post


Link to post
Share on other sites

Successful clean install of Mojave DB5_18A347e on my legacy BIOS Dell XPS1530 (Core2Duo Penryn with Geforce 8600M GT).  

 

Installation was on HFS+ partition following @Asentientbot's instructions (booted into my High Sierra partition and launching patched OSInstall.mpkg).   On first boot into Mojave, I used single user mode to rebuild the prelinkedkernel and system caches ...

 

Spoiler

 

Patch the installer
1. Get a copy of the install app and open Contents/SharedSupport/InstallESD.dmg
2. Copy the folder Packages somewhere you can edit
3. cd to the folder and pkgutil --expand OSInstall.mpkg Expanded
4. Open the folder Expanded and open Distribution in a text editor
5. Find the function InstallationCheck(prefix) and put return true; at the very beginning
6. Remove the text installsOS=true from the same file
7. pkgutil --flatten Expanded Patched.mpkg
You will now have an install file "Patched.mpkg" that you can double-click and install to a HFS+ partition.

 

Patch the installed system to boot
1. On the partition, copy boot.efi from /usr/standalone/i386/ to /System/Library/CoreServices
2. Open /Library/Preferences/SystemConfiguration/com.apple.Boot.plist in a text editor
3. Make Kernel Flags as <string>-v -no_compat_check keepsyms=1</string>
This will make the disk bootable, bypass the prohibitory symbol (\) and show symbols in kernel panic logs (If it panics, let it reboot and pick your High Sierra partition; it should automatically show the log in "your computer was restarted because of a problem" dialog once it boots.)

 

Fix the kernel panic on Penryn systems
Patch /S/L/UserEventPlugins/com.apple.telemetry.plugin - replace "Mojave" with the name of your partition.


sudo perl -pi -e 's|\x28\x07\x00\x00\x85|\xC8\x06\x00\x00\x85|g' /Volumes/Mojave/System/Library/UserEventPlugins/com.apple.telemetry.plugin/Contents/MacOS/com.apple.telemetry

Patch USB
Replace from High Sierra:
/System/Library/Extensions/IOUSBHostFamily.kext

 

Recognize the Tesla GPU
Copy from High Sierra:

  • NVDANV50HalTesla.kext
  • NVDAResmanTesla.kext
  • IONDRVSupport.kext
  • IOGraphicsFamily.kext

This allows changing the brightness and shows the correct display in About This Mac

 

Enable the framebuffer and acceleration
Copy from High Sierra:

  • GeForceTesla.kext

   patch this kext from terminal 


sudo perl -pi -e 's|\x48\x8b\x07\xff\x90\xc0\x00\x00\x00|\x48\x8b\x07\x66\x0f\x1f\x44\x00\x00|g' /Volumes/Mojave/System/Library/Extensions/GeForceTesla.kext/Contents/MacOS/GeForceTesla

 

  • GeForceGA.kext
  • GeForceTeslaGLDriver.bundle
  • GeForceTeslaVADriver.bundle

On first boot into Mojave, fix kext permissions, rebuild prelinkedkernel and system caches in single user mode


/sbin/fsck -fy
/sbin/mount -uw /
chmod -R 755 /System/Library/Extensions
chown -R 0:0 /System/Library/Extensions
touch /System/Library/Extensions && kextcache -u /
reboot

 

 

 

 

Mojave DB5_18A347e on XPSM1530.png

Distribution.png

Patched18A347e_OSInstall.mpkg.zip

Edited by fusion71au

Share this post


Link to post
Share on other sites

Just updated to beta 5. Once again as usual each update removes my sound drivers (see below) and requires me to reinstall them. Other then that all went smooth. 

Screen Shot 2018-07-30 at 8.00.16 PM.png

Screen Shot 2018-07-30 at 8.03.28 PM.png

Screen Shot 2018-07-30 at 8.04.02 PM.png

Share this post


Link to post
Share on other sites

Hi

All works fine after update to Beta 5. :) Except: eficheck dump files generated by macOS, like Beta 4 update. What is it? Any solution. Please.

 

 

Capture d’écran 2018-07-31 à 08.42.13.png

eficheck.dump

Edited by Matgen84

Share this post


Link to post
Share on other sites
16 minutes ago, Matgen84 said:

Hi

All works fine after update to Beta 5. :) Except: eficheck dump files generated by macOS, like Beta 4 update. What is it? Any solution. Please.

 

 

Capture d’écran 2018-07-31 à 08.42.13.png

eficheck.dump

Try using Sherlock's EFICheckDisabler.kext..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×