Jump to content
fantomas1

[pre-release] macOS Mojave

2,457 posts in this topic

Recommended Posts

Posted (edited)
3 hours ago, crazybirdy said:

 

No.

It's just added back by Apple.

 

2018-07-06 17:02:01 .. 091-94338 .. 10.14.18A326h Update Beta

2018-07-06 17:10:28 .. 091-94199 .. 10.14.18A326g Update Beta

 

Thanks, it can be updated now.

But I need help from you or other friends here:

At 10.13.6 or lower I never got this update issue.

Only starting from Mojave beta1 (18A293u) to beta3 (18A326g) always got the same error at fresh installation or update:

The installer resources were not found. .............Restart !

No matter what I have done with the following methods:

Using Clover 4516 or newer

Booted by EFI

SMBIOS: had tried MacBook Pro 14,3 / Mac Pro 6,1 / iMac 18,3 / iMac Pro 1,1

Partition formated by GPID apfs

Currently I can use USB HDD from Real MacBook Pro and cloned by CCC to get the working partition in these Hackintoshs only.

 

IMG_0161.JPG

Edited by jsl2000

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
54 minutes ago, jsl2000 said:

Thanks, it can be updated now.

But I need help from you or other friends here:

At 10.13.6 or lower I never got this update issue.

Only starting from Mojave beta1 (18A293u) to beta3 (18A326g) always got the same error at fresh installation or update:

The installer resources were not found. .............Restart !

No matter what I have done with the following methods:

Using Clover 4516 or newer

Booted by EFI

SMBIOS: had tried MacBook Pro 14,3 / Mac Pro 6,1 / iMac 18,3 / iMac Pro 1,1

Partition formated by GPID apfs

Currently I can use USB HDD from Real MacBook Pro and cloned by CCC to get the working partition in these Hackintoshs only.

 

 


1. MBR method may works for you, I think it will also work with pre-formated GUID apfs.

Mojave MBR HFS Firmware Check Patch

 

2. How did you make you installer before?

and you can upload the install-log to see what's happened!

use mouse to find the top side tool bar on the screen of error,
Windows -> Log -> Show All Logs, or /Volumes/1014/macOS Install Data/ia.log

 

 

Edited by crazybirdy

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, crazybirdy said:


1. MBR method may works for you, I think it will also work with pre-formated GUID apfs.

Mojave MBR HFS Firmware Check Patch

 

2. How did you make you installer before?

and you can upload the install-log to see what's happened!

use mouse to find the top side tool bar on the screen of error,
Windows -> Log -> Show All Logs, or /Volumes/1014/macOS Install Data/ia.log

 

 

Thank you very much for your patch which can fresh install Mojave Public Beta 1 (18A314k) in MBR partition in my Z87 hackintosh without previous issue.

Now I am concerning these questions :

1. Is this patch also working for GUID partition which has been confirmed by other users ?

2. If this MBR partition cloned to GUID partition, can it be updated via normal way by App store ?

3. Can you fix with similar patch to Mojave HFS+ or apfs Firmware check during updating to avoid such an issue ?

 

Thanks a million because it's the first time I can install Mojave in my hackintosh without previous issue.

Please see the attached install.log for your reference if it's what you want to check.

BTW I'll send you the error log as soon as possible once I reproduce it again !

Because the previous install data were deleted during repeated installation failure !

install.log.zip

Edited by jsl2000

Share this post


Link to post
Share on other sites
Posted (edited)
54 minutes ago, jsl2000 said:

Thank you very much for your patch which can fresh install Mojave Public Beta 1 (18A314k) in MBR partition in my Z87 hackintosh without previous issue.

Now I am concerning these questions :

1. Is this patch also working for GUID partition which has been confirmed by other users ?

2. If this MBR partition cloned to GUID partition, can it be updated via normal way by App store ?

3. Can you fix with similar patch to Mojave HFS+ or apfs Firmware check during updating to avoid such an issue ?

 

Thanks a million because it's the first time I can install Mojave in my hackintosh without previous issue.

 

BTW I'll send you the error log as soon as possible once I reproduce it again !

Because the previous install data were deleted during repeated installation failure !

 

1.yes with GUID HFS+, not test with GUID apfs, but it should work too.

2.yes.

3.Read HowTo Q8.

--

I can't find the root cause of error with the install-log.

It seems you want to update to 10A326g and get error. I though it was a fresh install.

Maybe you should try to use the latest version of Clover, and remove install-log, then you will get new clean install-log.

 

 

Edited by crazybirdy

Share this post


Link to post
Share on other sites
3 hours ago, crazybirdy said:

 

1.yes with GUID HFS+, not test with GUID apfs, but it should work too.

2.yes.

3.Read HowTo Q8.

--

I can't find the root cause of error with the install-log.

It seems you want to update to 10A326g and get error. I though it was a fresh install.

Maybe you should try to use the latest version of Clover, and remove install-log, then you will get new clean install-log.

 

 

Yes, I can confirm that this MBR patch worked for both HFS+ and apfs partitions in my hackintoshs.

I'll try your advice ASAP.

Clover version was updated to 4586 already.

Share this post


Link to post
Share on other sites

Hi guys,

As anyone noticed that sound is much better in Mojave, than HS?

I think I read one of you saying just that, but today I got to listen closely and it's true the sound is more rich louder and clear.

Apple changed the algorithm, or what?

Thanks...

Share this post


Link to post
Share on other sites

I would to know if there is any possibility to avoid apfs conversion with gpt/guid partition table during mojave install, I've tried with unsolid.kext in efi/clover/kext/other without any success.

Share this post


Link to post
Share on other sites
Posted (edited)
46 minutes ago, mick3lson said:

I would to know if there is any possibility to avoid apfs conversion with gpt/guid partition table during mojave install, I've tried with unsolid.kext in efi/clover/kext/other without any success.

 

No way except patch-OSInstaller.

HFS+ Auto-convert to APFS is OSInstaller's must-to-do job now.

Edited by crazybirdy

Share this post


Link to post
Share on other sites
Posted (edited)

Hello Hackintosh community!

 macOS Mojave HD ( English Program )

1- This program works in real Mac or Hackintosh. You can use this program only in macOS Sierra 10.12, macOS High Sierra 10.13, and macOS Mojave 10.14 to create the installation volume

2- You can use an internal or external SSD or HD

3- NOTE: You can choose to install in HFS+J or APFS

4- For Hackintosh users you must have a recent Clover install to boot macOS Mojave, otherwise use the Post Installer included in the program

5- The installation time is 15 to 20 minutes depending on the speed of your drive and your system

See ➣ macOS Mojave HD

Of course you must have the SIP Security disable as well as the GateKeeper to use this program.

Hope that help people to install Mojave in HFS+J or APFS

Edit **

For any issue, you have to open new issue here ➢ Issue

Edited by chris1111

Share this post


Link to post
Share on other sites
17 hours ago, MorenoAv said:

Hi guys,

As anyone noticed that sound is much better in Mojave, than HS?

I think I read one of you saying just that, but today I got to listen closely and it's true the sound is more rich louder and clear.

Apple changed the algorithm, or what?

Thanks...

Yes I noticed that. It's great because that was the only thing that worked better for me in windoze. I'm running a DAC through a USB to a really nice stereo. Don't know if the normal sound is better. It's mainly the soundstage is bigger.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @surfinchina

The normal sound is much better, more profound, clear, rich... and I have no DAC...

 

Edited by MorenoAv

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, crazybirdy said:

 

Good news, I will try it when I have free time.

OK, I just got MacBook4,1 on my hand right now.. also going to try with Mojave (test only, no support for GMA X3100 for sure).

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Posted (edited)

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

 

 

found com.apple.telemetry.plugin is credit to jackluke at post#1761

Edited by nmano

Share this post


Link to post
Share on other sites
15 minutes ago, nmano said:

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

Thanks for corrections, I just wanna edit my post but you're one step faster. :)

Share this post


Link to post
Share on other sites
1 hour ago, nmano said:

replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

 

Maybe someone could check what difference there is between these both files and see if we can use Clover's patch on the fly?

Share this post


Link to post
Share on other sites

Any way to get my R7 working without helper card?

Replacing kexts from Sierra don't seem to work like in HS.

Share this post


Link to post
Share on other sites

is there a new minstolen patch for kabylake graphics on Mojave Public Beta 2 ?.

Im unable to boot my laptop, i added the current mojave KBL patch but its not working.

I was all fine when i tried Mojave Dev Beta 1.

 

@Sherlocks i did install the version of clover that you fixed the hang on UHD Kablylake graphics, but still not working.

 

I have somehow no clue at this point why it's insta panic-ing

It really has to be a new Minstolen/DVMT patch.

Share this post


Link to post
Share on other sites
3 minutes ago, LuCyr04 said:

Any way to get my R7 working without helper card?

Replacing kexts from Sierra don't seem to work like in HS.

R7 250X has device id 0x683D1002 and should work OOB. Upload your entire EFI folder

Share this post


Link to post
Share on other sites
R7 250X has device id 0x683D1002 and should work OOB. Upload your entire EFI folder
It's not working since High Sierra without helper card or UEFI bios+whatevergreen

Sent from my OnePlus 2 using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, LuCyr04 said:

It's not working since High Sierra without helper card or UEFI bios+whatevergreen

Sent from my OnePlus 2 using Tapatalk
 

Again upload your entire EFI folder

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/8/2018 at 7:17 PM, Badruzeus said:

@crazybirdy Just found this, it seems 10.14 Beta works with Core 2 Duo CPU by replacing these from 10.13.x:


/System/Library/UserEventPlugins

 

 

 

On 7/8/2018 at 11:21 PM, nmano said:

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

 

found UserEventPlugins is credit to ASentientBot at post#1683

found com.apple.telemetry.plugin is credit to jackluke at post#1761

 

Test is done.

Works fine here with Core2 Duo E7400 CPU with only SSE4.1, without SSE4.2.:thumbsup_anim::thumbsup_anim:

Replace only one file from 10.13.5.

/System/Library/UserEventPlugins/com.apple.telemetry.plugin

[edit]

here for you, if anyone need it.

telemetry-plugin-10135.zip

telemetry-plugin-10136.zip

 

E7400.thumb.gif.e3845c20e1ed9fde3637b7ee5bbfbbbb.gif

Edited by crazybirdy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×