Jump to content
fantomas1

[pre-release] macOS Mojave

2,463 posts in this topic

Recommended Posts

Hello Hackintosh community!

 macOS Mojave HD ( English Program )

1- This program works in real Mac or Hackintosh. You can use this program only in macOS Sierra 10.12, macOS High Sierra 10.13, and macOS Mojave 10.14 to create the installation volume

2- You can use an internal or external SSD or HD

3- NOTE: You can choose to install in HFS+J or APFS

4- For Hackintosh users you must have a recent Clover install to boot macOS Mojave, otherwise use the Post Installer included in the program

5- The installation time is 15 to 20 minutes depending on the speed of your drive and your system

See ➣ macOS Mojave HD

Of course you must have the SIP Security disable as well as the GateKeeper to use this program.

Hope that help people to install Mojave in HFS+J or APFS

Edit **

For any issue, you have to open new issue here ➢ Issue

Edited by chris1111

Share this post


Link to post
Share on other sites
Advertisement
17 hours ago, MorenoAv said:

Hi guys,

As anyone noticed that sound is much better in Mojave, than HS?

I think I read one of you saying just that, but today I got to listen closely and it's true the sound is more rich louder and clear.

Apple changed the algorithm, or what?

Thanks...

Yes I noticed that. It's great because that was the only thing that worked better for me in windoze. I'm running a DAC through a USB to a really nice stereo. Don't know if the normal sound is better. It's mainly the soundstage is bigger.

Share this post


Link to post
Share on other sites

Hi @surfinchina

The normal sound is much better, more profound, clear, rich... and I have no DAC...

 

Edited by MorenoAv

Share this post


Link to post
Share on other sites
30 minutes ago, crazybirdy said:

 

Good news, I will try it when I have free time.

OK, I just got MacBook4,1 on my hand right now.. also going to try with Mojave (test only, no support for GMA X3100 for sure).

Edited by Badruzeus

Share this post


Link to post
Share on other sites

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

 

 

found com.apple.telemetry.plugin is credit to jackluke at post#1761

Edited by nmano

Share this post


Link to post
Share on other sites
15 minutes ago, nmano said:

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

Thanks for corrections, I just wanna edit my post but you're one step faster. :)

Share this post


Link to post
Share on other sites
1 hour ago, nmano said:

replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

 

Maybe someone could check what difference there is between these both files and see if we can use Clover's patch on the fly?

Share this post


Link to post
Share on other sites

Any way to get my R7 working without helper card?

Replacing kexts from Sierra don't seem to work like in HS.

Share this post


Link to post
Share on other sites

is there a new minstolen patch for kabylake graphics on Mojave Public Beta 2 ?.

Im unable to boot my laptop, i added the current mojave KBL patch but its not working.

I was all fine when i tried Mojave Dev Beta 1.

 

@Sherlocks i did install the version of clover that you fixed the hang on UHD Kablylake graphics, but still not working.

 

I have somehow no clue at this point why it's insta panic-ing

It really has to be a new Minstolen/DVMT patch.

Share this post


Link to post
Share on other sites
3 minutes ago, LuCyr04 said:

Any way to get my R7 working without helper card?

Replacing kexts from Sierra don't seem to work like in HS.

R7 250X has device id 0x683D1002 and should work OOB. Upload your entire EFI folder

Share this post


Link to post
Share on other sites
R7 250X has device id 0x683D1002 and should work OOB. Upload your entire EFI folder
It's not working since High Sierra without helper card or UEFI bios+whatevergreen

Sent from my OnePlus 2 using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, LuCyr04 said:

It's not working since High Sierra without helper card or UEFI bios+whatevergreen

Sent from my OnePlus 2 using Tapatalk
 

Again upload your entire EFI folder

Share this post


Link to post
Share on other sites
On 7/8/2018 at 7:17 PM, Badruzeus said:

@crazybirdy Just found this, it seems 10.14 Beta works with Core 2 Duo CPU by replacing these from 10.13.x:


/System/Library/UserEventPlugins

 

 

 

On 7/8/2018 at 11:21 PM, nmano said:

I FOUND SAME LINK

 

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

 

found UserEventPlugins is credit to ASentientBot at post#1683

found com.apple.telemetry.plugin is credit to jackluke at post#1761

 

Test is done.

Works fine here with Core2 Duo E7400 CPU with only SSE4.1, without SSE4.2.:thumbsup_anim::thumbsup_anim:

Replace only one file from 10.13.5.

/System/Library/UserEventPlugins/com.apple.telemetry.plugin

[edit]

here for you, if anyone need it.

telemetry-plugin-10135.zip

telemetry-plugin-10136.zip

 

E7400.thumb.gif.e3845c20e1ed9fde3637b7ee5bbfbbbb.gif

Edited by crazybirdy

Share this post


Link to post
Share on other sites
1 minute ago, crazybirdy said:

 

 

 

Test is done.

Works fine here with Core2 Duo E7400 CPU with only SSE4.1, without SSE4.2.:thumbsup_anim::thumbsup_anim:

Replace only one file from 10.13.5.


/System/Library/UserEventPlugins/com.apple.telemetry.plugin

E7400.thumb.gif.e3845c20e1ed9fde3637b7ee5bbfbbbb.gif

Can you upload the /System/Library/UserEventPlugins/com.apple.telemetry.plugin file from HS so I can take a look at what changed, to make a patch for it.

Share this post


Link to post
Share on other sites
6 minutes ago, Pavo said:

Again upload your entire EFI folder

It's a bit messy now since I'm trying to get Mojave running.

config.plist is the one I'm using my main Sierra.

config2.plist have only smbios changed and it's the one I'm booting Mojave with.

EFI 2.zip

Share this post


Link to post
Share on other sites
29 minutes ago, crazybirdy said:

Test is done.

Works fine here with Core2 Duo E7400 CPU with only SSE4.1, without SSE4.2.:thumbsup_anim::thumbsup_anim:

Replace only one file from 10.13.5.


/System/Library/UserEventPlugins/com.apple.telemetry.plugin
 

E7400.thumb.gif.e3845c20e1ed9fde3637b7ee5bbfbbbb.gif

 

Good old day! :P though I've difficulties installing Mojave on an unsupported Real MacBook4,1 with Intel Core2Duo T8300 Penryn CPU (SSE4.1) and Intel GMA X3100. Seems my brain has poisoned with hackintosh method which is simpler configured through Clover Bootloader #LoL

Edited by Badruzeus

Share this post


Link to post
Share on other sites
22 minutes ago, LuCyr04 said:

It's a bit messy now since I'm trying to get Mojave running.

config.plist is the one I'm using my main Sierra.

config2.plist have only smbios changed and it's the one I'm booting Mojave with.

EFI 2.zip

Try adding these to EFI>Clover>ACPI>patched, and remove WhateverGreen.kext from other folder

SSDT-DTGP.aml

SSDT-GFX.aml

Share this post


Link to post
Share on other sites

macOS Mojave Public Beta 1 changes the MinStolenSize Patches, after two days of attempting, i thought that this should be the only issue that i failed to boot my Lenovo V330-15IKB with Intel UHD 620 Graphics.

 

Checked Framebuffers with HexFiend and results were positive.

So far i haven't seen someone post them so i guess i deserve the credits as my nickname "Sniki"

 

Here are the new Patches:

 

Disable minStolenSize less or equal fStolenMemorySize assertion, 10.14 PB1 Credits (Sniki)

 

KabyLake:

Name: com.apple.driver.AppleIntelKBLGraphicsFramebuffer
Find: 764648FF 05E25108
Replace: EB4648FF 05E25108


Skylake:

Name: com.apple.driver.AppleIntelSKLGraphicsFramebuffer
Find : 764048FF 05927E07
Replace: EB404FF 05927E07


Broadwell:
Name: com.apple.driver.AppleIntelBDWGraphicsFramebuffer
Find: 764048FF 05122B06
Replace: EB4048FF 05122B06

 

 

Edited by "Sniki"

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×