Jump to content
About Just Joined group Read more... ×
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      This thread for installing Catalina on the Dell Latitude E6410 WITH NVIDIA GRAPHICS (BIOS A17, NVidia 3100m) will help you install a fresh installation of Catalina on your Dell Latitude E6410, it will help you upgrade from 10.15.2 to 10.15.x (if you originally installed Catalina from this thread) and it will also help you upgrade from Mojave 10.14.6 if you have already installed Mojave by following the instructions here.  The instructions in this first post assume that you are installing Catalina in an APFS container.  If you are curious about the evolution of this solution and how sleep/wake was solved, review the Mojave installation thread.
       
      Important: This Thread is NOT intended to help you install macOS on a Latitude E6410 with Intel HD Graphics (without Nvidia graphics).  The DSDT attached to this first post (in E6410-Catalina.zip) is VERY SPECIFIC to the Nvidia graphics implementation and has not been edited for HD Graphics - there are elements required for HD Graphics that are missing from the attached DSDT and there are DSDT mods that have not been tested with HD Graphics.  Also, the kexts attached to this first post are specific to a Broadcom Wi-Fi card which must replace the original Intel Wi-Fi card.
       
      This first post will be modified to reflect lessons learned and to reflect the most current working state of my Latitude E6410 (with NVidia 3100m discrete graphics) running Catalina.  Issues, observations and performance tips are recorded toward the bottom of this first post.  My recommended CLOVER configuration is specified toward the bottom of this first post.
       
      *** If you want help with your installation, please post your issue along with problem reporting files generated using @black.dragon74's problem reporting tool.  Google 'GENERATE PROPER PROBLEM REPORTING FILES black.dragon74' to find it. ***.  If Catalina's Read-Only protections block your installation of black.dragon74's gen_debug script, please copy the attached gen_debug script to your Desktop, change script properties with the terminal command 'chmod a+x ~/Desktop/gen_debug' and run the script from your Desktop.
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) Wi-Fi: Broadcom BCM 94352HMB (replaced original Wi-Fi card) BIOS (version A17) configured as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC:Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace:Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;   
      Versions of the software used in this installation are listed below the installation steps.  EFI and kexts for Catalina are attached to this first post in E6410-Catalina.zip.  CLOVER configuration is specified below the installation steps.  You MUST BE LOGGED-IN to download attachments from this forum.
       
      Wi-Fi connection to an Access Point is delayed when using AppleALC for sound.  Do not use Apple ALC.  Use VoodooHDA pkg 2.9.2 v15 for sound.
       
      Steps to install Catalina on a Dell Latitude E6410 (BIOS A17, NVidia 3100m)
       
      If you want to upgrade to 10.15.7, see instructions at this post.
       
      If you want to upgrade to 10.15.6, see instructions at this post.
       
      If you want to upgrade to 10.15.5, see instructions at this post.
       
      If you want to upgrade to 10.15.4, see instructions at this post.  
       
      Follow instructions below for 10.15.2 and 10.15.3.
       
      Make sure that your system matches my system description above (including BIOS version, Wi-Fi card, BIOS settings) If performing an upgrade from Mojave or a previous version of Catalina, backup your Mojave or Catalina partition! (Carbon Copy or similar) Download Catalina Installer Download DosDude Catalina Patcher Use DosDude Patcher to create Catalina USB Installer Delete LegacyUSBInjector.kext (we're using @RehabMan's USBInjectAll.kext with custom SSDT) and delete SIPManager.kext (CLOVER is managing SIP) from Catalina USB Installer's /Library/Extensions folder Copy all but the FakeSMC sensor kexts in E6410-Catalina.zip (attached) LE folder to the Catalina USB Installer /Library/Extensions (copy all kexts (including FakeSMC.kext) but not the FakeSMC sensor kexts) Install CLOVER Bootloader (Legacy) on USB Installer using the EFI in the E6410-Catalina.zip (attached).  Use the CLOVER configuration specified below.  Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values. Reset your Latitude E6410 NVRAM by doing the following (this may be important if you're making changes to your existing EFI and won't hurt anything if you're not making any changes) turn-off your laptop remove A/C power and main battery press and hold the power button for 30 seconds restore A/C power and battery Boot your Latitude E6410 from the Catalina USB Installer that you created in steps 5-8. Select "Reinstall macOS" (note that I have existing installations of Mojave and High Sierra on my Latitude E6410, so it's possible that this menu item changes to "Install macOS" if you don't have any previous macOS installations). Select your Catalina destination partition (which will be your Mojave or previous Catalina partition if you are upgrading) After the Catalina Installer reboots the first time, boot from the "macOS Installer" partition on the disk that you selected as your Catalina destination (not the macOS installer on the USB) After the Catalina Installer reboots the second time, boot the Catalina macOS Installer on the USB Select the Post Install Patcher utility Select only the following Post Install Patches (no other patches / options) Install Patch Updater Legacy Video After the Post Install Patcher reboots,  boot from the newly installed (or upgraded) Catalina partition and complete the macOS configuration Remove these kexts (if they exist) from /Library/Extensions: LegacyUSBInjector.kext, LegacyUSBVideoSupport.kext and SIPManager.kext If you are performing a fresh installation of Catalina: Install CLOVER (LEGACY - NOT UEFI) on your boot disk and configure EFI using files in the attached E6410-Catalina.zip.  Use the CLOVER configuration below.  Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values. Install all kexts in the attached E6410-Catalina.zip LE folder to your /Library/Extensions folder. Copy HWMonitor from the application folder in the attached E6410-Catalina.zip to your Applications folder. Install VoodooHDA (I installed using the Classic method) Skip to Step 21 If you are upgrading from a previous version of Catalina using the instructions from this thread or from Mojave that you installed using the instructions here: Replace 3rd-party kexts in EFI/Clover/kexts/Other with those in the attached EFI folder.   Replace EFI/Clover config.plist with the attached config.plist (Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values) Replace EFI/Clover/ACPI/patched with the files in the attached EFI/Clover/ACPI/patched Replace 3rd-party kexts in /Library/Extensions with those in the attached LE folder Remove VoodooSDHC.kext from /Library/Extensions Re-install VoodooHDA if necessary (I installed using the Classic method for Catalina) Ensure PROPER kext installation: If you're manually installing kexts in /Library/Extensions, make sure that you execute the following (in terminal) cd /Library/Extensions sudo chown -R root:wheel *.kext sudo chmod -R 755 *.kext sudo kextcache -i / After you execute 'sudo kextcache -i /' you should observe that ALL kexts are allowed.  If not, your kext directory attributes are probably incorrect.  Repeat kext installation and try again. Reboot from your new/upgraded Catalina partition Welcome to macOS Catalina! Change the keyboard type to ISO (System Preferences > Keyboard > Change Keyboard Type) Swap the Command and Option keys (System Preferences > Keyboard > Modifier Keys) Set hibernatemode: In terminal, execute sudo pmset -a hibernatemode 0 sudo rm -f /var/vm/sleepimage sudo touch /var/vm/sleepimage sudo chflags schg /var/vm/sleepimage  
      Version Info at the time of this writing:
      Catalina Installer 10.15.7 CLOVER r5119 DosDude Catalina Patcher: v1.4.4 Lilu.kext 1.4.7 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) AirportBrcmFixup.kext 2.0.9 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmFirmwareData.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmBluetoothInjector.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmPatchRAM3.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) IntelMausi.kext 1.0.3 (Not IntelMausiEthernet.kext)
      EFICheckDisabler.kext 0.5
      VoodooHDA.kext 2.9.2 v15 (NOT AppleALC)
       
      What is not working (that was working in Mojave)
      SD Card Slot (had to remove VoodooSDHC.kext which caused system freeze on wake)  
      Known Issues and Their Solutions
      (Not yet included in E6410-Catalina.zip archive attached to Post #1) There are new versions of acidanthera kexts as described here.  I hadn't noticed any issues with the older kexts, so the kexts are not yet included in the E6410-Catalin.zip archive attached to this first post and will be included in a future update to the E6410-Catalina.zip archive. (Solved - no further work required) Clover r5118 requires the config.plist key <key>NoDefaultProperties</key><false> to permit macOS to boot with Clover's "Inject Nvidia" = True.  See details here.  config.plist in the attached E6410-Catalina.zip archive includes this change. (Solved - no further work required) EFICheck is loaded.  Solution is to install EFICheckDisabler.kext which you can get here.  EFICheck.kext is included in the attached E6410-Catalina.zip archive. (Solved - no further work required) Some users experience display issues.  The solution is to remove Device (PNLF) from the DSDT.  Use the attached DSDT.  Removal of PNLF will disable sleep on lid closure.  Device (PNLF) can be added without modifying the DSDT by enabling the Clover PNLF ACPI patch.  The attached Clover config.plist enables the PNLF DSDT patch.  Disable the Clover PNLF patch if you experience display issues. (Solved - no further work required) USB sleep/wake power IORegistry keys are not injected (not included in Mojave's or Catalina's IOUSBHostFamily.kext).  Solution is to added SSDT-USBX.aml to EFI/CLOVER/ACPI/patched.  The attached SSDT-USBX.aml includes USB sleep/wake properties for MacBookPro6,2 from High Sierra 10.13.6 IOUSBHostFamily.kext. (No solution yet) Brightness slider does not work in System Preferences > Displays.  Brightness is easily controlled with Dell brightness keys.  There is some work on this later in this thread, but I will not be solving this as I'm content with the Dell brightness keys (and Ambient Light Sensor works to auto-adjust brightness). (No intention to solve) Display Settings in System Preferences are "garbled" when bright slider is visible.  This is a known issue with the legacy graphics patch and does not affect laptop operation. I continue to refine the DSDT and CLOVER config.plist to optimize my Latitude E6410 for multi-booting between various macOS versions (High Sierra, Mojave and Catalina at the time of this writing). If you upgrade your Latitude E6410 EFI using my attached EFI, you may find that your Latitude E6410 is stuck in a boot-loop that ends in a white screen and reboots.  Clear your system by doing the following: turn off your laptop, remove A/C power, remove the main battery, press and hold the power button for 30 seconds, restore A/C power and battery, boot normally.  I have only found this to be necessary (very rarely) after making an EFI change, but you may find it helpful if making kext changes in /Library/Extensions as well. (Solved - no further work required) Brcm firmware does not update when using BrcmFirmwareRepo.kext in /Library/Extensions.  Solution is to install BrcmFirmwareData.kext and BrcmPatchRAM3.kext in E/C/k/O with Clover "Inject Kexts" = YES. (Solved - no further work required) Laptop does not sleep when closing lid.  Solution appears to be a combination of adding Notify (LID0) code to Method (BTNV) and adding Device (PNLF) in the DSDT. I am using the same EFI for High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.3 and it works in all three macOSes. (No solution yet) No SD Card Slot (had to remove VoodooSDHC.kext) - I read somewhere that there is a solution that does not require any kexts (just a DSDT edit).  Haven't yet implemented this fix. (Not a problem that needs to be solved - leaving for historical purposes.  I am running Catalina without this.) - IOHWControl does not load under GFX0 (as observed in IORegistryExplorer).  Solution (if it needs to be solved) is to install AppleHWSensor.kext from a DosDude-patched Mojave /S/L/E in Catalina's /L/E.  Copy and install your own or use the kext attached to this post. (Solved - no further work required) Wi-Fi connection is delayed until a minute or so after boot - Use VoodooHDA and NOT AppleALC (Solved - no further work required) External USB ports do not work after waking from sleep (S3) - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Boot and shut-down time of Catalina is slower than Mojave - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Wi-Fi is not immediately available at OS startup - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Laptop freezes on wake - Remove VoodooSDHC.kext from /Library/Extensions  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z (I haven't noticed this issue for a while since I completed DSDT edits for Mojave, but keeping this here for historical purposes)  
      CLOVER Installation: Use these configuration options (These configuration options configure Clover for LEGACY BIOS - NOT UEFI)
      Install Clover in the ESP Boot Sectors Install boot0af in MBR Clover for BIOS (LEGACY - NOT UEFI) booting Clover EFI 64-bits SATA BIOS Drivers, 64-bit Recommended drivers FSInject File System drivers ApfsDriverLoader Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane After clicking "Continue", if prompted with "This Clover package is incompatible with this version of macOS," install anyway  
      After CLOVER installation is complete Copy the following from the attached E6410-Catalina.zip ACPI patched contents config.plist (change XX-MASKED-XX values to your own) kexts/Other (remove all other kext folders) Remove christmas and new year folders from themes (if present)  
      Screenshots
       
      Credits
      Thanks to those who contributed to my Mojave solution and to the DosDude team (for the incredible macOS patchers), I think this Catalina installation was the easiest macOS installation that I have experienced (so far).  Many thanks to @Slice and his team for the incredible work on CLOVER and for continuing to support old legacy systems like this.  Also, thanks to @Mieze and @headkaze and others I'm sure for maintaining the Brcm kexts.  And finally, I still prefer to manually apply patches to the DSDTs in my systems.  CLOVER offers extensive patching functionality, but I'm old-school and like to have an error-free, fully-patched DSDT with a simple CLOVER config.plist.  I think that this manual DSDT patching approach (which required an extensive review and debugging of the original unpatched DSDT in this thread) is the reason that this Latitude E6410 is such a perfect MacBookPro6,2.  Thank you @RehabMan for being a great teacher and for always insisting on problem reporting files .
       
       
      AppleHWSensor.kext.zip
      gen_debug
      E6410 Catalina-5v2.zip
    • By Ciumann
      Ho fatto l'aggiornamento sicurezza 2020-005 e all'avvio non mi carica i webdrivers. Il Webdrivers updater mi dice che non ci sono aggiornamenti per questa build (17G14033). Come posso risolvere?
      Grazie!
    • By miliuco
      macOS Catalina on: Gigabyte Z390 Aorus Elite motherboard + i3 9100 Coffee Lake processor + AMD Radeon RX 580 graphics card + fenvi FV-T919 WIFI and Bluetooth card + Clover r5121 + AppleALC, Lilu, VirtualSMC, XHCI-unsupported, IntelMausiEthernet, USBPorts and WhateverGreen.

      Hardware
       
      Gigabyte Z390 Aorus Elite motherboard: support for Intel 8 and 9 generation processors, Realtek ALC1220 audio, Intel I219V Ethernet, 4 PCI-E slots, 2, 3 and 3.1 USB ports, Intel Graphics 630 integrated graphics card 9th generation Intel i3 9100 processor Nox Hummer H-212 120mm CPU Fan Corsair Vengeance LPX 3200 MHz 16 GB RAM (2 x 8) AMD Radeon RX 580 8GB graphics card Wifi and Bluetooth Card Fenvi FV-T919 Mars Gaming MPII850 Power Supply (850W) Samsung EVO 860 SSD disk.
        What works well?

      Pretty much everything I've tried:
      Radeon RX 580: 3 DP ports and 1 HDMI port, output to 2 displays simultaneously Shutdown, reboot and sleep Integrated sound and HDMI sound output USB ports (2, 3 and 3.1) Enable TRIM for SSD drive AirDrop, Sidecar, etc.
        What is not working well?

      Integrated Intel UHD Graphics 630 card: see below.

      BIOS settings (version F9)

      I only write down the significant options, there are many other options that do not influence macOS and that you can configure to your liking (for example the LEDs on the board, etc.).
      XMP Profile: Auto / Profile 1 / Enabled (eXtreme Memory Profile, I use 3200 MHz memory and without this profile it works at 2600) Platform Power Management: Disabled VT-d: Disabled XHCI Hand-Off: Enabled Legacy USB Support: Enabled Network Stack: Disabled CSM: Disabled Secure Boot: Disabled Fast Boot: Disabled OS Type: Other OS Wake on LAN: Disabled Integrated Graphics: Auto Initial Display Output: PCIe 1 Slot DVMT Pre-Allocated: 256M or higher.
        EFI folder for Clover (installation USB stick / SSD disk with Catalina)

      SSDT

      Some SSDT.aml files in EFI/CLOVER/ACPI/patched.

      SSDT-DTPG.aml (helper module for SSDT)
      SSDT-EC.aml (USB power charge)
      SSDT-UIAC.aml (USB port mapping)
      SSDT-USBX.aml (USB port mapping)
      SSDT-PMC.aml got from OpenCore to have native NVRAM on Z390 mother boards
      SSDT-Z390-RP21-SLOT4-TB3HP.aml (Thunderbolt devices hot plug) it can be skipped.

      Drivers in EFI/CLOVER/drivers/UEFI

      ApfsDriverLoader.efi
      AudioDxe.efi
      DataHubDxe.efi
      FSInject.efi
      VBoxHfs.efi
      SMCHelper.efi
      OcQuirks.efi *
      OpenRuntime.efi *
      OcQuirks.plist *.

      * see OC Quirks below.

      Extensions in EFI / CLOVER / kexts / Other

      AppleALC.kext
      IntelMausi.kext
      Lilu.kext
      USBPorts.kext
      VirtualSMC.kext
      WhateverGreen.kext
      XHCI-unsupported.kext.

      NOTE 1: The USBPorts.kext extension along with 3 aml files included in patched folder (SSDT-EC.aml, SSDT-UIAC.aml y SSDT-USBX.aml) were generated by joanserramiret with the configuration of USB ports for this motherboard so that the limit defined by macOS of 15 ports is not exceeded. Leaves the system configured in this way:
      Enabled all USB2 ports that are not part of a USB3 port (1 internal for BT + 4 rear that are together + 2 on the front) Enabled the USB2 ports that are part of the 2 rear red USB3.1 ports Disabled the USB2 ports that are part of the 4 rear blue USB3 ports Enabled all USB3 ports except the internal one for USB type C connection. Summary: Rear blue ports do not recognize USB2 devices.

      NOTE 2: XHCI-unsupported.kext is required for XHC chipsets whose Device ID is not included in macOS. Depending on the USB driver of your board, it may be necessary to install some additional extension:
      8086: 8CB1 on macOS 10.11.1 or lower: XHCI-9-series.kext 8086: 8D31, 8086: A2AF, 8086: A36D, 8086: 9DED: XHCI-unsupported.kext 8086: 1E31, 8086: 8C31, 8086: 8CB1, 8086: 8D31, 8086: 9C31, 8086: 9CB1: FakePCIID.kext + FakePCIID_XHCIMux.kext. This board (generally Z390 chipset boards) carries the USB 3.1 controller with device ID A36D so the XHCI-unsupported kext is required. You can check your device ID at
      /System/Library/Extensions/IOUSBHostFamily.kext/Contents/Plugins/AppleUSBXHCIPCI.kext/Contents/Info.plist Config.plist file

      The differential options are:

      Acpi> DSDT: change HECI to IMEI / change SAT0 to SATA
      Acpi> Fixes: FixShutdown
      Acpi> Drop OEM_DSM
      Acpi> Drop Tables> DMAR / MATS
      Acpi> SSDT> PluginType selected (Plugin Type number blank)
      Acpi> Halt Enabler / FixHeaders

      Boot> Boot Arguments> slide = 0 / darkwake = 8

      Devices> USB> Inject / FixOwnership / HighCurrent
      Devices> Audio> Inject 11

      Kernel and Kext Patches> Apple RTC and KernelXCPM selected
      Kernel and Kext Patches> KextsToPatch> Name: com.apple.driver.AppleAHCIPort / Find: 40600200 / Replace: 00000000 / Comment: SATA hot plug
      Kernel and Kext Patches> KextsToPatch> Name: com.apple.driver.AppleAHCIPort / Find: 45787465 726E616C / Replace: 496E7465 726E616C / SATA orange icons

      SMBIOS> iMac19.1

      System Parameters> Inject Kexts: Yes / Inject System ID: selected.

      Quirks > select AvoidRuntimeDefrag – DevirtualiseMmio – EnableSafeModeSlide – ForceExitBootServices – ProtectUefiServices – ProvideConsoleGopEnable – ProvideCustomSlide – SetupVirtualMap – SyncRuntimePermissions and set ProvideMaxSlide = 0. *

      Set true DevirtualiseMmio and ProtectUefiServices in OcQuirks.plist file (recommended on Z390 mother boards).

      * see OC Quirks below.

      macOS Catalina install

      There are many publications with instructions so I will only comment on a few specific details.
      The installation USB memory must have a GUID partition scheme so that the board's UEFI can boot from it. I have prepared the USB with the createinstallmedia method + the application "Install macOS Catalina" in the Applications folder The device is USB 3 and, connected to the front USB 3 port, it performs the task quite quickly I have used Clover r5121 which is currently the latest version. The EFI folder of the installation USB can be the same as that of the hard disk with 2 differences: Acpi> SSDT> PluginType deselected and Acpi> Boot leave Default Boot Volume blank and Timeout -1 (so that no volume will boot automatically from the Clover menu). To mount the EFI partition (of the disk or the USB device) I have used Clover Configurator which makes this task very simple or the command line (diskutil), first finding out what disk and partition number is the EFI (diskutil list) and showing it later (mountdisk):
      sudo diskutil list
      sudo diskutil mountdisk / dev / disk2s3  
      RX 580

      Although my RX 580 card is a model from the XFX brand, known for using custom VBios and giving problems in macOS, in my case it seems to work well with Lilu and WhatEverGreen. Booting the operating system it does not show artifacts, the 3 DP ports and the only HDMI port work, you can send the image simultaneously to 2 screens (I have not tried more) with the usual duplication options, yo can send sound in addition to image to one TV by HDMI, during the installation of the operating system it works correctly provided that Lilu and WhatEverGreen are in the USB device, etc. GeekBench 5 Scores: Metal 50100 / OpenCL 44100. As a comparison, the integrated card does not reach 4800 in Metal.
      Regarding the hardware decoding of H264 and HEVC videos, the Hackintool tool and the VideoProc application report that it is not supported although the playback of files of both types with rates of up to 20 mbps is correct so I suspect that it actually encodes well. In order for hardware decoding to appear as supported in the commented applications, the integrated Intel Graphics 630 card must be enabled even if it is disconnected in headless mode (using the RX 580 card as primary sending image to the screen).
       


      Sound

      This board incorporates the Realtek ALC1220 chip that needs the AppleALC extension to work. AppleALC is a Lilu plugin so both must be properly installed.
      Note: Clover > Devices > Audio > Inject 11 or 13 or 15. I’ve tried several layouts and this are the only valid at least in my case.
      Some users have commented that the system does not load AppleALC and they have no sound despite having the extensions in EFI / CLOVER / kexts / Other. In these cases it can be successful to install AppleALC and Lilu in / Library / Extensions and rebuild the extensions cache with Hackintool (a very convenient way to do it) or with this Terminal command:
      sudo spctl --master-disable; sudo mount -uw /; killall Finder; sudo chown -v -R root: wheel / System / Library / Extensions; sudo touch / System / Library / Extensions; sudo chmod -v -R 755 / Library / Extensions; sudo chown -v -R root: wheel / Library / Extensions; sudo touch / Library / Extensions; sudo kextcache -i /  
      What this command does is disable Gatekeeper, mount the system disk in read / write mode, repair permissions on the extensions folders and rebuild the cache. But all of that is done by Hackintool with less work on our part.

      Ethernet

      This board carries the Intel I219V chip that works well with the IntelMausiEthernet extension.

      Wifi & Bluetooth

      I use a Fenvi FV T-919 mini PCI-E card that carries both wifi and bluetooth chips. This card works perfectly in macOS without needing anything other than placing it on the board because it is recognized as Airport Extreme and Bluetooth Apple. Has its own article on perez987.

      Disks

      Samsung EVO 860 SSD. It is a solid state disk with references to work well in Mac. In my case it works well, with a read speed of 430 and a write speed of 250. I have tried faster SSDs but they have given problems to install Catalina, instead with the EVO 860 everything has worked perfectly.

      Integrated graphics

      Integrated Intel Graphics 630 card: we can to make it work correctly by adding some properties in Clover's Devices tab. For it to work you have to:

      - enable it on the board as primary graphics: Initial Display Output IGFX instead of PCIe 1 Slot (actually this is the final step after modifying config.plist)
      - add in config.plist: Boot> Boot Arguments> igfxonln = 1
      - apply a patch (video and audio) in config.plist: Devices> Properties. It is easier to do it from the config.plist file in text mode than from Clover Configurator. With the file open as text find the lines
      <key>Audio</key> <dict> <key>ResetHDA</key> <false/> <key>Inject</key> <integer>11</integer> </dict>  
      Immediately above of them paste this text:
      <key>Properties</key> <dict> <key>PciRoot(0x0)/Pci(0x1F,0x3)</key> <dict> <key>layout-id</key> <data>CwAAAA==</data> <key>model</key> <string>Cannon Lake HDMI</string> <key>hda-gfx</key> <string>onboard-2</string> <key>AAPL,slot-name</key> <string>Internal@0,31,3</string> <key>device_type</key> <string>Audio device</string> </dict> <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>framebuffer-con0-busid</key> <data>AAAAAA==</data> <key>framebuffer-con0-type</key> <data>AAgAAA==</data> <key>framebuffer-con2-flags</key> <data>xwMAAA==</data> <key>model</key> <string>Intel UHD Graphics 630</string> <key>framebuffer-con1-busid</key> <data>AAAAAA==</data> <key>device-id</key> <data>kT4AAA==</data> <key>framebuffer-con2-type</key> <data>AAgAAA==</data> <key>framebuffer-con2-busid</key> <data>BAAAAA==</data> <key>device_type</key> <string>Display controller</string> <key>hda-gfx</key> <string>onboard-1</string> <key>framebuffer-patch-enable</key> <data>AQAAAA==</data> <key>framebuffer-con1-type</key> <data>AAgAAA==</data> <key>AAPL,slot-name</key> <string>Internal@0,2,0</string> <key>AAPL,ig-platform-id</key> <data>BwCbPg==</data> <key>framebuffer-con2-enable</key> <data>AQAAAA==</data> <key>framebuffer-con1-enable</key> <data>AQAAAA==</data> <key>framebuffer-con0-enable</key> <data>AQAAAA==</data> </dict> </dict> But the system crashes when comes out of sleep mode (the PC restarts after a few seconds of leaving sleep mode). This behavior occurs if the cable that comes out from the HDMI port on the motherboard (the only existing connector on this Mobo) plugs in a DisplayPort port on the monitor; if it plugs directly into another HDMI port (monitor or TV) the bug does not occurs and the PC goes in and out of sleep normally.

      Currently the only way to have the graphics card connected to a port other than HDMI without this crash is by replacing the "hda-gfx" property with "no-hda-gfx" in the above code of config.plist. The 2 lines
      <key>hda-gfx</key> <string>onboard-2</string> must be replaced by
      <key>No-hda-gfx</key> <data>AAAAAAAAAAA=</data> After adding this property, you will no longer have sound over HDMI / DP but sleep works very well.

      In summary:
      - Intel HDMI to DisplayPort monitor> has HDMI audio output but has kernel panic when coming from sleep
      - Intel HDMI to HDMI TV> has HDMI audio output and sleep works fine
      - Intel HDMI to DisplayPort monitor with "no-hda-gfx"> sleep works fine but HDMI audio output is lost.

      (based on the post "[GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)" by CaseySJ; thanks also to deeveedee for his help).

      This card can be left activated without connection to the monitor (headless mode) and apparently does not show any interference with the rest of the system.

      With the integrated card as the main card, the system shows enabled both graphics cards and allows to have a screen connected to the Intel 630 via HDMI and a different screen connected to the RX 580 via DP or HDMI, in this case the primary screen is that from the Intel and the other only works when the graphics driver is loaded but, once the system is up and running, the screens allow duplication options as if they depend on a single card.
       
       
       
       
       
      Evolution to Oc Quirks

      OC Quirks is an EFI driver for Clover that replaces AptioMemoryFix and all OsxAptioFix variants. It supports the OpenCore quirks model. AptioMemoryFix has evolved little in the most recent stage and is in a way becoming obsolete. Next versions of Clover will probably stop installing AptioMemoryFix and switch to OC Quirks which is evolving and receiving frequent improvements. You can read about this on the working group website: ReddestDream.

      Migrating our installation from AptioMemoryFix to OC Quirks is relatively simple:
      download the latest version of OC Quirks (search Releases, current version is 23) have a USB device that boots up properly to use in case of failure mount the disk's EFI partition delete AptioMemoryFix and any other OsxAptioFix variant add OcQuirks.efi, OpenRuntime.efi and OcQuirks.plist to Clover's drivers/UEFI folder change to true DevirtualiseMmio and ProtectUefiServices in the file OcQuirks.plist (recommended on boards with Z390 chipset) in Clover> Quirks config.plist file, check the boxes AvoidRuntimeDefrag - DevirtualiseMmio - EnableSafeModeSlide - ForceExitBootServices - ProtectUefiServices - ProvideConsoleGopEnable - ProvideCustomSlide - SetupVirtualMap - SyncRuntimePermissions and assign the value 0 to ProvideMaxSlide Restart the PC.  
      Kernel Panic with BIOS F10c if integrated graphics is enabled

      The Z390 Aorus Elite board comes with BIOS F9 with which the text of this post has been written.

      A few days ago I updated to the current version which is F10c and, since then, I have suffered a kernel panic with the forbidden symbol when going from the Clover menu to the macOS boot screen if the integrated card was enabled in BIOS. This happened regardless of whether the Intel UHD Graphics 630 card was set to Clover (fully for monitor output or headless mode for encoding) or not.

      Returning to BIOS F9 the system has returned to working as before and the kernel panic has disappeared. I can have the card enabled or disabled again in BIOS without problems.
       
      efi-quirks.zip
    • By lizdav
      Hi,
       
      I would like to ask for some advice or help even.
       
      I have had some usability issues in the past with my hackintosh so I installed Mojave for the second time but it keeps producing the same exact problem. Most of the time the system stutters and lags after login. The app icons just bounce if I want to open them and even if it does it takes forever. Another thing I picked up on is that it seems like there's no internet access whenever this occurs. The problem ceases after like 2-3 restarts and everything is back to normal. 
       
      What could cause an issue like this? I had the same thing happening with my previous install but I thought that was because of unnecessary kexts I left in the EFI. I only have the bare minimum required this time so I'm kinda lost.
       
      Computer specs:
       
      Mobo: Gigabyte B360M D3H
      Graphics: Radeon Vega 64 8OC
      CPU: Intel i7 8700k
      Ram: 32 Gig
      SSD: Samsung Evo 860 250gb
       
      I also have a separate HDD with Windows 10 installed for gaming purposes. I would greatly appreciate any kind of help, thanks in advance!
       
      –David
       
       
      config.plist
    • By Forzenny
      Hi there,
       
      I managed to install Mojave on my MSI GP62-6QE laptop with somewhat success. The only annoying thing left is that everytime I shut it down it seemingly kernel panics and I get the "Your computer has restarted because of a problem" at startup.
       
      I tried many different things such as removing emuvariablesuefi64, checking FixShutdown in CloverConfig but it seems the NVRAM is causing this issue.
       
      I have deleted the nvram file from the EFI partition but it seems stuck somewhere else, I can't clear out the nvram from the terminal or in single user mode as it returns a "Not permitted" error.
      Clearing out the nvram by pressing F11 at the boot menu screen works however.
      crashlog.rtf
×