Jump to content
Sign in to follow this  
Followers 0
Electromaniac

Machine won't shutdown MacBook Pro 2012

3 posts in this topic

Recommended Posts

Hello.

 

I've installed build 18A314k on two MacBook Pros
Home machine is Mid2012 15" non-Retina model and work machine is also Mid2012 15" Retina.
Both have almost same configuration i7 8GB RAM but Retina has SSD, while non-Retina has HDD.
They are upgraded from High Sierra and data is preserved, but I didn't have enough space or external drive to make Time Machine backup. 
Work machine doesn't show any issues, but my home machine has several issues and I hope someone has an idea to solve this. Some of these issues I have reported to Apple, hope they will fix it.

- System is laggy and can become unresponsive for short time, that means wheel is spinning and everything is frozen, but it comes back to functional state after several minutes
- Lock screen has no image, it's gray. No matter what I've tried, turn transparency on/off, change different wallpapers etc. On login screen where I select users it has default Mojave background, however when I select user it doesn't change background.
- Some parts of UI still doesn't have Dark Mode applied. Mostly 3rd party apps e.g. Firefox Developer Edition has Open file menu still in Light Mode when choosing Image to Upload...
- What is this Yara Scan Service, it seems to increase disk usage and grows swap space...
- Laptop is unable to shutdown or restart properly. It closes apps (well, it seems so) and blank screen is shown with spinner spinning. Instead of shutting down after a minute or two it keeps spinning forever. 

Does anyone have this shutdown issue and anything one can do to resolve the problem?
It surely hangs as it generates shutdown stall log. Here's the log: https://pastebin.com/Hq8tcC3v

I've tried different suggestions so far like clearing the SMC/PRAM/NVRAM, and last suggestion made system unbootable to clean the ~/Library/Caches folder. I was lucky to still have data after reinstall, so I'm not going to try this again.

Three processes are showing up here: iogdiagnose, spindump, system_profiler and warmd (zombie). I think suspect is warmd since it is only suspended process which is still alive.

Any suggestion will be appreciated. Thanks.

Share this post


Link to post
Share on other sites
Advertisement

Maybe help

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 5
sudo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 5
sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 5
sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 5
sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 5
Edited by wodawoda

Share this post


Link to post
Share on other sites

On a Mac without an eject key, you can force your computer to shut down at any point by pushing Command + Control + Option + Power button. Before you resort to this, first try a force quit on a problem application by pushing Command + Option + Esc.


regarding any issue with mac get help from this 

apple customer support number

 

mac.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×