Jump to content
Montelli

[Problem] High Sierra 10.13.5 black screen after apple loading

9 posts in this topic

Recommended Posts

Greetings,

I upgraded clover at 4586 and my pcdesktop from high sierra 10.13.2 at 10.13.5 with comboupdate from apple site...after loading apple the screen remains black it seems to lose the signal or something...how can I fix it?

video card has always worked with readeonDelNit

Thank you

 

i7-8700K  
Asus Rog Strix z370-E  
Asus rog rx 560 O4G Gaming  
M.2 Nvme Samsung 960 Evo 250GB

 

screen1.thumb.png.876550f5cb9de4401b9529ed91857e1b.pngscreen2.thumb.png.4182ab2773e27e67c1561ecf078e3684.png

Share this post


Link to post
Share on other sites
Advertisement
5 hours ago, Montelli said:

Greetings,

I upgraded clover at 4586 and my pcdesktop from high sierra 10.13.2 at 10.13.5 with comboupdate from apple site...after loading apple the screen remains black it seems to lose the signal or something...how can I fix it?

video card has always worked with readeonDelNit

Thank you

 

i7-8700K  
Asus Rog Strix z370-E  
Asus rog rx 560 O4G Gaming  
M.2 Nvme Samsung 960 Evo 250GB

Hi @Montelli

Ever since macOS 10.13.4 came out we don't need to use RadeonDeInit or any other patch on many AMD GPUs, they will work OOB (almost).

 

I have the same GPU as you do and it needs a little bit more push to work flawlessly and here's how:

 

1. First remove these flags from the "Boot" section in your config.plist you don't need them anyway: nvda_drv=1 and kext-dev-mode=1 and also remove the RadeonDeInit from the "Graphics" Section

2. You need to add these flags under the Graphics section in your config.plist : Inject ATI you can also use the framebuffer Acre or just use WhateverGreen.kext+Lilu which I don't recommend

3. add the following patch under the "Kernel and Kext Patches"

    

Name: com.apple.driver.AppleGraphicsDevicePolicy

Find: BA050000 00

Replace: BA000000 00

Comment: Disable board-id check to prevent no signal

 

If I use the framebuffer Acre for my RX 560 or the framebuffer Orinoco for my RX 580, I will get a reddish color on the menu bar and it's annoying but without the framebuffer it works good on both my RX 580 and RX 560 GPUs. I guess Asus is using a modified version of a VBIOS on their cards which ends up in this behavior.

 

Goof Luck.

Share this post


Link to post
Share on other sites

Hi @Cyberdevs Thanks for the support,

I read your answer now, but a friend told me to put next to lilu.kext also WhateverGreen.kext and leave the file config unchanged...then now the video signal is back and works properly at least I think..

why did you recommend this method here and not lilu + WhateverGreen?
I await your response, thank you

Share this post


Link to post
Share on other sites
On 7/1/2018 at 3:41 PM, Montelli said:

Hi @Cyberdevs Thanks for the support,

I read your answer now, but a friend told me to put next to lilu.kext also WhateverGreen.kext and leave the file config unchanged...then now the video signal is back and works properly at least I think..

why did you recommend this method here and not lilu + WhateverGreen?
I await your response, thank you

Hi there, Sorry for the delay on the reply I didn't get any notifications on your posts.

Lilu+WhateverGreen work fine but with a cost. WhateverGreen will affect the GPU's performance and slows it down. I did lost of benchmarks and sometimes they will differ upto 700 points in LuxMark.

The patch simply changes the config map of the AGDP which is the root cause for the black screen issue on several SMBIOS settings.

 

You can use whichever method that suits you best I just shared what I have experienced :)

Share this post


Link to post
Share on other sites

Hi @Cyberdevs, I thank you for sharing your experience and I bring back some screens :) ..I made benchmark OpenCL GPUs with LuxMark, four times with patches and four with whateveregreen


I deleted whatevergreen but I kept lilu (for the audio I think) and I applied the patch and I did not use the Acre framebuffer I do not know where it fits,

mm there does not seem to be much difference in scoring between patch and whatevergreen..

It's right?

 

+with patch

Spoiler

1281144997_withpatch.png.42f1fc0974f38e02afb6a2174d59e4d5.png1193349513_withpatch1.thumb.png.f242fc9b421013f1f7a1403ea90f66f4.png1281094338_withpatch2.thumb.png.e063bede56aa28a545924dca9f52552a.png223729376_withpatch3.thumb.png.cbe11c0320e43712c2401524ab1f64cb.png

 

+with wahtevergreen

Spoiler

208606027_withwhatevergreen.png.9657fee43b0b770bb7247ea6b74d6b9e.png1406946887_withwhatevergreen1.png.60b4d80a86ebf73e98537fa7eef5b0a1.png1270941496_withwhatevergreen2.png.c30dcfc2ea132fc850be600afad1a4d7.png915339997_withwhatevergreen3.png.fccb1fbf4c3dabd4683f1a13ed74e36a.png

Edited by Montelli

Share this post


Link to post
Share on other sites
On 7/4/2018 at 10:24 PM, Montelli said:

Hi @Cyberdevs, I thank you for sharing your experience and I bring back some screens :) ..I made benchmark OpenCL GPUs with LuxMark, four times with patches and four with whateveregreen


I deleted whatevergreen but I kept lilu (for the audio I think) and I applied the patch and I did not use the Acre framebuffer I do not know where it fits,

mm there does not seem to be much difference in scoring between patch and whatevergreen..

It's right?

 

Hi @Montelli

Well it seems that there's a slight difference in the LuxMark's results but it's not that much and besides if that's not that noticeable you can use the WEG if you like it really reduces the headaches :)

If your GPU is performing as it should you don't need to use the Acre framebuffer, macOS will automatically load the default framebuffer for your GPU.

When it comes to hackintosh you can use whatever that works for you because there are lots of factors in play and the milage may vary from one user to another.

 

I'm just glad that the issue is resolved now :)

Share this post


Link to post
Share on other sites
10 hours ago, Cyberdevs said:

 

Hi @Montelli

Well it seems that there's a slight difference in the LuxMark's results but it's not that much and besides if that's not that noticeable you can use the WEG if you like it really reduces the headaches :)

If your GPU is performing as it should you don't need to use the Acre framebuffer, macOS will automatically load the default framebuffer for your GPU.

When it comes to hackintosh you can use whatever that works for you because there are lots of factors in play and the milage may vary from one user to another.

 

I'm just glad that the issue is resolved now :)

Ok, thank fi support!;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×