Jump to content
Ajoy karmakar

Nvidia IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0 error

95 posts in this topic

Recommended Posts

I am able integrate nvidia using nvidia hdmi port. I have to add nvda_drv =0 and nv_disable=1. Now the graphics is horrible. I have already installed nvidia web driver and select graphics driver - nvidia web driver.

IMG_20180704_233716.jpg

Screen Shot 2018-07-04 at 11.00.43 AM.png

And if I replace nvda_drv=1 and remove nvdisable then boot but stuck at black screen with a active cursor.

Edited by Ajoy karmakar

Share this post


Link to post
Share on other sites
Advertisement
59 minutes ago, Ajoy karmakar said:

I am able integrate nvidia using nvidia hdmi port. I have to add nvda_drv =0 and nv_disable=1. Now the graphics is horrible. I have already installed nvidia web driver and select graphics driver - nvidia web driver.

And if I replace nvda_drv=1 and remove nvdisable then boot but stuck at black screen with a active cursor.

nv_disable=1 simply disables the nVidia GPUs drivers being loaded by macOS but with nvda_drv=1 (which I think is deprecated) they get loaded, have you tried adding NvidiaWeb in config.plist under the System Parameters?

Share this post


Link to post
Share on other sites
5 minutes ago, Cyberdevs said:

have you tried adding NvidiaWeb in config.plist under the System Parameters?

Yesss

Share this post


Link to post
Share on other sites

I have managed to fix the resolution of the screen and also bios screen. Just need to accelerate with Nvidia driver which can't boot with nvda_drv = 1 , Boot only with nv_disable =1

1692307210_ScreenShot2018-07-07at2_07_08AM.thumb.png.0247a699fe91c3eb4d59aebcfa9fd565.png

Share this post


Link to post
Share on other sites
57 minutes ago, Ajoy karmakar said:

I have managed to fix the resolution of the screen and also bios screen. Just need to accelerate with Nvidia driver which can't boot with nvda_drv = 1 , Boot only with nv_disable =1

Which OsxAptioFix driver are you using?

If you are using OsxAptioFixDrv or OsxAptioFix2Drv you need to add the EmuVaraiableUEFI.efi to your config.plist as well.

Share this post


Link to post
Share on other sites

Hello, Cyberdevs thanks for the support. insanelymac is the best forum for new bae hackintosher. i will recommend everyone Insanelymac. And I have succeeded to installed Sierra on my machine and it's working fine with this graphics cards. Just one thing to ask that can I adjust the brightness of the screen?

 

Screen Shot 2018-08-13 at 12.png

Edited by Ajoy karmakar

Share this post


Link to post
Share on other sites
18 minutes ago, Ajoy karmakar said:

Hello, Cyberdevs thanks for the support. insanelymac is the best forum for new bae hackintosher. i will recommend everyone Insanelymac. And I have succeeded to installed Sierra on my machine and it's working fine with this graphics cards. 

Hello @Ajoy karmakar

You're welcome :)

I'm glad that your hack is up and running ;)

Edited by Cyberdevs

Share this post


Link to post
Share on other sites

Hello @Cyberdevs, Can you please guide me on how to control the brightness of the screen? Some experts said that it's impossible to control on pc and I have remembered that you said that we can do but it's very tricky.

Share this post


Link to post
Share on other sites
1 hour ago, ajoykarmakar said:

Hello @Cyberdevs, Can you please guide me on how to control the brightness of the screen? Some experts said that it's impossible to control on pc and I have remembered that you said that we can do but it's very tricky.

Take a look at this post it might help you. I have to say that it didn't work on my rig anyways but the only working solution so far is described in this post:

https://www.insanelymac.com/forum/topic/333876-brightness-not-working-on-wake-on-desktop-pc-locked-level-from-prior-to-sleep/?do=findComment&comment=2610430

Share this post


Link to post
Share on other sites

Hello @Cyberdevs,

I am thinking about to upgrade my graphics card. So I can build my .ipa to the latest version of iOS supported. So should I buy this graphics card or can you suggest the best graphics card that best suit my system and even play the latest games with that?

Name - Zotac GeForce GTX 1050 Ti OC Edition ZT-P10510B-10L 4GB PCI Express Graphics Card

 

 

Screen Shot 2018-09-08 at 11.43.47 AM.png

Share this post


Link to post
Share on other sites
28 minutes ago, ajoykarmakar said:

Hello @Cyberdevs,

I am thinking about to upgrade my graphics card. So I can build my .ipa to the latest version of iOS supported. So should I buy this graphics card or can you suggest the best graphics card that best suit my system and even play the latest games with that?

Name - Zotac GeForce GTX 1050 Ti OC Edition ZT-P10510B-10L 4GB PCI Express Graphics Card

Hi there,

I personally suggest using AMD GPUs instead of nVidia if you want to buy a 1050 TI I recommend using RX 580 or Vega (Sapphire and PowerColor) which are the best choices. AMD has full and native support in macOS and there's no need to wait and install nVidia WebDrivers after each macOS update.

 

But if you insist of using nVidia 1050 TI and 1060 TI are more reasonable in price rather than the 1070 or 1080.

Share this post


Link to post
Share on other sites

Hello, thank you for the reply but still, I didn't change the graphics card because Mac OS released a new version Mojave. Before upgrading I want to know is Mojave work with Nvidia gt730 4gb ddr3 128 bit graphics card? and one more thing after downloading the os from the apple store and after the upgrade, if I faced any problem can I reverse all the things like I have before upgrading the OS?  I know only you can assist me with the best things as you already did in previous time.

Share this post


Link to post
Share on other sites
10 minutes ago, ajoykarmakar said:

Hello, thank you for the reply but still, I didn't change the graphics card because Mac OS released a new version Mojave. Before upgrading I want to know is Mojave work with Nvidia gt730 4gb ddr3 128 bit graphics card? and one more thing after downloading the os from the apple store and after the upgrade, if I faced any problem can I reverse all the things like I have before upgrading the OS?  I know only you can assist me with the best things as you already did in previous time.

Hi there, how is it going?

 

If your GPU needs thawed drivers DON'T update to Mojave until nVidia releases the new web drivers because they haven't release them for macOS Mojave.

To answer your second question, the EFI folder (a working EFI folder) is all you need, if you make backups and keep it updated you can use it to install, re-install, upgrade, downgrade to any version of macOS that you like as long as your hardware is supported by macOS.

Share this post


Link to post
Share on other sites

Hello, the mac is working fine in sierra version and now I don't need any web driver to run the graphics card still is it risky to upgrade the Mojave version? Actually, I didn't sure this graphics card is worked well or not in Mojave because in Sierra it's working absolutely fine but in high Sierra, it's not working.

Share this post


Link to post
Share on other sites
3 hours ago, ajoykarmakar said:

Hello, the mac is working fine in sierra version and now I don't need any web driver to run the graphics card still is it risky to upgrade the Mojave version? Actually, I didn't sure this graphics card is worked well or not in Mojave because in Sierra it's working absolutely fine but in high Sierra, it's not working.

Yeah if you couldn't manage to get it to work on High Sierra it might not be easy to activate it on Mojave and besides Mojave has some new issues with systems GPU regarding the preview and quick look.

look here:

https://www.insanelymac.com/forum/topic/334881-how-to-fix-quick-look-and-preview-issues-in-mojave/

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same issue on laptop up ProBook 6360b:

Intel Core I5-2520M

Intel HD 3000

trying to install Mac OS 10.12.6 Sierra

image.jpg

Edited by Ivan T

Share this post


Link to post
Share on other sites

Hello 

 

My Config is

 

Intel core i5 9400f
Gigabyte z390 aorus Pro Wifi Motherboard (with latest BIOS version F9a)
8gb x 2 Corsair Vengeance Ram 3000 Mhz
Zotac GTX 1060 Amp! Edition 6gb (Dual Fan)
1 TB Baracuda Hard Disk
Corsair Spec Delta Atc Cabinet
TP-Link w832n USB Wifi Dongle for wifi 

 

macOS Sierra 10.12.6 (16G29)

 

I am able to get onboard audio, bluetooth, ethernet and all USB ports working.

 

But as I install Nvidia web drivers and input boot flag "nada_drv=1" my screen gets stuck at 

 

IOConsoleUsers : time(0) 0->0, Lin 0, lik 1

IOConsoleUsers : gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

 

Please help me 

 

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×