Jump to content
C.Frio

Mojave..G210, (Tesla)

27 posts in this topic

Recommended Posts

hi..

 

does anyone has experience with Mojave and Nvidia G210 ?

thank you

c.frio

 

EDITED by moderator

see post #8

 

Share this post


Link to post
Share on other sites
Advertisement

I would also like to know. I tried to install Mojave and the installation went through, but I had no graphics acceleration, the only resolution available was 1280x1024. @Gigamaxx suggested using graphics kexts from 10.13.5, but unfortunately I wasn't able to achieve anything that way, maybe he succeeded. 

Share this post


Link to post
Share on other sites

Mojave requires Metal API compatible GPUs, so anything below Intel HD4000/ Nvidia Kepler/ AMD 7xxx Series will not work OOB. I heard that there is an OpenCL renderer hidden by default but don't know how it will affect things

Share this post


Link to post
Share on other sites

OpenCL hidden or not, if Apple removed the kext(s) (or the support) for no-metal gpu's, barring a miracle, it will never work - unless if nvidia (in our case here) or someone else provides the kext(s) in question.  :)

Share this post


Link to post
Share on other sites
Posted (edited)

What would be the hackintosh successor of gt 210? Card to go with if you don't  need anything powerful, card which is cheap and reliable, which supports metal and works oob? GT 610, GT 620 maybe?

Edited by Morpheus NS

Share this post


Link to post
Share on other sites

hi..

would be more secure..wait for the final  release to 

make a decision...

c.frio

Share this post


Link to post
Share on other sites
Posted (edited)
Quote

I was able to get dock/menu bar translucency with Mojave Beta 3 on my legacy XPS M1530 laptop (system no 3 in sig, Core2Duo Penryn with NVidia 8600M GT) after following @AsentientBot's instructions in post#2082 and using his patched GeforceTesla.kext from post#2125.  This stopped the kps after login when using HS Nvidia legacy kexts

 

Base on ASentientBot's great job.

If you want to use latest version kexts all from 10.13.6, you can patch it by yourself.

GeForceTesla.kext/Contents/MacOS/GeForceTesla

 

Old Method : GeforceTesla.kext from post#2125.

Find
554889e553504889fb83bb38030000007426488b03488bb3e80000004889dfff90c8050000488b03488bb3e80000004889dfff907806000031c04883c4085b5d
Replace
6666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000000f1f4000

or perl patch code.

perl -pi -e 's|\x55\x48\x89\xe5\x53\x50\x48\x89\xfb\x83\xbb\x38\x03\x00\x00\x00\x74\x26\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\xc8\x05\x00\x00\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\x78\x06\x00\x00\x31\xc0\x48\x83\xc4\x08\x5b\x5d|\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x0f\x1f\x40\x00|g' GeForceTesla.kext/Contents/MacOS/GeForceTesla

New Method : GeforceTesla.kext from post#2529 .

Find
488b07ff90c0000000
Replace
488b07660f1f440000

or perl patch code.

perl -pi -e 's|\x48\x8b\x07\xff\x90\xc0\x00\x00\x00|\x48\x8b\x07\x66\x0f\x1f\x44\x00\x00|g' GeForceTesla.kext/Contents/MacOS/GeForceTesla

the patch code is the same as ASentientBot provided 10.13.4 patched GeforceTesla.kext.

You need only one method between Old Method and New Method, each of them works fine here.

 

10.13.6 kexts works fine as below,

GeForceGA.bundle

GeForceTesla.kext ..... (patched)
GeForceTeslaGLDriver.bundle
GeForceTeslaVADriver.bundle
NVDANV50HalTesla.kext
NVDAResmanTesla.kext

IOGraphicsFamily.kext
IONDRVSupport.kext

 

or

 

You can try to use NDRVShim.kext instead of replacing IONDRVSupport and IOGraphicsFamily post#1875, get NDRVShim.kext from post#1865, at /Volumes/macOS Mojave Patcher/macOS Mojave Patcher.app/Contents/Resources/macOS Post Install.app/Contents/Resources/legacynvidia/NDRVShim.kext

 

And need to edit NVDAResmanTesla.kext/Contents/Info.plist to add the following string.

        <key>com.parrotgeek.NDRVShim</key>
        <string>1</string>

	<dict>
		<key>com.apple.iokit.IOGraphicsFamily</key>
		<string>1.5</string>
		<key>com.parrotgeek.NDRVShim</key>
		<string>1</string>
		<key>com.apple.iokit.IONDRVSupport</key>
		<string>1.5</string>
		<key>com.apple.iokit.IOPCIFamily</key>
		<string>2.4</string>
		<key>com.apple.kpi.bsd</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.iokit</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.libkern</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.mach</key>
		<string>9.0.0</string>
	</dict>

10.13.6 kexts works fine as below,

GeForceTesla.kext ..... (patched)
GeForceTeslaGLDriver.bundle
GeForceTeslaVADriver.bundle
NVDANV50HalTesla.kext
NVDAResmanTesla.kext ..... (edit Info.plist)

NDRVShim.kext ..... (added)

 

If you still have troube, try the following 10.13.6 kexts too.

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext

Refer to /Volumes/macOS Mojave Patcher/macOS Mojave Patcher.app/Contents/Resources/macOS Post Install.app/Contents/Resources/legacyGPUPatch.sh

credits to: ASentientBot, parrotgeek1, dosdude1.

 

And My nVidia 9300GE always need to fix reboot error with NVDAStartup.kext.310.42.25f01.zip from nawcom since 10.12.

 

Download all the patche kexts here. All works fine here too.:yes:

It's better to use Kext Utility.app to install kexts.

 

GeForce1014-10136.gif.a5c662ffea18a0a804497fc601a0d928.gif

 

Edited by crazybirdy

Share this post


Link to post
Share on other sites
2 hours ago, crazybirdy said:

 

Base on ASentientBot's great job.

If you want to use latest version kexts all from 10.13.6, you can patch it by yourself.

 

GeForceTesla.kext/Contents/MacOS/GeForceTesla


Find
554889e553504889fb83bb38030000007426488b03488bb3e80000004889dfff90c8050000488b03488bb3e80000004889dfff907806000031c04883c4085b5d
Replace
6666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000000f1f4000

or perl patch code.


perl -pi -e 's|\x55\x48\x89\xe5\x53\x50\x48\x89\xfb\x83\xbb\x38\x03\x00\x00\x00\x74\x26\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\xc8\x05\x00\x00\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\x78\x06\x00\x00\x31\xc0\x48\x83\xc4\x08\x5b\x5d|\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x0f\x1f\x40\x00|g' GeForceTesla.kext/Contents/MacOS/GeForceTesla

the patch code is the same as ASentientBot provided 10.13.4 patched GeforceTesla.kext.

 

10.13.6 kexts works fine as below,

GeForceGA.bundle
GeForceTesla.kext
GeForceTeslaGLDriver.bundle
GeForceTeslaVADriver.bundle
IOGraphicsFamily.kext
IONDRVSupport.kext
NVDANV50HalTesla.kext
NVDAResmanTesla.kext

 

And My nVidia 9300GE always need to fix reboot error with NVDAStartup.kext.310.42.25f01.zip from nawcom since 10.12.

 

Thanks @crazybirdy.

 

He's just posted a newer/simpler patched GeForceTesla.kext that also seems to work well (attached to post#2529 in macrumors thread :thumbsup_anim:)

Share this post


Link to post
Share on other sites
1 hour ago, fusion71au said:

 

Thanks @crazybirdy.

 

He's just posted a newer/simpler patched GeForceTesla.kext that also seems to work well (attached to post#2529 in macrumors thread :thumbsup_anim:)

 

Great, New Method : GeforceTesla.kext works fine here too, patch code updated. :thumbsup_anim::)

Share this post


Link to post
Share on other sites
21 hours ago, crazybirdy said:

@crazybirdy,

I have attempted the above method and my kext load but no graphics acceleration in Mojave .

Any help on this front my, specs are in sig. and I have a gt 320m.

I had accélération once but lost it at next boot and now I cannot get it at all.

 

Thanks Macq

 

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, macq said:

@crazybirdy,

I have attempted the above method and my kext load but no graphics acceleration in Mojave .

Any help on this front my, specs are in sig. and I have a gt 320m.

I had accélération once but lost it at next boot and now I cannot get it at all.

 

Thanks Macq

 

 

This method is work, only if your nVidia card was worked fine on 10.13.6 with those native kexts.

Otherwise, I don't think it will work for your nVidia card.

I don't have the same card as yours, I can't tell you how to make it work.

--

If you have graphics acceleration once, you may remove all the kexts, rebuild prelinkedkernel and reboot,

then, patch the kext, install the kext again.

Edited by crazybirdy

Share this post


Link to post
Share on other sites
1 hour ago, crazybirdy said:

 

This method is work, only if your nVidia card was worked fine on 10.13.6 with those native kexts.

Otherwise, I don't think it will work for your nVidia card.

I don't have the same card as yours, I can't tell you how to make it work.

--

If you have graphics acceleration once, you may remove all the kexts, rebuild prelinkedkernel and reboot,

then, patch the kext, install the kext again.

Yeah 10.13.6 is fully functional, nvdrstartup and hal50 kexts are loaded but no acceleration.

Corresponds to macbook pro 6.2.

Any config.plist or boot argument suggestions.

 

Thanks

Share this post


Link to post
Share on other sites
3 hours ago, macq said:

Yeah 10.13.6 is fully functional, nvdrstartup and hal50 kexts are loaded but no acceleration.

Corresponds to macbook pro 6.2.

Any config.plist or boot argument suggestions.

 

Thanks

 

You can try another kext, use NDRVShim.kext instead of replacing IONDRVSupport and IOGraphicsFamily post#1875.

 

Previous post updated here. It's better to use Kext Utility.app to install kexts.

Share this post


Link to post
Share on other sites
On 6/26/2018 at 3:03 PM, Morpheus NS said:

What would be the hackintosh successor of gt 210? Card to go with if you don't  need anything powerful, card which is cheap and reliable, which supports metal and works oob? GT 610, GT 620 maybe?

My 650 is very cheap and supported OOB.

Share this post


Link to post
Share on other sites
On 6/26/2018 at 10:27 AM, fantomas1 said:

OpenCL hidden or not, if Apple removed the kext(s) (or the support) for no-metal gpu's, barring a miracle, it will never work - unless if nvidia (in our case here) or someone else provides the kext(s) in question.  :)

 

A miracle or not, my g210 works very well  :)

 

 

 

nVidia non-Metal GPU's on Mojave (crazybirdy)

Share this post


Link to post
Share on other sites

help,

after install all new patched kext files with kext wizard , then reboot nVidia kext not working for 9500gt with boot args inject nvidia and with uncheck nv_disable=1(can't boot to the system) with kernel panic :( any solution???

On 7/13/2018 at 3:28 PM, crazybirdy said:

 

Base on ASentientBot's great job.

If you want to use latest version kexts all from 10.13.6, you can patch it by yourself.

GeForceTesla.kext/Contents/MacOS/GeForceTesla

 

Old Method : GeforceTesla.kext from post#2125.


Find
554889e553504889fb83bb38030000007426488b03488bb3e80000004889dfff90c8050000488b03488bb3e80000004889dfff907806000031c04883c4085b5d
Replace
6666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000006666666666662e0f1f8400000000000f1f4000

or perl patch code.


perl -pi -e 's|\x55\x48\x89\xe5\x53\x50\x48\x89\xfb\x83\xbb\x38\x03\x00\x00\x00\x74\x26\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\xc8\x05\x00\x00\x48\x8b\x03\x48\x8b\xb3\xe8\x00\x00\x00\x48\x89\xdf\xff\x90\x78\x06\x00\x00\x31\xc0\x48\x83\xc4\x08\x5b\x5d|\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x66\x66\x66\x66\x66\x66\x2e\x0f\x1f\x84\x00\x00\x00\x00\x00\x0f\x1f\x40\x00|g' GeForceTesla.kext/Contents/MacOS/GeForceTesla

New Method : GeforceTesla.kext from post#2529 .


Find
488b07ff90c0000000
Replace
488b07660f1f440000

or perl patch code.


perl -pi -e 's|\x48\x8b\x07\xff\x90\xc0\x00\x00\x00|\x48\x8b\x07\x66\x0f\x1f\x44\x00\x00|g' GeForceTesla.kext/Contents/MacOS/GeForceTesla

the patch code is the same as ASentientBot provided 10.13.4 patched GeforceTesla.kext.

You need only one method between Old Method and New Method, each of them works fine here.

 

10.13.6 kexts works fine as below,

GeForceGA.bundle

GeForceTesla.kext ..... (patched)
GeForceTeslaGLDriver.bundle
GeForceTeslaVADriver.bundle
NVDANV50HalTesla.kext
NVDAResmanTesla.kext

IOGraphicsFamily.kext
IONDRVSupport.kext

 

or

 

You can try to use NDRVShim.kext instead of replacing IONDRVSupport and IOGraphicsFamily post#1875, get NDRVShim.kext from post#1865, at /Volumes/macOS Mojave Patcher/macOS Mojave Patcher.app/Contents/Resources/macOS Post Install.app/Contents/Resources/legacynvidia/NDRVShim.kext

 

And need to edit NVDAResmanTesla.kext/Contents/Info.plist to add the following string.

        <key>com.parrotgeek.NDRVShim</key>
        <string>1</string>


	<dict>
		<key>com.apple.iokit.IOGraphicsFamily</key>
		<string>1.5</string>
		<key>com.parrotgeek.NDRVShim</key>
		<string>1</string>
		<key>com.apple.iokit.IONDRVSupport</key>
		<string>1.5</string>
		<key>com.apple.iokit.IOPCIFamily</key>
		<string>2.4</string>
		<key>com.apple.kpi.bsd</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.iokit</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.libkern</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.mach</key>
		<string>9.0.0</string>
	</dict>

10.13.6 kexts works fine as below,

GeForceTesla.kext ..... (patched)
GeForceTeslaGLDriver.bundle
GeForceTeslaVADriver.bundle
NVDANV50HalTesla.kext
NVDAResmanTesla.kext ..... (edit Info.plist)

NDRVShim.kext ..... (added)

 

If you still have troube, try the following 10.13.6 kexts too.

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext

Refer to /Volumes/macOS Mojave Patcher/macOS Mojave Patcher.app/Contents/Resources/macOS Post Install.app/Contents/Resources/legacyGPUPatch.sh

credits to: ASentientBot, parrotgeek1, dosdude1.

 

And My nVidia 9300GE always need to fix reboot error with NVDAStartup.kext.310.42.25f01.zip from nawcom since 10.12.

 

Download all the patche kexts here. All works fine here too.:yes:

It's better to use Kext Utility.app to install kexts.

 

GeForce1014-10136.gif.a5c662ffea18a0a804497fc601a0d928.gif

 

help,

after install all new patched kext files with kext wizard , then reboot nVidia kext not working for 9500gt with boot args inject nvidia and with uncheck nv_disable=1(can't boot to the system) with kernel panic :( any solution???

Share this post


Link to post
Share on other sites
2 hours ago, robif2002 said:

help,

after install all new patched kext files with kext wizard , then reboot nVidia kext not working for 9500gt with boot args inject nvidia and with uncheck nv_disable=1(can't boot to the system) with kernel panic :( any solution???

 

Remove all /S/L/E/Geforce*** and /S/L/E/NVDA***.

If you still get kernel panic, I think, it's not graphic kext issue, it's something wrong else.

Share this post


Link to post
Share on other sites
35 minutes ago, crazybirdy said:

 

Remove all /S/L/E/Geforce*** and /S/L/E/NVDA***.

If you still get kernel panic, I think, it's not graphic kext issue, it's something wrong else.

 

after deleted selsected files then reboot with inject nvidia, detected 1 gb video memory, but still laggy when open lainchpad, not fix resolution and no alpha blur :( what's wrong.???.

thanks b4..

IMG_20181103_071016-picsay.jpg

Edited by robif2002

Share this post


Link to post
Share on other sites
6 minutes ago, robif2002 said:

after deleted selsected files then reboot with inject nvidia, detected 1 gb video memory, but still not fix resolution and no alpha blur :( what's wrong.???.

thanks b4..

 

Refer to my config.plist.zip. FYI.

And re-install all the kexts, if you need NVDAStartup.kext.310.42.25f01.zip from nawcom too.

 

Share this post


Link to post
Share on other sites

Hello guys the Nvidia GT 220 TESLA graphics Its possible to run 10.14 mojave? If yes how? By rollback system kexts? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×