Jump to content

401 posts in this topic

Recommended Posts

6 hours ago, Slice said:

This commit is right. I got good image using radialGradients, but yes, something is wrong. If you compile Clover with debug enabled in nanosvg and nanosvgrast then we can see what is the issue.

line 73

#define DEBUG_SVG 0

change to 1

I'll try to test this weekend.

 

6 hours ago, Slice said:

Out af that. Did you propose Clover Theme Manager can show SVG themes set as one file?

Not sure yet.

That CloverThemeTemplateAI.svg is good for a preview of a theme. But if it's to hold ALL icons then there could be maybe 50 icons in there if all linux flavours are present. Do you envisage these icons to be hidden so they don't appear in the preview?

Share this post


Link to post
Share on other sites
Advertisement

I think they may be hidden and not appear in the preview. visibility="none". Clover will show them when necessary.

In this template they are absent as well as many other elements. I am not decided yet what to do in this case.

Share this post


Link to post
Share on other sites

Slice

 

I've tested Clover debug but only saw the following which doesn't help trying to identify the gradient changes.

5:450  0:454  GUI ready
7:565  2:115  image real bounds:  29.500000  29.600006  254.000000  254.000000 
7:578  0:013  scaled width= 224.500000 height= 224.399993
7:580  0:002  Image width=224 heigth=224
7:584  0:003  timing rasterize start tx= 0.000000 ty= 0.000000
7:586  0:002   image will be shifted by [ -52.561248, -52.739433]
7:683  0:096  timing rasterize end
7:695  0:012  create textbuffer
7:698  0:002  font loaded status=Not Found
9:975  2:276  ConnectAll after refresh menu

 

I see I would need to enable deeper debugging statements to understand what's going on but I'm not sure what I'd be looking for and TBH don't have the time.

 

You say commit 4699 was to give you good radialGradients. Can you post your code used for radialGradients?

 

I've tested radialGradient code from here:
https://developer.mozilla.org/en-US/docs/Web/SVG/Element/radialGradient

 

Both Clover 4674 and 4706 show it incorrectly, but I feel 4674 shows it better.
KBg2Pcs.png
FtfsY0W.png


But I see Adobe Illustrator shows it differently to how it's shown on Mozilla's page.
2ByXWMl.png

 

Argh.. I understand this is just not simple...

Share this post


Link to post
Share on other sites

Issues I notice

1. Opacity. May be there is not need in nsvg__unpremultiplyAlpha(dst, w, h, stride); at the end of nanosvgrast.c?

2. Gradients. Not sure if it related to 1.

3. Scale. When I raster a theme then I see large elements.

4. DrowSVGtext shows nothing.

I continue working on these issues.

Share this post


Link to post
Share on other sites

Sorry, does it mean *.plist file will be replaced by "theme.svg" on Vector theme?

Thanks (ah, ignore the screenshot, it was bad *.plist file from my prev. commit).

 

Screenshot 4.png

Share this post


Link to post
Share on other sites
On 10/22/2018 at 11:47 AM, Slice said:

I fix this but Clover is not ready yet

OK, thanks @Slice for r4720, above "radialGradient" looks as it is. I just tried with more complex gradients (linear, radial) at a same time but it seems not ready yet, or it' s just my bad svg design.

Sample_multiGrads.png

Sample_multiGrads.svg

Edited by Badruzeus

Share this post


Link to post
Share on other sites

rev 4723. I think gradients repaired finally.

Radial

Снимок экрана 2018-10-26 в 23.17.53.png

Linear

Снимок экрана 2018-10-26 в 23.19.57.png

 

I make it very different from initial nanosvg and my method is times faster.

 

There is one feature lack: focus of Radial Gradient is not implemented initially.

Comments by Mikko

		// TODO: spread modes.
		// TODO: plenty of opportunities to optimize.
		// TODO: focus (fx,fy)

Hope later I will make this but there is complex mathematics.

 

Other remaining problem is a distance between the spheres. It is not as designed.

And a feature for future ( :) ). I can implement gradient dithering. Later.

 

Otherwise we can account SVG rasterization as complete. So begin to parse a theme.svg.

Share this post


Link to post
Share on other sites

Rev 4725. Vector theme can be used. 

The problem is to draw it so that Clover can render 1:1 as designed.

I have not good result.

 

Instructions are not ready, briefly:

1. Create a folder with new name

/EFI/CLOVER/themes/MyNewTheme

2. Place "Theme.svg" inside. The name is exact this.

3. It should be looked by Safari as theme preview.

4. Use as simple SVG language as possible. Avoid multilevel styles and transformations.

5. Write into config.plist

GUI->theme=MyNewTheme

6. Test.

 

Share this post


Link to post
Share on other sites

This is what I see in Photoshop when viewing the SVG on dark background and white background.

Left side is original SVG, right side is screenshot from clover gui.

 

VvMXk7n.png

 

Centre square when the 50% green is overlaid on the red is good and any visual differences is due to optical illusion.

 

50% green is different in Clover due to the way it's being blended with the background.

 

Share this post


Link to post
Share on other sites
12 hours ago, Slice said:

Rev 4725. Vector theme can be used. 

The problem is to draw it so that Clover can render 1:1 as designed.

I have not good result.

 

Instructions are not ready, briefly:

1. Create a folder with new name

/EFI/CLOVER/themes/MyNewTheme

2. Place "Theme.svg" inside. The name is exact this.

3. It should be looked by Safari as theme preview.

4. Use as simple SVG language as possible. Avoid multilevel styles and transformations.

5. Write into config.plist

GUI->theme=MyNewTheme

6. Test.

 

What structure does the Theme.svg need to have?

 

I'm testing with simple attached .svg file but clover debug shows it's not finding any icons inside the file?

1:725  0:005  === [ InitTheme ] =========================================
1:907  0:181  Theme view-bounds: w=1786 h=1116 units=px
1:911  0:004  using scale  0.688110
1:929  0:017  icon Background width= 0.000000 height= 0.000000
1:933  0:004  begin rasterize Background
1:946  0:012  icon Banner width= 0.000000 height= 0.000000
1:950  0:004  begin rasterize Banner
1:954  0:004  parsed banner->width=0
1:958  0:004  search for icon name func_about
1:964  0:005  icon func_about width= 0.000000 height= 0.000000
1:968  0:003  begin rasterize func_about
1:972  0:004  search for icon name func_options
1:977  0:005  icon func_options width= 0.000000 height= 0.000000
1:982  0:004  begin rasterize func_options
1:986  0:004  search for icon name func_clover
1:998  0:012  icon func_clover width= 0.000000 height= 0.000000
2:002  0:004  begin rasterize func_clover
2:006  0:004  search for icon name func_secureboot
2:012  0:005  icon func_secureboot width= 0.000000 height= 0.000000
2:016  0:004  begin rasterize func_secureboot
2:020  0:004  search for icon name func_secureboot_config
2:026  0:005  icon func_secureboot_config width= 0.000000 height= 0.000000
2:030  0:004  begin rasterize func_secureboot_config
2:035  0:004  search for icon name func_reset
2:047  0:012  icon func_reset width= 0.000000 height= 0.000000
2:052  0:004  begin rasterize func_reset
2:056  0:004  search for icon name func_shutdown
2:062  0:005  icon func_shutdown width= 0.000000 height= 0.000000
2:067  0:004  begin rasterize func_shutdown
2:072  0:005  search for icon name func_help
2:078  0:005  icon func_help width= 0.000000 height= 0.000000
2:081  0:003  begin rasterize func_help
2:086  0:005  search for icon name tool_shell
2:092  0:005  icon tool_shell width= 0.000000 height= 0.000000
2:104  0:011  begin rasterize tool_shell
2:108  0:004  search for icon name tool_part
2:115  0:006  icon tool_part width= 0.000000 height= 0.000000
2:120  0:004  begin rasterize tool_part
2:124  0:004  search for icon name tool_rescue
2:131  0:006  icon tool_rescue width= 0.000000 height= 0.000000
2:138  0:006  begin rasterize tool_rescue
2:143  0:005  search for icon name pointer
2:150  0:006  icon pointer width= 0.000000 height= 0.000000
2:154  0:004  begin rasterize pointer
2:166  0:011  search for icon name vol_internal
2:173  0:007  icon vol_internal width= 0.000000 height= 0.000000
2:179  0:005  begin rasterize vol_internal
2:184  0:005  search for icon name vol_external
2:189  0:005  icon vol_external width= 0.000000 height= 0.000000
2:194  0:004  begin rasterize vol_external
2:201  0:007  search for icon name vol_optical
2:207  0:005  icon vol_optical width= 0.000000 height= 0.000000
2:210  0:003  begin rasterize vol_optical
2:214  0:003  search for icon name vol_firewire
2:225  0:011  icon vol_firewire width= 0.000000 height= 0.000000
2:229  0:004  begin rasterize vol_firewire
2:233  0:004  search for icon name vol_clover
2:240  0:006  icon vol_clover width= 0.000000 height= 0.000000
2:245  0:004  begin rasterize vol_clover
2:249  0:003  search for icon name vol_internal_hfs
2:259  0:009  icon vol_internal_hfs width= 0.000000 height= 0.000000
2:264  0:005  begin rasterize vol_internal_hfs
2:269  0:005  search for icon name vol_internal_apfs
2:284  0:014  icon vol_internal_apfs width= 0.000000 height= 0.000000
2:289  0:005  begin rasterize vol_internal_apfs
2:293  0:003  search for icon name vol_internal_ntfs
2:304  0:011  icon vol_internal_ntfs width= 0.000000 height= 0.000000
2:309  0:004  begin rasterize vol_internal_ntfs
2:314  0:005  search for icon name vol_internal_ext3
2:321  0:006  icon vol_internal_ext3 width= 0.000000 height= 0.000000
2:324  0:002  begin rasterize vol_internal_ext3
2:328  0:004  search for icon name vol_recovery
2:340  0:011  icon vol_recovery width= 0.000000 height= 0.000000
2:345  0:004  begin rasterize vol_recovery
2:349  0:004  search for icon name logo
2:356  0:006  icon logo width= 0.000000 height= 0.000000
2:360  0:004  begin rasterize logo
2:366  0:005  search for icon name selection_small
2:374  0:008  icon selection_small width= 0.000000 height= 0.000000
2:379  0:005  begin rasterize selection_small
2:384  0:005  search for icon name selection_big
2:391  0:006  icon selection_big width= 0.000000 height= 0.000000
2:398  0:007  begin rasterize selection_big
2:401  0:002  search for os_mac
2:407  0:005  icon os_mac width= 0.000000 height= 0.000000
2:408  0:001  begin rasterize os_mac
2:410  0:001  search for os_tiger
2:414  0:004  icon os_tiger width= 0.000000 height= 0.000000
2:418  0:003  begin rasterize os_tiger
2:422  0:004  search for os_leo
2:427  0:004  icon os_leo width= 0.000000 height= 0.000000
2:431  0:003  begin rasterize os_leo
2:435  0:003  search for os_snow
2:440  0:005  icon os_snow width= 0.000000 height= 0.000000
2:451  0:010  begin rasterize os_snow
2:452  0:001  search for os_lion
2:456  0:004  icon os_lion width= 0.000000 height= 0.000000
2:460  0:003  begin rasterize os_lion
2:465  0:004  search for os_cougar
2:470  0:005  icon os_cougar width= 0.000000 height= 0.000000
2:475  0:004  begin rasterize os_cougar
2:480  0:005  search for os_mav
2:487  0:006  icon os_mav width= 0.000000 height= 0.000000
2:490  0:003  begin rasterize os_mav
2:494  0:003  search for os_yos
2:511  0:016  icon os_yos width= 0.000000 height= 0.000000
2:517  0:006  begin rasterize os_yos
2:525  0:007  search for os_cap
2:534  0:008  icon os_cap width= 0.000000 height= 0.000000
2:541  0:006  begin rasterize os_cap
2:546  0:005  search for os_sierra
2:556  0:009  icon os_sierra width= 0.000000 height= 0.000000
2:561  0:004  begin rasterize os_sierra
2:565  0:004  search for os_hsierra
2:571  0:005  icon os_hsierra width= 0.000000 height= 0.000000
2:576  0:005  begin rasterize os_hsierra
2:586  0:010  search for os_moja
2:593  0:007  icon os_moja width= 0.000000 height= 0.000000
2:598  0:004  begin rasterize os_moja
2:603  0:005  search for os_linux
2:609  0:006  icon os_linux width= 0.000000 height= 0.000000
2:614  0:004  begin rasterize os_linux
2:619  0:005  search for os_freebsd
2:623  0:003  icon os_freebsd width= 0.000000 height= 0.000000
2:627  0:004  begin rasterize os_freebsd
2:630  0:003  search for os_freedos
2:637  0:006  icon os_freedos width= 0.000000 height= 0.000000
2:647  0:010  begin rasterize os_freedos
2:653  0:005  search for os_win
2:659  0:006  icon os_win width= 0.000000 height= 0.000000
2:663  0:004  begin rasterize os_win
2:669  0:005  search for os_vista
2:675  0:006  icon os_vista width= 0.000000 height= 0.000000
2:679  0:004  begin rasterize os_vista
2:683  0:003  search for radio_button
2:688  0:005  icon radio_button width= 0.000000 height= 0.000000
2:692  0:003  begin rasterize radio_button
2:695  0:002  search for radio_button_selected
2:708  0:012  icon radio_button_selected width= 0.000000 height= 0.000000
2:712  0:004  begin rasterize radio_button_selected
2:717  0:004  search for checkbox
2:723  0:005  icon checkbox width= 0.000000 height= 0.000000
2:728  0:005  begin rasterize checkbox
2:732  0:004  search for checkbox_checked
2:737  0:005  icon checkbox_checked width= 0.000000 height= 0.000000
2:743  0:005  begin rasterize checkbox_checked
2:748  0:004  Using vector theme 'BGM_SVG' (EFI\CLOVER\themes\BGM_SVG)

 

Theme.svg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rodrinico19
      Hola a todos, primero que nada estoy muy contento de a ver econtrado un foro de español sobre hackintosh.
      Mi problema consesite en que descargue unos drivers de esta pagina: https://github.com/chris1111/Wireless-USB-Adapter-Clover
      Seguí los pasos instale los kets en la carpeta EFI/CLOVER/OTHERS todo tal cual como dice ahi la instalación. luego segui los pasos de configurar la red dentro de configuracion del sistema etc.
      Lo cual el nombre me quedo en en0.
      El driver o kets funciona bien es reconocible por el S.O de hecho conecta la red, pero me dice que no tiene IP AUTO ASIGNADA Y LA OTRA QUE HAY UNA DESCONEXION A CADA RATO(como que desconectaras y conectaras el dispositvo usb a cada rato)
      Me gustaria que me ayuden con eso si es posible, Muchas Gracias!!
    • By Klaidonis
      I am making a minimal Clover build for the fastest boot possible with the boot6 file in legacy mode.
      While looking at the preboot.log, I noticed that there is a line without explanation (at 0:892). Apparently, whatever it is, the execution time of it is close to 2 seconds, more than 55% of the total logged boot time in the current configuration. This does not change whether I use USB 2 or USB 3 port.
       
      Is there a way to eliminate or speed up the above? Also, is there anything else you can suggest to improve the performance based on the below log file? Which moment in the boot process corresponds to the start time in preboot.log?  
      The last thing I would like to understand is the delay/timeout after the boot6 file has loaded, and the number 6 disappears from the screen. For about 2 seconds or slightly less, I can press any key, and then it will enter the BIOS-like interface from the boot6 file. Without further knowledge, it seems like those 2 seconds are just delay time, and only after that is CLOVERX64.efi actually started, which, I presume, is approximately when the preboot.log timer starts. So, if the aforementioned is correct, can I get rid of this delay as well? Note that I am using the boot1f32 file to chain-load boot6, which does not include the initial 2-second wait period for a keypress.
       
      === preboot.log ===
      0:100 0:100 MemLog inited, TSC freq: 2394459554 0:100 0:000 CPU was calibrated with ACPI PM Timer 0:100 0:000 LegacyRegion2: Chipset/proc: 0x0A048086 0:100 0:000 Next Generation Core processors (PAM 0x80-0x86) 0:100 0:000 Test PAM1=(0x41=90, 0x5a=90, 0x81=11, 0x91=00) at chipset 0A048086 0:100 0:000 , Install = Success 0:112 0:012 BiosVideoDriverBindingStart! 0:112 0:000 BiosVideoCheckForVbe 0:112 0:000 EdidOverride not found 0:121 0:009 Edid1+ 0:121 0:000 found Detail Timing 1920x1080 0:121 0:000 timing string after 0xFE:AUO 0:121 0:000 timing string after 0xFE:B156HAN01.2 0:122 0:000 0 1280x1024 attr=9B - ok, edid- 0:122 0:000 1 1024x768 attr=9B - ok, edid-, 1024x768, working, highest, pref=1 0:122 0:000 2 640x480 attr=9B - ok, edid-, 640x480, working 0:122 0:000 3 800x600 attr=9B - ok, edid-, 800x600, working 0:123 0:000 4 1920x1080 attr=9B - ok, edid+, working, highest, pref=4 0:123 0:000 BV new mode: 4 1920x1080 0:398 0:275 SetMode pref 4 (4) = Success 0:892 0:493 VGA Pci.Hdr.Command=6 - not enabled 2:623 1:731 2:623 0:000 Now is 21.02.2020, 13:03:21 (GMT) 2:623 0:000 Starting Clover revision: 5103 (master, commit 3f3b85da0) on CLOVER EFI 2:623 0:000 Build with: [Args: -D NO_GRUB_DRIVERS_EMBEDDED -t GCC53 | -D NO_GRUB_DRIVERS_EMBEDDED --conf=/Users/sergey/src/CloverHackyColor/Conf -D USE_LOW_EBDA -a X64 -b RELEASE -t GCC53 -n 5 | OS: 10.14.6] 2:623 0:000 SelfDevicePath=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) @940C9698 2:623 0:000 SelfDirPath = \EFI\CLOVER 2:623 0:000 SimpleTextEx Status=Success 2:623 0:000 === [ Get Smbios ] ======================================== 2:623 0:000 Type 16 Index = 0 2:623 0:000 Total Memory Slots Count = 2 2:623 0:000 Type 17 Index = 0 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 4096MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 0 DIMM0 2:623 0:000 SmbiosTable.Type17->Vendor = Hynix 2:623 0:000 SmbiosTable.Type17->SerialNumber = 00000000 2:623 0:000 SmbiosTable.Type17->PartNumber = HMT451S6MFR6A-PB 2:623 0:000 Type 17 Index = 1 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 8192MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 2 DIMM1 2:623 0:000 SmbiosTable.Type17->Vendor = Kingston 2:623 0:000 SmbiosTable.Type17->SerialNumber = 5A060A8A 2:623 0:000 SmbiosTable.Type17->PartNumber = KHX1600C9S3L/8G 2:623 0:000 Boot status=0 2:623 0:000 Running on: 'Aspire V5-573G' with board 'Dazzle_HW' 2:623 0:000 === [ GetCPUProperties ] ================================== 2:623 0:000 CPU Vendor = 756E6547 Model=40651 2:623 0:000 The CPU supported SSE4.1 2:623 0:000 BrandString = Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz 2:623 0:000 The CPU supported turbo 2:623 0:000 MSR 0x35 20004 2:623 0:000 MSR 0xE2 before patch 1E008405 2:623 0:000 MSR 0xE2 is locked, PM patches will be turned on 2:623 0:000 MSR 0xCE 0008083D_F3011800 2:623 0:000 corrected FLEX_RATIO = 0 2:623 0:000 MSR 0x1B0 00000000 2:623 0:000 FSBFrequency = 71 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz 2:623 0:000 MaxDiv/MinDiv: 24.0/8 2:623 0:000 Turbo: 27/27/27/30 2:623 0:000 Features: 0xBFEBFBFF 2:623 0:000 Threads: 4 2:623 0:000 Cores: 2 2:623 0:000 FSB: 100 MHz 2:623 0:000 CPU: 1700 MHz 2:623 0:000 TSC: 1700 MHz 2:623 0:000 PIS: 100 MHz 2:623 0:000 ExternalClock: 25 MHz 2:623 0:000 === [ GetDevices ] ======================================== 2:623 0:000 GOP found at: PcieRoot(0x0)/Pci(0x2,0x0)/AcpiAdr(0x80010100) 2:623 0:000 PCI (00|00:00.00) : 8086 0A04 class=060000 2:623 0:000 PCI (00|00:02.00) : 8086 0A16 class=030000 2:623 0:000 - GOP: Provided by device 2:623 0:000 - GFX: Model=Intel HD Graphics 4400 (Intel) 2:623 0:000 PCI (00|00:03.00) : 8086 0A0C class=040300 2:623 0:000 PCI (00|00:14.00) : 8086 9C31 class=0C0330 2:623 0:000 PCI (00|00:16.00) : 8086 9C3A class=078000 2:623 0:000 PCI (00|00:1B.00) : 8086 9C20 class=040300 2:623 0:000 PCI (00|00:1C.00) : 8086 9C10 class=060400 2:623 0:000 PCI (00|00:1C.02) : 8086 9C14 class=060400 2:623 0:000 PCI (00|04:00.00) : 168C 0034 class=028000 2:623 0:000 - WIFI: Vendor=Atheros 2:623 0:000 PCI (00|00:1C.03) : 8086 9C16 class=060400 2:623 0:000 PCI (00|05:00.00) : 10EC 5287 class=FF0000 2:623 0:000 PCI (00|05:00.01) : 10EC 8168 class=020000 2:623 0:000 - LAN: 0 Vendor=Realtek 2:623 0:000 PCI (00|00:1C.04) : 8086 9C18 class=060400 2:624 0:000 PCI (00|01:00.00) : 10DE 0FE4 class=030200 2:624 0:000 PCI (00|00:1D.00) : 8086 9C26 class=0C0320 2:624 0:000 PCI (00|00:1F.00) : 8086 9C43 class=060100 2:624 0:000 PCI (00|00:1F.02) : 8086 9C03 class=010601 2:624 0:000 PCI (00|00:1F.03) : 8086 9C22 class=0C0500 2:624 0:000 === [ GetDefaultSettings ] ================================ 2:624 0:000 Clover load options size = 0 bytes 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G--00-00-00-00-00-00. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G-1700. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW-1700. Dir not exists 2:624 0:000 set OEMPath by default: EFI\CLOVER 2:637 0:012 EFI\CLOVER\config.plist loaded: Success 2:637 0:000 === [ GetListOfThemes ] =================================== 2:637 0:000 === [ Found config plists ] =============================== 2:637 0:000 - config.plist 2:637 0:000 === [ GetEarlyUserSettings ] ============================== 2:637 0:000 timeout set to 0 2:637 0:000 Custom boot CUSTOM_BOOT_DISABLED (0x0) 2:637 0:000 Default theme: embedded 2:637 0:000 === [ LoadDrivers ] ======================================= 2:637 0:000 === [ InitScreen ] ======================================== 2:637 0:000 Console modes reported: 4, available modes: 2:637 0:000 - [01]: 80x25 2:637 0:000 - [02]: 80x50 2:637 0:000 - [03]: 100x31 2:637 0:000 - [04]: 240x56 (current mode) 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 reinit: self device path=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:637 0:000 === [ GetMacAddress ] ===================================== 2:637 0:000 === [ ScanSPD ] =========================================== 2:637 0:000 Scanning SMBus [8086:9C22], mmio: 0xB3619004, ioport: 0x5040, hostc: 0x1 2:656 0:018 Slot: 2 Type 24 8192MB 1600MHz Vendor=Kingston PartNo=KHX1600C9S3L8G SerialNo=050A0006000A080A 2:657 0:000 === [ GetAcpiTablesList ] ================================= 2:657 0:000 Get Acpi Tables List from RSDT: 2:657 0:000 - [00]: FACP ACRPRDCT len=268 2:657 0:000 - [01]: UEFI ACRPRDCT len=566 2:657 0:000 - [02]: FPDT ACRPRDCT len=68 2:657 0:000 - [03]: ASF! ACRPRDCT len=165 2:657 0:000 - [04]: HPET ACRPRDCT len=56 2:657 0:000 - [05]: APIC ACRPRDCT len=140 2:657 0:000 - [06]: MCFG ACRPRDCT len=60 2:657 0:000 - [07]: BOOT ACRPRDCT len=40 2:657 0:000 - [08]: LPIT ACRPRDCT len=148 2:657 0:000 - [09]: ASPT ACRPRDCT len=52 2:657 0:000 - [10]: DBGP ACRPRDCT len=52 2:657 0:000 - [11]: SSDT ACRPRDCT len=1337 2:657 0:000 - [12]: SSDT ACRPRDCT len=2776 2:657 0:000 - [13]: SSDT ACRPRDCT len=12013 2:657 0:000 - [14]: SSDT ACRPRDCT len=11433 2:657 0:000 - [15]: SSDT ACRPRDCT len=2230 2:657 0:000 Calibrated TSC Frequency = 2394459554 = 2394MHz 2:657 0:000 === [ GetUserSettings ] =================================== 2:657 0:000 === [ Found DSDT tables ] ================================= 2:657 0:000 === [ ScanVolumes ] ======================================= 2:657 0:000 Found 8 volumes with blockIO 2:657 0:000 - [00]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0) 2:659 0:001 Result of bootcode detection: bootable Linux (grub,linux) 2:659 0:000 - [01]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0) 2:660 0:001 Result of bootcode detection: bootable unknown (legacy) 2:660 0:000 - [02]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,8017BD66-1E24-4B31-8E09-BC49BECD6CC4,0x800,0x21330000) 2:661 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:661 0:000 - [03]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,GPT,82F3B738-65E9-458E-B2F1-BB55D4F00885,0x21331000,0x3D0800) 2:663 0:001 - [04]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,GPT,E701DCD8-E3C5-4BFA-B61B-BFF4D80153FD,0x21701800,0x18C4F000) 2:664 0:001 - [05]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(4,GPT,4DB1239A-A9D7-4045-A162-7EF1B3A5913B,0x3A350C21,0x3A3B616E) 2:665 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:665 0:000 - [06]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0) 2:677 0:011 Result of bootcode detection: bootable unknown (legacy) 2:677 0:000 USB volume 2:677 0:000 USB volume 2:677 0:000 - [07]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:688 0:011 Result of bootcode detection: bootable unknown (legacy) 2:688 0:000 USB volume 2:688 0:000 USB volume 2:688 0:000 This is SelfVolume !! 2:688 0:000 PutNvramPlistToRtVars: nvram.plist not found 2:689 0:000 No AudioIoProtocols, status=Not Found 2:689 0:000 === [ InitTheme ] ========================================= 2:689 0:000 use daylight theme 2:689 0:000 using embedded theme 2:689 0:000 got embedded sound 2:689 0:000 Channels: 2 Sample rate: 8000 Hz Bits: 16 2:689 0:000 output to channel 0 with volume 70, len=25600 2:689 0:000 sound channels=2 bits=16 freq=8000 2:689 0:000 sound converted to 48kHz 2:689 0:000 not found AudioIo to play 2:689 0:000 sound play end with status=Not Found 2:690 0:001 Using embedded font: Success 2:691 0:000 theme inited 2:691 0:000 Chosen embedded theme 2:691 0:000 after NVRAM boot-args= 2:691 0:000 === [ Dump SMC keys from NVRAM ] ========================== 2:691 0:000 no AppleSMC protocol 2:691 0:000 Entry scan disabled 2:691 0:000 === [ AddCustomTool ] ===================================== 2:692 0:000 === [ GetEfiBootDeviceFromNvram ] ========================= 2:692 0:000 Default boot entry not found 2:692 0:000 DefaultIndex=-1 and MainMenu.EntryCount=4 2:973 0:281 GUI ready  
    • By Jancey
      I used this command: diskutil info disk0s2 | grep -i "Partition UUID" | rev | cut -d' ' -f 1 | rev

      But I accidentally removed the wrong disk and now my main windows drive is not appearing in the bootloader. I can't figure out how to get it back. I tried resetting my windows drive, but I kept getting an error. I also reset my mac and reinstalled Catalina.
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
×