Jump to content

391 posts in this topic

Recommended Posts

4 hours ago, Slice said:

Inkscape is not working in macOS 10.11+. Pity.

My last try under 10.11.6, Inkscape v0.92.3 is still working using brew:

brew install caskformula/caskformula/inkscape

.. plus XQuartz 2.7.11

 

But on my case, it was running damn slow.. seems my Fermi got no Graphics accell with X11.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Advertisement

I get a simpler way running Inkscape v0.9.22 (latest official package for mac) under 10.11+:

1. Go to /Applications/Inkscape.app/Contents/MacOS

2. Right click "Inkscape" binary, choose "Open with" and select XQuatrz.app

 

The problem is, it won't run by directly selecting the app from Launchpad or /Applications folder, better idea? Thanks.

Screenshot 45.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites
49 minutes ago, Slice said:

Since rev 4588 gradients are shown.

 

 


Снимок экрана 2018-07-03 в 7.15.16.png

 

Снимок экрана 2018-07-03 в 7.24.40.png
 

 

 

@Slice Sorry, I still wonder why it looks different here.. on my case, I lost vector coloring (nor even gradient). Sample.svg below actually contains Orange-Yellow gradient colors, it's generated with Illustrator > File > Export for Screens. Or, if you're using different SVG options when saving, plz let me know. Thanks.

screenshot0.png

Screenshot1.png

Sample.svg

Edited by Badruzeus

Share this post


Link to post
Share on other sites

I had been testing in QEMU with the SVG file from here but Clover crashes when pressing F8. To rule out QEMU I tested on my hack and also experienced a crash.

 

Testing with the two .svg files posted by Badruzeus works though I also only see just the solid black filled graphic rather than colour images.

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

 

@Slice Sorry, I still wonder why it looks different here.. on my case, I lost vector coloring (nor even gradient). Sample.svg below actually contains Orange-Yellow gradient colors, it's generated with Illustrator > File > Export for Screens. Or, if you're using different SVG options when saving, plz let me know. Thanks.

screenshot0.png

Screenshot1.png

Sample.svg

I see non-supported feature

<style>.cls-1{fill:url(#linear-gradient);}

class="cls-1"

 

Try to set SVG 1.0. I will think how to support this.

1 minute ago, blackosx said:

I had been testing in QEMU with the SVG file from here but Clover crashes when pressing F8. To rule out QEMU I tested on my hack and also experienced a crash.

 

Testing with the two .svg files posted by Badruzeus works though I also only see just the solid black filled graphic rather than colour images.

GoogleChrome open this svg just fine.

Share this post


Link to post
Share on other sites
24 minutes ago, blackosx said:

I had been testing in QEMU with the SVG file from here

Good article! We should recommend it to SVG creators.

 

16 minutes ago, blackosx said:

Yeah, chrome and all other software renders that svg file just fine. It’s Clover that crashes when trying to.

The work in progress.

Share this post


Link to post
Share on other sites

@Badruzeus

I may propose to you manually edit your svg files with follow rules:

1. Exclude

	<style>.cls-1{fill:url(#linear-gradient);}.cls-2{fill:url(#linear-gradient-2);}.cls-3{fill:url(#linear-gradient-3);}.cls-4{fill:url(#linear-gradient-4);}.cls-5{fill:url(#linear-gradient-5);}.cls-6{fill:url(#linear-gradient-6);}</style>

2. Replace

<path class="cls-2"

to

<path style="fill:url(#linear-gradient-2)"

and so on

 

 

What is "Advanced options-> CSS Properties? What can be choosen?

 

 

EDITED.

Now this style is supported. Don't need to remove it.

Share this post


Link to post
Share on other sites
2 hours ago, Slice said:

@Badruzeus

I may propose to you manually edit your svg files with follow rules:

1. Exclude


	<style>.cls-1{fill:url(#linear-gradient);}.cls-2{fill:url(#linear-gradient-2);}.cls-3{fill:url(#linear-gradient-3);}.cls-4{fill:url(#linear-gradient-4);}.cls-5{fill:url(#linear-gradient-5);}.cls-6{fill:url(#linear-gradient-6);}</style>

2. Replace

<path class="cls-2"

to

<path style="fill:url(#linear-gradient-2)"

and so on

 

 

What is "Advanced options-> CSS Properties? What can be choosen?

OK, it seems illustrator stuffs. I'm trying to repoduce it with diff. options, or diff. vector editor.. just read a good article given by @blackosx too.

Share this post


Link to post
Share on other sites
On 7/3/2018 at 8:42 AM, Badruzeus said:

 

@Slice Sorry, I still wonder why it looks different here.. on my case, I lost vector coloring (nor even gradient). Sample.svg below actually contains Orange-Yellow gradient colors, it's generated with Illustrator > File > Export for Screens. Or, if you're using different SVG options when saving, plz let me know. Thanks.

 

 

Sample.svg

Since rev 4593 this file played fine.

Now CSS style class supported as illustrator do.

It is not my invention, it is from pull requests from github project. But initially there was a little mistake.

Share this post


Link to post
Share on other sites
30 minutes ago, Slice said:

Since rev 4593 this file played fine.

Now CSS style class supported as illustrator do.

It is not my invention, it is from pull requests from github project. But initially there was a little mistake.

@Slice Awesome works! Thank you. :thumbsup_anim:

screenshot_sample.png

Share this post


Link to post
Share on other sites

Hi

 

Can vector themes use the same rules as normal themes (icon sizes, scale, etc). What about background format, Please.

Share this post


Link to post
Share on other sites
13 hours ago, Matgen84 said:

Can vector themes use the same rules as normal themes (icon sizes, scale, etc). What about background format, Please.

It' s still under early devel. and not ready yet, I guess..

Share this post


Link to post
Share on other sites
On 7/13/2018 at 6:27 PM, Matgen84 said:

Hi

 


Can vector themes use the same rules as normal themes (icon sizes, scale, etc). What about background format, Please.

I am ready to accept good ideas 

Share this post


Link to post
Share on other sites
2 hours ago, Slice said:

I am ready to accept good ideas 

 

Sorry for my bad english. What I meant: will vector themes use the same rules as the classic themes described in clover wiki? I do not have special skills to find good ideas.

Share this post


Link to post
Share on other sites
19 hours ago, Matgen84 said:

 

Sorry for my bad english. What I meant: will vector themes use the same rules as the classic themes described in clover wiki? I do not have special skills to find good ideas.

I think there will be some new rules because of scalability.

Share this post


Link to post
Share on other sites
1 hour ago, Slice said:

I think there will be some new rules because of scalability.

I hope someone do a tutorial for this "great" Vector Themes. Thanks

Share this post


Link to post
Share on other sites

The final instruction is not ready so we will speak here.

SVG images and fonts mostly can be read by Clover.

As a first step I may propose to use vector graphics same way as raster graphics but scaled inside Clover taking into account real screen height.

So, you may draw icons in Illustrator as having 144 units (assumes pixels) for design screen size 1920x1080. So drawing to screen 1600x900 clover will scale the icon to

144/1080*900=120 pixels.

os_mac.icns should be os_mac.svg

I propose also to raster font to matrix and then using this font matrix to draw menu.

Later will be more features. I just have to start somehow.

 

SVG images proposed to have some additional features that is not working yet:

1. Text using embedded or external font.

2. PNG image.

3. Linked shapes as <use xlink:href="other_image">

4. <def> after <group>

5. <clip-path>

6. <conic-gradient>

CSS, JavaScripts and animations are not proposed yet.

 

To test current Clover you may place Sample.svg and Font.svg (exactly these names) files into the root of EFI partition and press F8 in Clover GUI.

I want to know how many bugs remain here.

 

One of the possible fonts attached.

PT_Sans_Caption-Regular.zip

Share this post


Link to post
Share on other sites

I have an idea. Let overview of your theme ( like screenshot.png ) will be same as theme.plist and named as “theme.svg”. 

For common viewer like QuickView  it is a picture to show how the theme will be looked. For Clover it will be settings like theme.plist. 

Creating the theme.svg be sure you grouped graphics for each icons.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work 10.10, 10.11, 10,12
      camera not work in 10.13, 10.14
      You need SwitchResX that the screen does not freeze
      Custom resolutions: Back porch - lines change to 2
      UEFI boot moded bios https://github.com/Thiblizz/l502x-modded-bios
       
      For 10.14 you need: HD3000 Fix for Mojave.zip
      Installed in S/L/E 
       
      SMBIOS: MacbookPro 8.3 or MacbookPro 9.1
       
       

       

       
       
    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
×