Jump to content

455 posts in this topic

Recommended Posts

13 hours ago, apianti said:

Install Xcode from the app store and it includes a plist editor, so when you just open your config.plist it will open in the plist editor.

Thank you.

Share this post


Link to post
Share on other sites
Advertisement

Kinda relevant but kinda not. How can I correct my bios time to local time and stop macOS from changing it so that my themes change colour at the right times.

 

I ask because if I set my Timezone in GUI to +10.30 (South Australia Daylight Savings time) at 6:30 pm local time I get the dark (night) GUI for BGM_SVG instead of the daylight one. So I must be doing something wrong. If I add +10.30 to my bios time it is correct with local time but after booting into macOS my bios reverts back. So my question is how to make either macOS use local time and not change bios or what Timezone information do I need to add to clover GUI to make it local time.

 

Found a fix for macOS to bring it inline with other operating systems.

https://github.com/oxycoder/TimeHaxk

With this i can set my bios to local time and macOS uses bios time instead of changing it to UTC.

 

 

Sent from my iPhone using Tapatalk

 

Edited by SavageAUS

Share this post


Link to post
Share on other sites
Timezone in Clover should be integer value, sorry! You have to set 10 or 11 and see daylight from 8:30 to 20:30 in local time. 

Thanks Slice, So for my Timezone +10:30 what would I need to add?

I don’t see integer in Xcode or plistedit pro

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
9 minutes ago, SavageAUS said:

Thanks Slice, So for my Timezone +10:30 what would I need to add?

I don’t see integer in Xcode or plistedit pro

 

 

Sent from my iPhone using Tapatalk

Снимок экрана 2018-12-22 в 13.25.33.png

but I have to repeat: not 10.30!!!! Set "10".

Share this post


Link to post
Share on other sites
7 hours ago, SavageAUS said:

Kinda relevant but kinda not. How can I correct my bios time to local time and stop macOS from changing it so that my themes change colour at the right times.

 

I ask because if I set my Timezone in GUI to +10.30 (South Australia Daylight Savings time) at 6:30 pm local time I get the dark (night) GUI for BGM_SVG instead of the daylight one. So I must be doing something wrong. If I add +10.30 to my bios time it is correct with local time but after booting into macOS my bios reverts back. So my question is how to make either macOS use local time and not change bios or what Timezone information do I need to add to clover GUI to make it local time.

 

Found a fix for macOS to bring it inline with other operating systems.

https://github.com/oxycoder/TimeHaxk

With this i can set my bios to local time and macOS uses bios time instead of changing it to UTC.

 

 

Sent from my iPhone using Tapatalk

 

 

You should have changed Windows to use UTC time as almost every OS does this with hardware time, except windows, and apparently ubuntu (and its derivatives) when windows is present. Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal=1 in registry. Also even if you wanted a half hour offset, that would be 10.5, but it only uses integers, so as slice said, choose 10 or 11.

Share this post


Link to post
Share on other sites

I have added config screenshot where are visible setting for theme Clovy.

 

Theme switches from night mode to day mode at 09.00 (GMT+1). Is there a possibility to change this to an earlier time.

Thanks in advance for help.

 

 

Clovy.png

Edited by luky35

Share this post


Link to post
Share on other sites

@Slice

 

Vector themes are currently drawn differently depending on whether the selection is on top or not.

 

Clovy theme has:
- bounding box for selection_big set at 144px wide
- bounding box for OSIcons set at 128px wide
- SelectionOnTop="0"


As SelectionOnTop is not set

 

In ParseSVGIcon()

https://sourceforge.net/p/cloverefiboot/code/4819/tree/rEFIt_UEFI/libeg/VectorGraphics.c#l107

 

MainEntriesSize is taken from selection_big so ends up being 144px. But, row0TileSize is then also set to the same 144px which results in the following layout, which as Badruzeus pointed out, is not centred.

 

1_Clover_Proper_Clovy_Proper_BELOW.thumb.jpg.3f040426629963905ea85a760c783bfd.jpg


However, if I change:
SelectionOnTop="1"

 

In ParseSVGTheme()

https://sourceforge.net/p/cloverefiboot/code/4819/tree/rEFIt_UEFI/libeg/VectorGraphics.c#l406

 

row0TileSize is set to 144px * scale and MainEntriesSize is set to 128px * scale which results in this layout which is centred.

 

2_Clover_Proper_Clovy_TOP.thumb.jpg.f002720c911c99d2dca698a3d01cc7c8.jpg


Which is the intended correct result?

 

Edited by blackosx

Share this post


Link to post
Share on other sites

Sure, visually.


But I think what I meant with my question was is it correct that Clovy's selection_big BoundingRect (144px) is larger then the actual selection image (128px)?

 

940499225_Screenshot2018-12-23at22_44_21.png.c677e6a44ea8c080879969fcdd2af13a.png

 

This, in turn then sets row0TileSize (as selection is below) to the same size of the BoundingRect which affects the spacing when drawn.

 

Share this post


Link to post
Share on other sites

Oh, probably not. I personally think that the design of the vector themes is wrong. It really shouldn't rely on specific sizes since the whole point of the vector themes is to scale appropriately across any display size. It should rely on percentages of how much the screen an item should use, relying on specific sizes is going to cause problems because you'll have to use those sizes for each item. This is the exact issue with raster themes currently. I think there just is not enough understanding that this should be done like a web layout. Even more still a very strange size was selected for the default screen size, one that is not supported by every display... If this was to be done this way, the correct size should have been 1024x768, since it is the only size that needs to be required by the drawing protocols. But like I said, I'm not even going to attempt to do anything with the GUI anymore, it's beyond a mess and SVG support is severely crippled. I am of the belief that just because something exists and is easy to incorporate does not make it the best choice, or even a good choice against writing something the way you need it to behave....

Share this post


Link to post
Share on other sites
15 hours ago, apianti said:

Change the timezone to a different offset like if you want it to happen at 0500, then choose -3.

I set Timezone yesterday to config.plist at -3.
Now in Slovenia, 07.40 in the morning, even the Clovy theme is not confused, but it still says the night.

Share this post


Link to post
Share on other sites
8 hours ago, apianti said:

Oh, probably not. I personally think that the design of the vector themes is wrong. It really shouldn't rely on specific sizes since the whole point of the vector themes is to scale appropriately across any display size. It should rely on percentages of how much the screen an item should use, relying on specific sizes is going to cause problems because you'll have to use those sizes for each item. This is the exact issue with raster themes currently. I think there just is not enough understanding that this should be done like a web layout. Even more still a very strange size was selected for the default screen size, one that is not supported by every display... If this was to be done this way, the correct size should have been 1024x768, since it is the only size that needs to be required by the drawing protocols. But like I said, I'm not even going to attempt to do anything with the GUI anymore, it's beyond a mess and SVG support is severely crippled. I am of the belief that just because something exists and is easy to incorporate does not make it the best choice, or even a good choice against writing something the way you need it to behave....

 

You are totally right, but we have what we have so that's what I've got to play with.

Share this post


Link to post
Share on other sites

In the case of SelectionOnTop we have no selection-big and so can't use it as row0 entry size.

We can use boundingRect but we have many possible row0 icons. Which one should be used to measure geometry?

May be claim os_mac to be obligatory and use its geometry? Or vol_internal? I am not sure. os-mac can be used for badges so it can have smaller size.

Share this post


Link to post
Share on other sites
12 hours ago, luky35 said:

I set Timezone yesterday to config.plist at -3.
Now in Slovenia, 07.40 in the morning, even the Clovy theme is not confused, but it still says the night.

Slovenia is not -3, it is +3.

Share this post


Link to post
Share on other sites

He said that he set it to +1 and it changed at 0900, so he already has firmware hardware time that is same as localtime, I was just giving an example that if he wanted to change it to earlier that he needs to change the offset to subtract from 0800. Now he will get 1100 as daytime since before he said +1 was changing at 0900. He does not need a timezone to get change at 0800.

Share this post


Link to post
Share on other sites

Because

 

In ParseSVGIcon()

 

https://sourceforge.net/p/cloverefiboot/code/4819/tree/rEFIt_UEFI/libeg/VectorGraphics.c#l107

 

MainEntriesSize is taken from selection_big so ends up being 144px. But, row0TileSize is then also set to the same 144px which is not correct and results in the icons not being centred.  

But Clovy will be centred if SelectionOnTop="1"

 

BTW. Merry Christmas Slice

 

 

 

Edited by blackosx

Share this post


Link to post
Share on other sites

Been waiting to say it, you jerks already having Christmas, finally just turned here.... Merry Christmas! lol

 

27 minutes ago, Slice said:

There is a good idea to provide different themes with different sounds

https://github.com/Goldfish64/AudioPkg

 

Oh my will this be a disaster to maintain, so many audio devices.... But cool.

Edited by apianti

Share this post


Link to post
Share on other sites
12 hours ago, Slice said:

Slovenia is not -3, it is +3.


Try to use +7 and -7 but get Night Theme with "BGM_SVG".

Where did i get wrong???

i am in indonesia, now is 14.25
image.thumb.png.9ceaa42077e445b7b402033667b7291b.png

screenshot0.thumb.png.18ae78e068acd711a6b2f940e5c77413.png

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By Nomade
      Hello All,
       
      It's been a while that I am trying to update my system to 10.15.16.
      The install seem to start, then at reboot time I only see the Normal boot and the Recovery option from the Clover boot menu.
      None of those 2 allow to complete the update.
       
      Is there any ways to force it to install and/or show the "Update" option on the Clover boot screen?
       
      PS: I'm using Z97-Gaming-3
    • By Damx
      The specs CPU: Intel® Core™ i3 Processor 8130U, 2.20 GHz (Kaby Lake Refresh) Chipset: Intel® 300 Series Graphics: Intel® UHD Graphics 620 Display: 21.5'' 1920x1200 RAM: DDR4 PC2400 4GB SSD1: M.2 PLEXTOR (with original Windows 10) SSD2: SATA SAMSUNG 850 EVO (for macOS) Sound: Realtek ALC269 WiFi / BT: Intel 3168 NGW Realtek Card-reader  
       
      Not working
      WiFi: Intel 3168 NGW Realtek Card-reader  
       
      Pre-Installation
       
      I will not go through the basics since it is explained in details here on this site. Briefly, the process is to:
      Get Clover Get Catalina macOS installer Create USB with 2 MBR partitions (FAT32 for Clover and HFS+J for the installer)  
       
      Required kexts
      AppleALC.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext  
       
      Config.plist
      I used the one provided by RehabMan called config_HD615_620_630_640_650.plist. Download it from GitHub. It has almost everything you will need with only few edits for audio.
      Edits:
      [CPU] Make sure there is lilcpu=9 setting in boot arguments needed for Kaby Lake R CPU to be recognised correctly. [GPU] Make sure there is a patch GFX0 to IGPU under ACPI->DSDT [GPU] Under Devices->Properties->PciRoot(0)/Pci(0x02,0) make sure that the AAPL,ig-platform-id value is 00001B59, and the device-id value is 16590000 [AUDIO] Under Devices->Properties->PciRoot(0)/Pci(0x1f,3) set the layout-id to 40 and the device-id to 70A10000 [SMBIOS] Set Mac model ID is iMac19,2  

       

       
      Notes
      For some reason with latest version of Clover the install partition was not visible. If you run into the same issue you can downgrade Clover to r5103, which worked perfectly. WiFi / BT Intel 3168 NGW needs to be replaced if one needs WiFi. Someone mentioned that to get HDMI work properly you may need to change AAPL,ig-platform-id value to 00001659 for PciRoot(0)/Pci(0x02,0) - not my case but may be considered if you get this issue. Don't forget to generate your serial and other SMBUS values before signing in with iCloud services.  
       
    • By MaLd0n
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 
       
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Original DSDT have 167,880 lines and 762kb
       
      DSDT ORIGINAL.aml.zip138.01 kB · 8 downloads
       
      -Patched DSDT have 30,912 lines and 111kb
       
      DSDT PATCHED.aml.zip27.01 kB · 17 downloads
       
      --Hardware--
      Asus ROG RAMPAGE VI EXTREME OMEGA

      Processor  Intel i9-10980XE

      GPU Radeon RX 5700 XT

      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -XSPI -EC -PNLF -ARPT -GFX0 -NVME  
      --Screenshots-



















       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145 Model with Intel Core i5-1035G1 IceLake / Intel HD Graphics ICL
      -Update bios/uefi to last version 
       
      *For now we have 2 problems. Wake from sleep and some bugs in trackpad*
       
      --Bios/UEFI config--
      Go to Security tab and disable Secure boot
       
      -IceLake Premade installation Folder (easy way installation)
      https://tinyurl.com/y3tl6xlx
       
      --Clover and OpenCore Folders--
      Just paste EFI folder inside EFI partition
      -OpenCore
      https://tinyurl.com/y3c4rjkr
      -Clover
      https://tinyurl.com/y4496nq8
       
      --Enable Trackpad Dragging Option--
      Go to System Preferences/Accessibility/PointerControl/Trackpad Options and "Enable dragging"

      -Bluetooth Broadcom
       
      BrcmBluetoothInjector.zip2.46 MB · 4 downloads
       
      -OcQuirks.efi for Clover (Just replace Drivers folder)
       
      drivers.zip74.57 kB · 4 downloads
       
      --DSDT Patches--

      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 12 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -FULL RENAMED DEVICES   --IGPU Patch-- (All credits to Austere.J) Discussion about that HERE
       
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key>             <dict>                 <key>AAPL,ig-platform-id</key>                 <data>AABSig==</data>                 <key>device-id</key>                 <data>UooAAA==</data>                 <key>framebuffer-fbmem</key>                 <data>AACQAA==</data>                 <key>framebuffer-patch-enable</key>                 <data>AQAAAA==</data>                 <key>framebuffer-stolenmem</key>                 <data>AAAwAQ==</data>                 <key>framebuffer-unifiedmem</key>                 <data>AAAAgA==</data>                 <key>hda-gfx</key>                 <string>onboard-1</string>                 <key>igfxfw</key>                 <data>AgAAAA==</data>             </dict>  
      --USB Fix-- https://tinyurl.com/y4mqfahz
       
      -ScreenShots

       


























      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Acidanthera Team, Olarila Facebook Community, Hackintosh Facebook Community and many others!     We're all here to have fun and learn from each other!
×