Jump to content

391 posts in this topic

Recommended Posts

28 minutes ago, blackosx said:

Good point about custom images and I don't know the answer to that. I guess that's not been implemented yet.

 

Yes, the night/day switching option is default in Clover. If the theme contains images for night then they will be shown when viewing at the appropriate time of day. Are you after an option to disable this day/night switching and say, always show the daytime version? 

 

I don't test. But there is now  Timezone and daytime strings in config.plist (r4773)

 

 

Edited by Matgen84

Share this post


Link to post
Share on other sites
Advertisement
Good point about custom images and I don't know the answer to that. I guess that's not been implemented yet.
 
Yes, the night/day switching option is default in Clover. If the theme contains images for night then they will be shown when viewing at the appropriate time of day. Are you after an option to disable this day/night switching and say, always show the daytime version? 


Ok was just curious, thought I saw somewhere that we need to add “Daytime” to embeddedthemetype in config.plist.
Hopefully custom images for custom entries will be implemented soon.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

On Clovy - I have a widescreen monitor (3440x1440), but the background is set for 16:9, so I have black bars on the sides.  I have the resolution set in the config.plist and all other themes work with that resolution.  Any way to get rid of the black bars?  Thanks!

Share this post


Link to post
Share on other sites
I don't test. But there is now  Timezone and daytime strings in config.plist (r4773)

 

Ok was just curious, thought I saw somewhere that we need to add “Daytime” to embeddedthemetype in config.plist.

 

 

Thanks for the note.

 

Looking at the code, the EmbeddedThemeType setting is for the embedded theme only. You can set it to Light or Dark, or choose Daytime which will toggle Light or Dark depending on the time of day.

 

Hopefully custom images for custom entries will be implemented soon.

 

Yeah. I'll try to take look at what's happening. Though I'm sure Slice will be quicker to provide a solution.

 

Edited by blackosx

Share this post


Link to post
Share on other sites
2 hours ago, burkett375 said:

On Clovy - I have a widescreen monitor (3440x1440), but the background is set for 16:9, so I have black bars on the sides.  I have the resolution set in the config.plist and all other themes work with that resolution.  Any way to get rid of the black bars?  Thanks!

 

This is obviously not right. I would have thought the background could be scaled independently of the icons. Hopefully this will be resolved soon.

Edited by blackosx

Share this post


Link to post
Share on other sites
4 hours ago, burkett375 said:

On Clovy - I have a widescreen monitor (3440x1440), but the background is set for 16:9, so I have black bars on the sides.  I have the resolution set in the config.plist and all other themes work with that resolution.  Any way to get rid of the black bars?  Thanks!

 

2 hours ago, blackosx said:

 

This is obviously not right. I would have thought the background could be scaled independently of the icons. Hopefully this will be resolved soon.

 

Sorry, meant to attach a screenshot, too.

 

 

screenshot0.png

Share this post


Link to post
Share on other sites

Open Clovy/theme.svg with TextEdit and change the line

BackgroundScale="crop"

to

BackgroundScale="scale"

I am not sure if it helps as it is Clover bug not scaling images to such monitors.

Share this post


Link to post
Share on other sites
44 minutes ago, luky35 said:

@Slice hi,

 

Please help me with how to move the CLOVER symbol (in the image) to the center.

Thank you very much.

 

Clovy

It depends on how did you make it shifted.

Share this post


Link to post
Share on other sites
25 minutes ago, Slice said:

It depends on how did you make it shifted.

set the resolution 1920x1080 and it's great

Share this post


Link to post
Share on other sites

It's 11:35am here should the BGM_SVG be this colour or green?

 

Edit: Never mind, bios clock was wrong. For some reason it keeps changing.

 

screenshot0.png

Edited by SavageAUS

Share this post


Link to post
Share on other sites
16 hours ago, Slice said:

Open Clovy/theme.svg with TextEdit and change the line

BackgroundScale="crop"

to

BackgroundScale="scale"

I am not sure if it helps as it is Clover bug not scaling images to such monitors.

 

That worked, thanks!

Share this post


Link to post
Share on other sites

How can I add my Timezone to clover for vector themes to show day/night modes correctly. My bios seems to be using utc instead of local time.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Set the key GUI/Timezone to an integer offset from UTC in config.plist.

Could you please share an example of how this would be written?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, apianti said:

<key>GUI</key>
<dict>
  <key>Timezone</key>
  <integer>-5</integer>
</dict>

 

Where does this enter in the config.plist please?
I attach my config.plist.

config.plist.zip

Share this post


Link to post
Share on other sites
23 minutes ago, blackosx said:

It goes inside the GUI dict exactly as apianti showed in his example. Just add it under your theme entry for example.

I did not work, I'm doing something wrong.

Share this post


Link to post
Share on other sites
3 hours ago, apianti said:

<key>GUI</key>
<dict>
  <key>Timezone</key>
  <integer>-5</integer>
</dict>

 

Thank you. This worked for me.

South Australia.

What time should vector themes change to "night"?

Screen Shot 2018-12-21 at 7.34.35 pm.png

Edited by SavageAUS

Share this post


Link to post
Share on other sites
57 minutes ago, SavageAUS said:

Thank you. This worked for me.

South Australia.

What time should vector themes change to "night"?

Screen Shot 2018-12-21 at 7.34.35 pm.png

Which tool do you use config.plist?

Share this post


Link to post
Share on other sites
1 hour ago, SavageAUS said:

Thank you. This worked for me.

South Australia.

What time should vector themes change to "night"?

Screen Shot 2018-12-21 at 7.34.35 pm.png

A vector theme will always be time dependent if *_night images present inside.

If local time is between 8:00 and 20:00 then this is daylight. Else it is night.

7 minutes ago, luky35 said:

Which tool do you use config.plist?

Xcode.app ?

Share this post


Link to post
Share on other sites
19 hours ago, SavageAUS said:


Xcode


Sent from my iPhone using Tapatalk

Clovy themes show normal day and night on the icons of the time of the Boot. I do not have any Timezone .. or in the config.plist. DayTime.

 

@Slice did it great, only when it could reduce the size of the icons according to the user's monitor.

 

For my monitor 23.8 ich the best size is 128x128.

Edited by luky35

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip





       

    • By corbrink
      Hi,
      I have the following system:
      - Gigabyte Z370M-D3H M-ATX
      - Core i7-8700K Coffee Lake
      - Gigabyte Radeon RX 560 4GB
      - Crucial Ballistix 16GB DDR4
      - 960 EVO 1TB NVMe SSD
      - 850 EVO 500GB SSD
      - Crucial 500GB SSD
      - The 2 500GB SSD's run in Raid for data storage.
      - Western Digital 3TB HDD - Time machine
      - EFI here (too large to attach): EFI.zip

      Questions:
      1. I have a dual screen running from Radeon card, 1 on DP and 1 on HDMI. The one screen on DP goes randomly blank from time to time. Any ideas?
      2. I've read that the kexts should preferably be installed in /library/extensions. I would like to know what kexts should remain in the EFI. I read that you should install FakeSMC in both locations (EFI and L/E). If I follow this route must I change something in the config.plist?
      3. USB info in System Information (attached does not seem correct. I've followed the changes suggested but I'm not sure if this is the best it can be.
      4. Are there something in the EFI and config.plist I don't need or doing wrong?

      Feedback will be appreciated.


    • By blackosx
      I've created a new tool to help with Clover vector themes. It's a perl script that will search and globally replace RGB hex colours in the format #000000 and replace them with new calculated RGB hex colours using the adjustments you ask for.
       
      https://bitbucket.org/blackosx/cloversvgthemeadjuster
       
      You can download it using:
      git clone https://bitbucket.org/blackosx/cloversvgthemeadjuster.git See the usage instructions on the README.
       
      Current Version
      0.0.5 (changelog)
       
      Overview
      The script identifies all colours in the theme file and applies adjustments to the hue, saturation and lightness before saving a new file. The adjustments can be progressively increased in a loop to generate multiple files.
       
      Example:
       
      Using the following commands to adjust the hue:
      perl AdjustThemeColour.pl -20 0 0 10 perl AdjustThemeColour.pl +20 0 0 10 Against my original Silver theme

       
      Can generate multiple variations and choose one I like
       

       
      Say, this one...
       

       
      ** Of course, this type of adjustment will not work on all themes. It all depends on what colours have been used in the design.
       
      Or how about a de-saturated BGM_SVG?
       

       
       
      Known Issues
      - There's always a possibility that a newly replaced hex value may match an already existing hex value which is due to be changed afterwards. This would mean that the newly replaced colours will then be replaced incorrectly. The likely hood of this happening increases with the more colours used in the theme.
       
       
       
×